Jump to content
Sign in to follow this  
Followers 6
Moun10Bike

Release Notes - January 14, 2014

Recommended Posts

Read the last update's release notes

 

Release Notes

 

Much of this last cycle of development was devoted to improving the tools that the volunteer reviewers use to keep your supply of geocaches flowing. In addition to that, we focused on squashing bugs and mopping up compatibility with rapidly evolving browser updates. Updates include:

 

  • Select size for hiding a geocache now works in Internet Explorer 11
  • Fixed bug related to error messages on Email Us page
  • Fixed bug related to correct number of Favorite Points showing on geocache page
  • Updated links across several pages
  • Many other smaller bug fixes

Share this post


Link to post

Changed the browser icon to a green theme (matching the new banner). Icons for http://forums.Groundspeak.com and http://blog.geocaching.com/ not updated.

 

I was wondering about that. I thought that my browser cached a bad version of the favicon. Since I use a dark browser theme, it really looks yucky. What's with this trend to remove color from the website?

 

7d59d5fe-5e48-49ce-ac45-a8862d206f00.jpg?rnd=0.6308972

Share this post


Link to post

Changed the browser icon to a green theme (matching the new banner). Icons for http://forums.Groundspeak.com and http://blog.geocaching.com/ not updated.

 

I was wondering about that. I thought that my browser cached a bad version of the favicon. Since I use a dark browser theme, it really looks yucky. What's with this trend to remove color from the website?

 

7d59d5fe-5e48-49ce-ac45-a8862d206f00.jpg?rnd=0.6308972

 

Yeah, I've been wondering this myself...huh.gif

Share this post


Link to post

The update seems to have introduced a bug on cache listings that include waypoints. The map shows the waypoint markers, but no basemap, just a grey background. You can't zoom or pan the markers either. The maps still seem to work fine for geocaches that don't have waypoints listed. Here's one of my caches that now exhibits the bug: http://coord.info/GC1K327

 

I've got this problem on Firefox 26, Chrome 32 and Opera 12.16, all on Win 8.1. I'm guessing it has been caused by the update of the maps API to Leaflet 0.7.1.

Share this post


Link to post

The update seems to have introduced a bug on cache listings that include waypoints. The map shows the waypoint markers, but no basemap, just a grey background. You can't zoom or pan the markers either. The maps still seem to work fine for geocaches that don't have waypoints listed. Here's one of my caches that now exhibits the bug: http://coord.info/GC1K327

 

I've got this problem on Firefox 26, Chrome 32 and Opera 12.16, all on Win 8.1. I'm guessing it has been caused by the update of the maps API to Leaflet 0.7.1.

 

I'm seeing that on your listing, but not on one of my own with additional waypoints: http://coord.info/GCH6R6

 

I'll continue to investigate; shout if you discover something!

 

I'm experiencing the same bug

http://coord.info/GC4K87R

Share this post


Link to post

The update seems to have introduced a bug on cache listings that include waypoints. The map shows the waypoint markers, but no basemap, just a grey background. You can't zoom or pan the markers either. The maps still seem to work fine for geocaches that don't have waypoints listed. Here's one of my caches that now exhibits the bug: http://coord.info/GC1K327

 

I've got this problem on Firefox 26, Chrome 32 and Opera 12.16, all on Win 8.1. I'm guessing it has been caused by the update of the maps API to Leaflet 0.7.1.

 

I'm seeing that on your listing, but not on one of my own with additional waypoints: http://coord.info/GCH6R6

 

I'll continue to investigate; shout if you discover something!

 

I'm experiencing the same bug

http://coord.info/GC4K87R

I am see this as well using Firefox 26.0 on my iMac with the latest software. The cache is Kubota Garden

Edited by WeightMan

Share this post


Link to post

I'm seeing the same thing on one of my caches, Dead Bull's Rock: The Legend. It has three Additional Waypoints.

 

The + and - buttons for zooming in and out also don't work for this map.

 

Same symptoms in both Firefox 26.0 and Internet Explorer 11.

 

Another of my caches, Dragon's Hoard, doesn't display either of these symptoms in Firefox or IE. It has no Additional Waypoints.

 

There seems to be a pattern developing.

 

--Larry

Share this post


Link to post

I'm seeing that on your listing, but not on one of my own with additional waypoints: http://coord.info/GCH6R6

 

I'll continue to investigate; shout if you discover something!

 

At a guess, it's something to do with zooming, possibly a bug in Leaflet. The website change also introduced a similar bug in my Geocaching Map Enhancements script: waypoint markers would show OK, but the basemap and polylines drawn on it appeared half-zoomed (blurry and enlarged), and the map controls wouldn't zoom or pan. It seemed that Leaflet couldn't handle panning and zooming the map in quick succession. This happened whether I panned and zoomed separately, or did both together with map.fitBounds(). Panning the map using the javascript console rectified the problem.

 

My script was fine for showing a basic cache without waypoints, but zooming in to focus on a collection of points broke it. I'm guessing that it's that similar problem on the unadulterated website, with the map breaking when it tries to zoom in to show waypoints. I think your cache works because the waypoints are spread wide enough apart that the map doesn't try to zoom to fit them in.

 

My fix in the script was to pan the map fractionally from its starting point (not enough to trigger a new tile load), then zoom, then listen for the zoomend event before panning back to the correct point. Hope this helps!

Share this post


Link to post

My fix in the script was to pan the map fractionally from its starting point (not enough to trigger a new tile load), then zoom, then listen for the zoomend event before panning back to the correct point. Hope this helps!

 

While writing this a much more elegant solution occured to me: using a layerGroup to hold all the markers, zoom the map to the bounds of the group first, then add group to the map afterwards.

Share this post


Link to post

I'm seeing that on your listing, but not on one of my own with additional waypoints: http://coord.info/GCH6R6

 

I'll continue to investigate; shout if you discover something!

 

Me too - FF 25.0.1, XP

All caches with aditional waypoints broken.

All caches without aditional waypoints OK.

Share this post


Link to post

Changed the browser icon to a green theme (matching the new banner). Icons for http://forums.Groundspeak.com and http://blog.geocaching.com/ not updated.

 

I was wondering about that. I thought that my browser cached a bad version of the favicon. Since I use a dark browser theme, it really looks yucky. What's with this trend to remove color from the website?

 

7d59d5fe-5e48-49ce-ac45-a8862d206f00.jpg?rnd=0.6308972

Not a good change from my point of view. A dark, single color icon looks pretty drab on the desktop with all the other multi-color (and pretty) icons of other sites/programs.

Share this post


Link to post

I'm seeing the blank maps on all caches with waypoints too. Also, I can't zoom either the large or small map, nor pan the large.

Here's one: GC1JWDR.

Win 7 & Chrome 32 with no extensions. I log in & out for each visit.

Share this post


Link to post

Same here OS X Safari 5.1.10 and FF 26.0 with and without Greasemonkey scripts.

A multicache with Parking doesn’t work:

http://coord.info/GC4WVXE

 

whereas a traditional with PARKING coordinates works:

http://coord.info/GC3MMR3

 

In all cases the scale in the lower left corner moves to the center of the map.

 

After loading the cache page the map is in most cases just gray, after changing the maptype all versions show quite well, but no panning or klicking on the map ist possible.

Share this post


Link to post

Same here OS X Safari 5.1.10 and FF 26.0 with and without Greasemonkey scripts.

A multicache with Parking doesn’t work:

http://coord.info/GC4WVXE

 

whereas a traditional with PARKING coordinates works:

http://coord.info/GC3MMR3

 

In all cases the scale in the lower left corner moves to the center of the map.

 

After loading the cache page the map is in most cases just gray, after changing the maptype all versions show quite well, but no panning or klicking on the map ist possible.

Wow, that's really interesting. I've seen that a couple times, but I thought my system was just glitching. Great examples to help them track it down.

 

Off topic, but this reminds me how much I'd love the "show larger map" to take me to a map that shows the waypoints, since that's what I typically want the bigger map for. But, of course, it just takes you to the standard map showing all the geocaches in the area. Not a surprise, but for some reason I'm always disappointed...

 

Edited to add: Oh, I should have mentioned: Firefox 26.0 without Greasemonkey.

Edited by dprovan

Share this post


Link to post

It's weird that the Moun10Bike's one displays correctly - map with waypoints zoomable/movable. :blink: (Do you have sort of an exception from the devs? :) )

I know of many others with additional waypoints which have the map blind and stuck, like my "B-17 going down" for instance.

 

Firefox 26.0

Share this post


Link to post

Off topic, but this reminds me how much I'd love the "show larger map" to take me to a map that shows the waypoints, since that's what I typically want the bigger map for. But, of course, it just takes you to the standard map showing all the geocaches in the area. Not a surprise, but for some reason I'm always disappointed...

 

Edited to add: Oh, I should have mentioned: Firefox 26.0 without Greasemonkey.

 

Now that's why you might want to have Greasemonkey installed! :P See http://geo.inge.org.uk/gme.htm#features

Share this post


Link to post

It's weird that the Moun10Bike's one displays correctly - map with waypoints zoomable/movable. :blink: (Do you have sort of an exception from the devs? :) )

I know of many others with additional waypoints which have the map blind and stuck...

 

I've been doing some more testing and found the following:

 


  1.  
  2. If a cache has no additional waypoints, the map loads at zoomLevel 14, and everything looks fine.
  3. If a cache has got additional waypoints, the map initially loads at zoomLevel 14, but then pans and zooms to fit all the points into the map view. This currently breaks the map.
  4. If a cache has additional waypoints at just the right spacing, the map still pans, but doesn't have to zoom to fit them all in. It stays at zoomLevel 14 and everything works.
     

You can test this by viewing a puzzle or multi-cache, then adjusting the Corrected Coordinates. e.g. If you look at my cache GC1K327, the map will be broken. But if you correct the coordinates to N51 29.595 W2 35.783 (not the actual location), the waypoints spread out far enough to fit in the map view at zoomLevel 14. When the page reloads, the map will work again and you can zoom/pan as normal.

 

I think that this proves that the problem is linked to having to zoom and pan the map on page load. I guess that it might be something to do with animation in Leaflet, if the map tries to zoom mid-way though panning or visa versa. My solution would be to re-code the page to get the map to the right place first, then add on the waypoint markers afterward.

Share this post


Link to post

Just spotted a different bug, also associated with this website update. This one is specific to Chrome v32 (Firefox and earlier Chrome versions seem OK).

 

If you try to zoom the map on a cache listing page by double-clicking or using a mouse wheel, the map will zoom in on a point way to the north, rather than zooming in on the centre of the map. Using the zoom buttons works OK though.

 

This is a documented bug in Leaflet Maps v0.7.1, caused by a change in how Chrome reports the mouse location. According to the Leaflet Changelog, it has been fixed in v0.7.2. See the entry in the Leaflet Issues Log for more details.

Share this post


Link to post

The zoom/pan issue will be fixed in tomorrow's release, which will also include an update to Leaflet v0.7.2.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 6

×
×
  • Create New...