Jump to content

Compass Calibration broken on eTrex with v3.20?

Followers 5

Recommended Posts

I’m no longer able to calibrate the compass on my eTrex 30 since upgrading to v3.20.


Tried rotating slower, faster, delaying a sec before rotating, reinserted batteries, tried fully charged batteries, changed location, tried it in a different profile, nothing works, just says Compass Calibration Failed. After +20 attempts I give up.


Once it even gave a long beep at the Compass Calibration Failed message then shut down. I rebooted and it took a good 5 minutes to find the satellites again.


I think something broke with the 3.20 update. Can someone else verify the Compass Calibration is still working with v3.20?

Link to comment

Update on my original post...


I tried again to calibrate the compass (from the Compass page as with all other attempts) with no success.


I thought I had tried every permutation of trying slightly alternate ways to recalibrate it, except this time I tried it from the Setup/Heading/Calibrate Compass page and it worked first time!


Coincidence? Now I’m afraid to experiment to see if it consistently recalibrates for fear of messing it up again, so for now, I’m not touching it unless I really feel the need to recalibrate it or until another update comes out that addresses it.

Edited by radix4
Link to comment

BTW, did You, who can't succeed in calibration, performer MASTER RESET after upgrade to 3.20.

I did master reset and since then no problem with calibration at all!

Nope, I didn't perform a Master Reset. Guess I should of tried that but was out in the field caching and didn't want to lose all my data. But if performing a Master Reset does the trick, that sort of points to a v3.20 upgrade issue that the internal GPS flags were not initialized properly when the 3.2 update was applied. But you make a valid point... I will try a Master Reset next time a suspicious change in behaviour happens after an update is applied.

Link to comment


To perform a master reset:


1. Power off device

2. Press and hold Menu and Enter (joystick pressed in)

3. Press and release Light while continuing to hold Menu and Enter

Select Yes once the Do you really want to erase all user data? message appears

Edited by wmarek74
Link to comment

I have noticed my etrex 30 compass seems to be about 8- 10 degrees in error all the time while my 62 sc compass is about 4-5 degrees in error and in the opposite direction from my etrex 30. So I decided to use the user declination adjustment on both to make them both read more accurate

ie: N points to north, instead of using the True setting.

I got my declination value from a web site that checks my ip address to find my declination and then double checked it against a topo map and used a Brunton a Suunto and a Nexus compass as reference for True north ( 3 different compasses)

I am able to adjust the 62sc compass more accurately this way but not my etrex 30 compass, it stays the same no matter what user value I use and yet I think I read somewhere where the Garmin compass if properly calibrated should be accurate to 2-4 degrees. But testing shows other wise.I know that these gps get their declination value from some software and that , that value always remains constant over the years so depending where you are it can become inacurate

Edited by Forkeye
Link to comment

I suspect rotating doesn't totally calibrate a three axis compass. Maybe they added a way to calibrate the third sensor that people are missing.

They have a nice little animated sequence which shows what direction to rotate it, and around what axis. It still doesn't work.

I can see where that would calibrate the x and y sensors, the the z vertical sensor doesn't move. The only Garmin I got a hit on Google was this:


Link to comment

Nope. Not getting that to work, no matter how slowly.

Harry, I installed a new set of batteries into my eTrex 30 this morning and re-calibratd the compass without incident. As previously noted, the new calibration procedure since version 290 is SETUP-HEADING-CALIBRATE COMPASS. Do the third step very slowly. I hope this works for you.

Link to comment

I just purchased a brand new eTrex 30 yesterday. Calibration fails systematically at the 3rd step. Firmware is v3.20. (Indeed it is the second unit, they replaced the first one in a matter of hours very kindly because of this issue. Second unit has the same problem.)


I have noticed that if I do the 3rd step very very slowly, the failure message takes longer to appear, but it does. I have not been able to calibrate the compass once in many attempts. And I have tried to go both from the compass screen -> menu -> calibrate, and from the setup screen as mentioned in the thread (although as a computer programmer I doubt there is any difference, both paths should yield to the same calibration code).


Also, the master reset sequence does not seem to work here either, I have tried several times. The GPS only has a geocache entry and one extra .img, should be in factory settings for the most part.

Edited by bilikituri
Link to comment

I have heard just too many horror stories from the Etrex 30 to warrant risking a purchase. I have the same features anyway because the money I saved on the Etrex 20 got me a very nice Suunto compass, with change! GPS altimeter also seems to fail in pressurised planes because you can't disable barometer. E-compass software bugs and constant need to recalibrate negates it for me as I have a Suunto hand compass that never fails.


Suunto Clipper L/B NH = $17.95 USD







Link to comment

Once again I have managed to calibrate my Etrex 30 compass at least 6x over until I was tired of doing it with no problem tonight with V3.20 software. I don't know why some units don't seem to operate correctly. I would like to see a poll as to who has issues and who doesn't. The compass did seem to run a very long time with V2.80 without needing calibration, it seems to require it a little more often with V3.20, but I have yet to have the calibration operation fail. I figure 3 seconds per revolution when turning it during the calibration process. I have lots of real compasses too. Just puzzled as to why so many units seem to have compass problems.

Link to comment

I've only had my eTrex 30 for a short period of time but I've been using it exclusively for geocaching over the last month with no problem. I will admit that I've had a few minor issues with it that I never experienced in either of my eTrex 20's. Initially, I couldn't get the profile to change to geocaching no matter how many times I highlighted it and then finally it worked. Despite having found several geocaches recently, the unit will only show a maximum of two when I highlight "recent finds". It's not really a big concern for me but I will agree with others that there does still appear to be some issues that may frustrate some users. On the other hand, I can't stop praising the eTrex 20 for a reliable (and now inexpensive) geocaching experience right out of the box.

Link to comment

I have had the profile problem happen to me once, the other issue of caches found I probably haven't tried. One issue I do notice sometimes is that the unit falls asleep, you start to push buttons and nothing happens for 3-4 seconds and then all of a sudden the screen jumps to where it should be, doesn't happen too often and slow map panning due to the slow CPU it has.

Link to comment

Nevertheless, I don't really use the compass, what I use in practice is the inner arrow that points to the cache (together with reported distance).


The arrow is slaved to the compass, or is displayed there just because of the user interface but actually uses relative GPS position? If that was the case I would not care about the compass in practice, except for having faulty firmware.

Link to comment

I bought a new etrex 30, because I lost my previous one. FW version 3.70. I had major troubles with calibrating the compass. "take it slow and persevere" I read. Well, the latter was needed indeed. About the former, I am not so sure. It took me more than 50 tries. I sat there at least half an hour on the deck.


I tried taking 10 secs about the third step, it didn't help. I took out the batteries, I was hopeless that I even tried to rotate the opposite direction. I suspect, when I finally succeeded I might have been more stable with no sudden movements, but the fact is that I don't know why I succeeded in the end. I think it is a shame. Garmin should really fix this. This is absolutely not user friendly. I am still not sure whether to send back my Garmin again. What a disappointment!

Link to comment

I wondered that as well and read through the FW upgrade list:

From 2.80 to 2.90 it says:

"Improved accuracy of compass calibration on eTrex 30 devices. A new manual compass calibration is required (Setup > Heading > Calibrate Compass)."


I guess this has been a problem since 2.90. I know that the first poster writes it si a problem since upgrading to 3.20, but this person didn't tell from which version he upgraded. In the release notes nothing is mentioned about fixing the calibrating process since then, though I understand that not everything might be mentioned in the release notes.


Btw some people mentioned that you should do a master reset first. I didn't do this, I assumed that this wasn't needed since I have a new GPS anyway. Calibrating the GPS was the first thing after changing the the battery type to Lithium, since I inserted (new) ones of that type. I posted my story just to share my experiences for other who are having problems, to state that it is still a problem in 3.70. And that I needed a very long time, while sitting on a deck: an environment made of wood, nothing magnetic there.

Link to comment

Hi Fnparrotts


I don't know why I succeeded in the end, but I must say, compared to my previous eTrex 30 with old FW, I must say that the compass is really, really stable. I am glad that I didn't give up. Once again I not sure why I succeeded. I moved to the wooden deck, where there were no electronics in the neighbourhood and no other metal objects and ended up in a mode doing this many times. I cannot say I did something special when I succeeded in the end, but I did. The only thing I can say: don't give up! And let us know how it went.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 5
  • Create New...