Jump to content
Sign in to follow this  
Followers 11
HelgeLarsen

Error or slow response from API

Recommended Posts

I'm sure the Apps work well for Jeremy, since he averages about 5 cache finds per month. It's a fine app for that sort of find rate, but too clumsy and cumbersome for someone who likes to cache at a higher rate.

Share this post


Link to post

It seems the API is working better today. I imported a 900 cache PQ into GeoSphere in about 4-5 minutes versus the 25-30 minutes last weekend.

Share this post


Link to post

It seems the API is working better today. I imported a 900 cache PQ into GeoSphere in about 4-5 minutes versus the 25-30 minutes last weekend.

Tuesdays and Wednesdays are the slowest days of the week. There is a reason they do updates on Tuesdays. Try it Sunday afternoon and see what your results are.

Share this post


Link to post

Same error. It would be nice, if this can be fixed. GSAK is a very essential Geocaching-App.

Share this post


Link to post

It seems the API is working better today. I imported a 900 cache PQ into GeoSphere in about 4-5 minutes versus the 25-30 minutes last weekend.

Tuesdays and Wednesdays are the slowest days of the week. There is a reason they do updates on Tuesdays. Try it Sunday afternoon and see what your results are.

 

I don't buy that either. I tried today (Thursday) with the same results as the previous week including Sunday. Numerous timeouts and taking over an hour to refresh my cache database. Something is obviously going on with GS servers. This has not been the case in the recent past. I've had no trouble updating my database but the last couple of weeks it has been getting slower no matter what day I try.

Share this post


Link to post
GSAK is a very essential Geocaching-App.

Not for Groundspeak, I have the impression they ignore GSAK users... :sad:

Share this post


Link to post

It seems the API is working better today. I imported a 900 cache PQ into GeoSphere in about 4-5 minutes versus the 25-30 minutes last weekend.

I do not see any improvements.

 

Contrary, getting available download balance needs retries now...

 

Fetching balances...

... no response after 120 seconds

Previous request ended in error, now doing a retry.... 1/10

Retry delay started: 120/120

Share this post


Link to post

I have the same problemen.Net as anyone.

Have now downloaded and still have problems Gapp but a lot less burden. I can now download my geocaches.

Edited by windekind1973

Share this post


Link to post

I have just used GSAK and the API to download 5500 caches. There was not a single error, and it only used up 5500 of my daily download credits. So perhaps the problem really is fixed. Perhaps somebody in GS really is listening. If so many thanks.

 

But please, GS, will you remember that communication is a two way process. I can only assume this is fixed, it would be really nice to get some comms out of you so that we know what is really going on.

Share this post


Link to post

I have just used GSAK and the API to download 5500 caches. There was not a single error, and it only used up 5500 of my daily download credits. So perhaps the problem really is fixed. Perhaps somebody in GS really is listening. If so many thanks.

 

But please, GS, will you remember that communication is a two way process. I can only assume this is fixed, it would be really nice to get some comms out of you so that we know what is really going on.

I had several timeouts over a 10 minute period last night trying to update about 300 caches.

Share this post


Link to post

What i wonder is GSAK the only app suffering from this API-problem or are all API-apps impacted?

Share this post


Link to post

What i wonder is GSAK the only app suffering from this API-problem or are all API-apps impacted?

Geosphere is also affected. I gave up after 30 minutes of failing to download a single PQ into Geosphere last night :-(

 

As of this minute, it does seem to be working properly. Same PQ just loaded in 60 seconds. Whether the problem has been fixed permanently or I was just lucky remains to be seen.

 

I suspect, given Groundspeak's appalling record of communication, we'll probably never hear anything more from them about this. :-(

Share this post


Link to post

Trying to load my weekly homezone PQ on friday after noon (CEST) gave me several Timeout and Connection errors. After 5 or 6 attempts, I got them on my iPhone.

Share this post


Link to post

Today i did a "refresh cache data" of 350 caches without any errors/retries and it took about 3 minutes.

 

It seems the API performance is back under control. Keep it that way!

 

Thx GS.

Generating GPX file

23/07/2013 1:41:36 api call was successful

23/07/2013 1:41:52 api call was successful

23/07/2013 1:42:11 api call was successful

23/07/2013 1:42:29 api call was successful

23/07/2013 1:42:47 api call was successful

23/07/2013 1:43:11 api call was successful

23/07/2013 1:43:26 api call was successful

23/07/2013 1:43:48 api call was successful

23/07/2013 1:44:07 api call was successful

23/07/2013 1:44:22 api call was successful

23/07/2013 1:44:34 api call was successful

Edited by DanPan

Share this post


Link to post

Again, the API is very slowwww and not responding...

 

Due to everyone logging their 31 days of geocaching souvenirs "Found its"...?

 

 

GS, please have a look and fix it.

 

 

Generating GPX file

... no response after 20 seconds

04/08/2013 20:08:51 api call was successful

... no response after 20 seconds

04/08/2013 20:09:32 api call was successful

... no response after 20 seconds

04/08/2013 20:10:10 api call was successful

... no response after 20 seconds

04/08/2013 20:10:52 api call was successful

... no response after 20 seconds

04/08/2013 20:11:34 api call was successful

... no response after 40 seconds

04/08/2013 20:12:29 api call was successful

... no response after 40 seconds

04/08/2013 20:13:22 api call was successful

... no response after 40 seconds

04/08/2013 20:14:17 api call was successful

... no response after 20 seconds

04/08/2013 20:15:11 api call was successful

... no response after 20 seconds

04/08/2013 20:16:00 api call was successful

... no response after 20 seconds

04/08/2013 20:16:51 api call was successful

... no response after 20 seconds

04/08/2013 20:17:39 api call was successful

... no response after 40 seconds

04/08/2013 20:18:43 api call was successful

... no response after 40 seconds

04/08/2013 20:19:41 api call was successful

... no response after 40 seconds

04/08/2013 20:20:46 api call was successful

... no response after 40 seconds

04/08/2013 20:21:40 api call was successful

... no response after 40 seconds

04/08/2013 20:22:46 api call was successful

... no response after 40 seconds

Edited by DanPan

Share this post


Link to post

No improvement...

 

Generating GPX file

... no response after 20 seconds

05/08/2013 22:54:08 api call was successful

... no response after 20 seconds

05/08/2013 22:54:47 api call was successful

... no response after 20 seconds

05/08/2013 22:55:39 api call was successful

05/08/2013 22:56:13 api call was successful

05/08/2013 22:56:51 api call was successful

... no response after 20 seconds

05/08/2013 22:57:38 api call was successful

 

 

FYI: Timestamp is GMT+01:00

 

Shall this issue be fixed in tomorrow's site update?

Edited by DanPan

Share this post


Link to post

Today:

 

0% of the api calls responded after the first time

30% of the api calls responded after the second try

70% of the api calls responded after the third try

 

Under normal circumstances:

you should have 10 api calls and takes 180s, now you need 27 api calls and takes 448s => efficiency: 35%

 

Could someone at GS please have a look and fix it.

 

 

Generating GPX file

... no response after 40 seconds

08/08/2013 22:05:38 api call was successful

... no response after 20 seconds

08/08/2013 22:06:22 api call was successful

... no response after 40 seconds

08/08/2013 22:07:18 api call was successful

... no response after 40 seconds

08/08/2013 22:08:08 api call was successful

... no response after 40 seconds

08/08/2013 22:09:02 api call was successful

... no response after 40 seconds

08/08/2013 22:09:55 api call was successful

... no response after 20 seconds

08/08/2013 22:10:41 api call was successful

... no response after 20 seconds

08/08/2013 22:11:26 api call was successful

... no response after 40 seconds

08/08/2013 22:12:15 api call was successful

... no response after 40 seconds

08/08/2013 22:13:06 api call was successful

 

Timestamp is GMT+01:00

Edited by DanPan

Share this post


Link to post

What calls are you making and via what means (i.e. what app, etc.)? I'm in the midst of a status check on a large database in GSAK and receiving no such errors.

Share this post


Link to post

What calls are you making and via what means (i.e. what app, etc.)? I'm in the midst of a status check on a large database in GSAK and receiving no such errors.

I had some failures last night. I was doing a refresh of just under 2000 caches using GSAK, and there were a number of "no response" timeouts along the way. I just let it run in the background, so I'm not sure how many timeouts there were, but the refresh did take noticeably longer than usual. I just did the same operation again while I was typing this, and it went through without any problems, so it seems to be an intermittent problem. Maybe a server is getting hit harder at certain times of day?

Share this post


Link to post

We're definitely having some server issues of late due to record traffic. I'll make sure that the API team is aware of these periodic issues.

Share this post


Link to post

Completely borked right now (09:52 UTC 09-Aug-2013). Geosphere got 300 caches into a 990 cache PQ and bombed out, retrying is met with an immediate "Unexpected Response" in the app. :angry:

Share this post


Link to post
What calls are you making and via what means (i.e. what app, etc.)? I'm in the midst of a status check on a large database in GSAK and receiving no such errors.

The "Refresh cache data" function in GSAK with enabled filter of 250 caches.

 

It seems to be an intermittent problem at certain times of the day.

 

Thx for forwarding this isue to the API team.

Share this post


Link to post

FYI:

 

Today, the API response is fast lightning again.

 

All api calls were successful, no more "no response" messages when doing GSAK/Refresh cache data and an avg per api call of 14s

 

Thx API team!

Edited by DanPan

Share this post


Link to post

Sorry. Still not working:

 

Generating GPX file

... no response after 20 seconds

2013-08-13 00:10:48 api call was successful

... no response after 20 seconds

2013-08-13 00:11:18 api call was successful

... no response after 20 seconds

2013-08-13 00:11:51 api call was successful

... no response after 20 seconds

2013-08-13 00:12:27 api call was successful

... no response after 20 seconds

2013-08-13 00:13:08 api call was successful

... no response after 20 seconds

2013-08-13 00:13:52 api call was successful

 

This is right now, so the error is not fixed

 

Trying to refresh 900 caches

 

PS: The next 2 batches was done with no errors, so at least it is getting better

 

/HelgeLarsen

Edited by HelgeLarsen

Share this post


Link to post

So Groundspeak, should premium members expect some sort of credit or free month due to this? I'm a systems architect and if our system was acting up this way for multiple days heads would roll and job openings would probably appear. We pay for a service and you haven't delivered. The "record traffic" excuse doesn't cut it. Seems like someone there needs Capacity Planning training.

Share this post


Link to post

"Refresh cache data" and "Download PQs" in GSAK: errors and slow/no response...

Please have a look.

Generating GPX file

... no response after 20 seconds

20/09/2013 21:34:14 api call was successful

... no response after 20 seconds

20/09/2013 21:43:50 api call was successful

... no response after 20 seconds

20/09/2013 21:53:09 api call was successful

... no response after 20 seconds

20/09/2013 22:00:58 api call was successful

... no response after 60 seconds

Previous request ended in error, now doing a retry.... 1/10

Retry delay started: 120/120

20/09/2013 22:16:24 api call was successful

... no response after 120 seconds

20/09/2013 22:24:18 api call was successful

... no response after 180 seconds

Previous request ended in error, now doing a retry.... 1/10

Retry delay started: 120/120

... no response after 120 seconds

Previous request ended in error, now doing a retry.... 2/10

Retry delay started: 120/120

Previous request ended in error, now doing a retry.... 3/10

Retry delay started: 120/120

... no response after 20 seconds

Previous request ended in error, now doing a retry.... 4/10

Retry delay started: 120/120

... no response after 180 seconds

Previous request ended in error, now doing a retry.... 5/10

Retry delay started: 120/120

... no response after 120 seconds

Previous request ended in error, now doing a retry.... 6/10

Retry delay started: 120/120

... no response after 20 seconds

Previous request ended in error, now doing a retry.... 7/10

Retry delay started: 120/120

Previous request ended in error, now doing a retry.... 8/10

Retry delay started: 120/120

... no response after 120 seconds

Previous request ended in error, now doing a retry.... 9/10

Retry delay started: 120/120

... no response after 60 seconds

 

Fetching Pocket Query: Foundinthelast7days

PercentDone: 20

... no response after 120 seconds

... no response after 60 seconds

... no response after 20 seconds

PercentDone: 100

Fetching Pocket Query: allcachespart15

PercentDone: 20

... no response after 120 seconds

... no response after 120 seconds

... no response after 20 seconds

. no response after 20 seconds

PercentDone: 100

Previous request ended in error, now doing a retry.... 1/10

Retry delay started: 120/120

Edited by DanPan

Share this post


Link to post

Is anyone getting api errors today? I updated my caches in GSAK last week just fine, but it is crapping out today with the message "There was a problem communicating with the Groundspeak api."

Share this post


Link to post

Is anyone getting api errors today? I updated my caches in GSAK last week just fine, but it is crapping out today with the message "There was a problem communicating with the Groundspeak api."

 

And now it's working. Go figure.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 11

×
×
  • Create New...