Jump to content

What's happened to the map?

Jasper Gracioso
Followers 2

Recommended Posts

Since yesterday all I get is a blank map with no caches on it. No matter what I do. Even bringing up a search for an individual cache and then clicking on it's map is just the same. I leave it sitting hoping that it will refresh but still no. I tried clicking compatibility view like someone here suggested but still no joy.


Very Frustrating.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 2
  • Create New...