Jump to content
Sign in to follow this  
Followers 6
Socal ZukiCachers

Magellan eXplorist GC update v2.15 released

Recommended Posts

The long awaited update to Magellan's eXplorist GC is now available on their website. This update changes the main menu, incorporates a better basemap and allows the user to add custom maps to the units as well as several other upgrades.

 

David

Magellan Insider

Share this post


Link to post

Saw the updated this morning before I left for work.

 

I started the download but it still had a while to go when I left for work...ITS BIG.

 

Looking forward to getting home and updating out GC.

 

I need to update my 710 too.

Share this post


Link to post

Just one of the many ways you can customize a Magellan GC.

 

28o0ad.png

 

I just downloaded it myself.. have yet to feed it to the GC.. Already seeing a few minor glitches still exist.. I saw someone already mentioned a (at your own risk) patch for the maximum waypoints.. (something about the Atlas.ini file.) Took close to an even hour to download.. We'll see.... We'll see....

Share this post


Link to post

According to the someone on the MagellanInsider forum, MITAC does not release beta versions of the firmware.. So... 2.15 is supposed to be an Alpha release.. It does have a few quirks.. the patch changing the maxwaypoints entry all the way near the bottom of the Atlas.ini file (to 10000, the default release sets it at 500.) DOES work! and I've had no problems with adding new waypoints in the field. the only other quirk I can't stand, I have 4 fields on the map page, but the placement of the central point/smart arrow, is right on the top edge of the top 2 fields. and likewise, it obscures view of a breadcrumb trail (which, when I posted the screen shot, it shows slightly through the (Ugh!) aero-glass fields. (Sorry, I never was a Windows Vista/7 fan. the curse of Win-CE, they brought the Aero-Glass view to the portable.)

 

It works, DOn't get me wrong.. I brute-tested it on a series someone placed here in Connecticut, and it performed great. Not perfect, still the occasional Win-CE Lag, but it works.

Share this post


Link to post

When I got the notice that VantagePoint had an update, I downloaded it (Version 2.32).. When I restarted it, to download the track & waypoint data, It asked if I wanted to exchange the background map.. With the GPS's.. Yes, the base map that is loaded with firmware 2.15, transfers to VantagePoint. giving you a more detailed base map for VP!

Share this post


Link to post

In other news: Still no Vantage Point for Apple computers. :(

Edited by rav_bunneh

Share this post


Link to post

Anyone have trouble with gc not showing caches? Tried to load, they show up in the folder on the computer but when I look on the GPSr its empty. Also tried to do the update and all I got was 'wrong device for this update'

Share this post


Link to post

Don't really know where to post this question. I just got my Explorist GC today so still playing around with it, this is my first GPS. I have been using the iPhone app. My question is, how do you delete caches off the app that you marked as found. Before I went out I used the option on the Geocaching website to SEND TO GPS, now I would like to get them off there. Any ideas? thanks

Share this post


Link to post

Don't really know where to post this question. I just got my Explorist GC today so still playing around with it, this is my first GPS. I have been using the iPhone app. My question is, how do you delete caches off the app that you marked as found. Before I went out I used the option on the Geocaching website to SEND TO GPS, now I would like to get them off there. Any ideas? thanks

I've only just had my GC too so I'm still learning the ropes. I'm not sure if you can directly delete them from the unit itself but once you connect it to your computer, open up the Magellan drive ( mine happened to be (G:) ) and you'll find a Geocache folder. In there you'll find all the caches' you've downloaded.

Hope this helps.

Share this post


Link to post

Thanks ShakeyMic. But I don't see anything on my pc other than the Magellan Communicator which is a program file and I can't open that. I don't see a Magellan drive. Is there something that I can download off the Magellan website. Also when I connect to the pc, the gps itself just displays connected to pc and I can't move around in the gps until I disconnect from the pc. Also does anyone know if there is an explorist forum somewhere I can post and get some answers?

Share this post


Link to post

Thanks ShakeyMic. But I don't see anything on my pc other than the Magellan Communicator which is a program file and I can't open that. I don't see a Magellan drive. Is there something that I can download off the Magellan website. Also when I connect to the pc, the gps itself just displays connected to pc and I can't move around in the gps until I disconnect from the pc. Also does anyone know if there is an explorist forum somewhere I can post and get some answers?

 

Hi AZPaleo, To delete a cache directly from your device, select cache you wish to delete in list, press enter. Now press the menu-button. You should see a list with available actions (start, found-it, etc.) scroll all the way down, the delete option is the last option. This way you can only delete caches one by one.

 

When connected to your pc, go to start>my computer. You should see your gps as a storage device there. Open the device, there should be a folder "geocaches". You will find your saved caches in here, and you can delete them all at once, or just a few as you like.

Share this post


Link to post

Hi, I like to update my device, but it doesn't seem to work. How do I run the update? My device runs on software version 1.8 right now, is it even possible to 'skip' to version 2.15? Or should I run previous updates first?

Edited by CoBi05

Share this post


Link to post

Hi, I like to update my device, but it doesn't seem to work. How do I run the update? My device runs on software version 1.8 right now, is it even possible to 'skip' to version 2.15? Or should I run previous updates first?

 

Very odd that some are having trouble.. the Software self-extracts, then copies the contents of the unacked files onto the device. I had 1.8 running on min before the upgrade.. Whole process takes about a good 1/2 hour to complete. ( thought this was a USB 2.0 compliant? Why is it acting like a 1.2?) with the device off/not plugged in, start the software, it will prompt you to plug the device in, and place it in "Connect To PC" mode, then it will begin the transfer.

 

Alas, I sympathize with the Mac owners.. Only way around this, since MITAC seems to be locked with Windows-CE, their development tools also seem to be limited to Micro$oft platforms. I've played both sides of the fence, until OS-X.3.. when my poor G3 wouldn't take anymore..

Share this post


Link to post

Thanks gelfling6! It didn't work the first time because I'd already connected my device to PC before starting the update. Worked fine now, so I'm all set to find some more caches!

Share this post


Link to post

Well, we installed 2.15 onto our team's four ExGC units yesterday. Today we went caching and found that our ExGC looks and feels completely different. There are some screen data we don't understand. (We'll try to post screen shot.) Additionally, we couldn't get tracking to stay OFF. Too, once we 'stepped into' the cache details, the route mode (joystick to the left), the new 2.15 doesn't seem to decrement the distance as we closed in on the cache. In fact, we were within 29 feet and the ExGC still showed the original .01 miles - even though the track and arrow had closed in on the cache. We looked at the posted manual, and it hasn't caught up with all the features. We've got a few other issues, but I'm so mad I can't type. Anyone else having issues?

Share this post


Link to post

Well, we installed 2.15 onto our team's four ExGC units yesterday. Today we went caching and found that our ExGC looks and feels completely different. There are some screen data we don't understand. (We'll try to post screen shot.) Additionally, we couldn't get tracking to stay OFF. Too, once we 'stepped into' the cache details, the route mode (joystick to the left), the new 2.15 doesn't seem to decrement the distance as we closed in on the cache. In fact, we were within 29 feet and the ExGC still showed the original .01 miles - even though the track and arrow had closed in on the cache. We looked at the posted manual, and it hasn't caught up with all the features. We've got a few other issues, but I'm so mad I can't type. Anyone else having issues?

 

Ok, with my GC I go to 'Tools' 'Settings' 'Tracks' uncheck 'Tracking ON' and it makes no track.

Set check mark for 'Tracking ON' and it creates a track.

 

Moving the joystick to the left is not "route mode".

The joystick left while on the geocache list or description page will only show the map and the distance from where you are to that geocache, it will not set a 'Go To' to that geocache and it will not give a changing distance to the geocache.

Joystick to the right sets the Go To for the geocache.

Use the map with a 'Distance to End' display or use the dashboard to get a distance to your target.

Share this post


Link to post

Thanks ShakeyMic. But I don't see anything on my pc other than the Magellan Communicator which is a program file and I can't open that. I don't see a Magellan drive. Is there something that I can download off the Magellan website. Also when I connect to the pc, the gps itself just displays connected to pc and I can't move around in the gps until I disconnect from the pc. Also does anyone know if there is an explorist forum somewhere I can post and get some answers?

 

There is an eXplorist forum that is not part of Magellan but experienced explorist users and some beta testers.

 

Go here - Magellaninsiders.com

Share this post


Link to post

Well, we installed 2.15 onto our team's four ExGC units yesterday. Today we went caching and found that our ExGC looks and feels completely different. There are some screen data we don't understand. (We'll try to post screen shot.) Additionally, we couldn't get tracking to stay OFF.

 

Now I see what you mean, when I set a 'GO' to a cache it starts tracking again and can't be turned off until the route is canceled.

That's not something I noticed before because I always leave the tracking on.

Share this post


Link to post

I received the Explorist GC for Christmas and just now starting to want to get out there and cache. I have not been able to send the coords to the GPS, it says it can't find Magellan Communicator, even though I've download it several times and used several different PCs. Is it because I don't have the update and how do I get the update? If I do the pocket query (which I don't know how to do) do I need the Mag communicator?

Share this post


Link to post

Did anyone have trouble updating their software on the eXplorist GC? I just bought one and when I try to install the software update from the preinstalled v. 1.0.1085.145 to the latest I keep getting an error that says: “The product identifier of the uniteXplorist is not compatible with this upgrade.” I definitely have the GC and otherwise don't have a clue what this means.

 

I imagine the problem is simply due to my inexperience but have no clue how to proceed. I found nothing on their FAQs to help.

 

was all excited about playing with my new toy later today... :(

 

~M

Share this post


Link to post

Did anyone have trouble updating their software on the eXplorist GC? I just bought one and when I try to install the software update from the preinstalled v. 1.0.1085.145 to the latest I keep getting an error that says: “The product identifier of the uniteXplorist is not compatible with this upgrade.” I definitely have the GC and otherwise don't have a clue what this means.

 

I imagine the problem is simply due to my inexperience but have no clue how to proceed. I found nothing on their FAQs to help.

 

was all excited about playing with my new toy later today... :(

 

~M

 

I doubt it is you.

 

Sounds like Magellan is outsourcing some work to Garmin software engineers :)

 

Contact Magellan Support yet?

Share this post


Link to post

Did anyone have trouble updating their software on the eXplorist GC? I just bought one and when I try to install the software update from the preinstalled v. 1.0.1085.145 to the latest I keep getting an error that says: “The product identifier of the uniteXplorist is not compatible with this upgrade.” I definitely have the GC and otherwise don't have a clue what this means.

 

I imagine the problem is simply due to my inexperience but have no clue how to proceed. I found nothing on their FAQs to help.

 

was all excited about playing with my new toy later today... :(

 

~M

 

I doubt it is you.

 

Sounds like Magellan is outsourcing some work to Garmin software engineers :)

 

Contact Magellan Support yet?

 

Thanks for the response!

 

I did shoot Magellan an email since I couldn't find anything on their site about it. Haven't heard back yet (it was only 1.5hr ago) but when I tried searching on Google found this thread and thought I'd give it a shot. Will post anything I find out here in case it comes up for someone else in the future.

Share this post


Link to post

Did anyone have trouble updating their software on the eXplorist GC? I just bought one and when I try to install the software update from the preinstalled v. 1.0.1085.145 to the latest I keep getting an error that says: “The product identifier of the uniteXplorist is not compatible with this upgrade.” I definitely have the GC and otherwise don't have a clue what this means.

 

I imagine the problem is simply due to my inexperience but have no clue how to proceed. I found nothing on their FAQs to help.

 

was all excited about playing with my new toy later today... :(

 

~M

 

I doubt it is you.

 

Sounds like Magellan is outsourcing some work to Garmin software engineers :)

 

Contact Magellan Support yet?

 

Thanks for the response!

 

I did shoot Magellan an email since I couldn't find anything on their site about it. Haven't heard back yet (it was only 1.5hr ago) but when I tried searching on Google found this thread and thought I'd give it a shot. Will post anything I find out here in case it comes up for someone else in the future.

 

Here is a more direct contact, may get you quicker response:

 

Jeff Caulfield

National Product Trainer/Brand Advocate

Magellan Outdoor GPS

801-816-5774

jcaulfield@magellangps.com

Share this post


Link to post

Did anyone have trouble updating their software on the eXplorist GC? I just bought one and when I try to install the software update from the preinstalled v. 1.0.1085.145 to the latest I keep getting an error that says: “The product identifier of the uniteXplorist is not compatible with this upgrade.” I definitely have the GC and otherwise don't have a clue what this means.

 

I imagine the problem is simply due to my inexperience but have no clue how to proceed. I found nothing on their FAQs to help.

 

was all excited about playing with my new toy later today... :(

 

~M

 

I doubt it is you.

 

Sounds like Magellan is outsourcing some work to Garmin software engineers :)

 

Contact Magellan Support yet?

 

Thanks for the response!

 

I did shoot Magellan an email since I couldn't find anything on their site about it. Haven't heard back yet (it was only 1.5hr ago) but when I tried searching on Google found this thread and thought I'd give it a shot. Will post anything I find out here in case it comes up for someone else in the future.

 

Here is a more direct contact, may get you quicker response:

 

Jeff Caulfield

National Product Trainer/Brand Advocate

Magellan Outdoor GPS

801-816-5774

jcaulfield@magellangps.com

 

Thank you so much, BMW Jedi! I have already heard back from Mr. Caulfield. We don't have it fully resolved yet but I am already much further along than I was this morning. :)

Share this post


Link to post

Woohoo! I was sent a link to first update to v1.7 and then the upgrade to v2.15 worked just fine.

Thanks for the tip to contact Jeff. He was fantastic!

 

~M

Share this post


Link to post

Woohoo! I was sent a link to first update to v1.7 and then the upgrade to v2.15 worked just fine.

Thanks for the tip to contact Jeff. He was fantastic!

 

~M

 

Awesome!

Share this post


Link to post

I was on v1.7 and I've upgraded to v2.15 - but the install won't finish cleanly. It installs the system, tells me it's not installed - and when I turn on the device it's on v2.15 with no maps! Anyone got any clues as to what to do to resolve this? I've used vantage point to put on the most basic basemap - but it's very basic and has absolutely no detail for where I live (central Scotland) over basic coastlines.

Share this post


Link to post

OK I still have my GPS plugged into my computer.. I ran the update for both the GPS and the software but am unable to DL caches to my GPS.. anyone.. what AM I doing wrong?

Share this post


Link to post

Hi

 

Ive run the update - all worked great, however i noticed my waypoints I have already installed on the previous version were different didgets to those in my book of caches ive solved. I then notice that the way the coordinates are inputted is different , missing a decimal point.

How can I change this back? which settings do i need to be using so that the coordinates i solve are the ones that will work on the gc?

thanks

 

UPDATE - SOLVED IT I CHANGED THE DEGREE/MINUTE SETTINGS....HURRAH!!

Edited by LittleGaySpoon

Share this post


Link to post

I was on v1.7 and I've upgraded to v2.15 - but the install won't finish cleanly. It installs the system, tells me it's not installed - and when I turn on the device it's on v2.15 with no maps! Anyone got any clues as to what to do to resolve this? I've used vantage point to put on the most basic basemap - but it's very basic and has absolutely no detail for where I live (central Scotland) over basic coastlines.

 

Same Problem here, Updated from version 1.6 and no maps either.

tried to reïnstall version 1.6, but that doesn't work either.

I've contacted the helpdesk, but but no response yet.

Share this post


Link to post

Did anyone have trouble updating their software on the eXplorist GC? I just bought one and when I try to install the software update from the preinstalled v. 1.0.1085.145 to the latest I keep getting an error that says: “The product identifier of the uniteXplorist is not compatible with this upgrade.” I definitely have the GC and otherwise don't have a clue what this means.

 

I imagine the problem is simply due to my inexperience but have no clue how to proceed. I found nothing on their FAQs to help.

 

was all excited about playing with my new toy later today... :(

 

~M

 

I doubt it is you.

 

Sounds like Magellan is outsourcing some work to Garmin software engineers :)

 

Contact Magellan Support yet?

 

Thanks for the response!

 

I did shoot Magellan an email since I couldn't find anything on their site about it. Haven't heard back yet (it was only 1.5hr ago) but when I tried searching on Google found this thread and thought I'd give it a shot. Will post anything I find out here in case it comes up for someone else in the future.

 

Here is a more direct contact, may get you quicker response:

 

Jeff Caulfield

National Product Trainer/Brand Advocate

Magellan Outdoor GPS

801-816-5774

jcaulfield@magellangps.com

 

Thank you so much, BMW Jedi! I have already heard back from Mr. Caulfield. We don't have it fully resolved yet but I am already much further along than I was this morning. :)

 

Hi M,

 

Can you send me that link as well? I have the same problem

Share this post


Link to post

For those missing the maps, did you check SETTINGS/MAPS and make sure that World Maps is checked?

 

Here's a workaround to get maps back into your GC if Magellan can't help

 

1) Download GC update 2.15 if you haven't so already

2) Download a program called 7zip (google it), install program

3) Use 7zip to extract the 2.15 exe file, this will create a directory of all the files on that exe

4) You will see a directory called MAP with two files in it, you will need both files

5) Copy that directory into your GC (or create a MAP subfolder x:\MAP where x is the drive of your GC) copy the two files in that directory

6) Restart your GC.... You should have your map now

 

Hope this helps

 

BTW - that map also works on the GC/310

Edited by gpsblake

Share this post


Link to post

The update i tried to install (at least 15 times, with different cables, settings, computer etc.) didn't complete, but the GC seemed to work, but i had no maps.

I Tried to figure out where it went wrong. After Unzipping the install file I found out that the script conains a file: \eXplorist_2_15\COPY_GROUP_9\MAPWWEU_BM.mgi of 1.17 GB, while the space left op the exporist was around 500MB, that doesnt work!

So I transferred the old map data file ( in \APP\MapData ) to my PC and gave it a retry..TADA that was the problem.

Now the script succeeded perfectly..

Share this post


Link to post

Does anyone know if the update is available from any other location other than the Magellan website? I've tried downloading it a number of times over the last 24 hours and it keeps failing - largest file I've managed to download so far is about 900meg.

 

Cheers

 

Andy

Share this post


Link to post

Just downloaded the update to 2.15, I pulled down the PC version and ran the update, after it had done the GPX files, it reported an error and said some things have not been updated. Then carried on and upgraded. When it booted up (fine), I found everything was fine, but the database of my finds (over 900) was missing and it was telling me I had no finds.

 

I had sensibly backed up the whole GPS image, and restored it back, tonight I tried the Mac version, (if you download 2.15, there is a link for the mac), but that unzips from the IMG but reports the wrong GPS is connected.

 

Any help on either would be great, I am happy to do the PC one, if I dont lose my settings on the finds etc!

Share this post


Link to post

Hi, I just got mine today, so I decided, why not update! My version is running 1.8.1349.777 and when I tried to install the update, it says it's "not a valid Win32 application". On the same note, I can't send caches from the site to my GPS either and I did install the plug-in (see other post for that problem). I'm getting frustrated! :angry:

Edited by Cr8zyC8tL8dy

Share this post


Link to post

I updated my gc just over a month ago. I wanted to get a feel for it before I said anything, but I don't think it's quite right. I have had a lot of problems with the receiver showing which direction I am heading. At first I called it up to power lines or being close enough to the cache. However, today I wasn't near any power lines, walking due west (or pretty darn close) and the unit showed me in every direction except. This wouldn't be too bad except the tracking, that I can't turn off his along with the jumping icon. So now after a few hundred feet of walking, I have a big blob on my map. I haven't gotten used to the dash board yet. And since it's all over the map is usually how I know where to go. I have to turn the tracking off after each find, and any time I go off the map. So if I set my route then check the details, I have to turn the tracks off again. My last 'major' issue is my PQ does not load completely. I was it today and 2 of the 4 caches I loaded to navigate on my phone, weren't in the GPS. I used the same PQ to load both devices. These are issues I didn't have with the unit before update.

 

When I updated the GPS in March I had a few issues. Originally, after the update I had a white screen with words at the top. There were 4 words, but I can't remember what they were. After the fourth attempt to install the update, it worked. I don't know if that's my problem, or if I am doing something wrong. Anyone else have that problem? Oh, and how many waypoints are allowed now? It seems like I always have the limit.

Share this post


Link to post
Originally, after the update I had a white screen with words at the top. There were 4 words, but I can't remember what they were.

 

Probably "RESTARTING TO IMPROVEMENT PERFORMANCE". That's normal when you update to 2.15

 

As far as pocket queries not completely loading, make sure you don't have any filters enabled on the unit. Version 2.15 also has a "bug" that limits waypoints to 500. The workaround is to edit your atlas.ini on the unit (use notepad) to change that from 500 to say 10000.

 

I hope some of this helps.

Edited by gpsblake

Share this post


Link to post

I was on v1.7 and I've upgraded to v2.15 - but the install won't finish cleanly. It installs the system, tells me it's not installed - and when I turn on the device it's on v2.15 with no maps! Anyone got any clues as to what to do to resolve this? I've used vantage point to put on the most basic basemap - but it's very basic and has absolutely no detail for where I live (central Scotland) over basic coastlines.

 

Same Problem here, Updated from version 1.6 and no maps either.

tried to reïnstall version 1.6, but that doesn't work either.

I've contacted the helpdesk, but but no response yet.

 

Maybe this will help everyone. I just bought eXplorist GC it came with v1.8 and after taking it out of the box and doing the initial set up I logged into Magellans web site and done the v2.15 update. No problem with down load install but after my first GC hunt went and bought a different unit from garmin because the were no "maps" just blank scene behind the compass. So now I have been messing with magellan's digital globe and filled the GC's memory up and then could figure out how to remove digital images. So if all else fails hit the "RESET" button next to the usb port, then went to reset factory defaults in options. It must have reset the maps because now I have maps and roads in the unit. Hope this helps.

Share this post


Link to post

OK, we've got a long list of potential problems when you upgrade to v2.15 but for someone still running v1.7 (and happy with its basic functionality) will I see a marked improvement moving to v2.15 or is it just not worth the trouble?

Share this post


Link to post

OK, we've got a long list of potential problems when you upgrade to v2.15 but for someone still running v1.7 (and happy with its basic functionality) will I see a marked improvement moving to v2.15 or is it just not worth the trouble?

 

I seem to be finding it's appetite for batteries has increased, but the new basemap, which has better detail is one plus.. navigation, is totally different from the 1.7/1.8 firmwares.. finding a cache, a lot of additional info put into the 'newlogs.txt' file than needs to be. 'Found/Not Found' a little too far down the menu, likewise the smilies for when you do add a comment. the click/type menu is a whole different ballgame as well. (I usually mark it with a smilie, then I'll edit the text file later on the laptop before sending it online. Otherwise, I'll be spending 5 minutes click-typing the entire log entry.)

 

The the accuracy is about the same, but noticing a little more movement/reaction to movement.. Only ONE minor patch I heavily suggest, is changing the maximum waypoints value in the atlas.ini file, to allow for more than the 500 limit.. (since child waypoints occupy less memory than the actual cache profiles, though, limit to 10,000 , just like maximum caches.) Also, you'll find your user space on the GC will be reduced.. (read this as nearly filling a flash drive to maximum, and possibly having the computer complain the space is too low.)

 

It's not a total waste of time, but as others have said, it's not 100% perfect. Everyone seems to want to use as much space as possible, but forget there IS a limit to that space.

Stephen (gelfling6)

Share this post


Link to post

Firmware 2.15 has bricked my Magellan Explorist GC!

 

It all uploaded perfectly well and I have done one cache with it - added cache co-ords as a waypoint while at work to do the cache on my way home. All worked fine.

 

When I tried to upload the cache details from the website to the device at home to log it as found on the GPS the device never rebooted after disconnecting from my PC. It's just stuck with a dark screen and a big Magellan logo at the top.

 

I have tried many times to force the device into service mode using the instructions on this forum but it always returns to the screen described above.

 

My conclusion is that I have bricked my Magellan GPS!!!! :mad:

 

Oh, well, at least the new GUI looked nice for five minutes......

Share this post


Link to post

I've upgraded to 2.15 and am looking to go back to where it was. If I try to go back to 1.7, will I mess this thing up, or is it possible that I'll be able to revert to 1.7 and be OK? I'm sort of in the middle of a caching trip, so I'm not going to do it right away. I'll check back for feedback before trying. Thanks.

Share this post


Link to post

I received the Explorist GC for Christmas and just now starting to want to get out there and cache. I have not been able to send the coords to the GPS, it says it can't find Magellan Communicator, even though I've download it several times and used several different PCs. Is it because I don't have the update and how do I get the update? If I do the pocket query (which I don't know how to do) do I need the Mag communicator?

10/17 Update: With help from Jeff Caulfield at Magellan (contact found on this forum)I was able to do everything but download the caches to the GC. Something in my computer was changing them from gpx format to...something else. After 6 months, found a computer (from work) that I could use to load caches. Went caching this past weekend and there are times the GC won't turn on. I have to take out the batteries and put them back in to get it to turn on. Doesn't work every time but most of the time. The batteries are difficult to get out. I had some trouble navigating to different screens, but couldn't a compass view with distance. Maybe more practice is needed for me to be completely comfortable. Jeff was great. Very patient and was talking me through the pocket query screens while driving. Knows his stuff.

Share this post


Link to post

The long awaited update to Magellan's eXplorist GC is now available on their website. This update changes the main menu, incorporates a better basemap and allows the user to add custom maps to the units as well as several other upgrades.

 

David

Magellan Insider

maybe some day they will come up with a fix for the triton 500, I still have one on the box. Bought two boy was that a dumb move

Share this post


Link to post

In other news: Still no Vantage Point for Apple computers. :(

vantage point! be careful of what you ask for, I have vantage point and I never used it.

Share this post


Link to post

Spent a whole morning updating to 2.15 and resetting the geocache found counts and found geocaches with help from some previous posts. Something i really feel the update should have set for me. The map is better and there are some nice features but it is a lot slower to respond to button presses to the point that you are not sure if you have pressed or not. The GPS accuracy does not seem quite so good or responsive when approaching a geocache either. Although to be fair I have only tried it on one that I knew where it was, but displayed 20 FT when I was right on top of it. Count in the dashboard does not increment either but someone else mentioned this.

 

Has anyone found out how to find child waypoints for a geocache as this option (menu after you select geocache) has disappeared from v1.7 to 2.15 and is something you really need with multi caches as the child waypoints contain the locations and description of questions you need to answer.

 

Overall not that impressed so far and seriously thinking about reinstalling v1.7 from the backup I did before installing 2.15

Edited by H&RG

Share this post


Link to post

Spent a whole morning updating to 2.15 and resetting the geocache found counts and found geocaches with help from some previous posts. Something i really feel the update should have set for me. The map is better and there are some nice features but it is a lot slower to respond to button presses to the point that you are not sure if you have pressed or not. The GPS accuracy does not seem quite so good or responsive when approaching a geocache either. Although to be fair I have only tried it on one that I knew where it was, but displayed 20 FT when I was right on top of it. Count in the dashboard does not increment either but someone else mentioned this.

 

Has anyone found out how to find child waypoints for a geocache as this option (menu after you select geocache) has disappeared from v1.7 to 2.15 and is something you really need with multi caches as the child waypoints contain the locations and description of questions you need to answer.

 

Overall not that impressed so far and seriously thinking about reinstalling v1.7 from the backup I did before installing 2.15

 

There was a 1.8 release if you really want to go back....

 

Yes, 2.15 is a monster! Huge, bloated, and battery-hungry! (You'll notice battery consumption is 2.5X what it was under 1.7. Also your computer will occasionally complain that the device will run faster on a USB 2.0 port. Ignore it..)

The detailed map is far better! Even found, in the latest releases of VantagePoint, it will import the map from the GC, for it's own use.)

 

Here's a step by step.

 

To Add a Waypoint, if you're on the map, at the stage you've just found, click the Menu button

 

Scroll down 8 selections, to [Add a Waypoint].. click the joy-button

 

it'll give a name, distance, description, and Location menu..

 

Press the Joy Button twice when on the waypoint name, to edit it. (scroll to the checkmark to exit)

 

Scroll down to location, click the joy button

 

scroll down once more to Location, Then Press the Menu button scroll down 2 selections to Edit, click the joy button.

 

It will show your present location. scroll to the area you want to edit, click the joy button, and up/down scroll the numbers, left-right to which one to change. joy-button click inward to set the numbers once entered.

 

scroll down to the [OK] selection, click Back once,

 

Scroll down once, to select the Diskette image, and joy-button click in once to save it.

 

Click the back menu until you're at the main page, and go to the waypoint selection, choose the new waypoint, and then

Joy-button click on it, press Menu, It'll still be on route to the 1st stage, so cancel route, click menu again, and then click GO on the waypoint.

 

I know, L-O-N-G & CoNfUsInG! I learned how to do this out in the field, when tracking a Multi.. it was BONKERS!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 6

×
×
  • Create New...