Jump to content
Sign in to follow this  
Followers 1
BADFISH2

GSAK & Nuvi Issue

Recommended Posts

Sorry if this has already been addressed...couldn't find a solution after searching.

I have been using GSAK for a few years and I like to add PQs to my Nuvi to use while I drive around. Recently, my PQs fail to load to my Nuvi, I get a message that the file is invalid. I tried reloading an older (a few months ago) PQ that I have on my PC and it works fine. Has something changed with the PQ format recently?

Thanks

Share this post


Link to post

Not having any problems loading into the nuvi. Do you use POI Loader?

Yes I use the POI loader and used this set up for years with no problems. In fact I used it in November 2012 with no problems. I wonder if there has been a change to the PQ format?

Share this post


Link to post
I wonder if there has been a change to the PQ format?

Check this page and scroll down to the bottom and make sure the GPX version is set to 1.0 not 1.0.1.

Share this post


Link to post

I changed the type to 1.0 (it was indeed 1.01) but still no luck. Here is the error I get:

The C:\Documents and Settings.....the path name is here..../Geocache TourGuide.gpx is invalid. Do you want to continue?

Any other ideas?

Edited by BADFISH2

Share this post


Link to post

Research has shown me that some cache names (especially those with a lot of symbols) can cause this issue. I am trying to find if there is an offending cache in my query. If anyone knows of any specific issues with a cache name I would appreciate the info.

Thanks

Share this post


Link to post

Research has shown me that some cache names (especially those with a lot of symbols) can cause this issue. I am trying to find if there is an offending cache in my query. If anyone knows of any specific issues with a cache name I would appreciate the info.

Thanks

I recently found a problem with one of the caches that I have had in a pocket query with no problem for a few years. It took a while to figure out which one was causing the error as I have several PQs that load close to 1,000 caches each. The culprit (for me) is GC19YE1 - Delta 2. It is and Earth Cache that was Hidden: 03/05/2008. Not sure what changed. So, I had to ignore the listing so that it does not show up in my PQs any longer.

Interesting...

Dan

Share this post


Link to post

Actually, I did have that problem in March. Something was 'invalid', and POI Loader stopped loading the GPX files. It took quite a bit of work to find which four caches were 'invalid'. (I did the search on a county basis.) They were not new caches either. Put those four caches on the Ignore List, and everything is working well again. So, obviously, something changed somewhere. I reported it as a bug, but the moderator said to take it up with GSAK forum. But I don't use the GSAK forum.

Share this post


Link to post

Hi

I am just now having the exact same problem, and its driving me mad. Any fix? Or what is the best way to search for which cache is causing the problem so i can select ignore it.

Thanks

Share this post


Link to post

Just the other day, we had a similar problem and never had it before ???..... My husband was working on it and I'm not exactly sure what he did but I think he exported directly from GSAK. I think he used EXPORT Garmin POI. I remember he put it on the desktop and then dragged it into the Nuvi. I could be missing something...but I'm pretty sure he did not use POI loader.

Share this post


Link to post

Had the same problem and eventually changed the macro to one I found on the GSAK forum

Nuvi_GPX_by_CT.Gsk by jjreds - now maintained by Red Roo (Wayne)

Share this post


Link to post

Hi

I am just now having the exact same problem, and its driving me mad. Any fix? Or what is the best way to search for which cache is causing the problem so i can select ignore it.

Thanks

I'm having the same exact problem on my recent cross country trip. Several times in different locations same problem. So anyone know how to search for the offending caches?

Share this post


Link to post

Have a Nuvi 550 and we might be comparing apples to oranges. 500/550 series loads GPX files directly and not through the "POI route"

 

From time to time I get a failure to load.

 

Turning the Nuvi off prior to connecting to the PC and allowing the computer to boot the Nuvi has been my work around.

Share this post


Link to post

It seems to be a recent problem. (Presumably due to an update by GS.) I ran into this problem again today. Took me an hour to eliminate the cache causing the problem. The caches causing the problem are not new caches. The problem seems to be with using 'control' characters. (I would assume in a log?) In my 'geocaching problems' log, I was told to take it to GSAK.

Nuvi_GPX_by_CT.Gsk by jjreds - now maintained by Red Roo (Wayne)seems to understand the problem, and offer a correction. Fortunately, I have a geeky bird brother to help me through such problems. I feel sorry for anyone who does not have such help. Finding the 'patches' to update GSAK to the required verison was anything but obvious!

I will try the Nuvi_GPX_by_CT.gsk macro next week. Hopefully, I will not run into this problem again! But, it is quite obvious that GS made a change that caused this problem. I guess it is up to GSAK to rectify the problem.

Share this post


Link to post

I recently started using Nuvi_GPX_by_CT.gsk. Working now but did run into a few bumps along the way. Like POILoader not removing my previous;y loaded data.

Share this post


Link to post

It happened again today, at least the 4th time all over the country, so I decided to find out what cache listing was cause. After a couple of hours I found GC2TANY which upon deleting from th PQ cured the problem.

 

Don't know if this information helps or not but I do wish GS would fix it as it just not fair to have to put this cache on my ignore list in order to use PQs.

Share this post


Link to post

Yeah, I pretty much gave up on GSAK. I import directly to my Lowrance and use the Geocaching app on my iPhone to get me in the area. Oh well.

Share this post


Link to post

I recently started using Nuvi_GPX_by_CT.gsk. Working now but did run into a few bumps along the way. Like POILoader not removing my previous;y loaded data.

 

Maybe you can help. When I try to run the new macro, I run into a problem "Unable to copy sox.exe. Please check the path. Macro will now abort." Where should the SOX.exe file be? It doesn't tell me that.

Share this post


Link to post

I'm having the problem too on a POI for a long trip. I broke the trip in half and the first half loaded O.K. but not the second......I'll try some things mentioned here.

Bummer though.....I've used the macro for years.

Years ago using Easy GPS, Spinner, and Plucker, certain caches would lock up our devices.

Share this post


Link to post

Maybe you can help. When I try to run the new macro, I run into a problem "Unable to copy sox.exe. Please check the path. Macro will now abort." Where should the SOX.exe file be? It doesn't tell me that.

Sox.exe is used by POI Loader. It needs to be in the same folder where POI Loader is installed

Share this post


Link to post
I'm having the problem too on a POI for a long trip. I broke the trip in half and the first half loaded O.K. but not the second......I'll try some things mentioned here.

 

I am pretty certain that the problem started when geocaching.com allowed Unicode into cache listings. I only use my nuvi to get me to the cache area, so I changed the script to leave out the description, etc. and since then I have had no problems.

 

My main problem is that the GSAK macro language is so bad. I think I may end up writing a version in Python that takes the caches directly from the SQLite database. Should be a lot faster, as well.

Share this post


Link to post

OK, I've posted this under the "Report Bug" forum, lets hope that GS fixes it soon.

Share this post


Link to post

I've finally gotten the new macro working properly. I don't speak geekalese. It took many hours IMing my geeky brother to get it working. (Including reinstalling GSAK a few times.) Microsoft hid roaming/appdata from view to prevent people from doing dumb stuff. But that's where I needed to go to copy Tour_Guide. (It would be nice if GSAK mentioned these things!) I have no idea how a non-geeky prson without a geeky brother could get tis to work! Thank goodness TG&P was willing to work with me.

Share this post


Link to post

I am having this problem for the first time today... and I leave for my honeymoon in London in 48 hours. Not great timing... Not bringing my phone, so can't cache with that. Garmin Nuvi is my only option. Boo. :(

Share this post


Link to post

OK, I've posted this under the "Report Bug" forum, lets hope that GS fixes it soon.

 

The problem is with GSAK/POILoader, not with geocaching.com

 

Probably. It is possible that gc.com is sending illegal XML in the GPX files, but if that were true we would have heard howls of protest from many quarters.

Share this post


Link to post

OK, I've posted this under the "Report Bug" forum, lets hope that GS fixes it soon.

 

The problem is with GSAK/POILoader, not with geocaching.com

 

Probably. It is possible that gc.com is sending illegal XML in the GPX files, but if that were true we would have heard howls of protest from many quarters.

From the Repot Bug forum, Per Moun10Bike on 5/23/13: "I did some investigation of this last week and determined that the iPhone app is allowing users to enter "Emoji" emoticons into their logs. These are not getting properly parsed and end up as unrecognizable characters on the web site in most browsers. The bigger problem is that these characters are also breaking the GPX encoding, leading to problems with POI loaded and GPS units.

 

The team is working on a fix to prevent this from happening."

 

Hopefully the fix is coming soon.

Edited by captnemo

Share this post


Link to post

not sure if this will help, I use this macro on my 255w.

It's Lignumaqua's basic nuvi export for 36xx and other models, ver. 1.7

Never had any problems with it and it loads description, hint, and last 5 logs

Share this post


Link to post

I am having this problem for the first time today... and I leave for my honeymoon in London in 48 hours. Not great timing... Not bringing my phone, so can't cache with that. Garmin Nuvi is my only option. Boo. :(

 

I guess everyone knows the Pilotsnipes has stopped working. I ended up using a German one [nuvifavoriteexport.gsk] for now on the NUVI. This is OK, since now I have a PN40 plus and Oregon 450 to give me detailed information.

 

In your case you can save a PQ to your phone [GCing App] and bring the NUVI for finding caches by entering coords manually.

Share this post


Link to post

I am having this problem for the first time today... and I leave for my honeymoon in London in 48 hours. Not great timing... Not bringing my phone, so can't cache with that. Garmin Nuvi is my only option. Boo. :(

 

I guess everyone knows the Pilotsnipes has stopped working. I ended up using a German one [nuvifavoriteexport.gsk] for now on the NUVI. This is OK, since now I have a PN40 plus and Oregon 450 to give me detailed information.

 

In your case you can save a PQ to your phone [GCing App] and bring the NUVI for finding caches by entering coords manually.

 

Yes there is a direct replacement for the Pilotsnipes macro

 

Nuvi_GPX_by_CT.Gsk

 

Works like a charm

Share this post


Link to post

I am having this problem for the first time today... and I leave for my honeymoon in London in 48 hours. Not great timing... Not bringing my phone, so can't cache with that. Garmin Nuvi is my only option. Boo. :(

 

I guess everyone knows the Pilotsnipes has stopped working. I ended up using a German one [nuvifavoriteexport.gsk] for now on the NUVI. This is OK, since now I have a PN40 plus and Oregon 450 to give me detailed information.

 

In your case you can save a PQ to your phone [GCing App] and bring the NUVI for finding caches by entering coords manually.

 

Yes there is a direct replacement for the Pilotsnipes macro

 

Nuvi_GPX_by_CT.Gsk

 

Works like a charm

Share this post


Link to post

THANKS, ...I JUST TESTED THIS and yes it works perfectly. BUT, you will have to pay $20 to update GSAK to version 8!

For me, I will use the German Macro for now, since I have an Oregon and will not need the description, logs and hint that you will get with this MACRO....but for 20 buck [for GSAK 8] it is worth it, if you don't want an Oregon or PN60.

Share this post


Link to post

 

Yes there is a direct replacement for the Pilotsnipes macro

 

Nuvi_GPX_by_CT.Gsk

 

Works like a charm

 

I use this one as well and it is great - the only problem I have is that when I get to 400m (set it up that way) it does not only ping once, but keeps pinging - any suggestions?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 1

×
×
  • Create New...