Jump to content



Recommended Posts

Wherigo\\kit will be up whenever the DNS has time to populate the change I made. I have no idea how long that will take. I thought the change would have been populated throughout the world by now.


For kicks and giggles, you can now access Wherigo\\kit from a second URL: http://kit.wherigofoundation.com If you need to access your cartridge before the DNS change kicks in, please feel free to use this URL. Will I continue hosting Kit on this URL? Sure, why not?


I tested everything by creating a new cartridge, giving it a few images, saving it, playing in Webwigo, and exporting the cartridge (as ZIP, GWZ, and GWC).

Link to comment

Yeah! The DNS has been updated!


Please let me know if you experience any issues. If you experience any problems with the site forgetting your images, it's now likely a coding issue. Considering the web host began having issues keeping the site up at the same time you began having problems with missing images, I'm attributing your problem to that.


I'm now using the same web host as the Wherigo Foundation site, at roughly the same service tier. I'm also able to add more resources to the site if it's ever slow. Fun times.

Link to comment

I'm having a problem with Wherigo\\kit and I don't know where the right place is to ask for help so I'll just try here.


I'm doing a new Wherigo geocache and decided to try the new Lights Out kit. I added three zones (group one with only one zone with a question, group two with five zones with various messages and questions and group three with only the final zone). After completing constructing the cartridge yesterday I downloaded the gwc file to my Iphone 4S (Wherigo app) and my Sony Experia Z1 (WhereYouGo app) and went out to test the cartridge in the field. First problem; after opening the cartridge and clicking play on my Z1 I encountered an error message saying "you hit a bug! please report at openwig.googlecode.com and i'll fix it for you! java.lang.RuntimeException:attempted index of non-table stack trace: at <cartridge name>.lua:921" (substitute <cartridge name> with the actual name of the cartridge). That was the end of the test of the Android version. On my Iphone on the other hand, it worked fine until I had completed the second zone group, then I encountered problem number two; no zone group completion message was shown and neither were the zones in the next group. I was stuck in the cartridge with no zones to go to.


So I went home and decided to do the cartridge with the Q&A kit instead since that should work just as well. I completed the cartridge, loaded it to my phones and went out to test it today. My Android phone had the same error with this new cartridge. My Iphone however worked like a charm and I could complete the Wherigo without any problems at all.


I have created a Wherigo with the Q&A kit before and that works fine on both my phones so I have no clue whatsoever what the problem might be. Any help or advice would be very much appreciated.

Link to comment

I tested the cartridge in the online emulator. There were no problems at all. Then I thought the problem might be with the WhereYouGo app so I started two other cartridges (also created with the Q&A kit) that I had on the phone, but they started alright, no error message. So it doesn't seem to be a general problem with the app.


Enjoy your stay in Phoenix. If you can have a look at this when you get back home then I'd be really grateful.

Link to comment

The only update I made to Kit recently was to move the task of compiling cartridges back to Kit. (Due to server permission issues, I had to compile the cartridges remotely as the hosting service I had been using didn't allow code like that to be run. Now that I'm hosting Kit in the same environment as the WF site, Kit can deal with compiling the cartridges on its own. This is what I mean.) I made this change on the thirtieth of January. Other than this change, the core Kit code has been the same since the beginning of November.


So let's do this step by step (because I don't have an Android device anymore). I'm wondering if it's due to how the cartridge is compiled. Where are you compiling the cartridge? Are you using Kit to compile it so you can test it? The WF site? Groundspeak's Wherigo.com site?


Do you have a version of a cartridge that works fine and a version of the same one that doesn't? I might be stretching things here. Do you have some older compiled cartridges? Do they work fine? What happens if you download a working cartridge again and run it (back up the old, working version, please, for comparison)?


I'll see about getting an Android emulator on my computer while you look at this.

Link to comment

I'm using Kit to compile the cartridge. I'm not much of a programmer so having everything needed to create a cartridge at the same place is really great. I wouldn't go doing some parts elsewhere unless necessary.


My first Wherigo which was compiled with Kit beginning of August last year was also loaded (the same cartridge version as can be downloaded from Wherigo.com) on my phone and it worked fine. I recompiled it using Kit and loaded the new version onto my phone and the new version doesn't work. I get the same error message as before. But the ending reads: "stack trace: at Slottsskogen.lua:1378". I have attached the new version of the cartridge to this post. The old (working) version is the one that can be downloaded from Wherigo.com (see previous link). Slottsskogen_150222.zip

Link to comment

I'm seeing some interesting things being injected into the end of the cartridge. I think it's to do with preventing the Garmin power off issue. But this also duplicates the the require("Wherigo") statement at the top of the cartridge, which could also be what's wrong. I wasn't aware the new compiler was doing these things. Without an Android device, it's a little hard to tell which part is wrong; I need to get a reliable emulator that's not part of the Android SDK. And for the line number you mentioned, the cartridge doesn't even get to 1300 lines. (The error message "HAX kernel module is not installed" doesn't mean much to me at the moment.)


Anyway, I'll ask behind the scenes at what I found from the compiler and see if that might be feeding into what everyone is seeing. By the way, if you were to download the GWZ (or zip file) from Kit and then go to Wherigo.com's test compile page, I doubt you'd see a problem. Anyway, I'll do some digging and some fixing and get back to you.

Link to comment

I compiled both my cartridges (the new that I'm building and the old that has been working before, but not with a new compilation) on the Wherigo.com test compile page and both gwc files start without problems on my Android. I need to do some field testing before I publish my new cartridge, but I expect no problems since I had none on my Iphone before.


Many thanks for the help! I'll keep watching this thread and compile with Kit and test again if/when you do any updates.

Link to comment

A fix is forthcoming on Kit, later tonight. The compiler code injection is justified: it tries to fix some problems that result from Garmin's implementation of Wherigo. I need to update Kit to compile cartridges based off target device so these helpful little fixes are used. So, first, I'll make an update that fixes the root issue while, over the next few days, I work on some UI changes to let people select their target device.


Thank you to those who brought this issue up.

Link to comment

I recompiled and loaded the new cartridge on my Android and it now starts without errors. I will test walk my new cartridge in the field before publishing it, but probably won't have time to do that until Sunday. I'm pretty sure it will work fine though since it has been tested OK with an Iphone before.


Many thanks for fixing this so quickly!

Link to comment

Not sure where I am suppose to ask this since your Foundation site is easy to set up and the Wherigo I don't understand. I published it to the Wherigo site but it says it's inactive. What do I do now. Wait til it becomes active or am I suppose to contact someone. I have someone breathing down my back on this.

Link to comment

If you've been following the forums, it seems as if my activity has slowed recently. So, what have I been doing? Well, aside from trying to catch up on my geocache logs? (I'm very close to 50K finds, by the way.)


I'm testing and tweaking an update to Kit. It's been a while since I was this serious. Here's what you can look forward to:

  • All new zones will use an eight meter default proximity radius. I have come to believe the default three meters was a dumb idea.
  • The anit-emulator test will guard against even more emulators than before.
  • The user's progress on a cartridge is saved automatically when the next zone is displayed.
  • The final zone will not be deactivated.
  • I have added text obfuscation. A large chunk of my work has been to get this to work right. I'm trying to be consistent with Earwigo instead of creating my own. As of this writing, I've completed testing this for English characters, but it tends not to work as well when it encounters non-English characters. Even after I resolve this issue, I will still consider this a risky feature. I'll allow cartridges to be built with and without obfuscation until I'm sure this can be trusted in all situations.


All these features will be available in the next version of Kit. If you want to use them in an existing cartridge, you just have to download your cartridge's GWZ again from the site and publish it to Wherigo.com. It'll be that easy. I do recommend testing it in an emulator before doing so--especially if you want to use text obfuscation.


I don't know when I'll be done and satisfied with the testing. I've been dealing with other things regarding Wherigo at the same time, so have been alternating where I spend my time (I know I need to get back to some of you who have sent me email). I also need to figure out where I'll be geocaching the next few weekends. If I want to hit that milestone, I need to go back to the way I used to cache in 2008. My commute killed the wanderlust I had back then, so it'll take some willpower and energy to cache solo like that again. As to what I'll use for the 50K milestone, I have no idea (suggestions via private email are welcome; I will refuse all cliche ideas, so no "Mingo" and definitely not Geowoodstock, though I will be attending that this year). I'd rather not use the funds I allocate to the year's three number runs on a weekend flight and car rental just to find one cache, even if it is a milestone.

Link to comment

I have just released the update to Wherigo\\kit. See my previous comment about what's in the update or look at Kit's News page for a more in-depth look at my progress over the past week. I had to put Kit on hold twice during that week to deal with something else Wherigo-related.


Anyway, since I couldn't test text obfuscation (pseudo encryption) with every cartridge the community has produced (as of this writing, Kit hosts 1,860 cartridges--and here I thought there were only 800), I made the obfuscation feature optional. When you download your cartridge, you can select either the usual way or the "encrypted text" link. If I don't hear any complaints from people from now towards autumn, I'll assume the obfuscation works. To test obfuscation, you'll have to download an obfuscated version and play it through in an emulator--or in the field.


Yeah! I released the update! I'm going to celebrate by getting some supper, watching a video, and eating some rocky road ice cream.

Link to comment

I've been using Google Analytics to see if anyone is on the site before I do an update. If you were on between 7:30 PM and 8:00 PM EST yesterday, that might explain it. However, if you did other things with your cartridge, saved it, and those other things are there and the pictures aren't, that'll be something I'll have to look into. I'm assuming those images were JPGs.

Link to comment

Hi Ranger Fox. I sent you an email via your GC profile, but perhaps I should write here.


I have never created a Wherigo before. I'm using the wherigofoundation kit.


Yesterday afternoon I collected coordinates for 5 stages which I'm using for my cemetery Wherigo. Spent the evening creating the Wherigo via the website. The name is Farnham Cemetery. Saved as I was creating each stage. Everything looked good (except the images were broken). Today my unpublished cartridge is gone. Is there anyway you can restore the cartridge? Was there something I did to cause my cartridge to disappear?

Link to comment

I have a way to impersonate user accounts on the site so I can look at reported issues like this.


I see your cartridge listed on your cartridge list page (Wherigo.rangerfox.com/account or kit.wherigofoundation.com/account, depending upon the URL you use to access Kit). It has six zones, all named "New Zone", that generally head in a southwesterly direction. You have two images currently associated with the cartridge. I haven't done anything to the server, nor have I nudged anything in the database. I have to be able to reproduce a problem before I can solve it effectively.


I tested this using both URLs for Kit. If it seems your cartridge disappeared, perhaps your browser cached the page? Try refreshing the page to see if that helps.



By the way, during work hours, I tend to check the forum before email. If it's a private issue that doesn't belong on the forum, though, please do feel free to email me. I don't want to discourage that.

Edited by Ranger Fox
I added the "by the way" comment.
Link to comment

I have a way to impersonate user accounts on the site so I can look at reported issues like this.


I see your cartridge listed on your cartridge list page (Wherigo.rangerfox.com/account or kit.wherigofoundation.com/account, depending upon the URL you use to access Kit). It has six zones, all named "New Zone", that generally head in a southwesterly direction. You have two images currently associated with the cartridge. I haven't done anything to the server, nor have I nudged anything in the database. I have to be able to reproduce a problem before I can solve it effectively.


I tested this using both URLs for Kit. If it seems your cartridge disappeared, perhaps your browser cached the page? Try refreshing the page to see if that helps.



By the way, during work hours, I tend to check the forum before email. If it's a private issue that doesn't belong on the forum, though, please do feel free to email me. I don't want to discourage that.


Thanks Ranger Fox. Being a complete newbie at this I didn't realize that my cartridge would be on kit.wherigofoundation.com. When I got home I checked my Firefox history and went back to the page where the cartridge is, alive and well. The images are broken on my page (viewing it on my laptop), but maybe they work via iphone. Yes, you're correct there are 6 zones, I wasn't at home when I wrote my initial post so I just guessed. :rolleyes: . Just figured out that "New Zone" can be renamed. Doh. Thanks. I'll keep working on my first Wherigo. I'm liking the kit. A bit of a learning curve but not hard. I like that I can create it at home. Much easier then out in the field. I should hopefully be able to test it in the field tomorrow or Wednesday.

Link to comment

Anything with a little pencil icon next to it can be renamed or edited (zone name, coordinates, and proximity radius). I opted for that type of UI because text boxes everywhere don't look as good.


I tried going on kit.WF (abbreviating the URL) to look for broken image links, but all I see are the two images you've had, one of a house and one of a grave marker.


I'm glad you've been enjoying Kit.


I remember doing a quick one day cache run up on London. It had nice variety. And I got a little fox in my Kinder Surprise; everyone laughed since it was appropriate.

Link to comment

Hi Ranger_Fox,


Thanks for fixing the glitch with the photos the other day.


I tested my new Cartridge out in the field today on my old Garmin Oregon and it worked perfectly. I've never tried to play a Wherigo using my smart phone (Samsung Galaxy S III mini) before but I thought I'd better try it out as I guess that is the way most people play? I successfully installed the WhereYouGo App and the cartridge started fine but when I got to the first question when I tapped the "Answer" box it returned "Try Again" and did not allow me to enter my answer. Is this likely to be a problem with my cartridge or a compatibility issue?


Many thanks



Link to comment

Please disregard my last message. I tested the cartridge on my daughter's phone today which has a larger screen and I saw that under the photo was the cursor which I needed to tap to be able to type my answer! So all OK :)

Edited by lost!
Link to comment

Hi Ranger Fox,


I'm working on a new Wherigo using Kit (Question & Answer) to create and compile it for testing. It seems I'm running in to the same problem that I reported on Feb 15 and that you fixed then. I.e. when I test the cartridge on my Sony Experia Z1 (WhereYouGo app), after opening the cartridge and clicking play I encountered an error message saying "you hit a bug! please report at openwig.googlecode.com and i'll fix it for you! java.lang.RuntimeException:attempted index of non-table stack trace: at cartInmemoryofGSS2015.lua:418". That was the end of the test of the Android version. On my Iphone on the other hand, it worked fine to the end.


So for test purposes I recompiled my previous Wherigo and loaded that cartridge to the phone with a different file name. The old compilation worked fine, but the new compilation crashed with a similar error message as my new Wherigo.


Can you please have a look at this and see if you can fix it?


Many thanks!


Link to comment

Did you use the obfuscated/encrypted text option? Something else? There were a few other things I did to cartridges, such as making sure the final zone remained active, but nothing else was as major as the text obfuscation.


Could you send me the two files for comparison? I'd like to make sure what I suspect is going on.


For now, I've removed the obfuscation option from Kit until I address how it handles special characters, such as smart quotes, that can't be rendered within the app.


I'm trying, but it's not that easy. And it's Kit, so it has to be easy on everyone else. And it has to work reliably for everyone. And if the problem is that text obfuscation, it didn't work reliably for everyone.


Oh, and thank you for reporting an issue. I'd much rather have someone say something than think everything is fine.

Edited by Ranger Fox
Link to comment

I have sent the cartridge files via email instead of through the forum. I hope that is OK.


I don't know if I used text obfuscation or anything else in particular. I just ran with the default settings, not changing anything.


By the way, you don't need to thank me for reporting the error, I'm happy to. :-)

And I'm also very grateful for this fantastic tool that you have created. I'm sure it has taken a lot of time and effort and developing it further and providing support to the community must take a lot of time too. So thank you!

Link to comment

Kit compiles the cartridge for the emulator. The compiler injects some code to try to be helpful. WhereYouGo doesn't like this code. So I told the compiler to compile for WhereYouGo, which seems to be the lowest common denominator. Had you updated Wherigo.com with your cartridge's changes, it would have been fine and people--downloading from Wherigo.com--wouldn't have had any problems.

Link to comment

Hi Ranger Fox


First off thank you so much for all your fantastic work on Wherigo\\kit.


I hope this is the correct place to ask a question,


We constructed a cartridge back in 2008 using the Wherigo builder but being far from programer we kept having bugs and eventually archived it.


Using your software made our next try a breeze, "Wooden Work 28: The Wherigo V2" a very simple one to star with.


We ran it in the emulator and it worked fine we copied it to the android and took it for a field test again it worked faultlessly.


When we try and load it to Wherigo.com it just says error and the only option is to return to the home page.


Copy of <a href=" http://www.Wherigo.com/error/err.aspx?aspxerrorpath=/cartridge/edit.aspx

">Error</a> message


Am I missing something?


Any assistance will be greatfully accepted.


Again thank you for all the time and effort you spend helping us make these cartridges.

Edited by Team Crackers
Link to comment

The short answer: remove the HTML from the description boxes on Wherigo.com and you won't see that error.


The Long Answer

Okay, so I gave Kit a very thorough checking-over. The description fields are stored with regular non-HTML line breaks in Kit. That's how it puts what you type into the cartridge file. Wherigo.com then looks in your cartridge file, sees the line breaks, and decides to be helpful and display them as HTML. In the text area on its site. Where if you save that form with HTML content in it, the site croaks and dies. Since transferring the cartridge over to Wherigo.com does not involve the front-end site, its code is fine with converting the line breaks to HTML and storing that in the database. It's the web UI code that's set to not allow "dangerous" form submissions that include HTML.


Here's an interesting bit of information (I've known this for a while). Let's say you upload a cartridge with "upload" as its description. On the Wherigo.com site, you change the online description to "site" and save your listing. You download the cartridge to play in an app. The cartridge's description is "site", not "upload". Any line breaks you put in the online form are translated into HTML (sort of; the line breaks are still there, but it also adds the HTML). Now, let's say you make your cartridge open source and download that. Your cartridge's description is "upload", just how it was when you uploaded it. Now, if you use two spaces in a description, Wherigo.com replaces it with "  ", but at least it doesn't crash if you save that.


The Fix

So I have two options: 1) continue to let people encounter this problem when publishing a cartridge or 2) remove the line breaks from the cartridge description, meaning you won't have any line breaks for those descriptions when someone looks at your cartridge in a player app. Considering Wherigo.com will replace your description with whatever you type there, I've chosen to remove all line breaks from your descriptions and replace them with one space, which isn't rendered ugly as " ".


Kit has been updated. (I wrote this post earlier in the day, but had to wait until people were off the site before I could update it.)

Link to comment

Thank you so much for your very prompt reply and explanation.


I tried again to upload the cartridge and took the HTML out of the description but still came up with the same error.


Rather than take up more of you valuable time explaining it to a person with very limited HTML knowledge I will take on board

your suggestions and make a whole new cartridge with out line breaks and only one space between words and see how that goes.


Again many thanks for your fantastic assistance.

Link to comment

I am very sorry ranger Fox but I must be missing something very simple.


I made a new cartridge "Wooden Work 28 The Wherigo Revisited". I had no line breaks and only put 1 space between and words or lines.


It played faultlessly in the emulator and on the phone.


Unfortunately when I tried to upload it I got the same message from Wherigo.com. ERROR.


I know I am missing something but do not understand what.


Again apologies for bringing up what is probably a very straight forward problem to someone who understands programming better than me.


I love the ease of using your kit and how simple it has made Wherigo creation.

Link to comment

I've used Kit several times now and it performs flawlessly. It has potential to make Wherigo mainstream.


If I want to expand a little, for the audience to interact with characters and items, or perhaps have a choice in Wherigo paths they choose, am I best off laying down the groundwork in kit and then exporting to another builder? Or should I be doing everything in another builder? Will the kit ever add characters/items/item dependent zones (if yes then I will wait!)

Link to comment

You can lay the groundwork quickly and easily in Kit, then export it to another builder application since I've been trying to restrict Kit to outputting the same cartridge code as Groundspeak's builder. This allows you to import into Urwigo (or Groundspeak's builder, of course). I could do some interesting things if I departed from that.


I've considered adding characters, items, and nonlinear story elements to Kit. But the more stuff I add, the more complicated things get for beginners. I'd need a lot of free time to draw out how I want everything to look so the additional things don't make cartridge authorship more complicated. Here's a really good example: let's say you have a player looking around for the answer to a question. If the player wanders around, there's a chance he or she will exit and reenter the zone. If this were to happen, the messages and inputs would be displayed again (causing the infamous Garmin power-off bug, for which the Wherigo Foundation now has additional code injected into a cartridge to fix that). Kit solves this problem by disabling the zone automatically upon entry. If I were to allow characters, items, and zones that have to remain active, I have to give that control over to beginning authors. Not adding something that prevents a zone's event chain from firing upon subsequent reentries is an all too common author mistake. So whatever Kit does, I have to handle that in the background. So it's not as simple as it looks to add more things to a builder that's geared towards making things easy on the author.


(If you were wondering how I'd solve the example problem, I'd create a flag variable that tells the cartridge to ignore the event chain. When a user enters a zone, there'd be an if/then statement to prevent the chain from firing. At every possible exit point in the event chain, I'd make a callback to reset the flag. If I abandoned builder compatibility, I could make some more elegant code. However, I'm still trying to retain that compatibility.)


(If I was just working on Kit, I'd be able to do a lot more. I'm just running out of time to do things these days, plus I'm working more overtime at work.)

Link to comment

I wanted to say "THANK YOU" so much for the website and keeping it simple.


NOW, I think I'm just having issues and not getting this figured out.


I'm trying to create a simple Wherigo for the first one in our area of the state. I have all the coordinates and trying to get them put into zones and create a fun story to have the people work through.


When I type in the cords, it takes them quite a ways off (could be our GPS is off) and I can't get them to link. Also, after I hit it, it seems to lose where my cords are at. I have tried to duplicate it and start over and that just made more of the same mess.


Any help, I would appreciate! I'm pretty new to this and would like to make something fun and get kids involved.

Link to comment

Perhaps you're pressing the return key after typing the coordinates and that is causing the page to be resubmitted? (If so, I need to prevent that, though I thought I had.)


After you enter coordinates, try clicking elsewhere in the white balloon box. See if that helps. If not, can you email me some steps to reproduce, such as the cartridge name, zone name, and the coordinates you're trying to use?


I've been tempted several times to expand Kit to include other things. Two things have thus far prevented me from doing so: 1) I'm working on the Wherigo Foundation site, which I hope will replace Wherigo.com (at the moment, I'm reading up on new technology so I can improve the front end and code to the new standards--it's tedious reading), and 2) as you've stated, Kit is supposed to be simple, and I have to make sure any changes can be immediately understood by someone without any experience in Wherigo (or someone who wants to make a cartridge very quickly). But, mostly, it's a conflict between working on the WF site verses Kit.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...