Jump to content

New Garmin map62 problem, wierd


nedinwc
Followers 6

Recommended Posts

I bought a new map62 a week ago, and while using it to search for geocaches found that if I hit the menu button or another button to access some info, the unit would power off. This happened over and over again, but only while I'm in the hunt for a cache and I want to read the cache description, find a hint or just stop the search. Other times it works fine. I contacted Garmin and they figured it needed repair. Since it was two days old, I returned the unit and got a new one. The new one does the same thing!? Firmware is all up to date, I don't get it.

BTW, how DO you stop navigating? I tried to find that menu, but well, it shuts down.

Edited by nedinwc
Link to comment

Thanks for the hint. Pressing find during navigation will shut it down also...sometimes. Maybe I'm overloading it by searching around for what I want.

Someone mentioned this on another thread:

 

"ALSO, recent problems with resets and crashes on gpsmap62stc, all have been fixed for me by running GARMIN WEBUPDATER application. And installing firmware update.

If you find it's really not working, I got a reply from garmin after a 2 week wait which said do the following:

 

To perform a master reset:

1. Ensure the device is powered off 2. Press and hold Page and Enter simultaneously 3. Power on the GPS while continue to press both buttons

NOTE: Immediately release the power button once the GPS powers on

4. Release on the buttons once the Do you really want to erase all user data? message appears 5. Select Yes

The GPSMAP 62, 62s, 62st, 62sc, or 62stc is now reset. You will want to leave the device outside with a clear view of the sky for a minimum of 20 minutes to acquire satellite data."

 

I've done that, don't know if it will work.

Edited by nedinwc
Link to comment

I was having the same problem a few days ago, but can't replicate it now. When navigating to a cache, from the map screen, pressing menu would cause shutdown.

 

So, there is something wrong somewhere, it isn't just me? I was starting to get paranoid. Maybe it's in the PQ somewhere? a strange line of code? I am severely ignorant in tech matters, just grabbing at straws.

BTW, you'll find me again searching for answers in another thread you monitor.

Edited by nedinwc
Link to comment

I have found a solution. Perhaps a remedy not a cure, but it works. From the geocache navigation screen, before hitting the menu button or the find button, close the dashboard (with the compass pointer) at the top of the screen (by using the up pointer in the rocker button). The unit will now not shut down. Yay.

Link to comment

This seems to have started after I upgraded to the 4.5 level of the firmware. I've notice that from the detailed geocaching dashboard I have no problems but from the regular geocaching dashboard the unit will shut down when attempting to look at or find geocaches.

Link to comment

This seems to have started after I upgraded to the 4.5 level of the firmware. I've notice that from the detailed geocaching dashboard I have no problems but from the regular geocaching dashboard the unit will shut down when attempting to look at or find geocaches.

 

Updated my 62st to 4.50 and my unit now shuts down seemingly randomly. Seen it while on the Map display and switching to/from the Trip Odometer page. I have done a complete reset and notice that the battery type was changed back to Alkaline and so just set the correct type and see how we get on.

Edited by ApacheFlyer
Link to comment

Just adding my .02 worth, I have a 62s running version 4.5, and cannot duplicate the error. All buttons function as normal while navigating to a cache, and it works normally while displaying all screens (map, compass, elevation, routing). Is there another setting that may be causing it?

Link to comment

I updated my GPSmap 62s from firmware 4.3 to 4.5 this morning. Out at my first geocache today I saw my GPS turn off when I hit the quit key to change the page. I thought it was batteries so I changed batteries. The problem persisted with the new batteries. While navigating to a cache I wasn't able to change the page to see cache info or log it as found. The GPS would turn off when I'd hit any button except the zoom In or Out buttons or the panning button. If I navigate to a waypoint instead of a geocache the problem didn't exist.

 

I found a temporary work around until I could get home and try to troubleshoot this or find a way to downgrade the firmware. I found that while navigating to a cache if I pan with the pointer on the map screen I could hit menu without the GPS turning off. From here I could select View Geocache and get to the geocache menus to view info or log attempt. I only did a couple caches this way before I was sent home by some rain and frustration with the problem.

 

At home I realized the problem may be caused by a combination of settings I use on my GPS. The first thing I thought of was that I use the Geocaching Dashboard on the map page. I changed the dashboard to Geocaching-Detail and was very excited to see the problem was gone! The problem with the firmware seems to be limited to when you use the Geocaching Dashboard.

 

The problem is as good as solved by changing to using the Geocaching-Detail Dashboard.

 

To change the Dashboard, from the map page hit Menu => Setup Map => select Data Fields => select Dashboard. Change the Dashboard to I think anything but Geocaching. Mine tested OK with Compass or Geocaching-Detail. I didn't want to use the other choices.

 

Good luck,

Ron

Link to comment

Just a quick update,

 

I thought the problem had gone away as the unit ran for several days trouble free, but went out again today and in the 'real world' the GPS switched off again.

 

I also noticed that my screen kept dissappearing but pushing any key brought it back - wonder if this is some new economy mode rather than just switching the backlight off.

 

I'll try Raddad637's suggestion but at the end of the day, we shouldn't be having to work around this - Garmin should be looking at this. I for one will be sending an email to support.

 

Edit: I had a look at the suggestion and just thought I should add that my display Data Fields was set to '0' when this problem shows itself.

 

Edit 2 - Seems Garmin may have done a small update, but my software revision still shows 4.50 - however my battery type did change back to default Alkaline.

Edited by ApacheFlyer
Link to comment

Aha, I think. I managed to replicate the problem by turning on the Geocaching-Detail dashboard, as described by Raddad637. The problem also went away went I switched to the Geocaching dashboard. I think I'll go back to not using the Dashboard feature at all, although I agree it should be fixed.

Link to comment

Aha, I think. I managed to replicate the problem by turning on the Geocaching-Detail dashboard, as described by Raddad637. The problem also went away went I switched to the Geocaching dashboard. I think I'll go back to not using the Dashboard feature at all, although I agree it should be fixed.

 

Hmmmm. That's the opposite of my results. Do what works or you're without the GPS for caching. I'm going to report the problem to Garmin on Monday. 1-800-800-1020 The more people that do the better.

 

The best solution is as jmonti did, to downgrade the firmware.

 

jmonti told me "I used this page off the wiki to get the backlevel firmware:

http://garmingpsmap.wikispaces.com/Versions

I just downloaded the 4.4 level and then opened it with the webupdater.

(had to do an "open with"). I'm now running 4.4 with no problems."

 

Doing this resets all settings back to factory defaults. Be prepared to set things back your way.

Link to comment

I updated my GPSmap 62s from firmware 4.3 to 4.5 this morning. Out at my first geocache today I saw my GPS turn off when I hit the quit key to change the page. I thought it was batteries so I changed batteries. The problem persisted with the new batteries. While navigating to a cache I wasn't able to change the page to see cache info or log it as found. The GPS would turn off when I'd hit any button except the zoom In or Out buttons or the panning button. If I navigate to a waypoint instead of a geocache the problem didn't exist.

 

I found a temporary work around until I could get home and try to troubleshoot this or find a way to downgrade the firmware. I found that while navigating to a cache if I pan with the pointer on the map screen I could hit menu without the GPS turning off. From here I could select View Geocache and get to the geocache menus to view info or log attempt. I only did a couple caches this way before I was sent home by some rain and frustration with the problem.

 

At home I realized the problem may be caused by a combination of settings I use on my GPS. The first thing I thought of was that I use the Geocaching Dashboard on the map page. I changed the dashboard to Geocaching-Detail and was very excited to see the problem was gone! The problem with the firmware seems to be limited to when you use the Geocaching Dashboard.

 

The problem is as good as solved by changing to using the Geocaching-Detail Dashboard.

 

To change the Dashboard, from the map page hit Menu => Setup Map => select Data Fields => select Dashboard. Change the Dashboard to I think anything but Geocaching. Mine tested OK with Compass or Geocaching-Detail. I didn't want to use the other choices.

 

Good luck,

Ron

 

After A HUGE headache with my new 62s, and several not-so-fun caching days of abnormally high blood pressure, I tried this and it seems to have worked. Going from Geocaching dashboard to Geocaching-Detailed dashboard I think has solved the problem. I'll post back if there's still something wrong to let everyone know.

 

It was so frustrating... I spent weeks researching GPS devices, asking around... spend hundreds of dollars on a brand new device that had so many great reviews, only to have it rendered 95% unusable after upgrading from 2.* to 4.5. Thankfully, changing dashboards seems to have finally got it working again.

 

Thank you so much, Ron. Cheers from beautiful Autumn in NY!

Link to comment

 

It was so frustrating... I spent weeks researching GPS devices, asking around... spend hundreds of dollars on a brand new device that had so many great reviews, only to have it rendered 95% unusable after upgrading from 2.* to 4.5.

 

Don't give up, it is just firmware and can be changed. I have had my 62st for 10 months now and up until the 'upgrade' to 4.50 operation has been solid and I would still recommend this unit to anyone.

Link to comment

I talked to Garmin today and lead them through the problem and they also had the shutdown issue. It appears to only happen on the geocaching dash board and not the detailed geocaching dash board. Hopefully they will havew a fix soon.

 

I did revert back to software version 4.40 and the problem is gone.

That's great! I never have actually been able to talk to Garmin. And yes, it only happens to me when the geocaching dashboard is active. I was closing it up to move between options, but have changed to the detail view as others have done.

Link to comment

I talked to Garmin today and lead them through the problem and they also had the shutdown issue. It appears to only happen on the geocaching dash board and not the detailed geocaching dash board. Hopefully they will havew a fix soon.

 

I did revert back to software version 4.40 and the problem is gone.

 

That's perfect, Bango Shank. I'm glad you got them to see the problem. I dropped the ball and forgot to call them today. I'll try tomorrow just to log another vote to get it fixed.

 

I'm at 4.4 and it seems to have resolved a different issue also. I often experienced where the screen would freeze up if I reviewed a different cache's info while I was still navigating to the current cache. That's another topic and I told Garmin about that one too but never heard back. Hopefully they fixed it. Seems like they did.

Link to comment

I'm glad that I'm not the only one. I finally upgraded from my beloved 60csX, as it was having battery power recognition issues. Between that and the allure of paperless caching (now that Palm is not a good option), I was called over to the dark side.

 

Garmin has been pretty good about listening to their customer base in the past; I hope that this is no exception. Thanks, Bango Shank, for putting in the time and effort to contact Garmin.

 

-HC

Link to comment

Aha, I think. I managed to replicate the problem by turning on the Geocaching-Detail dashboard, as described by Raddad637. The problem also went away went I switched to the Geocaching dashboard. I think I'll go back to not using the Dashboard feature at all, although I agree it should be fixed.

 

Hmmmm. That's the opposite of my results. Do what works or you're without the GPS for caching. I'm going to report the problem to Garmin on Monday. 1-800-800-1020 The more people that do the better.

 

The best solution is as jmonti did, to downgrade the firmware.

 

jmonti told me "I used this page off the wiki to get the backlevel firmware:

http://garmingpsmap.wikispaces.com/Versions

I just downloaded the 4.4 level and then opened it with the webupdater.

(had to do an "open with"). I'm now running 4.4 with no problems."

 

Doing this resets all settings back to factory defaults. Be prepared to set things back your way.

 

Yea!!! Thank you for the tips, I confirm it solves the bug. I went back from 4.50 to 4.40 and was not able to reproduce this bug. Garmin should communicate more about this issue.

Link to comment

Brand new 62s here, was having a serious bout of buyer's remorse until I found this thread. Eagerly awaiting the next firmware upgrade, until then I will try the detailed geocaching dashboard or downgrading to 4.4.

 

Thank you for posting this.

 

EDIT:

I found a similar thread addressing this issue over on the Garmin Forums.

 

I was poking around on Garmin's site and found a beta version of a newer firmware, v4.52 (beta). Indicates they might have fixed the problem (maybe?)

Fixed potential issues with geocaching dashboard.

...Confirmed here. (With the help of Google Translate!)

Edited by rogue_hiker
Link to comment

Just discovered this problem the last couple days.

 

Version 4.5

 

Below is what happens when you hit these keys:

Log Attempt: OK

Show Description: Blank Screen - lock up

Show Logs: you get two words at the top left side of the screen (logs: Trackables:)

Show Hint: Blank Screen - lock up

Enter Next Stage: OK

Find Another: OK

Show Found: OK

 

This is what I've seen so far. My husband will probably downgrade to the previous version tonight.

Link to comment

I own a Garmin 62s & just downgraded the software to V4.4 from V4.5 ...and it now works fine...:rolleyes:

 

My problems started when I returned from overseas & I upgraded to Ver 4.5.. I loaded my GPX files & checked to make sure they were on the GPS. A week later I went Geocaching & my GPS could not find the GPX files ..

The screen said go to Geocaching.com :sad:

 

You can get older software Versions HERE install instructions are at the bottom of the page :)

 

CHEERS

 

Hope this Helps !!

Link to comment

I upgraded to 4.52 beta and I'm still having problems with the geocaching dashboard. Such as:

 

- when navigating to a daughter waypoint of a particular geocache, the map won't update (blank screen except for dashboard)

- slow refresh time for entire unit when dashboard displayed

- the dashboard shows the title of the closest geocache, even when 'navigating' to another one

 

With the geocaching dashboard turned off, everything works fine. I have reported this to the Garmin beta e-mail address.

 

Dave

Link to comment

I'm not exactly what my husband did ...still running 4.5.

It's working now (for now). He uses GSAK to load caches unit. Not sure if that's related. The icons changed and he's not sure why? Or whether its from GSAK. Our is still under warranty and we're halfway tempted to send it back!

Very disappointing. It's been our favorite since we bought it. Makes the Oregon look better at this point.

Edited by Lieblweb
Link to comment

I upgraded to 4.52 beta and I'm still having problems with the geocaching dashboard. Such as:

 

- when navigating to a daughter waypoint of a particular geocache, the map won't update (blank screen except for dashboard)

- slow refresh time for entire unit when dashboard displayed

- the dashboard shows the title of the closest geocache, even when 'navigating' to another one

 

With the geocaching dashboard turned off, everything works fine. I have reported this to the Garmin beta e-mail address.

 

Dave

 

- the dashboard shows the title of the closest geocache, even when 'navigating' to another one

This has always been the case. To avoid confusion, set the GPS to only show the dashboard when not navigating.

 

I upgraded to 4.60 and have posted my thoughts / findings on this thread:

http://forums.Groundspeak.com/GC/index.php?showtopic=304315

 

Link to comment

We upgraded to 4.6 yesterday. It'll get some geocaching time over the holidays. We'll see what happens. Initial findings - it hasn't locked up why viewing description or hints (as it did previously). Hoping this works. This has become our favorite unit and we were half tempted to send it back (still under warranty).

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 6
×
×
  • Create New...