Jump to content

Garmin etrex 10/20/30 bugs


a544jh
Followers 7

Recommended Posts

I'm taking the initiative to attempt to gather bug reports from us Etrex users to possibly make Garmin listen and improve our experience.

I know that Garmin listening, they have fixed a bug that I mentioned in my

 

As an owner of the Etrex 10 I don't really know how different the software is from the other models but I believe that they are similar in many ways.

 

Here are some bugs and other annoyances that I have with my Etrex 10

 

  • When returning to the geocahching page by pressing the back button (have it set in "page sequence") after starting goto to another waypoint or stopping navigation(from "where to"), the cache list will fail to load properly. Pressing up/down on the joystick will freeze the device. Pressing page and looping back to the geocaching page will fix the issue.
  • When marking a geocache as found, the map symbol fails to update properly (two icons overlay each other).
  • The "Low memory" warning is delayed after startup
  • An icon on the map will not be selected unless the cursor is in the middle, even if the icon appears to be selected.
  • The device will sometimes freeze when entering the Tracks page while the memory is full.
  • Corrupted lines in cache description (Related to full memory?)
  • Waypoints will sometimes get "mixed up" eg selecting a waypoint from the menu will show another.
  • Position updating is still a bit too insensitive.
  • The satellite page display sometimes gets corrupt when WAAS/EGNOS is acquired.

Those were some bugs that came to my mind right now.

 

Can the bugs I mentioned be reproduced on the 20 and 30, and what issues have you found in your devices?

 

I hope that Garmin will make efforts to improve the software in their devices and that we users could help out finding issues in the software.

Edited by a544jh
Link to comment

Recently my eTrex 20 has started hanging when I connect it to my computer. It gets to "Saving all waypoints, routes and trip log information in GPX format. 100% complete," then never goes to the USB connection verification screen. I've discovered that disconnecting the USB cable and then putting it back in does the trick. (The eTrex gets upset while the cable is out; it beeps plaintively. :laughing: )

 

Given that I can quickly get around the problem, it isn't a major issue. But it shouldn't be doing this. I'm running firmware v2.70. Anyone else seeing this (mis)behavior?

 

Patty

Link to comment

Recently my eTrex 20 has started hanging when I connect it to my computer. It gets to "Saving all waypoints, routes and trip log information in GPX format. 100% complete," then never goes to the USB connection verification screen. I've discovered that disconnecting the USB cable and then putting it back in does the trick. (The eTrex gets upset while the cable is out; it beeps plaintively. :laughing: )

 

Given that I can quickly get around the problem, it isn't a major issue. But it shouldn't be doing this. I'm running firmware v2.70. Anyone else seeing this (mis)behavior?

 

Patty

 

Yes I have seen this. Just once though. I am also taxing out my USB ports......

 

 

Link to comment

I have an Etrex 10, no matter how many geocaches I load, only 19 will show up. I go back and plug it into my computer, and it shows all 50 or so, but when I go to look at my screen (or try to find one), it only shows the first 19. Needless to say, I am not thrilled with the device.

Link to comment
no matter how many geocaches I load, only 19 will show up

Are you looking at the map, or the list view? List view of either waypoints or geocaches will only show closest items - though I though the cutoff was 20 items, not 19.

Edited by user13371
Link to comment

Is it really necessary to calibrate the compass on the eTrex 30 every day? Seems like I have to. Calibrated yesterday and today almost everywhere I point it, it says SW. Calibrate again, and it seems to be working fine again.

Link to comment

Is it really necessary to calibrate the compass on the eTrex 30 every day? Seems like I have to. Calibrated yesterday and today almost everywhere I point it, it says SW. Calibrate again, and it seems to be working fine again.

 

If you replace or reseat the batteries, then it would be normal to need to recalibrate it; they give rise to a strong magnetic field offset depending on type and rotation (try putting an ordinary Silva on top of your GPS!).

 

Unfortunately the compass on the eTrex-30 doesn't work that well... I'm lucky to see it work an hour after a calibration - normal situation is that it starts to randomly oscillate and rotate randomly half an hour post calibration. If the compass functionality is important to you then I suggest you return the device and point out that it does not work. It's really surprising that a navigation company dudded this one, when the smartphone manufacturers have succeeded so well (my $100 android needed calibrating once; since then, the compass has worked just fine.)

 

Compass isn't of importance to me though - I just turned it off, but i like the barometer in the 30. While the altimeter implementation is horrible, it's good as a weather tracker while out!

Edited by tr_s
Link to comment

I have an Etrex 10, no matter how many geocaches I load, only 19 will show up. I go back and plug it into my computer, and it shows all 50 or so, but when I go to look at my screen (or try to find one), it only shows the first 19. Needless to say, I am not thrilled with the device.

 

Curiously enough, despite having 76 waypoints appearing on my map page my Waypoint Manager displays only a list of 19.

Link to comment

Recently my eTrex 20 has started hanging when I connect it to my computer. It gets to "Saving all waypoints, routes and trip log information in GPX format. 100% complete," then never goes to the USB connection verification screen. I've discovered that disconnecting the USB cable and then putting it back in does the trick. (The eTrex gets upset while the cable is out; it beeps plaintively. :laughing: )

 

Given that I can quickly get around the problem, it isn't a major issue. But it shouldn't be doing this. I'm running firmware v2.70. Anyone else seeing this (mis)behavior?

 

Patty

 

Yes, mine does the same thing!

Link to comment

My eTrex 20 freezes up when autorouting and I miss a turn BUT only when I am viewing the "Active Route" page as I miss the turn.

 

Instead of recalculating a new route, like it does if I'm viewing any other page, when viewing the "Active Route" page, it freezes and I must either remove the batteries to get it to restart or hold down the on/off button for 10 seconds to restart it.

 

It's strange that it only freezes when on the Active Route page.

 

I use Software version 2.8

Link to comment

I have an Etrex 10, no matter how many geocaches I load, only 19 will show up. I go back and plug it into my computer, and it shows all 50 or so, but when I go to look at my screen (or try to find one), it only shows the first 19. Needless to say, I am not thrilled with the device.

 

Curiously enough, despite having 76 waypoints appearing on my map page my Waypoint Manager displays only a list of 19.

 

Weird, I've just checked my waypoint manager on my Etrex 20 and all 42 of my waypoints show up. Maybe the 10 works differently to the 20?

 

Apparently with the Etrex 10 only 19 of the nearest waypoints to where you are at the time appear in the Waypoint Manager. To see all of the waypoints you have to go to the map. You can, however, do a spell search and you'll find any waypoint, but it won't be on the waypoint list unless it's amongst those nearest to you.

Link to comment

Recently my eTrex 20 has started hanging when I connect it to my computer. It gets to "Saving all waypoints, routes and trip log information in GPX format. 100% complete," then never goes to the USB connection verification screen. I've discovered that disconnecting the USB cable and then putting it back in does the trick. (The eTrex gets upset while the cable is out; it beeps plaintively. :laughing: )

 

Given that I can quickly get around the problem, it isn't a major issue. But it shouldn't be doing this. I'm running firmware v2.70. Anyone else seeing this (mis)behavior?

 

Patty

 

Yes, mine does the same thing!

 

Make sure its switched on before you connect it to the PC. Most of the time I have mine switched on before connecting it to the PC, but once or twice it's been switched off, and I have had seen issue.

Link to comment

Not a bug as such, but I've been wondering if it's possible to get the 30 to ask on startup if you want to reset the current track. The reason is that I've got a bad memory and often find myself well into a walk before I remember that I didn't reset the track.

 

There is a setting which will automatic archive the track on a daily basis.

Link to comment

Not a bug as such, but I've been wondering if it's possible to get the 30 to ask on startup if you want to reset the current track. The reason is that I've got a bad memory and often find myself well into a walk before I remember that I didn't reset the track.

 

There is a setting which will automatic archive the track on a daily basis.

 

Thanks, I'll give it a go

Link to comment

I'm returning the 2nd eTrex 30 I have had since they came out. This one started acting erratically over the weekend on a road trip. First indicator was several rectangles like a test pattern screen in various colors when I selected the next cache. After that it would shut down every time I selected a cache page description, hint, etc. It required a battery removal to reset. Changed out all PQs, etc, and that seemed to fix it. Today, I tried to load a PQ and when removing from the PC it would not start. Would not accept a master reset. Unwilling to spend any more time on it so returning to REI.

 

Overall I really liked the 30 when it worked. Great size, needed a forward button, but not a deal breaker. Not sure what I am going to get next. Just use my 60CSx for the time being.

Link to comment

Been using an eTrex 30 for several weeks now running 2.8. So far, haven’t found a single bug, I’m very satisfied with it.

 

I would, however, like to see an additional menu option added to the Compass page.

 

When I press the MENU key from the compass page while searching for a geocache, I’d like to see a “View Geocache” selection available. Currently I have to be on the map page to see a “View Geocache” menu selection.

Link to comment

I have an eTrex 10 and really haven't had an issue out in the field. My biggest issue is with the freaking Garmin plugin to connect the eTrex. I use Ubuntu 11.04 OS and I cannot use the Garmin "My Dashboard" to connect to my device. I had to find a Windows machine to connect (which I do NOT own) to my eTrex to get the latest update. This also happens when I go on geocaching.com and click on the "upload to device" option - which is not and issue with gc by the way this is an issue with the plugin that Garmin provides. Garmin apparently does not support Linux users. Very annoying.

 

Fortunately, I can upload my pk's to the device manually without much fuss using my Ubuntu machine.

 

Edit: Also, I know I could get Wine and load up Internet Explorer and do it that way but seriously, should that be a necessary step for me? No it shouldn't. As many Linux users out there they need to support the major Linux distro's.

 

-Dave

Edited by davetherocketguy
Link to comment

Edit: Also, I know I could get Wine and load up Internet Explorer and do it that way but seriously, should that be a necessary step for me? No it shouldn't. As many Linux users out there they need to support the major Linux distro's.

 

Supporting Linux is probably not very high on their list I suppose. You could download the GCD-files from the E-trex wikispaces, and upload it to your device via mass-storage mode.

This, all of course "at your own risk" :)

Link to comment

Edit: Also, I know I could get Wine and load up Internet Explorer and do it that way but seriously, should that be a necessary step for me? No it shouldn't. As many Linux users out there they need to support the major Linux distro's.

 

Supporting Linux is probably not very high on their list I suppose. You could download the GCD-files from the E-trex wikispaces, and upload it to your device via mass-storage mode.

This, all of course "at your own risk" :)

 

Edit: Also, I know I could get Wine and load up Internet Explorer and do it that way but seriously, should that be a necessary step for me? No it shouldn't. As many Linux users out there they need to support the major Linux distro's.

 

Have you tried plugin for linux?

 

I don't use the plugin myself either, just mass-storage and gpx files (pocket queries), most flexible and platform independant :smile:

Link to comment

Recently my eTrex 20 has started hanging when I connect it to my computer. It gets to "Saving all waypoints, routes and trip log information in GPX format. 100% complete," then never goes to the USB connection verification screen. I've discovered that disconnecting the USB cable and then putting it back in does the trick. (The eTrex gets upset while the cable is out; it beeps plaintively. :laughing: )

 

Given that I can quickly get around the problem, it isn't a major issue. But it shouldn't be doing this. I'm running firmware v2.70. Anyone else seeing this (mis)behavior?

 

Patty

 

Mine has just started doing the same thing out of the blue. I know it is not supposed to do it which makes it very annoying.

Edited by Worthing Luvlies
Link to comment

Not sure if this IS a bug. But it's definitely something weird. I turned on my Etrex today and went into my waypoint manager and I had two new waypoints. Both had the Parking symbol. And had random letters and numbers as the name. I know I didn't create these because I name all of mine, and it didn't do it in my pocket because they don't have the usual 012, 013, etc names. They are in a city I was at recently, but I didn't mark these.

They are additional waypoints for caches you loaded from a GPX file you sent to your GPS from the site....it's normal.

Edited by BlackRose67
Link to comment

I have an Etrex 10, no matter how many geocaches I load, only 19 will show up. I go back and plug it into my computer, and it shows all 50 or so, but when I go to look at my screen (or try to find one), it only shows the first 19. Needless to say, I am not thrilled with the device.

 

I have an Etrex 20, if i load 200 Geocaches onto it then ALL 200 show up on the device.

 

Either thats an issue with the Etrex 10 or there is something up with your device.

 

Maybe another Etrex 10 user can comment.

 

Edited to make better sense ;)

Edited by Lowther Gang
Link to comment

 

I have an Etrex 20, if i load 200 Pocket Queries onto it then ALL 200 show up on the device.

 

Either thats an issue with the Etrex 10 or there is something up with your device.

 

Maybe another Etrex 10 user can comment.

 

Do you mean 200 GPX files, one cache per file? If not, why would you load 200 PQs?

Link to comment

 

I have an Etrex 20, if i load 200 Pocket Queries onto it then ALL 200 show up on the device.

 

Either thats an issue with the Etrex 10 or there is something up with your device.

 

Maybe another Etrex 10 user can comment.

 

Do you mean 200 GPX files, one cache per file? If not, why would you load 200 PQs?

 

I loaded 1 PQ which contained 200 geocaches as a gpx onto my etrex ... Thats 200 geocaches around my home.

 

I also loaded another PQ as a gpx onto my etrex containing another 100 geocaches around my holiday home in Blackpool.

 

That means there are 300 geocaches on my etrex that all show on the device.

 

Lowcash2012 is saying that only 19 will show up on his etrex 10.

 

I hope this post makes better sense, reading back my first post didnt ;)

Edited by Lowther Gang
Link to comment

Has anyone come across this one ? Today I downloaded four caches to my eTrex10. I got the added successfully report but they did not appear on the device when I clicked on Where to and Geocaches. I tried them again and I got the already added report so I clicked to overwrite but still they weren't on the eTrex. I went into the Garmin GPS folder on my desktop and they were there. After phoning Garmin I tried adding the files manually using the GPX file button rather than the more direct Send to my GPS option but this did not work although the files were again in the desktop Garmin GPS folder. At the request of Garmin I sent them an email enclosing the files of the four geocaches that won't load properly. After sending the email I realised that the four geocaches were ones I had already found and logged as such on the eTrex (I had intended to take my grandchildren to find them this time) and I began to wonder if it is just not possible to download a cache to the eTrex that has already been recorded as found. This notion was reinforced when I attempted to download several caches that I had not found and they downloaded perfectly normally.

Link to comment

That's a feature, not a bug ... it's how it works :)

I thought that might be the case. Thank you for confirming.

 

On most Garmin GPSr, you can mark found caches as unfound right on the unit, allowing you to see the cache in the Find Geocaches menu, just like the first time, and you can enjoy the hunt all over again!

Link to comment

At least with the eTrex 20, there is an option to display found caches in the list.

 

I do not have an eTrex, but once you do this, can you not select a found cache, and then select 'mark un-found'?

 

On an eTrex 20

 

Select Where to

Select Recent finds

Select The Cache You Want To Unfound (sic)

Select GO

Select View Geocache

Select Log attempt

Select Did Not Find

 

Cache will now appear in your geocache list with others waiting to be found.

Link to comment

I have an Etrex 10, no matter how many geocaches I load, only 19 will show up. I go back and plug it into my computer, and it shows all 50 or so, but when I go to look at my screen (or try to find one), it only shows the first 19. Needless to say, I am not thrilled with the device.

 

Curiously enough, despite having 76 waypoints appearing on my map page my Waypoint Manager displays only a list of 19.

 

Weird, I've just checked my waypoint manager on my Etrex 20 and all 42 of my waypoints show up. Maybe the 10 works differently to the 20?

 

Apparently with the Etrex 10 only 19 of the nearest waypoints to where you are at the time appear in the Waypoint Manager. To see all of the waypoints you have to go to the map. You can, however, do a spell search and you'll find any waypoint, but it won't be on the waypoint list unless it's amongst those nearest to you.

 

I recently bought an etrex 10 and can confirm that having loaded about 30 caches onto it, when selecting go to and then geocaches it only displays the first 19. REALLY irritating if I want to navigate to any of the ones after the closest 19 using the etrex. I can view them on the map and then select one but that's very fiddly when I've loaded a bunch from the same area for a cache blitz...

Link to comment

I have an Etrex 10, no matter how many geocaches I load, only 19 will show up. I go back and plug it into my computer, and it shows all 50 or so, but when I go to look at my screen (or try to find one), it only shows the first 19. Needless to say, I am not thrilled with the device.

 

Curiously enough, despite having 76 waypoints appearing on my map page my Waypoint Manager displays only a list of 19.

 

Weird, I've just checked my waypoint manager on my Etrex 20 and all 42 of my waypoints show up. Maybe the 10 works differently to the 20?

 

Apparently with the Etrex 10 only 19 of the nearest waypoints to where you are at the time appear in the Waypoint Manager. To see all of the waypoints you have to go to the map. You can, however, do a spell search and you'll find any waypoint, but it won't be on the waypoint list unless it's amongst those nearest to you.

 

I recently bought an etrex 10 and can confirm that having loaded about 30 caches onto it, when selecting go to and then geocaches it only displays the first 19. REALLY irritating if I want to navigate to any of the ones after the closest 19 using the etrex. I can view them on the map and then select one but that's very fiddly when I've loaded a bunch from the same area for a cache blitz...

Link to comment

I have an Etrex 10, no matter how many geocaches I load, only 19 will show up. I go back and plug it into my computer, and it shows all 50 or so, but when I go to look at my screen (or try to find one), it only shows the first 19. Needless to say, I am not thrilled with the device.

 

Curiously enough, despite having 76 waypoints appearing on my map page my Waypoint Manager displays only a list of 19.

 

Weird, I've just checked my waypoint manager on my Etrex 20 and all 42 of my waypoints show up. Maybe the 10 works differently to the 20?

 

Apparently with the Etrex 10 only 19 of the nearest waypoints to where you are at the time appear in the Waypoint Manager. To see all of the waypoints you have to go to the map. You can, however, do a spell search and you'll find any waypoint, but it won't be on the waypoint list unless it's amongst those nearest to you.

 

I recently bought an etrex 10 and can confirm that having loaded about 30 caches onto it, when selecting go to and then geocaches it only displays the first 19. REALLY irritating if I want to navigate to any of the ones after the closest 19 using the etrex. I can view them on the map and then select one but that's very fiddly when I've loaded a bunch from the same area for a cache blitz...

Link to comment

I have an Etrex 10, no matter how many geocaches I load, only 19 will show up. I go back and plug it into my computer, and it shows all 50 or so, but when I go to look at my screen (or try to find one), it only shows the first 19. Needless to say, I am not thrilled with the device.

 

Curiously enough, despite having 76 waypoints appearing on my map page my Waypoint Manager displays only a list of 19.

 

Weird, I've just checked my waypoint manager on my Etrex 20 and all 42 of my waypoints show up. Maybe the 10 works differently to the 20?

 

Apparently with the Etrex 10 only 19 of the nearest waypoints to where you are at the time appear in the Waypoint Manager. To see all of the waypoints you have to go to the map. You can, however, do a spell search and you'll find any waypoint, but it won't be on the waypoint list unless it's amongst those nearest to you.

 

I recently bought an etrex 10 and can confirm that having loaded about 30 caches onto it, when selecting go to and then geocaches it only displays the first 19. REALLY irritating if I want to navigate to any of the ones after the closest 19 using the etrex. I can view them on the map and then select one but that's very fiddly when I've loaded a bunch from the same area for a cache blitz...

This feature on the eTrex 10 is confusing and a little irritating but you should find that as you mark earlier caches as found on the unit the hidden ones will appear.

Link to comment

Has anyone come across this one ? Today I downloaded four caches to my eTrex10. I got the added successfully report but they did not appear on the device when I clicked on Where to and Geocaches. I tried them again and I got the already added report so I clicked to overwrite but still they weren't on the eTrex. I went into the Garmin GPS folder on my desktop and they were there. After phoning Garmin I tried adding the files manually using the GPX file button rather than the more direct Send to my GPS option but this did not work although the files were again in the desktop Garmin GPS folder. At the request of Garmin I sent them an email enclosing the files of the four geocaches that won't load properly. After sending the email I realised that the four geocaches were ones I had already found and logged as such on the eTrex (I had intended to take my grandchildren to find them this time) and I began to wonder if it is just not possible to download a cache to the eTrex that has already been recorded as found. This notion was reinforced when I attempted to download several caches that I had not found and they downloaded perfectly normally.

 

This is exactly my problem with my eTrex 30, but after sending NEW geocaches to my GPS, sometimes I'll go out and find that they aren't in my GPS. The difference is I have never loaded or found these geocaches before. This has happened a couple times, but then it works if I go back home and send all the geocaches to the GPS again. Any ideas?

Edited by typrince
Link to comment

Has anyone come across this one ? Today I downloaded four caches to my eTrex10. I got the added successfully report but they did not appear on the device when I clicked on Where to and Geocaches. I tried them again and I got the already added report so I clicked to overwrite but still they weren't on the eTrex. I went into the Garmin GPS folder on my desktop and they were there. After phoning Garmin I tried adding the files manually using the GPX file button rather than the more direct Send to my GPS option but this did not work although the files were again in the desktop Garmin GPS folder. At the request of Garmin I sent them an email enclosing the files of the four geocaches that won't load properly. After sending the email I realised that the four geocaches were ones I had already found and logged as such on the eTrex (I had intended to take my grandchildren to find them this time) and I began to wonder if it is just not possible to download a cache to the eTrex that has already been recorded as found. This notion was reinforced when I attempted to download several caches that I had not found and they downloaded perfectly normally.

 

This is exactly my problem with my eTrex 30, but after sending NEW geocaches to my GPS, sometimes I'll go out and find that they aren't in my GPS. The difference is I have never loaded or found these geocaches before. This has happened a couple times, but then it works if I go back home and send all the geocaches to the GPS again. Any ideas?

I've had the same thing happen a few times. I now download the GPX files to the computer, then move them all at once to the GPX folder on the GPS. That has never failed.

Edited by SoonerSoftail
Link to comment

I've been having issues recently with my Garmin eTrex 30 losing track data; sometimes recoverable via USB after forcing it to rewrite the exported data by deleting the generated GPX files, sometimes they're just completely gone.

 

Yesterday I recorded track data going up a mountain then saved the track and cleared it so I could record the rest of the hike separately. I initially gave the saved track data the default timestamp name but decided to rename it, and then when I tried to View On Map the button was unresponsive (it didn't change to Hide On Map) so I power cycled and when I went back into Track Manager it was gone. Couldn't see it from my computer back at home either.

 

I'd also loaded a bunch of geocaches onto my GPS via ExpertGPS but when out in the field my eTrex 30 said there were no geocaches loaded, yet when I got home and plugged it into my computer via USB I could see the GPX file with all the geocaches right there.Annoying!

 

Not sure if I actually have the 2.8 update; will check that this evening.

 

I'm over the digital compass now. Switched to using lithium AA's but doesn't help much. Maybe it's because I usually have the unit upside down in a pouch on my shoulder? Maybe tri-axial isn't as tri-axial as claimed …

Edited by NathanaelB
Link to comment

I've been having issues recently with my Garmin eTrex 30 losing track data; sometimes recoverable via USB after forcing it to rewrite the exported data by deleting the generated GPX files, sometimes they're just completely gone.

 

Yesterday I recorded track data going up a mountain then saved the track and cleared it so I could record the rest of the hike separately. I initially gave the saved track data the default timestamp name but decided to rename it, and then when I tried to View On Map the button was unresponsive (it didn't change to Hide On Map) so I power cycled and when I went back into Track Manager it was gone. Couldn't see it from my computer back at home either.

 

I'd also loaded a bunch of geocaches onto my GPS via ExpertGPS but when out in the field my eTrex 30 said there were no geocaches loaded, yet when I got home and plugged it into my computer via USB I could see the GPX file with all the geocaches right there.Annoying!

 

Not sure if I actually have the 2.8 update; will check that this evening.

 

I'm over the digital compass now. Switched to using lithium AA's but doesn't help much. Maybe it's because I usually have the unit upside down in a pouch on my shoulder? Maybe tri-axial isn't as tri-axial as claimed …

 

Actually, Garmins software for many of their uber expensive top of the line GPS units have suffered greatly in the past twelve months.... They are producing pure GARBAGE right now, while focusing on pushing out new products and all but abandoning the current market....

 

They may not realize it now, but if they continue on the current path, in another twelve months they will not enjoy the market share they do now.

 

I am not buying any new Garmin products any time soon....

Link to comment

Hi,

 

unfortunately I must agree. Garmin lunch to many products even finished them totally. In the past Garmin react much faster to the bugs that the users found. Even for the most expensive one.

Because I like Garmin I am sad about this situation. I hope this change soon. I prefer less models but more reliable.

 

Future will tell.

Link to comment

 

Actually, Garmins software for many of their uber expensive top of the line GPS units have suffered greatly in the past twelve months.... They are producing pure GARBAGE right now, while focusing on pushing out new products and all but abandoning the current market....

 

They may not realize it now, but if they continue on the current path, in another twelve months they will not enjoy the market share they do now.

 

I am not buying any new Garmin products any time soon....

 

I totally agree. Unfortunately I think the problem isn't isolated to Garmin - the market is shrinking so small for outdoor GPS that it won't see increasing budgets for development any time soon. The functionality is becoming generic and available in so many other devices (inexpensive smartphones).

Link to comment

Some other posts indicate that the problem you've experienced can happen if you don't do a power cycle between deleteing one set of caches and loading another, maybe something for you to try?

That's what I was thinking as well, but I do not power cycle when I load new caches onto my GPS from GSAK, I just overwrite the existing GPX file.

 

I also load my GPX file onto an external sd card, not the internal one.

Link to comment

Recently my eTrex 20 has started hanging when I connect it to my computer. It gets to "Saving all waypoints, routes and trip log information in GPX format. 100% complete," then never goes to the USB connection verification screen. I've discovered that disconnecting the USB cable and then putting it back in does the trick. (The eTrex gets upset while the cable is out; it beeps plaintively. :laughing: )

 

Given that I can quickly get around the problem, it isn't a major issue. But it shouldn't be doing this. I'm running firmware v2.70. Anyone else seeing this (mis)behavior?

 

Patty

 

Mine has been doing this as well. I find unplugging it and plugging it back in works. I have not gone to see if it actually saved my track logs though.

 

Shaun

Link to comment

Have sent the following support request to Garmin, although I'm pretty sure I won't be getting any satisfactory answers back:

 

I've been having issues with my eTrex 30 with generated Current.gpx data being corrupted, losing archived tracks, losing saved track data when attempting to rename it. I've also had the unit tell me there are no geocaches when I can confirm there is a valid GPX file with geocaches on the device over USB.

 

I do have an external microSD card with some topo and routing maps, but all track and geocache data is sent to the internal storage.

 

I'm running the latest firmware so I don't know what I can do to troubleshoot.

 

The poor reliability of data read/write is really starting to annoy me. Has my device failed or could it be software? It's less than a year old.

 

In the meantime I've resorted to never clearing current track data while on the trail, never renaming tracks, never archiving tracks, and doing it all on the computer instead.

Edited by NathanaelB
Link to comment
Guest
This topic is now closed to further replies.
Followers 7
×
×
  • Create New...