Jump to content

Magellan Explorist GC


jennjo
Followers 2

Recommended Posts

I have a Magellan Explorist GC that was been updated tot he newest version 1.7. It worked for a few days, but now when you start it produces an error screen and never completely boots.

 

The screen says:

 

A buffer overrun has been detected which has corrupted the program’s internal state. The program cannot safely continue execution and must now terminate.

Program: Compass.exe

 

I have reset it by the paper clip method. I have to pull the batteries to get it to actually turn it. The only way to get it to connect to the computer is to start it in mass storage modes (holding the joystick up, menu button, and power button) while it is already connected to the computer. I was able to rerun the firmware update and it completed, but when the GPS restarts it produces the same error. I even went so far as to take the compass.exe off a friends device and temporarily replace it on my device with no success. I did switch it back to the original compass.exe after this.

 

Anyone successfully recovered from this?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 2
×
×
  • Create New...