Jump to content

Login


Team BikeFast
Followers 5

Recommended Posts

I can consistently reproduce this issue with the following steps.

 

1. Start Chrome

2. Using my bookmark, go to http://www.geocaching.com/my (I am logged in fine)

3. Close chrome

4. Start Chrome

5. Using my bookmark, go to http://www.geocaching.com/my (I am logged in fine)

6. Close chrome

7. Start Chrome

8. Using my bookmark, go to http://www.geocaching.com/my (I am logged out)

 

Also at the point on #8 I have been redirected to the following URL

 

https://www.geocaching.com/login/default.aspx?RESETCOMPLETE=Y&redir=http%3a%2f%2fwww.geocaching.com/my/

 

I have tested it in both Chrome (19.0.1084.52 m), IE (9.0.8112) and FireFox (11)

 

 

EDIT: Missed the post from the Lakey. Sorry to beat the dead horse

Edited by WestSideDaddy
Link to comment

 

Nate posted about this in post 39. We made a change to cookies in the latest release that is misbehaving. We will have the issue fixed in next Tuesday's release.

 

Thank you!!!

 

It has been a pain in the *ss for the past several days. I'm betting it has someting (everything???) to do with the Facebook login stuff. Just throw it away! Facebook is a big pain too...

Edited by Mr Grinch
Link to comment

Hi all, thanks for the reports. It looks like a change to cookies made in the last release is misbehaving. We've identified the issue and will have a fix out next Tuesday. Thanks for your patience in the meantime!

 

I'll gladly pay you $30 today, for a valid log-in on Tuesday.

 

Why should we have to wait 'till Tuesday for you to fix something you messed up?

 

Yeah, it's just a game, but people are paying you money to have this site working properly.

Link to comment

Hi all, thanks for the reports. It looks like a change to cookies made in the last release is misbehaving. We've identified the issue and will have a fix out next Tuesday. Thanks for your patience in the meantime!

 

I'll gladly pay you $30 today, for a valid log-in on Tuesday.

 

Why should we have to wait 'till Tuesday for you to fix something you messed up?

 

Yeah, it's just a game, but people are paying you money to have this site working properly.

That's basically what I asked back in post #41. For a widespread and extremely annoying bug like this, wouldn't a brief downtime be preferable to a week+ of complaining and unhappy customers? Not very professional in my eyes. They've hotfixed other bugs in the past, why not this one?

Link to comment

Hi all, thanks for the reports. It looks like a change to cookies made in the last release is misbehaving. We've identified the issue and will have a fix out next Tuesday. Thanks for your patience in the meantime!

Yay! This is driving me bonkers. Every single time I close the browser window (not quit the program), I have to log in again - multiple times a day - and "Keep me signed in" doesn't work. (Safari on a Mac here.) Finally came looking to see if it was a known issue. Glad to hear it will be fixed this week. Tuesday can't come soon enough. :P

Edited by hydnsek
Link to comment

That's basically what I asked back in post #41. For a widespread and extremely annoying bug like this, wouldn't a brief downtime be preferable to a week+ of complaining and unhappy customers? Not very professional in my eyes. They've hotfixed other bugs in the past, why not this one?

 

The issue is not hotfixable. It involves changes to the binaries, which means the entire site would have to be taken down to roll out the fix. Given that the code is forked at each release and the code changes would have to merged into the main branch to make an intermediate release, it is far less risky to wait two weeks for the next site release to make a change like this one (which while annoying does not prevent use of the site).

Link to comment

That's basically what I asked back in post #41. For a widespread and extremely annoying bug like this, wouldn't a brief downtime be preferable to a week+ of complaining and unhappy customers? Not very professional in my eyes. They've hotfixed other bugs in the past, why not this one?

 

The issue is not hotfixable. It involves changes to the binaries, which means the entire site would have to be taken down to roll out the fix. Given that the code is forked at each release and the code changes would have to merged into the main branch to make an intermediate release, it is far less risky to wait two weeks for the next site release to make a change like this one (which while annoying does not prevent use of the site).

OK, thanks for clarifying.

Link to comment

That's basically what I asked back in post #41. For a widespread and extremely annoying bug like this, wouldn't a brief downtime be preferable to a week+ of complaining and unhappy customers? Not very professional in my eyes. They've hotfixed other bugs in the past, why not this one?

 

The issue is not hotfixable. It involves changes to the binaries, which means the entire site would have to be taken down to roll out the fix. Given that the code is forked at each release and the code changes would have to merged into the main branch to make an intermediate release, it is far less risky to wait two weeks for the next site release to make a change like this one (which while annoying does not prevent use of the site).

 

I'll be honest with you, I'm really glad that you keep us up to date with the issue. I don't have any problem waiting for a fix if I am told that one is coming. I really appreciate the reply!

 

In the meanwhile, I just created a temporary icon on my bookmark bar in Firefox. I just click on it, and a login page with my info comes up. Just have to press "login".

 

Thanks again!

Link to comment
We've identified the issue and will have a fix out next Tuesday.

Interesting that it is now "next Monday" and there is no banner to warn us the site is going down tomorrow. I wonder if the fix has been delayed :unsure:

I never saw a banner for the last update, and I'm 100% positive I didn't dismiss it. Some did, though. Maybe there's now a bug in the downtime-banner code?

Link to comment

Well still not retaining log in.

 

Today's release has been postponed until tomorrow or Thursday. I'm waiting for official word. We want to have more time for testing the changes involved.

Thanks for the update. Testing is good.

Yes, as per the post you quoted, today's update hasn't happened and therefore the fix hasn't been applied yet.

Link to comment

I hate to come in, in the middle of a thread like this. But I came to the forums today with the specific intention of raising the issue of how I've been able to stay logged into the website for long terms, for years now, thought just recently, I've had to re-log in about every other day or so, and it's annoying, I wonder how I can fix it, I want the problem to just go away.

Link to comment

I hate to come in, in the middle of a thread like this. But I came to the forums today with the specific intention of raising the issue of how I've been able to stay logged into the website for long terms, for years now, thought just recently, I've had to re-log in about every other day or so, and it's annoying, I wonder how I can fix it, I want the problem to just go away.

Read the few posts above yours. A fix is coming, likely in the next day or two.

Link to comment

Please let us know when, no announcment usualy means unforseen issues. I will be pleasantly surprised if it is soon, this is so tedious...............

Ahhh, there we go! A banner just showed up for me:

Geocaching.com will be going offline temporarily for a site update on Wednesday, June 6, 2012 at approximately 2pm PST (convert to your local time here).

Yay!

Link to comment

I'm assumming that rather than just fix the cookie log in bug, they are introducing a cookie opt-in to comply with last months regulations.

I had never heard of this before, so I just did some Googling. As far as I can tell, it only applies to the EU. This is a US site, so it doesn't apply. Anyway, you're opting in by ticking the "Keep me signed in" box.

Link to comment

A fix is coming, likely in the next day or two.

 

...but at the expense of some unrelated function that (so far) has been working fine for years.

 

I'm guessing it will be notifications.

Anyone else?

Nope, those are already broken. See my bug report here.

 

Removal of the old submission form?

Nope, I was wrong. It turned out to be the "Map this location" link on cache lists. <_<

Link to comment

Hi all, thanks for the reports. It looks like a change to cookies made in the last release is misbehaving. We've identified the issue and will have a fix out next Tuesday. Thanks for your patience in the meantime!

 

Is this ever going to get fixed? I'm at the point where I want to punch my computer!!!!!

Link to comment

Hi all, thanks for the reports. It looks like a change to cookies made in the last release is misbehaving. We've identified the issue and will have a fix out next Tuesday. Thanks for your patience in the meantime!

 

Is this ever going to get fixed? I'm at the point where I want to punch my computer!!!!!

It was fixed this afternoon. Is it still not working for you?

Link to comment

Still not working, or even becoming worse!

 

Using: https://www.geocaching.com/login/default.aspx, I cannot log in at all - it just keeps redirecting me to the same page, again an again.

 

Using the login box in the upper right corner, I can log in, however, when I close the browser it is gone again, and I can re-login.

 

If anything, the last update made it WORSE for me, before I was kicked out every few hours and now it's EVERYTIME I close the browser.

 

Fix it please, this is VERY annoying!

 

FYI, I am using Firefox 13.0 on Windows 7 64-Bits

Link to comment

I cannot log in at all to my profile...

I did a reset of the password.

No chance.

Please fix this!

:(

Is there a limitation on the length of passwords? Mine has >10 characters. That might explain why it works for some and for others not...

I don't think that's the case. I just tried changing my password from my usual 8 characters to 14 and 18 character long ones, and I was able to log in with no problems with each.

Link to comment

Still not working, or even becoming worse!

 

Using: https://www.geocaching.com/login/default.aspx, I cannot log in at all - it just keeps redirecting me to the same page, again an again.

 

Using the login box in the upper right corner, I can log in, however, when I close the browser it is gone again, and I can re-login.

 

If anything, the last update made it WORSE for me, before I was kicked out every few hours and now it's EVERYTIME I close the browser.

 

Fix it please, this is VERY annoying!

 

FYI, I am using Firefox 13.0 on Windows 7 64-Bits

OK, now I found the problem: you need to delete the old "user-id"-cookie for geocaching.com.

After that everything works as expected... both login-pages.

Link to comment

Is this ever going to get fixed? I'm at the point where I want to punch my computer!!!!!

It was fixed this afternoon. Is it still not working for you?

 

I think it's fixed now but it wasn't when I posted the above frustration.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 5
×
×
  • Create New...