Jump to content

Magellan Triton 400 Will Not Turn On At All


Followers 1

Recommended Posts

Last night I was attempting to import the .gpx files to VantagePoint to put on my triton, but somewhere in the course of that, the unit shut off (I don't think the batteries died because they were new) and now I cannot get it to do anything. I have spent hours going through forums trying to find any solution to this, aside from sending the unit in to Magellan, but have found nothing that explains an alternative. The only thing I could find is that the SDRAM chip inside the unit needs to be reflashed and that requires it to be sent in for repairs. I am really hoping this is not the case, so any information that anyone could provide would be of great help. More information on what I have tried (nothing has worked so far) can be found below.

 

1) Tried to get the unit to boot in developer mode but it wouldn't even do that. The screen remains blank and several attempts proved unsuccessful.

 

2) Completely uninstalled VP (including running regedit afterward to erase all instances of it) and doing a hard reboot of the computer, then reinstalled to see if it might have been a driver issue of some sort, but had no luck.

 

3) Took the batteries out for a while and put new ones in.

 

I can't replace the files on the unit or delete whatever files on it might be causing the problem since it won't turn on at all. And I already tried taking the thing apart to see if there happened to be some sort of reset toggle on it, but of course, there isn't.

 

At this point, I just want to get the confounded thing working again so I can sell it (I bought it off eBay and am pretty sure Magellan won't be willing to replace it, otherwise I would just do that) and never have to deal with another Magellan product again.

Link to comment

I had a similar problem with a lowrance which had a bad flash clip. It would turn on but wouldn't accept gpx files. I contacted Lowrance and in less than a week I had a new unit. I've never contacted Magellan customer service but you might luck out. However, since you took it apart yourself that may have voided any warranty though.

 

If Magellan tells you it has a bad chip and they won't fix/replace it then contact the ebay seller and tell him it has a bad chip and ask for your money back. You may have to open a case but it should have been fine since you just recently received it.

Link to comment

Does it show any sign of trying to power on? Like the start up screen that shows Magellan Triton and the progress bar.

 

Nope, it doesn't. The screen stays off no matter what I try. Not even developer mode will run. I saw that a lot of people were able to at least somewhat fix whatever issue they were having as long as their unit was able to turn on in some way, but mine just does not want to.

 

The unit seemed to be working initially, but somehow got FUBAR'd during the transfer of the .gpx files. It almost seems as if something (a file/driver/etc) on the triton that was necessary to boot it up got moved or deleted. I'm not sure if that is the case but have no real way of finding out because I cannot access the unit to try and replace whatever got messed up/moved.

 

I think it might be a lost cause unless, like LadyBee4T said, I am able to get the person I bought it from on eBay to accept a return since I literally just received it yesterday.

Link to comment

I have a similar problem with my Magellan eXplorist GC unit. Let me just say that I still have no idea what is causing my unit to not turn on and I am posting this to help other people and maybe we can figure it out.

 

I updated the caches on the unit to a new set of PQ's, turned off the unit and now I can't get it back on. Changed the batteries, usb cable and nothing works. Sometimes if I let the unit sit around a while without batteries and with the usb cable plugged in, I then can turn the unit on (without batteries installed but with the usb cable for power). But, once it is on and I turn it off I can't turn it back on. This doesn't happen every time; sometimes I can't even turn it on at all. If I let the unit sit around for about 10 minutes with no power connected (usb cable or batteries) sometimes I can turn it on with just a usb cable connected but no batteries.

 

At first I also thought it was a bad cache that was causing the unit to not turn on so I reloaded the software on the unit. If you go here, Magellan support site (UK but it doesn't matter) and choose your unit, under the downloads section is the area to re-install the software on your unit to factory defaults.

 

Then I went back to the US magellan website, Magellan US support site, to download the latest firmware and re-installed that. Remember I am doing this with no batteries and just the usb cable for power, along with waiting about 10 minutes after I turn the unit off to "discharge" what ever is causing it to not turn back on.

 

This way I know that there is no funky cache that is causing the unit to not turn on

Link to comment

If the screen does not show signs of powering up, light the display lighting up, then the unit has failed and there is really nothing you're going to be able to do to repair it, which leaves you with only two options for repair/replacement.

 

1) You can contact Magellan, but they're not going to be able to replace it with another Triton since they units have been out of product for more than two years. However, they will offer you an exchange for a new "eX" unit through the Magellan Loyalty program. With this program you will be offered a percantage off of the price of a new GC, 110, 310, 510, 610 or 710. I would tell you the percentage; however, it changes so I haven't quote you one.

 

2) Contact the Jungle Ghost repair center which can be found at http://www.JungleGhost.com and see who much it would cost to repair the unit!

 

I wish I had better news..

 

David

Magellan Insider

Edited by Socal ZukiCachers
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...