Jump to content
Sign in to follow this  
Followers 10
PantherX

SUBMITTED (32975) - Errors with time stamps in logs and field notes

Recommended Posts

Merging duplicate topics.

This was the 9th merge since Feb 29 2012!

 

Are we not able to search the threads OR should GS get its watches globally synchronized?

Share this post


Link to post

Please, fix this bug, it is very annoying and keeps making things complicated if you want to keep you records straight!

Share this post


Link to post

I started a trail today (29th July) at 07:00 BST (GMT+1) writing up the logs as I went around.

 

I uploaded them all together at the end via the app.

 

When I checked my geocache finds on the website later, the first few were logged as 28th July (yesterday).

 

Is the Geocaching iphone app not using the iphone's date/time? It must be using a different timezone to the one I am in for it to be logging things as yesterday! I see someone posted a similar issue over time zones a couple of years ago.

Share this post


Link to post

Is it a bug or known issue that when those of us in the 'eastern hemisphere' post a log for a found cache from the field it will date the log as the previous day and not the day the cache was found.

 

I have all my timezone settings correct but cannot get this annoying issue to stop.

Share this post


Link to post

Even more odd is we have 2 finds on 6/7/11 and 1 find on 6/7/12 but all 3 show up as 6/8 for both years as the found date in the PQ but have the correct date on the web page. Because of these types of errors, we are unable to use any other reporting tools tool such as MyGeocachingProfile. Very annoying as I am a database manager.

Share this post


Link to post

Hello

 

I normally use my iPhone for logging while I'm in the field. I think it is a super nice way of logging, when you have the possibility.

 

During the last week I have encountered twice that my logs made from my iphone in the morning, get a log-date on the website that is the day old.

 

It happened this morning again. I found a cache between 08:15 and 08:30 on Oct 26th, by now later today I can see the log is dated Oct. 25th on geocacning.com

 

The logs made on the iphones need to get the time and date stamp from the phone and not from the website.

 

I hope you will look into this and correct it asap.

 

Please let me know if I can be of any assistance with any information, error findings or testing.

 

Best Regards

 

Rene Birk Laursen

- aka Mr. GeoJump

Share this post


Link to post

I do realise that this is a somewhat awkward trouble to solve in a way that has no side effects on all the logs already out there. But this date issue has some effects that we dont really want, must be admitted.

Attaching a link to a screendump of the (Swedish version of) the geocaching app. The only souvenir I have:

photo20120628204040.png

"Funnen 1 mars 2012" translates into "Found on March 1 2012".

A bit like an erroneously printed stamp...offers anyone for this misprint???

Edited by Stadskasheuren

Share this post


Link to post

Hi, just to throw in another experience on this:

 

I´m from Germany but currently located in Singapore. So i did a Cache on 12/12/12 at around 2 pm Singapore time. My iPhone was already adapted to this timezone for almost one week and everything was correct.

However after submitting my log i did not recieve the Souvenir. When checking via Webpage i saw my log being actually posted with a 12/11/12 timestamp :(

So i had to log again (late in the evening on 12/12/12 Singapore time) and then i recieved the Souvenir. Then i deleted my first log for this cache as otherwise it would have been counted twice as a find for my Profile.

 

All in all quite annoying. I do know about databases and that time-values can be a headache, but somewhere out in the galaxy there must be a solution for this - And i hope it´ll be found pretty soon.

 

And now i finally know why my "Most finds on a single day" has always been one Cache less than my own records showed me - Must also be related to timezone stuff... Kind of unsatisfying that all of this statistics might be incorrect on a certain Level - i mean statistics are for the numbers so they should be correct!

 

Lets see what this Topic will head to.

 

Best regards

Share this post


Link to post

...

"Funnen 1 mars 2012" translates into "Found on March 1 2012".

A bit like an erroneously printed stamp...offers anyone for this misprint???

 

I can send in an screenshot showing my latest "12/12/12" Souvenir being displayed in the iPhone app as "Found, tomorrow"...

Share this post


Link to post

I am having this issue too and am based in Australua, so it affects virtually my whole caching day. Having paid for the app it is very frustrating. I understand the fix may be tricky, but its been broken for a long time and it really reduces an otherwise great experience. Especially since there is no warning so you accumulate multiple logs only to discover the issue later :(

Share this post


Link to post

I've set all the right time zone on my account in the couple of places you can on the web interface, however when I go to log a cache at certain times of the day (I live in Australia) it sometimes logs as the day before.

 

Can someone resolve this issue as I would like to log my caches on the app instead of the pen and paper technique to log back at home later.

Share this post


Link to post

Since it seems to be impossible to heal that error, it would be nice to have an additional '+1' and a '-1' or '>' and '<' buttons around the date field on the 'compose log' page to edit the timeshift.

Share this post


Link to post

that would be a small but workable solution to the problem.

 

Every day when I get home, I may unfortunately again a half-hour edit my caches. Makes so real no fun.

When I write a message in the Facebook app on the website which is then wrong, then the problem is solved immediately. But no one here seems to know the error. Very sad. In our hobby is the date of crucial importance.

 

here http://forums.Groundspeak.com/GC/index.php?showtopic=293717&view=findpost&p=5285234

writes a German programmer, he had developed his own app that adds the correct date in the log. How did he do that without a million paying premium users?

 

I'm really frustrated with the current situation!

Share this post


Link to post

I am in the eastern US, (GMT-5) and that is what time my device is set to. Because the server is in GMT-8, my logs are always 3hrs off, so I fudged my account settings, saying I was in GMT+3, and my fieldnotes show up with the 'right' time now. I haven't seen any ill-effects of this, but I believe it might have something to do with what day/time your PQ's run.

 

(FYI, submit a field note, leave it in the queue. Change your timezone, check your field note queue and the time has changed. You can trial and error this.)

 

DOH, I see a statement error up above. I remember our logs being off, and I believe they were off by 8hrs (not three as stated above!) So we found to get our field notes to post correctly, we fudged our GC.com setting timezone to be equal to actual local + 8. Since we are GMT-5, this turned into -5+8 which is +3. With our GC.com setting at GMT+3, and our iPod set to true local time, all our logs have been submitting with the correct timestamp. I don't know what other effects this might have on our account, but I haven't noticed anything yet.

 

I know it worked for us, I would be curious to see if anyone else had luck with it....

 

I understand the issues Groundspeak is having trying to match a new technology (smartphone) with a 13 year old website. I have been using this method of pushing my timezone to +3 for my area and it has been working. I do not see any other effects. Until GC can build a whole new web database, I am happy with this work around.

Share this post


Link to post

When will there at least be an official recommendation from Groundspeak on this? As people start producing their own workarounds things will only get more messy on the data side. Especially after a month with an emphasis on getting more cachers to have longer streaks of caching this is something that should have been fixed loooong ago....(currently I only "correct" the dates of logs that interfere with statistics/souvenirs manually - every time with an awkvard feeling)

Share this post


Link to post

I'm wondering if there are any updates on this? I've noticed this is still happening now that I often switch back and forth during the day between my GPS and my iPhone. All iPhone created field notes seem to be out -8 hours, which makes sense as Seattle is -8 GMT. If every times zone has the same issue, wouldn't it just mean that 8 hours needs to be added to the time stamp when it comes from the app?

 

I know you said it is not an app problem but a database problem, but does the problem happen from somewhere other than the app?

 

:cool: BQ

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 10

×
×
  • Create New...