Jump to content

Garmin Montana FW 3.64 Beta


taeke
Followers 5

Recommended Posts

Beta 3.64

 

Changes made from version 3.63 to 3.64:

 

Added full profile support for Trip Computer Setup.

Improved display of configurable data field categories.

Fixed issues with supported configurable data fields in the nuvi dashboard.

Fixed issues with NMEA output using the AMPS Rugged Mount.

Problems with this beta software may be reported to MontanaBeta@garmin.com

Edited by taeke
Link to comment

Here's how the "Elev Above Ground" field works.

 

It takes your current barometer based elevation and subtracts the DEM elevation from the map. The field will report in 10 ft increments. The difference has to be greater than 50ft for anything to register.

 

You can test this field by calibrating your altimeter to be at least >50ft higher than the DEM says you are.

 

I can't think of many uses personally but hangliders, skydivers, and small craft pilots probably could.

 

It seems like Garmin is really promoting the benefits of their DEM infused products with these new data fields. We still don't fully understand what the improved elevation in tracklogs from v3.36 is about. Could they be taking elevation information from the DEM? Quite possibly.

Edited by yogazoo
Link to comment

 

Added full profile support for Trip Computer Setup.

 

 

I was hoping that this meant that fields setup in a profile were individual to that profile and not global as it is at present. Doesn't seem to be the case though. So anyone any ideas what this means?

 

It also seems there is a different email address for reporting problems now. It was oregon.beta@garmin.com. Note the new address MontanaBeta@garmin.com

Edited by WrongwayUK
Link to comment

I'll take that back. It has worked. Change to field layouts are now individual to the profile and not made global across the profiles. I had sent a request in to Garmin for this a couple of days ago. When I thought this latest beta hadn't implemented the change I emailed them again, about half an hour ago. They replied that the request had been implemented and after trying again, they are correct. I don't know why it didn't work the first time I tried.

 

I am totally amazed at the response and support. They seem to be really on the ball.

Link to comment

Montana 650 using either Montana_363 or 364Beta software. From the ‘start page’ using key sequence >setup>profiles>3 horizontal bars>set mount profiles>selecting any of the four mount choices turns off the Montana 650.

 

This simply means that I cannot change 'Mount' preference. Has anyone else had this experience?

Link to comment

Montana 650 using either Montana_363 or 364Beta software. From the ‘start page’ using key sequence >setup>profiles>3 horizontal bars>set mount profiles>selecting any of the four mount choices turns off the Montana 650.

 

This simply means that I cannot change 'Mount' preference. Has anyone else had this experience?

I also have a 650. It is running 364Beta. I tried the sequence you outlined above. My 650 also turned off.

Link to comment

Yes and I reported to Garmin and got a reply back thats its fixed in the next release.:)

 

 

Montana 650 using either Montana_363 or 364Beta software. From the 'start page' using key sequence >setup>profiles>3 horizontal bars>set mount profiles>selecting any of the four mount choices turns off the Montana 650.

 

This simply means that I cannot change 'Mount' preference. Has anyone else had this experience?

Link to comment

One thing I've grown quite tired of is the auto mount issue where half the time on an automatic power up, the unit freezes. Then you have to fiddle with pulling the batteries while driving and it's just a PITA.

 

I think it has something to do with birdseye imagery and here's why.

 

When I place my powered off unit into the auto mount it will automatically start up and half the time the unit freezes on the "loading images" startup screen. I then have to pull the batteries to get the unit to shut down. Even if it is in the cradle when I start my car (i.e. send power to the unit via the cradle) the auto startup freezes on "loading images" (birdseye) half the time.

 

I really, really wish Gamin would spend some time to investigate the auto-cradle issues with units freezing. It's probably my biggest annoyance at this point.

 

Another major annoyance is the speed limit not showing up when using City Navigator maps. I learned today that if Gamins Topo 24K product is enabled under the CityNavigator (to see the terrain shading and City Nav at the same time) the speed limit doesn't show. When I disable the Topo 24K and power cycle the unit, the speed limit shows up. Simply enabling or disabling the underlying Topo 24K map doesn't toggle the speed limit. In each case you have to power cycle (or maybe switching profiles would do the trick).

 

Garmin could do one of two things to solve the speed limit problem: 1) make the most detailed Terrain Shading Model (DEM) that's loaded the default whether the map is enabled or not, or 2) figure out why enabling an underlying map breaks the speed limit data track from City Navigator.

Edited by yogazoo
Link to comment

If you'd be so inclined I'd like to see if others are experiencing a problem with the position marker (blue arrow) on the 3D screen. It seems as though a large portion of the time the blue position arrow is in the wrong place on the 3D map. Test: look to see where you are on the 2D map screen and then go to the 3D screen and see if your location jives. Sometimes it's correct sometimes not but I just want to see if others are experiencing it before I report it to Garmin. Thanks in advance.

Link to comment

If you'd be so inclined I'd like to see if others are experiencing a problem with the position marker (blue arrow) on the 3D screen. It seems as though a large portion of the time the blue position arrow is in the wrong place on the 3D map. Test: look to see where you are on the 2D map screen and then go to the 3D screen and see if your location jives. Sometimes it's correct sometimes not but I just want to see if others are experiencing it before I report it to Garmin. Thanks in advance.

 

I hardly ever use the 3D view, but mine is off also. I'm at home and know where I live, and that's not it!

Link to comment

If you'd be so inclined I'd like to see if others are experiencing a problem with the position marker (blue arrow) on the 3D screen. It seems as though a large portion of the time the blue position arrow is in the wrong place on the 3D map. Test: look to see where you are on the 2D map screen and then go to the 3D screen and see if your location jives. Sometimes it's correct sometimes not but I just want to see if others are experiencing it before I report it to Garmin. Thanks in advance.

 

The arrow location is fine, for me, in 2D mode. In 3D mode it shows me about a block north of the actual location. If I exit the map, then turn the Montana to another direction and go back to the 3D map, the position can change. Oddly, when pointed E, S, or W, the arrow location was fairly reasonable. I wasn't 100% consistent either. Being off a block in this view doesn't bother me. The Montana seems to really have a hard time keeping this display updated. I think its a bit too much for it to process this view with the resources under the hood.

Link to comment

I am sure when I installed the 3.64 beta I noticed an aviation profile. I just looked and it's not there, I don't think I was dreaming. I don't know if there is a limit to the profiles that can be created but I have added two. Does anyone know of a way to delete a profile thats been added by mistake.

 

EDIT.. I found how to delete a profile. Or rather found you can't delete a profile if its the active one.

Edited by WrongwayUK
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 5
×
×
  • Create New...