Jump to content

Etrex 30 tones not working

Recommended Posts

Since updating the firmware to 2.4 I've noticed that the tones are no longer audible.

If I go to the Tones screen in Setup it says that Tones are on and that there's a tone assigned to Message Beep and Key Beep. In the Proximity Alarms sub-menu it shows as Tones on with a tone assigned to each alarm.


Before the firmware upgrade from 2.3 to 2.4 I was hearing a tone when approaching a cache but I no longer do. I also don't hear a tone when pressing any of the keys.


Does anyone else experience this issue?





Link to comment

Err no ... not on my Etrex 20 anyway ... :(


Not sure about the new Etrex range but on Garmin Nuvis the advice is always do a hard reset after a software upgrade, particularly if you're getting abnormal behaviour ... worth a try??


Garmin UK tech. support responded yesterday with :-


> I am happy to help with your query. You will need to do a master reset

> (this will take 45 minutes, and may delete your favourite or saved

> locations), this can be done by following these instructions.


> 1. Turn off the unit.

> 2. Hold down the Menu and Enter buttons, then press and release the

> Power button.

> 3. Keep the buttons held down for about 10 seconds

> 4. A message will appear, Select to clear all user data

> 5. Select yes, and fill in the relevant data.

> 6. Now leave the unit in clear view of the sky, outside is better, but a

> window sill or glass roofed conservatory will do.

> 7. Do not move the unit for 30 minutes, this is to allow it re-register

> its data with the satellites.

> 8. Then turn it off and on, and it should be working.


I tried this but it does not work. When I queried I was told to make sure that the I was pressing the Enter button (the Thumbstick), which of course I was. The unit just starts up as normal after a short delay.

If I press the Power button with just the enter button pressed the unit (after a while) goes to what looks like a setup screen but it's not the screen described by tech. support to do a Master Reset.


At the moment I'm receiving one email per day from Garmin and have to wait another 24 hours before a response, which is frustrating.


Anyone know how to correctly do a Master Reset on an Etrex 30?





Link to comment

Do you get any sounds at all? Try setting an alarm. If still no sound perhaps it's a hardware fault?


No sound at all. I tried it previously, but I just set an alarm again and told it to turn off. It turned itself on as expected and showed the alarm screen but with no sound.


At least I have something definite to tell the support guy tomorrow.


Thanks for your help

Link to comment

Have a look here and see what you think:




Doesn't mention the Etrex 10/20/30 range but 2.40 does the same thing.


The full list of what's changed is here:




Ok sussamb, the screen shots persuaded me to take a punt. Always nervous when downloading firmware updates for anything but need not have worried.


All went on simply, still have my tones an am loving the new look to the caches screen with the summary of them and extra detail :)



Link to comment

@ Chilli ... glad it's all OK and you pleased :)


@ duncanhoyle ... sounds like a hardware fault then, but as you say, at least you have something to tell garmin :(


My Etrex30 has now been sent back to Garmin :-( Turn around should be less than 10 days...


I now have a new Etrex replaced under warrantry. I'm a little annoyed that they didn't even apologise for the 3 weeks that I've been without my device and that I then had to phone up to get my mapping registration moved over.

Apparently there was a batch of these devices that had a sound issue and so far they've had to replace 3.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...