Jump to content
Sign in to follow this  
Followers 9
OpinioNate

iPhone v4.5.6 Release Notes

Recommended Posts

A new update to the Geocaching for iPhone Application is now available in the iTunes Store.

 

Previous version release notes

 

Updates include:

 

• Premium users can now add/remove Favorite points to caches they have found

• Fix for Favorites lists that were not loading successfully

• Fixed bug where Trackables were not being dropped

• Additional hidden waypoints are now appearing in the additional waypoints list in cache description

• Users now have access to Trackables inventory when offline

• Hidden and last found dates now appear in cache description for Pocket Queries

• Fixed compass markers for non-English devices

 

Many thanks to all geocachers who have provided feedback on User Voice. Happy Geocaching!

Share this post


Link to post

Thank you. Thus far, this is a great update with no significant steps backwards (as near as I can tell). Nicely done!!! Keep up the good work as you address the remaining issues!!!!

 

--Matt

Share this post


Link to post

Great update, my biggest grievance has still not been addressed however.

 

When will Ignored Caches be ignored in my iPhone app again? There are a lot of inactive caches near me that are not Disabled and they clog up my nearest unfound searches.

Share this post


Link to post

The new release seems to have rendered version 3.1 inoperable fro finding caches. It reports "No Results." I need version 3.1 because it lets me zoom in on almost any text and make it really big, which I need for my vision problem. Any ideas, as updating to the latest version is nearly useless to me.

 

Thanks

Share this post


Link to post

Did this have any impact on the Geocaching app for our Android? Our app is not working at all today! Help!!

Share this post


Link to post

Finally the additional waypoints are back again. And this time really good organised in a list, and directly connected to the map feature, pointing to the waypoint. :)

Edited by Ringeling

Share this post


Link to post

Great update, my biggest grievance has still not been addressed however.

 

When will Ignored Caches be ignored in my iPhone app again? There are a lot of inactive caches near me that are not Disabled and they clog up my nearest unfound searches.

 

Not downloaded yet, but the ignored cache issue where they appear does annoy me, any chance of it in the next update?

Share this post


Link to post

Great update, my biggest grievance has still not been addressed however.

 

When will Ignored Caches be ignored in my iPhone app again? There are a lot of inactive caches near me that are not Disabled and they clog up my nearest unfound searches.

 

Ditto

Share this post


Link to post

Since installing V4.5.6 my Geocaching App always shows the red LED in the lower left corner claiming to be offline. However, searching for caches or trackables works despite of this, so I'm not sure the display is correct. Unfortunately, when I try to load a pocket query, I get a popup box telling me this feature is only available when online. I am absolutely unable to load any pocket queries.

 

Edit: Killing the app and restarting it fixed the online/offline display and with it also the ability to download PQs.

 

All is well again :-)

Edited by sbeelis

Share this post


Link to post

Great update, my biggest grievance has still not been addressed however.

 

When will Ignored Caches be ignored in my iPhone app again? There are a lot of inactive caches near me that are not Disabled and they clog up my nearest unfound searches.

 

Not downloaded yet, but the ignored cache issue where they appear does annoy me, any chance of it in the next update?

 

This is not an issue with the app but rather with the API. We are working on correcting that.

Share this post


Link to post

Thanks for the timely response Moun10 bike! Since it is an API fix that means it could be resolved without a new version of the app being needed correct?

 

I will await the resolution eagerly. It has been broken for quite some time now.

Share this post


Link to post

The new release seems to have rendered version 3.1 inoperable fro finding caches. It reports "No Results." I need version 3.1 because it lets me zoom in on almost any text and make it really big, which I need for my vision problem. Any ideas, as updating to the latest version is nearly useless to me.

 

Thanks

 

I too find the update has rendered old versions inoperative. I find this unbelievable really.

 

I can no longer make any searches or download PQs in Version 4.2.2.

 

I have not been offered any updates presumably because newer version requires an iOS>3.1 and I do not wish to upgrade my iPod OS for various reasons.. Nevertheless it is APPALLING that any old version stops working particularly as it has been PAID FOR.

 

Please restore functionality to Version 4.2.2 as soon as possible. otherwise please offer a means of REFUNDING the cost of the app.

 

Thank you.

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

Edited by GermanyBert

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

 

Yes, but when older software is no longer supported, it usually still works. The old 4.2.2 Version of geocaching for iPhone does NOT.

Share this post


Link to post

"Premium users can now add/remove Favorite points to caches they have found"

 

how is this done? i can't see how to in the app.

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

 

Yes, but when older software is no longer supported, it usually still works. The old 4.2.2 Version of geocaching for iPhone does NOT.

 

..

Edited by GermanyBert

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

 

Yes, but when older software is no longer supported, it usually still works. The old 4.2.2 Version of geocaching for iPhone does NOT.

Technology changes, life moves on. I suspect that there are more apps on the iPhone that do not work with the older operating systems. You just happened to find one. I guess your faced with a choice, upgrade the OS or go find and old etrex.

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

 

Yes, but when older software is no longer supported, it usually still works. The old 4.2.2 Version of geocaching for iPhone does NOT.

Technology changes, life moves on. I suspect that there are more apps on the iPhone that do not work with the older operating systems. You just happened to find one. I guess your faced with a choice, upgrade the OS or go find and old etrex.

 

From what I can tell, there have been no changes to the operating system that would cause an older version of the app to stop working. From what I can tell, Groundspeak has changed its programming specifically to cause older versions not to work.Fact 1: The old version worked Fact 2: I changed nothing. Fact 3: GS released a new version of the app. Fact 4: I did not change anything. Fact 5: The old version stopped working. The logical inference is that GS intentionally and willfully disabled the old app. I suspect that the new version contains some sort of "flag" and that the GS database checks for that flag and returns "No Results" when it is not present.

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

 

Yes, but when older software is no longer supported, it usually still works. The old 4.2.2 Version of geocaching for iPhone does NOT.

 

This is the nature of the beast with iOS and with the changing landscape of API-reliant apps. You can't very well expect Groundspeak to ensure that its API runs a several-generations-old version of the app on a several-generations-old OS. It just doesn't work that way anymore.

Share this post


Link to post

"Premium users can now add/remove Favorite points to caches they have found"

 

how is this done? i can't see how to in the app.

 

When you go to log a find and select "found it" the option shows up.

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

 

Yes, but when older software is no longer supported, it usually still works. The old 4.2.2 Version of geocaching for iPhone does NOT.

Technology changes, life moves on. I suspect that there are more apps on the iPhone that do not work with the older operating systems. You just happened to find one. I guess your faced with a choice, upgrade the OS or go find and old etrex.

 

From what I can tell, there have been no changes to the operating system that would cause an older version of the app to stop working. From what I can tell, Groundspeak has changed its programming specifically to cause older versions not to work.Fact 1: The old version worked Fact 2: I changed nothing. Fact 3: GS released a new version of the app. Fact 4: I did not change anything. Fact 5: The old version stopped working. The logical inference is that GS intentionally and willfully disabled the old app. I suspect that the new version contains some sort of "flag" and that the GS database checks for that flag and returns "No Results" when it is not present.

 

The fact that your setup was supported as long as it was is a miracle. They aren't specifically targeting you. Why would they do that? Your being phased out because the way the API works has changed as the OS and the app have moved forward (and you have chosen not to). Why should they have to maintain the backwards compatibility of the API any more than they do the app? More importantly, why would they? Waste of resources.

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

 

Yes, but when older software is no longer supported, it usually still works. The old 4.2.2 Version of geocaching for iPhone does NOT.

Technology changes, life moves on. I suspect that there are more apps on the iPhone that do not work with the older operating systems. You just happened to find one. I guess your faced with a choice, upgrade the OS or go find and old etrex.

 

From what I can tell, there have been no changes to the operating system that would cause an older version of the app to stop working.

 

Of course you have access to source code for both the OS and the app in order to make this statement. Or is this just idle chatter?

 

From what I can tell, Groundspeak has changed its programming specifically to cause older versions not to work.

That is a really hard to accept statement. For what purpose? Do they charge for an upgrade? No, then it is not money. Maybe it simply is that the old OS does not support the newer programming and your one of the few that don't upgrade.

 

Fact 1: The old version worked Fact 2: I changed nothing. Fact 3: GS released a new version of the app. Fact 4: I did not change anything. Fact 5: The old version stopped working. The logical inference is that GS intentionally and willfully disabled the old app. I suspect that the new version contains some sort of "flag" and that the GS database checks for that flag and returns "No Results" when it is not present.

No, the logical conclusion is that your phone has ancient bits that no longer support the newer software. It is a failure on your part not to remain current, not GS malicious act to single you out. Could you possibly come up with a mildly plausible explanation why they disabled the old app?

Edited by jholly

Share this post


Link to post

Why should they refund you? You are the one who has decided not to upgrade your iPhone.

 

No company can afford to maintain older software. I wish Microsoft would refund me for all the outdated versions of their software I bought.

 

Yes, but when older software is no longer supported, it usually still works. The old 4.2.2 Version of geocaching for iPhone does NOT.

Technology changes, life moves on. I suspect that there are more apps on the iPhone that do not work with the older operating systems. You just happened to find one. I guess your faced with a choice, upgrade the OS or go find and old etrex.

 

From what I can tell, there have been no changes to the operating system that would cause an older version of the app to stop working.

 

Of course you have access to source code for both the OS and the app in order to make this statement. Or is this just idle chatter?

 

From what I can tell, Groundspeak has changed its programming specifically to cause older versions not to work.

That is a really hard to accept statement. For what purpose? Do they charge for an upgrade? No, then it is not money. Maybe it simply is that the old OS does not support the newer programming and your one of the few that don't upgrade.

 

Fact 1: The old version worked Fact 2: I changed nothing. Fact 3: GS released a new version of the app. Fact 4: I did not change anything. Fact 5: The old version stopped working. The logical inference is that GS intentionally and willfully disabled the old app. I suspect that the new version contains some sort of "flag" and that the GS database checks for that flag and returns "No Results" when it is not present.

No, the logical conclusion is that your phone has ancient bits that no longer support the newer software. It is a failure on your part not to remain current, not GS malicious act to single you out. Could you possibly come up with a mildly plausible explanation why they disabled the old app?

 

I've done programming for enough years that I'm pretty sure that it was not that support was dropped, but rather that something debilitating was expressly added. When my employer wanted everyone on its staff to switch to a new version of my program, I added something to the main database that checked version numbers and would not work with the old one. Based on my knowledge experience and training, my educated guess is that this is what happened here. (BTW: If it did, GS has likely run afoul of the ADA.)

Share this post


Link to post

I've done programming for enough years that I'm pretty sure that it was not that support was dropped, but rather that something debilitating was expressly added.

 

You would be incorrect. The old versions of our app used the old versions of our API. As I've mentioned elsewhere, we unfortunately had to remove support for the old version of the API on Wednesday and re-purpose the server that was running it. This was necessary due to security issues with the old API, the minimal number of devices dependent on it, and the need to devote resources to the new API. This change means that old versions of the iPhone and Android applications will no longer function. Most users will be able to update to the latest versions of our apps and recover full functionality. For those who are unable to upgrade, we sincerely apologize.

Share this post


Link to post

Thanks for your explanation. I stand corrected. I am disappointed, but no longer unhappy. I withdraw any criticism and ill-thoughts. I will upgrade and get a magnifying glass.

Share this post


Link to post

You could have at least waited until the new iPhone came out.

 

Some of us are WAITING to upgrade their phone. There is no reason for me to buy a new iPhone 4 when the iPhone 5 is supposed to be announced on October 4th, and on sale around October 15th.

 

Terrible timing, and I am very disappointed. Just because you have a few people who use the old versions, fine I get it.

 

BUT A SIMPLE HEADS UP WARNING WOULD HAVE BEEN NICE. That's common courtesy.

 

"Hey, this next update is unfortunately going to break 4.2.2, it will come out on or around this week, please be aware of this and deal accordingly"

 

Say this, and I'm not happy, but I can deal with it. But when I go to get the coords of a cache I know where it is generally but not exactly, and I think the server is down, but NO....the version was broken with no warning. That's bad customer relations.

 

Honestly, customer service around here has gotten worse the last 12 months.

Share this post


Link to post

The program on my iTouch version 3.1.3 stopped working tonight. It was fine for the last 2 days of use. I foolishly tried deleting and reloading but now can't because it wants a newer version of iTouch. What now?

Share this post


Link to post

The program on my iTouch version 3.1.3 stopped working tonight. It was fine for the last 2 days of use. I foolishly tried deleting and reloading but now can't because it wants a newer version of iTouch. What now?

 

Please send an email to contact@Groundspeak.com. We will address this matter for you.

We apologize that this decision was not communicated to the userbase affected prior to the change. It was a gross oversight and we are addressing individual user's needs at the above email address.

Share this post


Link to post

The program on my iTouch version 3.1.3 stopped working tonight. It was fine for the last 2 days of use. I foolishly tried deleting and reloading but now can't because it wants a newer version of iTouch. What now?

 

Please send an email to contact@Groundspeak.com. We will address this matter for you.

We apologize that this decision was not communicated to the userbase affected prior to the change. It was a gross oversight and we are addressing individual user's needs at the above email address.

 

This is one of those time, Sandy. Awesome! Well done! I tip my Tilly!

Share this post


Link to post

This one caught me unaware about 200 mi from home when I ran out of caches loaded on my iPod and could not get any more! I'm now at home, slowly downloading updates to programs that were working perfectly well for me earlier. I prefer the old saying 'if it aint broke, don't fix it'. Sigh.

Share this post


Link to post

This one caught me unaware about 200 mi from home when I ran out of caches loaded on my iPod and could not get any more! I'm now at home, slowly downloading updates to programs that were working perfectly well for me earlier. I prefer the old saying 'if it aint broke, don't fix it'. Sigh.

Like Moun10bike said, it was broke.

Share this post


Link to post

Since updating to this latest version on my iphone 3G, the accuracy has gone from 17 metres to 100 metres. Does anyone else have this problem?

Share this post


Link to post

Hi,

 

i've the geocaching application for iphone

it's a French iphone4 with 4.3.5

geocaching 4.5.6

Localisation option is active

 

But...

 

Compass don't work

it look block

on the map is the same.

it's the same with challenge application.

 

i try the compass of the iphone, all is right.

i think it's the compass of the geocaching application that don't work...

 

Could you help me please..?

Share this post


Link to post

Hi,

 

i've the geocaching application for iphone

it's a French iphone4 with 4.3.5

geocaching 4.5.6

Localisation option is active

 

But...

 

Compass don't work

it look block

on the map is the same.

it's the same with challenge application.

 

i try the compass of the iphone, all is right.

i think it's the compass of the geocaching application that don't work...

 

Could you help me please..?

 

Hello Fati & Kikkah,

I changed my language to Francais and checked both the Geocaching and Challenges apps. Both compasses worked as expected. Is your iPhone 4 any different other than setting the language as French?

 

You may want to try restarting the phone and uninstalling and reinstalling the app. This often fixes any issues.

 

We have not heard of this problem elsewhere. If anyone else has this compass issue, please let us know.

 

Again, to respond to the users that are upset about the API update, we apologize that we did not give warning that this would occur. If anyone cannot use the app because you cannot update to the latest version 4.5.6, please email contact at geocaching dot com and we will work with you.

 

Thank you for your anticipated understanding.

Share this post


Link to post

I have an issue with the new update - when geocaching with the new update, using the pointer screen while navigating to a cache, the distance changes every two minutes or worse.

 

It makes caching nearly impossible!

Share this post


Link to post

The program works fine, but I can't use the feature to retrieve trackables. I get error messages to try later.......several weeks later no change.

Share this post


Link to post

The new release seems to have rendered version 3.1 inoperable fro finding caches. It reports "No Results." I need version 3.1 because it lets me zoom in on almost any text and make it really big, which I need for my vision problem. Any ideas, as updating to the latest version is nearly useless to me.

 

Thanks

 

I too find the update has rendered old versions inoperative. I find this unbelievable really.

 

I can no longer make any searches or download PQs in Version 4.2.2.

 

I have not been offered any updates presumably because newer version requires an iOS>3.1 and I do not wish to upgrade my iPod OS for various reasons.. Nevertheless it is APPALLING that any old version stops working particularly as it has been PAID FOR.

 

Please restore functionality to Version 4.2.2 as soon as possible. otherwise please offer a means of REFUNDING the cost of the app.

 

Thank you.

Share this post


Link to post

With iphone 3GS, I notice that some caches just plain don't show up. These are caches that I see on geocaching.com. If I specifically search for the name (e.g., GC31Q2B), I can see it and add it to my "saved" caches, but it doesn't show up in a normal search (e.g., "Find Nearby Geocaches").

 

Is this true for all "Members Only" GCs, or is there another explanation?

Share this post


Link to post

Can anyone verify the apps compatibility with iOS 5 before I upgrade OS?

Share this post


Link to post

Seems to work fine on my Iphone 4 with IOS5

 

 

Can anyone verify the apps compatibility with iOS 5 before I upgrade OS?

Share this post


Link to post

Seems to work fine on my Iphone 4 with IOS5

 

 

Thanks bjkmack. Did all your data come across fine too? Especially waypoints for multis, but also saved lists, etc. everything that wasn't data on the server?

 

I have lots of waypoints in there for solved not found puzzles and multis only half done. Wouldn't want to lose those...

Share this post


Link to post

Yes, I have an iPhone 4 and iOS 5. The app still works great for me and still has saved lists. I had a multi with my entered waypoints that was not saved for offline use but by selecting 'find nearby Geocaches' and selecting the cache then navigating still showed the additional waypoints.

Thus, I am assuming any saved waypoints would still be included in the saved lists.

 

If you notice any issues with the iOS upgrade, please email contact at geocaching.com and we can look into this more.

 

Thanks and happy caching,

Share this post


Link to post

Premium caches no lomger show up on searches through the iPhone ap. They can, however, be found if I look them up online and enter the code.

This is awkward for me, as there are loads of premium caches in my neighbourhood.

Share this post


Link to post

I have tried and failed to upload pocket queries to my iPhone.

I have run a PQ, signed in on the app and clicked the saved button, but I just get a blank screen. Am I missing something?

 

Edited to add: forget this. After reindtalling my app I can see them just fine!

Edited by Cyberbloke

Share this post


Link to post

Same problem. Cannot download pocket queries or even do simple search anymore on Original iPhone os 3.1

 

The new release seems to have rendered version 3.1 inoperable fro finding caches. It reports "No Results." I need version 3.1 because it lets me zoom in on almost any text and make it really big, which I need for my vision problem. Any ideas, as updating to the latest version is nearly useless to me.

 

Thanks

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 9

×