Jump to content

Garmin Montana V3.00


Catch
Followers 6

Recommended Posts

Montana (WebUpdater) software version 3.00

 

Changes made from version 2.80 to 3.00:

Added support for advanced geocache logging with OpenCaching.com. See TrailTech http://garmin.blogs.com/softwareupdates/2011/08/advanced-geocache-logging-with-opencachingcom.html for more information.

Added Restore Defaults option to setup pages

Fixed issue where proximity alarms would not be audible

Fixed issue that occurred with the altimeter page when using a 24-hour clock

Fixed issue where the map would sometimes not refresh when using the active route page

Fixed an issue where the dashboard would sometimes appear while panning on the map

Fixed issue with saving tracks in area calculation page

Fixed issue with highlighting of some shortcuts in the drawer

Fixed issue with the keyboard layout in landscape orientation when the system language was set to French

Fixed issues that sometimes occurred when exiting Where To? > Address or Where To? > Intersection

Modified the 'Arriving at Destination' message banner so that it no longer appears when navigating to a geocache

Link to comment

When I go to setup -> about on my GPS, it says that I've got version 3.00.

 

However, the myDashboard website keeps insisting that a new software update is available. I have clicked "update now" and followed instructions three times after first install, but nothing seems to change. Anyone else with this problem?

 

The update didn't solve my invisible icon problem.

Link to comment

Hey nice.

They also fixed the problem that some GC descriptions won't be shown at all if the original description Page has been built with more "complex" html code.

Before V3.00 it only showed empty space in some cases.

Seems it DOES make sense writing to the Beta-Team after all. :ph34r::D

 

TC,

morph

Link to comment

Hey nice.

They also fixed the problem that some GC descriptions won't be shown at all if the original description Page has been built with more "complex" html code.

Before V3.00 it only showed empty space in some cases.

Seems it DOES make sense writing to the Beta-Team after all. :ph34r::D

 

TC,

morph

 

And no screen calibration fix either.

 

Although, I have read some people think it's a hardware problem and not a software issue.

Link to comment

Hey nice.

They also fixed the problem that some GC descriptions won't be shown at all if the original description Page has been built with more "complex" html code.

Before V3.00 it only showed empty space in some cases.

Seems it DOES make sense writing to the Beta-Team after all. :ph34r::D

 

TC,

morph

 

And no screen calibration fix either.

 

Although, I have read some people think it's a hardware problem and not a software issue.

 

I don't think the screen calibration is a software or firmware issue. If it was they wouldn't be taking units back and sending replacement ones out.

Link to comment

I downloaded V3.10 from WebUpdater

 

Change History

Changes made from version 2.80 to 3.10:

Added support for advanced geocache logging with OpenCaching.com. See TrailTech (http://garmin.blogs.com/softwareupdates/2011/08/advanced-geocache-logging-with-opencachingcom.html) for more information.

Added Restore Defaults option to setup pages

Fixed issue where proximity alarms would not be audible

Fixed issue that occurred with the altimeter page when using a 24-hour clock

Fixed issue where the map would sometimes not refresh when using the active route page

Fixed an issue where the dashboard would sometimes appear while panning on the map

Fixed issue with saving tracks in area calculation page

Fixed issue with highlighting of some shortcuts in the drawer

Fixed issue with the keyboard layout in landscape orientation when the system language was set to French

Fixed issues that sometimes occurred when exiting Where To? > Address or Where To? > Intersection

Modified the 'Arriving at Destination' message banner so that it no longer appears when navigating to a geocache

Edited by Barrikady
Link to comment

I downloaded V3.10 from WebUpdater

 

Change History

Changes made from version 2.80 to 3.10:

Added support for advanced geocache logging with OpenCaching.com. See TrailTech (http://garmin.blogs.com/softwareupdates/2011/08/advanced-geocache-logging-with-opencachingcom.html) for more information.

Added Restore Defaults option to setup pages

Fixed issue where proximity alarms would not be audible

Fixed issue that occurred with the altimeter page when using a 24-hour clock

Fixed issue where the map would sometimes not refresh when using the active route page

Fixed an issue where the dashboard would sometimes appear while panning on the map

Fixed issue with saving tracks in area calculation page

Fixed issue with highlighting of some shortcuts in the drawer

Fixed issue with the keyboard layout in landscape orientation when the system language was set to French

Fixed issues that sometimes occurred when exiting Where To? > Address or Where To? > Intersection

Modified the 'Arriving at Destination' message banner so that it no longer appears when navigating to a geocache

 

Wow. Version 3.00 did not last very long. I wonder what was the deal with that?

Link to comment

And no screen calibration fix either.

 

Although, I have read some people think it's a hardware problem and not a software issue.

 

100% hardware issue.

 

Is that coming from garmin?

 

Nah, that's my assumption given the symptoms. The dead spot in the lower left is static and as it spreads, the trouble spots are tied to the physical touchscreen and not attached to the rendered image (as you change landscape to portrait the bad area doesn't follow). Plus it gets worse and worse as time goes by. Nothing to me says software.

Edited by yogazoo
Link to comment

I wouldn't be so sure that the screen calibration issue is hardware. My Montana was working fine through versions 2.6 and then 2.8. Just upgraded to 3.1 and I now have a useless brick of rubbishness for a GPS. The calibration is screwed. I recalibrated, it stayed the same. I downgraded the firmware it was just as bad. I spent 5 minutes trying to click on the right buttons to get it to the calibrate section, recalibrated it again and it was still screwed. Performed a master reset and now I can't event click 'English' to get my GPS in the right language. It's stuck in some foreign language and I can barely click any menu items.

 

Looks like Garmin can have this one back.

Link to comment

I wouldn't be so sure that the screen calibration issue is hardware. My Montana was working fine through versions 2.6 and then 2.8. Just upgraded to 3.1 and I now have a useless brick of rubbishness for a GPS. The calibration is screwed. I recalibrated, it stayed the same. I downgraded the firmware it was just as bad. I spent 5 minutes trying to click on the right buttons to get it to the calibrate section, recalibrated it again and it was still screwed. Performed a master reset and now I can't event click 'English' to get my GPS in the right language. It's stuck in some foreign language and I can barely click any menu items.

 

Looks like Garmin can have this one back.

 

That is just the point. They have had this problem since the start; what has been different in the reports is how long after purchase it occurs. It occurs no matter which software update is being used. It has only been out a couple of months and more reports are coming in. If it was fixable with software/firmware it would most likely been fixed already. They certainly don't want to be taking bunches of these back.

 

I only got mine a few days ago and had told a friend I would sell him my 450 but now I think I will hang on to that for a few months for backup.

Link to comment

If it's hardware I'm surprised we haven't heard from a lot more who are experiencing the problem.

 

Maybe it's only a range of serial numbers which are affected using some sort of defective part from a supplier and then they changed suppliers.

 

Or could it be it just takes time for the part to go bad?

 

Seems like the problems is reported to get worse as time goes on.

Link to comment

A few hours of dedication and my calibration issue is now finally fixed. The dedication included plenty of downgrading and then upgrading. At one point when I was in v3.1 it would work fine, apart from in landscape map mode where the maps would just not show! I registered the device on the Garmin webpage and then got into the 'myDashboard' bit. Although I already had v3.1 it told me there was an update waiting. I updated and it seemed to nearly fix it. A downgrade then upgrade eventually got it back working how it was before I put the update on it. Phew!

 

What I don't get: Say "Fred" is at version 3.1 and I am at version 3.1. I've done a fair bit of software development in the past, and so my thought is that surely no matter what progression of versions we've been through, or downgrades and upgrades we've had, our software should be exactly the same and therefore our Montanas should be working the same. Some people get new bugs with the new firmware, some people find it makes their device function better. I just don't really get why many Montanas seem to be functioning so differently. I shouldn't be worried about installing the latest firmware on my device because Garmin would have tested it on their devices and therefore everything should be the same!! Grr...

 

Happy Geocaching day all you Montana owners, by the way! ;)

Edited by Cassandy
Link to comment

After using mine on a hour long car ride today, it stopped giving voice directions somewhere along the way. Happened on the way there and the way back. It would still speak if I used the turn preview button on the map screen, so I don't know what is going on. I am also still not getting my speed limit displayed all the time either. It seems to start working when it wants to, but when it does it will work correctly.

Link to comment

Geez... it sounds like Garmin should scrap the entire firmare/software package for the Montana and start over from scratch.

 

This seems to have the most inconsistant series of bugs so far in a new unit.

 

I would expect their capabilities to IMPROVE and for Garmin to be able to whip out firmaware that works with their eyes closed.

Link to comment

I also have a working Montana. Looks like it’s just you and me that have working Montana’s? Or could it be that when you read these forums that you only get one side of the story? This is the small percent of owners with problems and/or little issues that the majority of owners don’t ever use. Or, how about the single user that continues to regurgitate their experience over and over to vent their frustration. I remember many years ago wanting to buy a Garmin 60CSx when they were first released. But oh my, the problems with that model! The forum posts then were much scarier than these Montana posts. I eventually stumbled upon a deal too good to pass up and took the plunge. It was a great GPS and is now the high GPS standard that others are compared to.

Link to comment

Since using 3.0 I've noticed an issue where the battery/coordinate/time/date section on the main menu randomly disappears. Either turning the unit off or changing profile fixes it. Anyone else experiencing this after the update? It didn't do this before. It did it 5 times at the weekend during a time period of about 7 hours use.

 

This is what I see:

montana30_menu.jpg

Link to comment

After using mine on a hour long car ride today, it stopped giving voice directions somewhere along the way. Happened on the way there and the way back. It would still speak if I used the turn preview button on the map screen, so I don't know what is going on. I am also still not getting my speed limit displayed all the time either. It seems to start working when it wants to, but when it does it will work correctly.

 

Sounds like the problem I've been having that I mentioned here. Navigating to a place, then turning off and on again brings the unit back with the correct routing, and the chap starts talking again.

Link to comment

I was impressed at how quickly the team got back to me about my issue. They asked for a copy of my Geocaching profile (Garmin\profiles\geocaching.gpf) I made a backup of my Montana when I first got the unit so I'm wondering if replacing my profile with an older one may fix that issue if it's something in my profile causing it. Something to try anyway!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 6
×
×
  • Create New...