Jump to content

Chrome OS Maps


jri
Followers 16

Recommended Posts

 

So when we use this script is the "hit" coming from our individual machines ...

 

yes.

 

Thanks! This is a great script and enhancement. It's also very cool to be able to switch thru all the maps pretty easily because each one sometimes gives different details.

Link to comment

Just tried this for the first time and think it is FANTASTIC. I had been using another script since the Google Satellite view had disappeared and it "interacted" with this script adversely (no option to choose map source) so I removed that script and just run this one. A must for all UK geocachers. Many thanks. (p.s. I am using it in Chrome)

Link to comment

 

So when we use this script is the "hit" coming from our individual machines ...

 

yes.

 

If you're at all worried, the latest version of the script has a configuration button, so you can turn Google Maps off again! :unsure:

 

No! I just want to make sure we aren't causing Groundspeak any grief. I understand their business decision but clearly there is another way to approach this and Google Maps are superior overall to the other maps.

Link to comment

Just wanted to add, that I've just upgraded to 0.5.2 this morning and lo and behold there'a a scale line on the map, just as we asked for! Marvellous!!!!

 

This addition is really appreciated together with all the other stuff you've done for us on this add-on.

Link to comment

Hi

I've been using this script for a few weeks now to get OS maps with caches superimposed, but this morning it seems to have stopped working. When I click "map it" on my GC profile page, I do not get the option any more to select OS maps - indeed Tampermonkey itself seems unresponsive. Is this me, or is there something wrong somewhere else ?

Thanks.

Link to comment

Hi

I've been using this script for a few weeks now to get OS maps with caches superimposed, but this morning it seems to have stopped working. When I click "map it" on my GC profile page, I do not get the option any more to select OS maps - indeed Tampermonkey itself seems unresponsive. Is this me, or is there something wrong somewhere else ?

Thanks.

 

There was some website downtime earlier today, but I'm not getting any problems at the moment. If you're still having problems, you will need to post some more details of what you (don't) see. Do you still get Mapquest and the standard selection of maps? Can you see any of the script's icons? Do any error messages appear in the Javascript console that aren't there with the script disabled?

 

If Tampermonkey is unresponsive, you could have disabled it by accident, or there might be some other program interfering with it (a security or privacy app maybe?). You could try deliberately disabling Tampermonkey, then installing the script as a standalone Chrome extension to see if that works (remember to remove the 2nd copy again if you re-enable Tampermonkey)!

Link to comment

Hi jri, many thanks for the response. I confirm it's all working OK now without me having to do anything else; I must have just been unlucky with the timing earlier.

 

BTW, I really appreciate the effort you've put in to get this working. I really like to have an OS map of the area I'm caching, and the official OS "Get-a-Map" isn't nearly as versatile as your script for getting the caches superimposed, and being able to print map snippets at a legible size. Many thanks.

Link to comment

Wow !!!After been advised by a fellow geocacher to download OS maps from Google Chrome I decided to give it a go. Its quite amazing so easy to download and use. I tried at first to download it from Firefox but had a problem with greasemonkey.Caused all sorts of problems with my PC. After doing a quick security scan I found that there were lots of infected cookies. Took me ages to sort the problems out.Is there anyone out there who has had the same problem.Thank you for this great app.

barbycats

Link to comment

Another member advised on this when we were talking about GPS tracking etc.

Now installed this on one computer for Chrome and Firefox and it adds a entirely new element to viewing the caches on the maps.

Rather than flipping to various sites with different mappings I can do the lot all from the initial map.

 

Well done and thanks for the app, looks like this has saved a lot of people an awful lot of time. :)

Link to comment

I've had problems with this (incredibly useful add-on) working intermittently - I even posted a Q about it a while back, and I see others seem to be having similar issues. I've figured out a work around that I thought I'd pass on in case it helps anyone else. It seems to depend on how you open Chrome.

 

On my aging XP PC I have a "Favourites" entry on my Start menu which includes all the legacy Favourites from when I used IE. I've set Chrome as the default browser, so if I click on GC.com in that list, Chrome starts up and all looks OK. Except that the GME script doesn't run, and you get one frustrated cacher who can't print the map he wants.

 

If however I start Chrome first, and then select GC.com from the bookmarks imported into Chrome, GME works and I get the OS maps as I expect.

 

Quite why this should be I haven't a clue - probably something to do with the configuration of my PC - but now that I know about it I can work round it. Maybe worth trying if anyone else is finding GME to be intermittent.

Link to comment

Is anyone else finding that this extension causes the change overlay icon to just disappear (making it impossible to change the map at all)? :( Used to work perfectly for me before but I've had to disable it with recent updates to the map.

Link to comment

Is anyone else finding that this extension causes the change overlay icon to just disappear ...

 

Do you mean the icon at the top right that looks like a stack of paper? If so it's working for me on both Chrome and Firefox on both the embedded map on the cache pages and the main "geocaching.com map" page. I checked this on the last release, 0.5.8, and the current release 0.5.9.

Link to comment

Is anyone else finding that this extension causes the change overlay icon to just disappear (making it impossible to change the map at all)? :( Used to work perfectly for me before but I've had to disable it with recent updates to the map.

 

Try manually resetting the GME configuration. Instructions here.

Link to comment

Having used this excellent add-on in Chrome since jri first posted it, I have to say I have NEVER had ANY problems whatsoever! Always works, 1st time. I have just gave the link to a fellow cacher, who also runs Chrome, I'll soon find out if HE has any problems!

 

Oh dear, have I just given it the kiss of death on my laptop? :yikes: I hope not! :laughing:

Link to comment

Just noticed that Open Streetmap has a "Transport" map.

Any chance of adding this one so that green cachers (or just those without cars) can use it?

I'm not adding any more maps to the scripts - add too many and the selection menu would get unmanageable. sad.gif

 

However, it's easy to add the OSM Transport map yourself. smile.gif You just have to paste a string of code into the configuration screen. The instructions are online at http://geo.inge.org.uk/gme_maps.htm

 

The same page has lots of examples of other maps and overlays you can add. My personal favourite is Colin Marquardt's hill shading overlay, which gives an impression of terrain when you're using one of the street maps. cool.gif

Link to comment

Is anyone else finding that this extension causes the change overlay icon to just disappear (making it impossible to change the map at all)? :( Used to work perfectly for me before but I've had to disable it with recent updates to the map.

 

Try manually resetting the GME configuration. Instructions here.

Ahhh I totally forgot I had installed the separate script for google maps that was going around the forums after they were removed, turns out it was clashing. All working now, awesome stuff :D

Edited by fluoro
Link to comment

Had problems with the script this evening - it refused to load three of the map types. I followed the troubleshooting guide further up this page and brought up the console (which was reporting "Failure to load resource"). So, I used the reset commands and all is now well. However... and there is always a "however", the map list has changed. The order is different and I am sure there are one or two extra ones listed. Any idea what might have happened (so I don't do it again)? Many thanks for this great script. A real help in planning.

Link to comment

Is anyone else finding that this extension causes the change overlay icon to just disappear ...

 

Do you mean the icon at the top right that looks like a stack of paper? If so it's working for me on both Chrome and Firefox on both the embedded map on the cache pages and the main "geocaching.com map" page. I checked this on the last release, 0.5.8, and the current release 0.5.9.

Oh dear, after months of this working wonderfully (it's almost my favourite thing on geocaching.com!), I went away on holiday while Groundspeak updated their maps so everybody gets google maps, and when I come back, I'm getting exactly the problem detailed above.

 

Bizarrely the tiny map on the cache page works fine, but the large map no longer has that stack of papers icon on the top right hand side and I can't get the lovely lovely OS maps on at all. I use Chrome.

 

I've gone through all of the steps detailed in this thread. I've installed the newest version 0.5.9. I've checked I have no clashing extensions (I'm only running this one and AdBlock Plus). I've manually reset the GME settings by copying and pasting the trouble shooting text on to the console. I've logged out and back in. I've closed and re-opened Chrome, and nothing works. I suppose I could try turning it off and on again <_< but I'm now out of options.

 

Can someone take pity on me and suggest what I might be missing to get this fantastic add-on to work again...

Link to comment

 

Can someone take pity on me and suggest what I might be missing to get this fantastic add-on to work again...

 

Probably:

 

Open the map

Expand the frame down the left side (where the option to select/deselect cache types etc is).

Click the "Set Map Preferences" button near the bottom.

Choose "Leaflet"

 

and Bob's your mother's brother.

Link to comment

 

Can someone take pity on me and suggest what I might be missing to get this fantastic add-on to work again...

 

Probably:

 

Open the map

Expand the frame down the left side (where the option to select/deselect cache types etc is).

Click the "Set Map Preferences" button near the bottom.

Choose "Leaflet"

 

and Bob's your mother's brother.

Marty

 

Please feel free to join jri on my 'complete hero list' :wub:. As you may have gathered, it has worked.

 

If you knew just how much this add-on has integrated itself into my life and entire being, you would know just how grateful I am to have it working again. BTW may I take this opportunity to thank you very much for the info you have sent me on one of my caches. It seems that for the last four days I have done nothing but eat, sleep, work, cache and log so haven't had time to look at it properly, but I will drop you a reply as soon as I do.

 

You're a star.

Link to comment

 

If you knew just how much this add-on has integrated itself into my life and entire being

I'm with you on that, this is certainly the best add on I've come across, and puts the standard map offerings to shame - big thanks to jri!

 

BTW may I take this opportunity to thank you very much for the info you have sent me on one of my caches.

 

It's a pleasure, it was a fine day out in a great lovely spot.

Link to comment

If you go back to Google maps mode the icons will still respond;Open the menu on the left hand side of the map pageSelect Set Map PreferencesSelect Google mapsClose menuUnfortunately you use the JRIs wonderful extension but you can always change back to leaflet mode when you want to.

 

Ah, I see what you mean. Whilst it doesn't solve the problem, it's not at all a bad idea, given the current shortcomings of Chrome . Thanks for pointing it out!

Link to comment

If you go back to Google maps mode the icons will still respond;Open the menu on the left hand side of the map pageSelect Set Map PreferencesSelect Google mapsClose menuUnfortunately you use the JRIs wonderful extension but you can always change back to leaflet mode when you want to.

 

Ah, I see what you mean. Whilst it doesn't solve the problem, it's not at all a bad idea, given the current shortcomings of Chrome . Thanks for pointing it out!

 

Only if you're a PM.......

Link to comment

I added this enhancement a while back and have nothing but praise for it. However over the last week if I select OSmap on the cache page it appears but when I select View Larger Map the map appears using Google Maps and the top right menu to choose a map just appears for about half a second before disappearing. Help please. I am using Windows Vista Home, Google Chrome and Leaflet as my map prefernce

Link to comment

I added this enhancement a while back and have nothing but praise for it. However over the last week if I select OSmap on the cache page it appears but when I select View Larger Map the map appears using Google Maps and the top right menu to choose a map just appears for about half a second before disappearing. Help please. I am using Windows Vista Home, Google Chrome and Leaflet as my map prefernce

Link to comment

I added this enhancement a while back and have nothing but praise for it. However over the last week if I select OSmap on the cache page it appears but when I select View Larger Map the map appears using Google Maps and the top right menu to choose a map just appears for about half a second before disappearing. Help please. I am using Windows Vista Home, Google Chrome and Leaflet as my map prefernce

 

If the map selector appears, then disappears and doesn't return, it sounds as though GME is failing to load part-way through starting up. I would try re-setting GME's configuration using the instructions at http://geo.inge.org....htm#resetconfig . If that doesn't work, then I will need some more details before I can help: I can't reproduce your problem using my setup (Win XP, Chrome v22 and GME v0.6.0).

 

Can you see the GME icons in the bottom-left corner of the map? Does GME work normally when you go directly to http://www.geocaching.com/map rather than clicking the "View Larger Map" link? Do any error messages appear in the Chrome console (apart from the normal ones about viewport arguments)?

 

NB if you use the View Larger Map link, it is normal for the big map to load whatever map you have selected as the default in GME, rather than the one you were viewing on the cache page. Also, if you end up reinstalling / upgrading GME and you're not using a script manager like Tampermonkey, read this thread about how to install userscripts with the new security features in Chrome.

 

Hope this helps!

Link to comment

I added this enhancement a while back and have nothing but praise for it. However over the last week if I select OSmap on the cache page it appears but when I select View Larger Map the map appears using Google Maps and the top right menu to choose a map just appears for about half a second before disappearing. Help please. I am using Windows Vista Home, Google Chrome and Leaflet as my map prefernce

 

If the map selector appears, then disappears and doesn't return, it sounds as though GME is failing to load part-way through starting up. I would try re-setting GME's configuration using the instructions at http://geo.inge.org....htm#resetconfig . If that doesn't work, then I will need some more details before I can help: I can't reproduce your problem using my setup (Win XP, Chrome v22 and GME v0.6.0).

 

Can you see the GME icons in the bottom-left corner of the map? Does GME work normally when you go directly to http://www.geocaching.com/map rather than clicking the "View Larger Map" link? Do any error messages appear in the Chrome console (apart from the normal ones about viewport arguments)?

 

NB if you use the View Larger Map link, it is normal for the big map to load whatever map you have selected as the default in GME, rather than the one you were viewing on the cache page. Also, if you end up reinstalling / upgrading GME and you're not using a script manager like Tampermonkey, read this thread about how to install userscripts with the new security features in Chrome.

 

Hope this helps!

Link to comment

Hi jri,

I disabled the following enhancements in Chrome

 

GC Bag-o-Tricks 3.0

GC little helper 8.5

GeoPrinter 2.0.6

 

and the GME icons appeared at the bottom left of the screen. Tried reset defaults but could see no change.

Going straight to http://www.geocaching.com/map gave same problem .. top right menu briefly appeared then went.

 

Going to console gave following

 

Viewport argument value "device-width;" for key "width" not recognized. Content ignored. /map/:6

Viewport argument value "1.0;" for key "initial-scale" was truncated to its numeric prefix. /map/:6

Viewport argument value "1.0;" for key "maximum-scale" was truncated to its numeric prefix. /map/:6

Viewport argument value "1.0;" for key "minimum-scale" was truncated to its numeric prefix. /map/:6

Viewport argument value "no;" for key "user-scalable" not recognized. Content ignored. /map/:6

Tampermonkey started

Uncaught TypeError: Cannot read property '_leaflet_id' of undefined ScriptResource.axd:3857

7Uncaught RangeError: Maximum call stack size exceeded /map/:1

 

Hope this is of some help. I have also disabled Adblock but this has not made any difference.

 

Version 22.0.1229.94 m for Google Chrome

 

Hope this helps.

Link to comment

Glad it's now working for you both.

 

@geralduscambrensis: Do you think that having two copies of GME installed was your issue too (one in Chrome extensions, one in Tampermonkey)?

 

GME ought to be able to run in Chrome without Tampermonkey, but it looks like I should also check that it can cope gracefully with two versions being installed. I'm in the middle of a fairly major re-write at the moment, so I'm keen to wrap up any bugs I can at the same time.

 

I'm trying to make the next version of the script more robust, add new features, and possibly even work in Internet Explorer! If I can make it work, the big new feature will be the ability to print maps with all the caches labeled.

 

Link to comment

Hi there,

 

Well it had been working perfectly well since I first installed it, quite a while ago. I can only think that the new extensions I added from Chrome store

 

GC Bag-o-Tricks 3.0

GC little helper 8.5

GeoPrinter 2.0.6

 

must have messed it up and then the new Chrome thing about not adding scripts put the mockers on resetting the default for GME.

 

I tried the drag & drop idea but it didn't work so I added Tampermonkey then added it through that and hey presto.

Hope that helps.

It is a really great enhancement and makes geocaching so much more of a pleasure for me.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 16
×
×
  • Create New...