Jump to content

Garmin Oregon x50 software version 4.45 Beta


allory
Followers 11

Recommended Posts

Everyone here will be suprized to hear that you cannot reload the previous version of beta firmware. The Oregon x50 FREEZES WHEN TRYING TO REVERT!! Yeah, the unit locks up on the screen that asks you if your sure about loading a version older than the one already on the unit. NICE! We're beta tester/suckers who are stuck with a version where everythings broke until Garmin gets off their duff to release a new beta.

 

Edited to add: Well at least the 62 series does the same thing. <_<

 

Someone please verify this with the Oregons

Edited by yogazoo
Link to comment

Everyone here will be suprized to hear that you cannot reload the previous version of beta firmware. The Oregon x50 FREEZES WHEN TRYING TO REVERT!! Yeah, the unit locks up on the screen that asks you if your sure about loading a version older than the one already on the unit. NICE! We're beta tester/suckers who are stuck with a version where everythings broke until Garmin gets off their duff to release a new beta.

 

Edited to add: Well at least the 62 series does the same thing. <_<

 

Someone please verify this with the Oregons

 

After messing around I finally got it to load by placing the GCD directly into the Garmin folder on the unit itself. The unit resets to factory default though and I mean it asks you what language you want when you start it up.

Edited by yogazoo
Link to comment

Everyone here will be suprized to hear that you cannot reload the previous version of beta firmware. The Oregon x50 FREEZES WHEN TRYING TO REVERT!! Yeah, the unit locks up on the screen that asks you if your sure about loading a version older than the one already on the unit.

.....

Someone please verify this with the Oregons

Yeah, that does surprise me. I posted and used the same link (see Post #46, above - sorry I didn't see that you were having problems with that). Fired off the *.exe file and all went well. I was of course advised that I was about to load 'older' firmware, but said that was OK, and didn't get locked up. Takes a LONG time after the load/disconnect for things to complete, and in fact, takes a while before the progress monitor starts to move, but no lockups here.
Link to comment

I don't know whay but my units have been acting really wierd ever since the new betas came out. As if they are isolated or different somehow than most everyone here. My only conclusion is that it has everything to do with the maps I have loaded. Since I have almost 80 JNX Birdseye tiles loaded my guess is that, in an attempt to handle the JNX files differently they have messed things up a bit. My main problems have been related to freezing, slowing and a general mucking during certain menus and functions.

 

ADDED: So I reinstalled the current beta and removed all but a single vector mapset and all my Birdseye tiles. The results were completely different. They seemed to have placed some serious checks on the BirdsEye JNX files that messes with certain functions. Thanks to the firmware hackers I'm assuming.

 

ADDED: So without Birdseye on my unit I rolled back the firmware again and, poof, it happened in a flash without problems. The new Birdseye JNX handling seems to be the culprit. This is why some folks here aren't experiencing any problems and those with large chunks of JNX files are being frustrated.

Edited by yogazoo
Link to comment

This is confusing. The .45 beta has worked flawlessly for me on my 550 except for initially having to do a master reset to get the streets to show properly. No other issues at all that I've seen. From the complaining going on, it makes me wonder what is common to the problems you are having. Is anybody else, besides me, having no problem? I didn't install the early December beta and went straight to the middle Dec beta. Could that have something to do with it? Curiouser and curiouser said Alice.

Link to comment

This is confusing. The .45 beta has worked flawlessly for me on my 550 ..

Have you been using some of the features that are causing problems? Chirp? Birdseye? Not everyone will see the problems of this last release. I've had issues with them, but I'm using the features that have been mentioned here.
Link to comment

This is confusing. The .45 beta has worked flawlessly for me on my 550 except for initially having to do a master reset to get the streets to show properly. No other issues at all that I've seen. From the complaining going on, it makes me wonder what is common to the problems you are having. Is anybody else, besides me, having no problem? I didn't install the early December beta and went straight to the middle Dec beta. Could that have something to do with it? Curiouser and curiouser said Alice.

 

Well, did you try the wireless transfer thing? It's the only thing that's a (minor) showstopper for me, other than that it's been fine for me as well.

Link to comment

Yup - my chirp works fine, I sent both caches and waypoints to make sure it was working. Nobody around me has a gps with the wireless function so I haven't tested the transfer between units. So that's obviously not a big deal to me. Waypoint handling - no prob. I don't use birdseye so no info there either. I've been rooting around trying to provoke problems without result. If I had to say anything, it's working better than ever. But maybe I just haven't looked in the right place. Since the update I've done a couple dozen caches and all is well (so far, touch wood). Best of luck to those having issues. I know it is immensely frustrating.

Edited by arcs
Link to comment

If I had to say anything, it's working better than ever. But maybe I just haven't looked in the right place.

 

Do you have BirdsEye imagery on your unit? Doesn't sound like you do. The JNX handling in the latest beta seems to be playing patty-patty-poopcakes with the general responsiveness of some of the functions.

Link to comment
Nobody around me has a gps with the wireless function so I haven't tested the transfer between units.

 

Yeah, and that's where it would screw up. Not a big deal for me because I need to do that very infrequently anyway, but it's annoying when I do. Other than that I have no issues with the firmware, including Birdseye handling.

Link to comment

Well, for those who have birdseye, try selecting a point on the map screen (not a geocache, try a point of interest or road or something) and see how long of a wait it is until anything pops up on the screen. For me it's at best 20 seconds, sometimes 30. The "GO" screen should pop up right away. This, to me, is another downside to this beta.

Link to comment

Well, for those who have birdseye, try selecting a point on the map screen (not a geocache, try a point of interest or road or something) and see how long of a wait it is until anything pops up on the screen. For me it's at best 20 seconds, sometimes 30. The "GO" screen should pop up right away. This, to me, is another downside to this beta.

 

Can't confirm this, nice fast and responsive as ever for me.

Link to comment

Wow! What a day using my Oregon 450 with this software.

Found 16 caches.

Unit froze at least 8 times and had to pull the batteries once to restart it. The other times I just shut it off and re started it.

Lost satellite 5-6 times on top of the freezing, on a clear cool day with blue sky and hardly any to no tree cover in most instances.

I hope they fix the situation before I go out again or I will need to regress to a previous version.

Link to comment

I just reverted back 4.20. This new beta is even worse than 4.32 which froze my 550 many times, the picture viewer on 4.45 is broken. When I choose "Near A Location" and then "My Current Location", it shows pictures taken 3000 miles away! (GPS Accuracy was 7m when I tested it). Restart, removing batteries wouldn't help. Once I reverted back to 4.20, the picture viewer functioned perfectly.

Link to comment

OK.. maybe I'm missing something here. Just got my new 450 in the mail today and it's loaded with version 4.52

Am I looking at the wrong thing?? Garmin updater says I have the most current version (and I don't think they would send out new units with a beta version).

Just wondering out loud here... anyone????

Link to comment

OK.. maybe I'm missing something here. Just got my new 450 in the mail today and it's loaded with version 4.52

Am I looking at the wrong thing?? Garmin updater says I have the most current version (and I don't think they would send out new units with a beta version).

Just wondering out loud here... anyone????

OK.. never mind.. I see now that it's Software ver 4.40 and GPS software ver 4.52.. guess I was looking at the wrong line.

Link to comment

OK.. maybe I'm missing something here. Just got my new 450 in the mail today and it's loaded with version 4.52

Am I looking at the wrong thing?? Garmin updater says I have the most current version (and I don't think they would send out new units with a beta version).

Just wondering out loud here... anyone????

OK.. never mind.. I see now that it's Software ver 4.40 and GPS software ver 4.52.. guess I was looking at the wrong line.

 

Just got mine 3 days ago and even though 4.40 came from the factory there are still some software bugs in ver. 4.40. I have reported these to Garnin and they say they are checking into it.

No wirless communication after 1st successful wireless transfer. When changing waypt. symbol both old symbol and new symbol are both displayed on top of each other for a while; old symbol will go away instantly if you turn unit off and back on. If you delete a waypoint it's symbol will still appear on map page screen, even though it is no longer in the waypt. manager's list, turn unit off and back on and is no longer on map page screen.

Link to comment

OK.. maybe I'm missing something here. Just got my new 450 in the mail today and it's loaded with version 4.52

Am I looking at the wrong thing?? Garmin updater says I have the most current version (and I don't think they would send out new units with a beta version).

Just wondering out loud here... anyone????

OK.. never mind.. I see now that it's Software ver 4.40 and GPS software ver 4.52.. guess I was looking at the wrong line.

 

Just got mine 3 days ago and even though 4.40 came from the factory there are still some software bugs in ver. 4.40. I have reported these to Garnin and they say they are checking into it.

No wirless communication after 1st successful wireless transfer. When changing waypt. symbol both old symbol and new symbol are both displayed on top of each other for a while; old symbol will go away instantly if you turn unit off and back on. If you delete a waypoint it's symbol will still appear on map page screen, even though it is no longer in the waypt. manager's list, turn unit off and back on and is no longer on map page screen.

 

I can understand the bugs if you want to try out a Beta version, but to ship a unit with bugs seems pretty much unacceptable. Oh well.. guess we'll wait unti they get 4.45 stable and upgrade it then. Thanks for the info!

Link to comment

Well I've received some replys from the beta teams about the firmware issues. The big tripping point, as it was explained to me, was attempting to alow for the enabling/disabling of individual BirdsEye products (me thinks Birdseye USGS Topo scans for the US are right around the corner). They all but testified to the firmwares buggyness. This MIGHT explain why those with BirdsEye products seem to be taking notice to more issues.

Link to comment

Yup. Finally got together with a 450 owner and the connection doesn't work. I can talk to my chirp but sending or recieving from another unit fails at 33%. meh - noth thrilled but I've had worse problems in life.

OK Garmin get it together and fix stuff.

Link to comment

Sent off a note to Garmin this AM and within 30 minutes I got a reply saying the issue has been fixed in the next release. I am asking them when that will be.

 

Well, let's see if they fixed it.

Oregon x50 v4.47 Beta

 

Nice, pretty much everything in the changelog is fixes for bugs there were introduced in this beta :lol:

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 11
×
×
  • Create New...