Jump to content

Energizer Batteries not working in eXplorist GC

Followers 3

Recommended Posts

I don't know if this has to do with the eXplorist GC or it's something with Energizer batteries. I had some Energizer batteries that I put into my Magellan eXplorist GC but the GC wouldn't turn all the way on. (It'd act like it was booting up but then the screen would fade out.) I took those (new) batteries and tried putting them into a remote control and they wouldn't work. I assumed that I made a mistake and they were old, drained batteries.


This happened with several sets and I thought maybe I had a bad batch of batteries (they were all well under the expiration date - by more than year). I bought a whole new package of Energizers and put two of those in my GPSr, knowing that they were new and fresh. The eXplorist GC did the exact same thing. I can put in Rayovaks and the GC behaves normally.


I do have the GC set up to take alkaline batteries.


It kind of feels like something happens to the Energizer batteries once placed in the GC that render them useless after they've been inserted in the GC.


It's not that big of a deal to use Rayovacs. I just wondered if anyone else has noticed this odd behavior?

Link to comment

I have used the Energizer batteries that came with my GC unit when I bought it. Didn't have any problems with them, lasted a really long time, but I don't think I have tried any other Energizer batteries since then. Make sure that when you put the batteries in that they are fully in and the cover is locked in. Maybe the Energizer batteries wasn't fully in and while the GC was turning on they became disconnected?

Link to comment

Thanks for the help, wolf9545, but I've tried about 12 different Energizer batteries out of two different packages and they all won't work. It's quite strange. It's not a big deal to use Rayovacs - they're cheaper - but it's just so odd that it's these particular batteries. I haven't yet tried Duracell batteries.


You are right though about the Energizer lithium batteries that came with it. They *did* lost a long time :)

Link to comment

Are you sure they are not NiMH rechargeables? Presuming the batteries are not defective or discharged there is absolutely no reason for them not to work. There is obviously more to this picture than meets the eye. :blink:


I am absolutely positive that they are the average run-of-the-mill alkaline battery. I'd attach a picture, but trust me - they look just like the ones you'd stop off and buy at any store.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 3
  • Create New...