Jump to content

How big of a micro SD card for an Oregon 450?

Followers 0

Recommended Posts

Most people worry about max'ing out the Oregon's limit for tile count for topos before they reach 4GB. But City Navigator uses the better part of 2GB on its own. If your topos won't exceed 2GB (and it's likely that they won't), 4GB is going to be fine.


This is only a problem if you try and use Topo USA.... I have 10 GB of maps on my unit and I'm not near the tile limit..


To answer the qeustion, you can useany size card that you want.

Link to comment

No expert, but customer service said that I could put up to a 4gb card in my 550. You did good.



Sounds like the tech support people aren't experts, either. While 4GB will serve the needs of nearly everyone, the thing would run with 8, 16 or 32GB if you could round one up. What you'd find to put in that space is another question! :laughing: I could envision a configuration that would actually benefit from 8GB, but it's not something I'd ever need to do.
Link to comment

Just an issue that I found while using a 16GB card in my Oregon 450:


Living in the greater Los Angeles area, I found it really easy to quickly accumulate quite a bit of BirdsEye imagery - hence the need for the 16GB card. My 16GB card contains approximately 1.5GB of BirdsEye and about 3.5GB of map data (well under the Oregon's tile limit). Also, about ~4,000 caches spread into 2 GPX files (GSAK export, each file represents a country where I regularly cache).


With the 16GB card inserted, the following occurred twice during normal operation: while brining up a cache (either a description, hint or logs), the Oregon would freeze, requiring a battery pull to restart it. Meanwhile, the unit deleted both of my GPX files from my 16GB card. Ouch!


I re-formatted the card and copied all the data back and the unit worked fine for a week or so then the same thing happened again. That was a few weeks ago. Since then, I copied my GPX files onto the Oregon's internal SDRAM - leaving just BirdsEye and map data on the 16GB card. The unit has worked fine since then - over 50 more caches found since the last crash.


Caveat: I'm running the beta firmware (3.61). The issue also occured while I was on 3.52. It did not occur during the weeks I was on 3.50. There's always the possibility that it is a faulty SD card, but it seems to work flawlessly when connected to my PC...

Link to comment

I had an 8 GB card in my 450 for a few weeks. Once when I was on a caching road trip, none of my caches would load. When I got home, the micro SD card worked fine when connected to the PC...but the 450 had problems reading the GPX files. I can't remember if I had a problem in the field requiring a battery pull. I have since installed all GPX files on the built-in memory (since I'm only using about 500 MB). I swapped the 4 GB card from the Nexus One with the 8 GB card from the 450 (so now I have room for more movies when traveling). I'll try the 4 GB card again eventually...but am trying to see if the corrupted GPX problem returns when using the internal memory

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 0
  • Create New...