Jump to content

Can an OSM Map "Brick" My Dakota?

Recommended Posts

On May 31 I bought a Dakota 20 at REI. I enjoyed it quite a lot mountain biking and even tried some geocaching. It worked fine until I tried to show it off to my sister and it would not power up. I was away from home so I bought some new batteries and tried again. No luck. Later, on the computer it was not recognized at all. OK...a bad unit. On June 28 I returned it to REI and was sent a brand new replacement. It arrived on July 2. It worked fine and I went through a set of batteries playing with it. When I changed batteries today it would not power up. I tried different batteries with no luck. I plugged it into the computer and it is not recognized. I called Garmin and they said that my problem is not with their hardware but with my maps. I am using a routeable OSM map. I installed it on my PC and then opened it in Basecamp. With Basecamp I installed it on my Dakota. After installation it works fine for a while and then the Dakota dies. Is it possible that the map can do something to the Dakota to render it useless?

Link to comment

Next time install the map on your SD so if it happens again take the SD out.

For now reset your Dakota.


How do I reset the Dakota? I have tried to connect it to the computer with and without batteries. I have tried holding the power button for minutes and then plugging in the USB connector. Is there another way?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...