Jump to content

magellan meridian marine GPSr


darkarbl
Followers 1

Recommended Posts

I recently received a new in box meridian marine gpsr as a gift ,,unknown to me or the giver of gift that this unit has been discontinued since 2004 ,,the factory was no help as it is out of warrenty ,,any help on how to power up this unit for the first time would help,,,yes I know were the power button is + what direction the batteries go in + how to close + latch battery cover --so no stupid comments ..does this unit need the sd card to turn on?? help--

Link to comment

No need for an SD to turn on and use. Did you try different batteries? Alkaline not rechargable.

Battery cover doesn't need to be on to power up. i can't think of anything else.

have tried several sets of both style batteries all are tested as fully charged new,, just doesnt turn on

Link to comment

It' been a long time but didn't some of the meridians have a problem with the battery connection either at the battery of with the wires going to the circuit board

 

This is probably your problem. You may need to open the unit up and bend a wire. But first try holding the power button for 5 seconds, sometimes that is the issue. If that's not working, then join the yahoo meridian group. In the file section there under repairs there is a really nice PDF that explains the procedure. I've had to do this to one of mine. Some people solder the battery terminal to the board, I just bent mine and it worked fine.

Link to comment
But first try holding the power button for 5 seconds, sometimes that is the issue.

 

I didn't think of this, been a Meri owner for so long. Hold the button down 'till it beeps. Then the startup screen should appear. :anicute:

NIB new from retailer ---I have held the button down for 1 minute plus no beep no nothing ,,have tried bending the wire at the battery connection,scratching the contacts to make better contact still nothing

Link to comment

What Vagabond in post #3 means is if a battery was inserted wrong, it can move the wire connector that is touching the printed circuit board inside. What many of us have done is open the unit and move the connector back so that it is touching the pad on the PCB. Try this first before calling it dead.

 

The proper way to insert batteries is to take the flat end of the AA and compress the spring, move the other end (+) into place and then release. To remove, push the + end to compress the spring, then pull up on the + end.

Link to comment

Hello,

 

Check to see that the screws holding the cases together are snug. I had one Meridian that I purchased and it would come on then fade out. This fixed my problem. I had another that took a long time to solve - an interrupted firmware upgrade. If this is your problem there are several articles available that will walk you through the reset process. Good Luck Peoria Bill

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...