Jump to content

URWIGO builder


yourself
Followers 61

Recommended Posts

I have a question, would it be possible to add a "COPY" button next to "Edit Item", "New Item" and "Delete Item"?

That would be very helpful for me, because I use some very similar items in Zones, Tasks as well as in Items.

The best would of course be, if you could copy items from one file to another one, using clipboard:)

Thanx

Michal

Edited by stalkersMV
Link to comment

Here's hopefully a quickie... (I did do a topic search first)

 

Does "Ignore Case" on a compare command work?

I'm comparing input to a string value.

 

I have a text input to which I save the 'Answer' to a variable 'Answer 1'.

 

I then do a compare.

 

if Answer 1 = 'ABC' then blah blah

if Answer 1 #(Not equal) 'ABC' then blah blah other

 

(I don't want to use an else)

 

When I run it, if I put 'ABC' it works, if I put 'abc' it doesn't. I unchecked 'ignore case' and it still doesn't work.

I changed it to lower case and then only lowercase worked.

 

While GPS players might have no problem, iOS and Smartphone owners might have mixed case and I wanted to ensure it didn't matter.

 

Any thoughts?

 

346a2fd0-141c-4881-ade1-c2df9e2baab0.jpg

Link to comment
I would like to use the German Umlauts (äöü) in my cartridge.

At the moment this is not possible as URWIGO seems to translate them to aou.

I know the original Wherigo Builder has problems with such umlauts. But at least my Garmin Oregon does not have such problems: I replaced the aou in the *.gwc file with äöü and these äöü appeared fine on the GPS device.

 

An option or so to switch off this translation would be fine.

This is a complicated area because /a/ the Garmin players have a different representation of non-7-bit-ASCII characters compared to the other players, and /b/ the Lua file has to work around the compiler's desire to delete all such characters. So even if you use Earwigo - which handles all this automatically :) - you still need to publish your cartridge twice, because you need two different .Lua files, and when you upload your cartridge to Wherigo.com, the site only stores one .Lua file (and can't make the necessary adjustments when it recompiles the cache to include your username).

Link to comment

I have a problem with my new cartridge.

I have built it in Urwigo.

The "game" works fine in the emulator but when I try to play the game in my iPhone-app it doesn't work.

The problem:

When the first zone is entered it should be possible to press a button that I have named "Look around". It was created as a "command" in the zone.

The problem is that the button is not showing up. Any ideas why?

In properties for that button I have selected target "none". Otherwise it doesn't work in the emulator.

 

//Jonas

Link to comment

Hi,

I used Urwigo to create a gwc file and encountered a rater annoying problem when testing on my device. The media used is resizing randomly :( Is there an option to prevent the pictures used (media) from resizing? I noticed the official builder has this option...but I couldn't find any converter to go from gwc/gwl to .lua to use that option.

 

any suggestions?

 

Thanks!

Link to comment

I've been testing Urwigo for a few days. The learning curve is steep, but I'm sure once many people get the general gist of the commands, they have an "aha" moment and begin to create great cartridges. Could someone be merciful to a programming dummy and tell me what I'm doing wrong for this basic commands to function?

post-3712918-035795900 1316431904_thumb.jpg

Link to comment

I've been testing Urwigo for a few days. The learning curve is steep, but I'm sure once many people get the general gist of the commands, they have an "aha" moment and begin to create great cartridges. Could someone be merciful to a programming dummy and tell me what I'm doing wrong for this basic commands to function?

 

Hi,

 

-First of all you need to create the actual input. (go to inputs and add a new one. Name it and define it accordingly, from text based, number to multiple choices answer.)

Also define its "on get input" status to make it reflect the correct answer.

 

-Drag the newly created input on the Input element on your picture. The first error will dissapear.

-You cannot add more than one type of messages/dialogues per status (in your case, On Enter of a zone). That's why the warnings are displayed. That's why it's best to use the If/else condition in the defined Input rather than there.

 

Take a look at my defined input example in the image and it might give you an idea...:

-On enter definition (the status of a zone) only uses the actual input

-On get input definition does the good stuff

-The Input Properties lets you define the question (in my case, a multiple choices answer)

 

It's actually a screen made out of 3 pasted components, It's just an example, don't mind the Q1/Q4/Q5 input names...it was used in a series of consecutive inputs.

 

Hope that helps ;)

 

Kekemes

post-4210734-026303400 1316433245_thumb.jpg

Edited by kekemes
Link to comment

I'm getting the hang of this, and I have another question. This question is more basic than my last question. :laughing:

 

Which functions are used to activate and inactivate zones? I'm hoping to make a basic cart where a player goes to an active zone, answers a question. A correct answer activates the next zone. Should a correct answer also make that zone inactive so that only one zone is active at a given time? Wouldn't that be helpful for those with a Garmin?

Link to comment

I'm getting the hang of this, and I have another question. This question is more basic than my last question. :laughing:

 

Which functions are used to activate and inactivate zones? I'm hoping to make a basic cart where a player goes to an active zone, answers a question. A correct answer activates the next zone. Should a correct answer also make that zone inactive so that only one zone is active at a given time? Wouldn't that be helpful for those with a Garmin?

 

You can use the following scenario:

 

"On enter" of a Zone...question -> if answer is correct then (Set InitialZoneName.Active=False and Set NextZoneName.Active=True) else ask the question again.

 

Good luck!

Edited by kekemes
Link to comment

I'm getting the hang of this, and I have another question. This question is more basic than my last question. :laughing:

 

Which functions are used to activate and inactivate zones? I'm hoping to make a basic cart where a player goes to an active zone, answers a question. A correct answer activates the next zone. Should a correct answer also make that zone inactive so that only one zone is active at a given time? Wouldn't that be helpful for those with a Garmin?

 

Attached are screenshots of how I would do it. It's good practice to keep the number of active zones to a minimum. If the player doesn't need to go to a zone again (or doesn't for a while), go ahead and de-activate it.

 

In my example I made two test zones and an input. On Enter-ing the first Test Zone, the Plaque Question is triggered. When the question is answered correctly, the first zone is de-activated and the second is activated. If the player fails to answer the question correctly, the question is asked again.

post-1770836-022256800 1316545296_thumb.jpg

post-1770836-004444600 1316545310_thumb.jpg

Link to comment

Hi,

 

some days ago I installed Urwigo successfully on my PC. Today I try to install it on my Laptop as well and get the following error message:

 

PLATFORM VERSION INFO

Windows : 6.1.7601.65536 (Win32NT)

Common Language Runtime : 4.0.30319.237

System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)

clr.dll : 4.0.30319.237 (RTMGDR.030319-2300)

dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)

dfshim.dll : 4.0.31106.0 (Main.031106-0000)

 

SOURCES

Deployment url : http://apps.yourself.cz/Urwigo/Urwigo.application

Server : Apache/2.2.16 (Debian)

Deployment Provider url : http://apps.yourself.cz/Urwigo/Urwigo.application

Application url : http://apps.yourself.cz/Urwigo/Application%20Files/Urwigo_1_12_0_130/Urwigo.exe.manifest

Server : Apache/2.2.16 (Debian)

 

IDENTITIES

Deployment Identity : Urwigo.application, Version=1.12.0.130, Culture=neutral, PublicKeyToken=05d1297f39f02515, processorArchitecture=x86

Application Identity : Urwigo.exe, Version=1.12.0.130, Culture=neutral, PublicKeyToken=05d1297f39f02515, processorArchitecture=x86, type=win32

 

APPLICATION SUMMARY

* Installable application.

 

ERROR SUMMARY

Below is a summary of the errors, details of these errors are listed later in the log.

* Activation of http://apps.yourself.cz/Urwigo/Urwigo.application resulted in exception. Following failure messages were detected:

+ File, zone.htm, has a different computed hash than specified in manifest.

 

COMPONENT STORE TRANSACTION FAILURE SUMMARY

No transaction error was detected.

 

WARNINGS

There were no warnings during this operation.

 

OPERATION PROGRESS STATUS

* [21.09.2011 07:50:14] : Activation of http://apps.yourself.cz/Urwigo/Urwigo.application has started.

* [21.09.2011 07:50:17] : Processing of deployment manifest has successfully completed.

* [21.09.2011 07:50:17] : Installation of the application has started.

* [21.09.2011 07:50:25] : Processing of application manifest has successfully completed.

* [21.09.2011 07:50:27] : Found compatible runtime version 2.0.50727.

* [21.09.2011 07:50:27] : Detecting dependent assembly Sentinel.v3.5Client, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=msil using Sentinel.v3.5Client, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=msil.

* [21.09.2011 07:50:27] : Detecting dependent assembly System.Data.Entity, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil using System.Data.Entity, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil.

* [21.09.2011 07:50:27] : Detecting dependent assembly WindowsBase, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=msil using WindowsBase, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=msil.

* [21.09.2011 07:50:27] : Detecting dependent assembly System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil using System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil.

* [21.09.2011 07:50:27] : Request of trust and detection of platform is complete.

 

ERROR DETAILS

Following errors were detected during this operation.

* [21.09.2011 08:01:29] System.Deployment.Application.InvalidDeploymentException (HashValidation)

- File, zone.htm, has a different computed hash than specified in manifest.

- Source: System.Deployment

- Stack trace:

at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, Hash hash)

at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, HashCollection hashCollection)

at System.Deployment.Application.ComponentVerifier.VerifyComponents()

at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)

at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)

at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)

at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

 

COMPONENT STORE TRANSACTION DETAILS

No transaction information is available.

 

Can somebody kindly help?

 

Many thanks

Link to comment

ANd the same here:

 

ERROR DETAILS
Following errors were detected during this operation.
* [21-9-2011 19:59:57] System.Deployment.Application.InvalidDeploymentException (HashValidation)
	- File, zone.htm, has a different computed hash than specified in manifest.
	- Source: System.Deployment
	- Stack trace:
		at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, Hash hash)
		at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, HashCollection hashCollection)
		at System.Deployment.Application.ComponentVerifier.VerifyComponents()
		at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)
		at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
		at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
		at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
		at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

Link to comment

I don't believe it is a problem with the program itself, just something gone wrong in the installation part (so if you've already got it installed, there is no problem).

 

From what I can tell, the hash (sha1) of each file to be installed is provided in a manifest file, if the hash calculation does not agree with the hash number in the manifest the installation aborts with the message that we are seeing. The fix may be as simple as an update to the manifest file (http://apps.yourself.cz/Urwigo/Application%20Files/Urwigo_1_12_0_130/Urwigo.exe.manifest).

 

Oh, and add me as a "me too" for the problem.

 

Regards, John

Link to comment

I have a question about Media objects.

 

Firstly, you can put multiple images against a media object -- why? It seems to always use the first. What is the difference?

 

Secondly, what resolution and dpi should the images be? I've seem some very strange results on the emulator and Android Wherigo player when different sizes and dpi are used.

 

Third - Thumbnails. What size and dpi should they be? Should they be a separate media objec? It only seems to work if they are, though the dpi seems to mess things up a lot.

 

Finally, a non-media question. When you do a compare on strings, is it case-sensitive? It seems to be, but this is a nuisance when comparing an answer to a piece of text. It would be good to be able to do a case-insensitive regexp match, somehow - maybe this is possible with raw Lua code, but I wouldnt know how.

 

Hope someone can clear up these queries. This is a great development environment, just lacking in (English) documentation.

Link to comment

The Groundspeak builder does string comparison using a library routine called (from memory) Wherigo.NoCaseEquals.

 

Lua has some regex functionality, with its own flavour of regexes. But really, if you need a regex, your cartridge is maybe in danger of turning into a programming project rather than a fun outdoor game. If the answer to the question is "yellow" then you're entitled to expect that word to be spelt correctly, maybe with all caps; anything cleverer is a lot of wasted programmer time for something which will almost never happen.

Link to comment

This is a great builder. While using it I came across the need of peeking at the LUA source code that is generated; is there a way of doing this ? Thanks.

compile it, rename the filetype of the compiled file to .zip, unzip it and open the .lua file

Thanks. It's going to be an interesting study ;)

Link to comment

And here comes another question... Does anyone know convenient way of creating a string table ? What I want to do is avoid using duplicate texts; I mean define some sort of string table, much like the ones used in Windows resource files for instance.

 

I guess one way of doing it would be by using a text file with all strings, which are loaded at startup, but how to use them in a Message element ?

 

Maybe this is a practical feature for future releases, too.

Link to comment

And here comes another question... Does anyone know convenient way of creating a string table ?

 

You have to do it in LUA code:

myStrings = {"Hello World", "Here comes the sun", "How do you do?", "and so on" }

In your Message box you select "User Expression" from the list and enter myStrings[1] for "Hello World"

Link to comment

This may be a stupid question, as I know little about Wherigo objects and lua right now... Given a text media object, how can one access the content of the associated file ?

 

I have tried with something like :

 

for line in io.lines(mediaStringTable.Resources[1].Filename) do ...

 

But I get a message saying that "file not found"; examining the emulator folders, I see the gwc file and a log; nothing more, so I guess the message is legitimate, and there is another way of accessing that content.

Link to comment

Ok So does anyone know of a problem with the oregon 550t running the cartridges if the emulator and simulator are checked I just had someone play a cart and they said after the first zone it popped up and said they couldn't play?

Maybe, you can try this ; click on file, settings, tab build and disable emulator protection.

 

I hope it helps...

 

Greetz..ERic

Link to comment

Hello together,

I am new here!

 

The last weeks I've made some experiments with the URWIGO builder.

 

Now I have one suggestion an several questions.

 

I work with the german translation an there is one fatal mistake in translation. "New item" is translated in "Neuer Gegenstand". This is wrong, because a "Gegenstand" always is a physical object, like the items of a Wherigo, for example a knife, a gun, a box and so on. A variable, a zone, a charcter is not a "Gegenstand". Therefore the right translation is "Neues Element" or "Neues Objekt". But I think "Neues Element" is better. Perhaps someone can correct that.

 

In my cardridge I have an item. This item can be opened. The open box should have another picture (an open box). This works well, but wenn I look at that item afterwards in the inventory, there is the old picture of a closed box. How can I change the picture permanentely?

EDIT: This works now. Dot know why.

 

In case that I stick to some rules, is it possible to generate a cartridge for all platforms?

 

Can be german characters (äöüß) displayed in the emulator an on other platforms?

 

Perhaps this are stupid questions,

but I'm looking forward to your reply.

Thank you

docfred

post-2892748-056118700 1321101112_thumb.jpg

Edited by docfred
Link to comment

I work with the german translation an there is one fatal mistake in translation. "New item" is translated in "Neuer Gegenstand". This is wrong, because a "Gegenstand" always is a physical object, like the items of a Wherigo, for example a knife, a gun, a box and so on. A variable, a zone, a charcter is not a "Gegenstand". Therefore the right translation is "Neues Element" or "Neues Objekt". But I think "Neues Element" is better. Perhaps someone can correct that.

 

+1

 

In case that I stick to some rules, is it possible to generate a cartridge for all platforms?

 

in my experience the player that sucks most is the one on the garmin devices - so everything that works on garmin should pretty much work on other players. rules that come to mind:

 

- don't use the onClick event

- use displayScreen only for Mainscreen

- don't use *.png images

- if you want sound, you'll have to use a fork - deliver *.fdl for garmin, *. mp3 or *.wav for others (explained here: http://www.geocaching-dresden.de/tools/tutorial-Wherigo-urwigo/index6.php)

 

Can be german characters (äöüß) displayed in the emulator an on other platforms?

 

you should avoid using umlauts - most players can't display them. but it's akward watching oneself while writing text all the time - i usally write text using umlauts, and at the very end i open the cartridge in a text editor and run search-replace a couple of times for ä -> ae and so on.

Edited by laufkaefer
Link to comment

forum software broke the link in yesterday's post, because it auto corrects "Wherigo" (did it again here, only upper case W allowed in Wherigo) to "Wherigo". there seems to be no way to avoid that, so you'll have to fix it by hand, it needs a lower case w

Edited by laufkaefer
Link to comment

Hi!

 

I tried to install Urwigo on my Win XP system with all .NET frameworks up to v4 and all patches installed, but the installation process stops at a very early stages with the following error message:

 

PLATFORM VERSION INFO

Windows : 5.1.2600.196608 (Win32NT)

Common Language Runtime : 4.0.30319.239

System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)

clr.dll : 4.0.30319.239 (RTMGDR.030319-2300)

dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)

dfshim.dll : 4.0.31106.0 (Main.031106-0000)

 

SOURCES

Deployment url : http://apps.yourself.cz/Urwigo/Urwigo.application

 

ERROR SUMMARY

Below is a summary of the errors, details of these errors are listed later in the log.

* Activation of http://apps.yourself.cz/Urwigo/Urwigo.application resulted in exception. Following failure messages were detected:

+ Die referenzierte Assemblierung ist nicht auf dem Computer installiert. (Exception from HRESULT: 0x800736B3)

 

COMPONENT STORE TRANSACTION FAILURE SUMMARY

No transaction error was detected.

 

WARNINGS

There were no warnings during this operation.

 

OPERATION PROGRESS STATUS * [23.12.2011 14:07:29] : Activation of http://apps.yourself.cz/Urwigo/Urwigo.application has started.

 

ERROR DETAILS

Following errors were detected during this operation.

* [23.12.2011 14:07:32] System.Runtime.InteropServices.COMException

- Die referenzierte Assemblierung ist nicht auf dem Computer installiert. (Exception from HRESULT: 0x800736B3)

- Source: System.Deployment

- Stack trace:

at System.Deployment.Internal.Isolation.IStore.GetAssemblyInformation(UInt32 Flags, IDefinitionIdentity DefinitionIdentity, Guid& riid)

at System.Deployment.Internal.Isolation.Store.GetAssemblyManifest(UInt32 Flags, IDefinitionIdentity DefinitionIdentity)

at System.Deployment.Application.ComponentStore.GetAssemblyManifest(DefinitionIdentity asmId)

at System.Deployment.Application.ComponentStore.GetSubscriptionStateInternal(DefinitionIdentity subId)

at System.Deployment.Application.SubscriptionStore.GetSubscriptionStateInternal(SubscriptionState subState)

at System.Deployment.Application.SubscriptionStore.CheckAndReferenceApplication(SubscriptionState subState, DefinitionAppId appId, Int64 transactionId)

at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)

at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)

at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

 

COMPONENT STORE TRANSACTION DETAILS

No transaction information is available.

 

So it seems this is not the usual "hash error". The german line in the error details message means something like "The referenced assembly is not installed on this computer." It seems to be a .NET error but I do not know how to get rid of it.

Maybe someone encountered this error before?

 

Thanks in advance!

Link to comment

I tried to install Urwigo on my Win XP system with all .NET frameworks up to v4 and all patches installed, but the installation process stops at a very early stages with the following error message:

 

After a lot of searching I solved the problem by myself. You need to delete the folder "%userprofile%\Local Settings\Apps" then installation works without problems. Do not ask me why, it's one of those MS issues...

Link to comment
I had wondered where you were all hanging out. :ph34r:
Welcome to the party! It's our little corner of the cafe that is part, at the moment, of the greater geocaching universe. Now, if we can only get it like "Cheers", sans the drama.

 

I plan to join the coding fun to build-on the very limited presence of Wherigo in my area!!!
I'm sure those who have built a cartridge in your area will relish being able to play a cartridge they haven't made. Believe me, it's a very important part of the creative process.

 

Thx again for nurturing a great resource for outdoor virtual mindscapes.
It's close enough to augmented reality, that's for sure. Feel free to whip up a tornado of a question and see how we deal with it. I think I'll leave it there before I get too silly with that allusion.

Link to comment

It's December 2011 and I've just had a very successful launch of my 15th Wherigo (2 inside Unknown Mystery Caches); thanks to insights gained here; help from Yourself; and the outstanding Urwigo interface. One per month average has been my top development rate; but each and every one a joy to complete; plus I tried a new feature each launch. Seasons Greetings to all and a Happy 2012. Let's hope the Smart Phone evolution continues to breath new interest into ARG and WheriGos.

Link to comment

I tried to install Urwigo on my Win XP system with all .NET frameworks up to v4 and all patches installed, but the installation process stops at a very early stages with the following error message:

 

After a lot of searching I solved the problem by myself. You need to delete the folder "%userprofile%\Local Settings\Apps" then installation works without problems. Do not ask me why, it's one of those MS issues...

 

Glad to hear you got it working. I've installed it on XP Home, and XP Profession; on desktops and several Netbooks without problems; so I have to assume you had an unusual mechine specific glitz. Enjoy Urwigo .... I have.

Edited by cache4pat
Link to comment

Hi. I have had the same problem till today. I have installed Urwigo on many computers without any problems excepting my netbook. Today I have solved the problem. Thank you very much for this help. I have installed Urwigo without any problems after rename of Apps folder. Thanks, thanks, thanks, thanks, thanks, thanks, thanks, thanks, thanks...

Tom alias Xichteria

Link to comment

I also imported one of my cartridges into urwigo. I changed some things in urwigo, made a gwz in urwigo, changed the gwz into zip file and unzipped it. Now I have a lua file, which I opened in Wherigo builder, but this gives errors...

So it's not possible to use the handy urwigo for Wherigo.

 

I wanted to check this because I have a working wherigobuilderprogram with author script, which works in the urwigo emulator, but not in the field after I did some changes in the urwigo builder.

 

I imported one of my cartridges into Urwigo and used it to create a GWZ. I made the GWZ into a zip file, added the .urwigo file, renamed it GWZ, and uploaded it as a new version on the site. I then enabled Creative Commons and downloaded the source. The .urwigo file was still there and I was able to double-click it to launch Urwigo and the cartridge.

 

Looks like you can pack the .urwigo file with the GWZ.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 61
×
×
  • Create New...