Jump to content

URWIGO builder


yourself
Followers 61

Recommended Posts

Don't think there is one. I basically taught myself using the builder program I taught myself all the commands and there functions by trial and error and looking at what other people have done. Use there examples compare them to what you want to do and start off with something simple 1 or 2 zones and then build on that. import zooventure into urwigo (or any of the unlocked carts, and see how they did it then use the run command. go back and read though this whole thread and get ideas

Have fun! ask all the questions here you want someone will usually answer

Link to comment

Thank you so much for URWIGO as a great alternative to the buggy WIG Builder.

I personally treasure that drag & drop coding and the Error list. :rolleyes:

 

As I learn a lot from reading Tool Tips, i found some not yet translated ones:

Translation Issues on Urwigo Version 1.2.3719.30064:

  • In the Main Window that lists the objects the context Menue (Right Mouse Button) on an object brings up two not yet translated items. They should be "Edit Properties" and "Add new". Same error at the Media/Properties/Resources List.
  • Tasks/Properties/Events/ToolTips of the first 3 Events:
    • On active changed: This Event is not translated into English yet.
    • On complete changed: This Event has no Tooltip
    • On correct chng.: This Event has no Tooltip

    [*]Inputs/Properties/Input/Input Choices/Tooltiptext has a linebreak showing as a box.

    [*]Inputs/Properties/Events/On get input has no Tooltiptext

    [*]Timers/Properties/Timer/Type I can choose between a not yet translated word (should be Countdown) and Interval.

    [*]Media/Properties/Resources/New Item/Choose Media File/FileType

    The Third Entry is not yet translated (should be Text Files)

    [*]There are nearly no Tool Tips in Command/Properties.

    [*]Expressions/Value ToolTip has a mistype. Should be "Represents constant value like number, string (text)..."

    [*]Objects and Properties/Cartridge/Tooltiptext has a linebreak showing as a box.

I also have a Whishlist:

Edited by EW-Andy
Link to comment

Don't think there is one. I basically taught myself using the builder program I taught myself all the commands and there functions by trial and error and looking at what other people have done. Use there examples compare them to what you want to do and start off with something simple 1 or 2 zones and then build on that. import zooventure into urwigo (or any of the unlocked carts, and see how they did it then use the run command. go back and read though this whole thread and get ideas

Have fun! ask all the questions here you want someone will usually answer

 

I've recently built a Wherigo for an upcoming event; and the best guidance I can offer is: Create your Media; Zones; and Characters first. Then things in the interface start to fall together. You can do a lot without resorting to user functions; which tend to act as 'advanced user' augmentations; and require more serious LUA and system understanding. Luckily, some of that advanced programmimg wizardry can be acquired by looking at the generious examples offered here, by other users. ;)

Link to comment

Ok anyone ever have problems with edit map's This happened another time too. when I click edit map's I get a blank screen with my zones on it with no map info. do I need to change something on the computer?

 

In the early days of using the interface I discovered that lots of things go wacky, if you are not connected to a live internet feed. This interface seems to rely heavily on mapping info from the internet; and can't be used off-line. ;)

 

I also found that using something like Mapsource can help a lot with fine tuning of coord data for zones. There are free coord converter programs on the internet to help convert coord data to decimal degree format. Mind you, nothing beats 'field' testing; when it comes to get zones to occur as expected.

 

All in all, this is a great interface !!! :D

Link to comment

I just discovered urwigo builder. Looks good.

 

I don't know programming language lua - but i assume (knowing C very well) to solve with functions few things fastern than in Wherigo builder.

 

Here comes my first problem:

 

How can i set attributes (e.g. on entering stage1?)

 

Looking on a few examples i can call my user function, but because i don't know how he zones are encrypted i don't can write lua code for.

 

I tried ...

 

---- STAGE 1 functions ---

function ON_Enter_Stage1()

Stage1.Active = false;

Stage1.Display = false;

Stage2.Active = true;

Stage2.Display = true;

end

 

I called this function on event (ON ENTER) stage1 (so i called my fist zone) via drag and drop builder but system crashes because names are wrong.

 

Can anybody help me ? TIA

Andreas

Link to comment

Looking on a few examples i can call my user function, but because i don't know how he zones are encrypted i don't can write lua code for.

you have to set identifiers in zone properties, and then use those identifiers in your code.

 

Thx - so easy - when you know what to do. Now i can rebuild my Wherigo and do a few things i wanted to do - and could not with Wherigo builder

Link to comment

Hi,

 

i have a special problem.

 

I would like to show a picture on entering a zone.

With text, it's no problem, but i can not get it with a picture.

 

Could someone help me?

 

EDIT:

I solved my problem on my own.

The solution: You have to set an image directly to the message

Edited by Lamima
Link to comment

So i am still having problems with the satellite images in edit map it was working fine now is not and the same thing on my computer at home I thought it was the computer but now with this computer not working either it must be the program and something happened to the setup program I had to go reinstall the program all over again it kept trying to load some microsoft program instead of urwigo what the hecks is happening?

Link to comment

Hi, love the builder. Its fantastic.

 

I can make most stuff work but still have a few problems. How do I drop an item in the current zone?

 

I can pick up an item and it moves with the player.

I can have a put command associated with the item that will put it in a specified zone.

I can have a put command associated with a zone that will put the item into the zone, but the command is accessed from the zone, not the item.

 

I would like to have a put command that is associated with the item that will put the item into the current zone the player is in. A slight but distinct difference.

 

I am trying to do this to keep commands that act on items all accessible in a consistent manner i.e. all commands are access by viewing the item.

 

Does anyone know if this is easy or hard?

If it is really hard then I will just go with the easy method of associating the put command with the zones.

 

Thanks.

Link to comment
I would like to have a put command that is associated with the item that will put the item into the current zone the player is in. A slight but distinct difference.

 

Does anyone know if this is easy or hard?

If it is really hard then I will just go with the easy method of associating the put command with the zones

I created a demo cartridge for you. Its theme is delivering pizzas. Pick them up from the southeast zone (Fox's Pizza) and deliver the two pizzas to the nearby houses (a ridiculously short distance away). After that, return to the pizza parlor zone for a note of congratulations.

 

I only enabled a "Deliver" command when the player enters the zone (if anyone in your area uses a Garmin Wherigo Player, please use Proximity). I also disabled it when the player exits the zone (I can't recommend anything equivalent that's safe for a Garmin Player).

 

There are two ways you can accomplish what you want. The first way is to wait until the player is close to a zone, then enable all or some of your items' "put" commands so long as the player is close to the zone. When an item's "put" command fires (e.g. the player selects "put"), you'll have to test to see which zone your player is either in or in proximity to (test for both to avoid problems, please). Once you know this, you can do whatever else you want, such as telling the player if this is the right zone for the item or something. Don't forget to disable the "put" command (and, potentially, enable the "pick up" one) when your player places an item in a zone.

 

The second way to accomplish what you want is to have all the items' "put" commands already enabled. When the "put" command fires, you'll have to do everything I described above: check to see which zone your player is in, make sure that's the right zone for the item, and toggle the command states ("put" as inactive and "pick up" as active) depending upon what you want. Having the "put" command active all the time might not be as polished a solution as the first one, but it does cut down what you have to do to make the cartridge.

 

Depending upon the number of items and zones you have, this could be a slow process. I would recommend creating a test cartridge first, where you have all code needed to pick up an item and put it in a zone, and go somewhere (even next to where you live or work) and test what you wrote before you continue. Heck, you can even test the demo cartridge against a Player; it takes place where you last found a cache, "Hallowed Hollow". The demo cartridge does, though, require you to zero out (I was lazy and didn't add code to the proximity event). Either way, I do suggest you test in the field a pick up and drop off operation you wrote before creating the entire cartridge. You'll save time in the long run.

 

If you have any questions regarding this and reply, I'll split this conversation off the Urwigo Builder thread and into a new one. It's a good question and its answer is very informative.

Delivery_Boy.zip

Link to comment

Ranger Fox, awesome reply, worthy of being preserved for future developers. Checked the code and see exactly what you mean. I can easily add this into my cart, but as you suggested I might do a few quick tests. I will cut down on the number of zones I can put the object down in to make the coding easier.

 

sTeamTraen: thanks for the reply, the command you show looks to be what I was looking for first up but I am going to wait a bit before I just start doing the direct Lua editing (something to do with crawling before running).

 

Thanks to both of you.

Link to comment

So i am still having problems with the satellite images in edit map it was working fine now is not and the same thing on my computer at home I thought it was the computer but now with this computer not working either it must be the program and something happened to the setup program I had to go reinstall the program all over again it kept trying to load some microsoft program instead of urwigo what the hecks is happening?

 

Have you tried reinstalling the .net framework?

(It is necessary to have .NET Framework 3.5 SP1 installed. )

Here's a link - http://www.microsoft.com/downloads/en/deta...;displaylang=en

Link to comment

So i am still having problems with the satellite images in edit map it was working fine now is not and the same thing on my computer at home I thought it was the computer but now with this computer not working either it must be the program and something happened to the setup program I had to go reinstall the program all over again it kept trying to load some microsoft program instead of urwigo what the hecks is happening?

 

Have you tried reinstalling the .net framework?

(It is necessary to have .NET Framework 3.5 SP1 installed. )

Here's a link - http://www.microsoft.com/downloads/en/deta...;displaylang=en

 

Thanks fingers crossed I checked i have 3.5 installed so I dont think that is the problem???

I will try reinstalling it though

Link to comment

So i am still having problems with the satellite images in edit map it was working fine now is not and the same thing on my computer at home I thought it was the computer but now with this computer not working either it must be the program and something happened to the setup program I had to go reinstall the program all over again it kept trying to load some microsoft program instead of urwigo what the hecks is happening?

 

Have you tried reinstalling the .net framework?

(It is necessary to have .NET Framework 3.5 SP1 installed. )

Here's a link - http://www.microsoft.com/downloads/en/deta...;displaylang=en

 

Thanks fingers crossed I checked i have 3.5 installed so I dont think that is the problem???

I will try reinstalling it though

Ok so I uninstalled .net and reinstalled it. That didn't work. This is surley going to cause a stopage in my Wherigo creations. this is way harder to put together with out the Sat images and I am not driving out to check it after every little change. what a pain. Let me know if anyone else has any ideas

Link to comment
Ok so I uninstalled .net and reinstalled it. That didn't work. This is surley going to cause a stopage in my Wherigo creations. this is way harder to put together with out the Sat images and I am not driving out to check it after every little change. what a pain. Let me know if anyone else has any ideas

There is one other builder you could try. :anicute:

Link to comment
Ok so I uninstalled .net and reinstalled it. That didn't work. This is surley going to cause a stopage in my Wherigo creations. this is way harder to put together with out the Sat images and I am not driving out to check it after every little change. what a pain. Let me know if anyone else has any ideas

There is one other builder you could try. :anicute:

And that would be?

Link to comment

If I've followed correctly what's required here, it seems that this can be done with

zitemYourItemName:MoveTo(Player.Container)

 

I don't know if this is possible directly in Urwigo, without writing Lua code. (Yes, it is possible in Earwigo. :D)

 

sTeamTraen,

 

In those quiet moments in you head I realised that I can put in just a single line of code into my big bundle of urwigo code boxes so thanks for the correct line, I just had to change it to:

 

objYourItemName:MoveTo(Player.Container)

 

At least thats the code that works with urwigo.

 

Thanks,

Makes my life easier.

Link to comment

Danatisy: this is normal behaviour if you play cartridge compiled in your machine. If you upload cartridge to Wherigo.com, there will be correct completion code instead of "builder".

 

On a road cartridge test, I've notice that the Wherigo.com's generated code is set before the completion code I had indicated in the String Text mode screen. My completion code is "MOOSUS". Cartridge returns a code like GECGJJ576GRHBMOOSUS.

I had created a Task where MOOSUS code is written for further purpose when unlocking.

If I leave blank the completion code field, would it be ok?

How to set a task containaing the Wherigo.com's generated code?

Link to comment

You should be able to import it to Urwigo without a problem. I tried it just now and it imported just fine. I added a Urwigo file to the zip in this post for you. My original post was done with the Groundspeak Builder because all other third-party Builder applications can import this file.

 

In the future: To import a Builder cartridge to Urwigo, go to File: Import: Wherigo Builder Cartridge. From there, select the lua file.

Delivery_Boy.zip

Link to comment

I was asked to do a holloween cache that can only be done between 2300 to 0400. I have is started but it doesnt seem to be working. I attached the gwz file if someone would look at it and point me in the right direction.

attaching urwigo file as requested in zip

 

At 11:04 PM (23:04), your code returned t.hour as "23" and t.min as "4". So it looks like "getFormatedTime()" returned "234" which you are comparing to String"2300" and String"0400".

 

My first suggestion would be to simplify the problem and just deal with the hour portion of the time, since you only really need to worry about the current local hour being between 23 and 4

 

function getHour()

local t = os.date("*t");

return t.hour

end

 

So, then the cache can be done when the function returns >= 23 or <= 4

 

If I was building this, I would first be sure I understood exactly how those strings are being compared for example comparing "04" >= "4" might be different than comparing "4" >= "4".

 

Also, might want to look into using UTC since someone mentioned that a user could change their time zone in their GPS and make your code think its midnight in broad daylight. But then you have to be sure to handle that daylight savings time indicator.

 

I didn't have any luck playing with the following: return os.date('!%H%M'). Got the same results as a previous poster when trying to use these suggested tags.

 

DISCLAIMER: All I did was read the whole thread. I just downloaded URWIGO a few hours ago and wrote "hello world" then started playing around with the Pizza Delivery sample. I have no prior experience with wherigos - never found one and never built one. Maybe someday soon - URWIGO looks like fun.

Edited by dollarbell
Link to comment

:signalviolin:

Ran into a SERIOUS problem with the Urwigo builder today. Twice now, working on different type of user function coding then doing a test compile, Urwigo crashed with a very long error that ended up deleting EVERYTHING in the directory that my .urwigo files were and ALL my art/audio assets EXCEPT for the cartridge icon. If it weren't for the fact that I luckily have backups OUTSIDE of the work directory otherwise I would have lost everything that I've been working on for the past 2 months. There are no files in the recycling bin to recover, nothing. I seriously wish the xml urwigo were more edit friendly and readable or that urwigo had an export to lua feature. Just an FYI for the author. Love the program. Hate the delete error. The strange thing is that it deletes ANYTHING in the directory (even things not locked or used by urwigo in the creation of the cartridge).

 

Steve (Waya)

 

(screenshot of error attached)

post-3053158-1286610754.png

Link to comment

Help! The program at my .urwigo file! Then it ate itself!

 

I have been using Urwigo to build my first cart, and for the most part, it's been great. I really like the program, but I occasionally get fatal errors that cause me to reboot. For this reason, I've been saving often and made a backup of the whole folder elsewhere on my hard drive.

 

However, today I encountered the worst error. Not only did I get the blue screen of death and a forced reboot, the computer ran a chkdsk and seemed to find something wrong with the .urwigo file. When I finally got back to Windows, the .urwigo file was gone.

 

Even that wouldn't be so bad since I had a backup copy elsewhere, but now it wasn't even letting me restart the program. I would continually get a fatal error when I try to start the program.

 

So my next thought was to download a fresh copy of the program and re-install it. But even that didn't work. I still get a fatal error when I try to run the program. I thought maybe it was a .NET issue, so I re-installed 3.5 SP1, but I still have the problem. I am running XP SP2 on an Apple MacBook.

 

I decided to install the program on a different machine (a Mac Mini running Windows 7). It installed and ran fine. I retrieved my backup, but it was from yesterday and I had done some good work on it today. I ran the temporary gwc files the program creates when it runs the emulator and I found one that had some (though not all) of my work from today.

 

So long story short, the .urwigo file is older than the .gwc file. Is there any way to retrieve a "newer" .urwigo file from the .gwc file? I would really doubt it, because then you could do that with any .gwc file out there. But I have to ask.

 

And I want to get Urwigo back up and running on my laptop. Any suggestions?

Link to comment

And I want to get Urwigo back up and running on my laptop. Any suggestions?

 

Well, I solved this problem. There seemed to be something wrong in the Apps folder (C:\Documents and Settings\username\Local Settings\Apps). I determined that everything in there was related to Urwigo, so I renamed the folder (to Appsbak). I then ran the installer and it ran perfectly and created a new Apps folder. I deleted the Appsbak folder and now I'm back in business.

 

Now to see if I can recover some of the work I did today.

Link to comment

I realized after the fact that when I posted a question to a new topic that it place my question in the general Wherigo site rather than within the Urwigo.

 

I am adding sound to my game. it is a historical game based on the civil war. it isn't critical to the game, but it adds color.

 

I added them in Midi because i thought that the Garmin's support that format. now I find that they do not.

 

When i put the game into the builder, there is no audio. I tried an MP3 with the same result.

 

I remember hearing audio in one of the games from J2b2. Looking at his game I noticed that it was a wav file. i linked to one of his wav files and it worked in the builder. When I added other wav files that I downloaded, I hear nothing but silence.

 

Is there a special file that must be used for sound?

 

If I leave the sounds in the game, will that screw up playing it on a Garmin?

 

Edit:

I did get wav file to work.

Edited by syzygy54
Link to comment

I made a nice (big) Urwigo-Cartridge... about 60 stages.

 

And I'm playing it on a Android 1.6 mobile.

 

The cartridge saves the game very often...

When I quit the Whereyougo-program and restart it and load the program it is fine.

 

But when I quit the program, turn off the mobile and turn on the mobile again... I can't load the cartridge anymore.

 

I think I had the same problem that I couldn't resume when I phoned while I played.

 

Anyone encountered something like this?

Link to comment

good evening

there is another problem with Urwigo now when I do "build, compiles cartridge GWC" I get an error (file attached) and also will delete all my files, folder and shortcuts that are on the desktop.

I tried three times and still the same result is indeed a bug Urwigo

 

helppost-1370818-1288637708.jpg

Link to comment

I encounter the same problem as "Woyi and Waya and Team Peredox" but I do not find (C: \ Documents and Settings \ username \ Local Settings \ Apps)

What version of Windows are you running?

 

Note that "username" in the Documents and Settings folder should be YOUR username, not "username".

 

 

Hello Team Peredox

 

I am running Windows Seven and the C: \ Documents and Settings \ my name \ Local Settings \ Apps is not present

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 61
×
×
  • Create New...