Jump to content

URWIGO builder

Followers 61

Recommended Posts

Last update I guess: I dug out my old laptop and tried it there - and everything works as it should. There's something wrong with my computer that won't let me use Urwigo properly but I have no idea what. The Urwigo website only mentions .net framework 3.5 as requirement, and I checked that one.


This error seems to be somehow related to something within the zones, but I can't figure out what. Location/number settings maybe? As in: my current computer is continental European and I use a mix of British and European settings (decimal separators, dates, language), while the old one is totally British. I can't quite imagine that this would be an issue though.

Link to comment

Well, we needed to produce a new WIG in a crashing hurry, actually running urwigo in a Windows-10 session under VirtualBox on a Mac ... and ... "It worked.  Beautifully."


Because I am not yet familiar with this programming environment, I found it very beneficial to be able to work within a visual tool-set that was obviously designed by someone who understood it thoroughly.  Speaking as a professional programmer, I am quick to tip my hat to a colleague and admit that "I am mightily impressed This Is A Great Hack.™" 


Of course I have dealt with plenty of "visual programming environments" over these (koff, koff ...) many years, and I need not say what I felt about most of them. But this one is a functional and beneficial tool.  It saved me from a bunch of mistakes that I otherwise would have made "merely due to inexperience," and it enabled me to meet a very tight deadline.  The "real-time error checker" was exceptionally helpful since it pointed out errors in my logic that I otherwise would never have guessed, again "due to inexperience."


"Very. Impressive." 

Edited by Team Bear-Cat
Link to comment

This is my first go at Urwigo and I have no experience in programming. After some time I managed to construct a cartridge that works, but I am not happy with the layout of one part. I have calculated the distance between two points using the Lua user expression: Wherigo.VectorToPoint(Player.ObjectLocation,Zonepoint) and got following output: distance(233.015451651, 'm'). Instead I would like to get only 233.015451651, in other words I'd like to get rid of the words distance and 'm'.

Some assistance would be appreciated.

Link to comment

VectorToPoint returns two objects: a distance and a bearing.  Thus:


local d2,b2 = Wherigo.VectorToPoint(Player.ObjectLocation, zoneGeocache.Points[1])

local distInMeters = d2("m")
local distInFeet = d2("ft")
local distInMiles = d2("mi")
local distInKm = d2("km")

Wherigo.MessageBox{Text="The geocache zone as related to your location:<BR>Geocache: " .. zoneGeocache.Points[1].latitude .. " " .. zoneGeocache.Points[1].longitude .. "<BR><BR>You: " .. Player.ObjectLocation.latitude .. " " .. Player.ObjectLocation.longitude .. "<BR><BR>Meters: " .. distInMeters .. "<BR>Kilometers: " .. distInKm .. "<BR>Feet: " .. distInFeet .. "<BR>Miles: " .. distInMiles}

I believe miles does not work in some player applications.  I'd suggest testing this and staying with the metric system unless you need to convert it to show in the heathen, arcane system.  Ha, ha.

Link to comment

So I downloaded the software and have made progress building my cartridge. Unfortunately, as I progressed in the build it started crashing frequently. I am running windows 10. First the sound don't play in the emulator then it just crashes.   I am a total newbie and have been following the You Tube tutorial. I really like the interface of the application but the near constant crashing is making it unworkable. Anyone else experience this? Is there a solution or should I try Earwigo? 




Link to comment

Sadly the official Install Link (https://www.urwigo.cz/?page_id=6 and then Install) gave me a 404 today (Btw the HTTPS Certificate expired on 11th June).

I was able to obtain the Installer from Archive.org, but that is not a very good solution in my opinion.

I Hope That the official Link will work again some day.

@yourself will you fix the Download (and Certificate) or is Urwigo already discontinued?

Link to comment

When using a command on an item, how do I get a reference to the item in Lua User Code.


I want to write a script that can be added to  multiple items that then modify the item, but I need to know what item called it.


Thanks in advance for any help.


Never mind, I found it by trial and (mainly) error, it is “self” for those who are curious.

Edited by The Royles
Found it
Link to comment



I created a cartridge with Urwigo. I am pleased with it. I created a GWZ-file and uploaded it to the Wherigo.com website. It uploaded fine, but I cannot download it. The error message is: 

Error During Upload

System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Exception of type 'System.ApplicationException' was thrown. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Wherigo.GSPCartridgeService.CartridgeService.GetCompiledCartridgeWithMetaData(GWZMetaData gwzMetaData, String CartridgeFileName, String CartridgeId, Int64 PlayerId, String PlayerName, DeviceType deviceType, String CompletionCode) at cartridge_download.btnDownload_Click(Object sender, EventArgs e)

Edited by DeborahVanDerLinden
Link to comment
17 hours ago, J3chy said:

hello, how do I create a true or false? thank you

In Urwigo, you can create a variable. You can click at value and choose true or false.

In the program, you can change this by using "set" variable true or false.

You can use the if/else action, to check whether the variable is currently true or false.

Link to comment
18 hours ago, J3chy said:

hello, how do I create a true or false? thank you

In the left upper-left section, you will the block "Value" under "Expressions" between "Contains" and "Answer". Put the block at the place you need. Then you can change the value at the right section

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 61
  • Create New...