Jump to content

URWIGO builder


yourself
Followers 61

Recommended Posts

I had a older version of Urwigo (year 2011) on my windows vista system. It works well!

 

Now I have tried to install the newest Urwigo builder ( from www.urwigo.cz/) on my windows 7 (SP1) platform. Windows 7 should include the recommended .NET Framework 3.5 SP1. It is also installed .NET Framework 4.5.1.

The installation of URWIGO doesn't work. I'm not sure if the problem is my Anti-Spy programm 'Sophos'. It has a Adware/PUA in quarantine?!

Can someone help and explain installation for dummies (me)?

Link to comment

I installed the program and wanted to have a look at one of the open source cartridges. I downloaded 4 different ones, renamed them as zip and extracted the files but none of the lua files will import into Urwigo, including one built in Urwigo. Is there some knack to getting them to import?

Link to comment

99,9% of the owners, who publish their cartridge as open source, have forgotten to copy the Urwigo source (*.urwigo) into the GWZ file. The generated *.lua from Urwigo doesn't work with Urwigo !!!!

 

I have a test cartridge as real open source, have a look at Wherigo Testuite (english) or Wherigo Testsuite (german) and download the GWZ (not the GWC). Unpack all files with an unzipper and load the urwigo file into Urwigo application.

Link to comment

99,9% of the owners, who publish their cartridge as open source, have forgotten to copy the Urwigo source (*.urwigo) into the GWZ file. The generated *.lua from Urwigo doesn't work with Urwigo !!!!

 

I have a test cartridge as real open source, have a look at Wherigo Testuite (english) or Wherigo Testsuite (german) and download the GWZ (not the GWC). Unpack all files with an unzipper and load the urwigo file into Urwigo application.

That works a treat. Many thanks.

Link to comment

Hello!

I don't know if I am posting on the right topic but I can't understand what is happening with urwigo on my computer...

Well the problem is when I try edit zones or select the Start the map don't appear... Like you can see on the images...

Does anyone know how can I solve this problem?

 

Thank You!!

post-5688466-050812900 1408545921_thumb.jpg

post-5688466-019050200 1408545930_thumb.jpg

Link to comment

Hi

 

I'm having a problem about upload the cartridge to Wherigo.com. Urwigo only allows me to compile to cartridge as GWC file, but when I try to build a package (GWZ) with Urwigo it shows an error message 'Error while building cartridge:1 is not a supported code page. Parameter name: codepage'. Any solutions?

Link to comment

Hi,

I would like to introduce Urwigo - an alternative to official Wherigo Builder. It is not trying to be a competition for Earwigo, which I am sure is great, it was created solely from my frustration with Builder. I believe it will be useful for the Wherigo/Geocaching community.

Urwigo can import cartridges created in Whergo Builder, it has a different take on building the cartridge code, it has a few more functions and most importantly it should be more reliable and stable.

 

In addition to Wherigo builder Urwigo allows:

- create, edit, view all zones on google maps

- random numbers generation

- obfuscating and encrypting answers

- showing errors in your cartridge

- syntax highlighting in user LUA functions

- automatic shortening of unlock code

- run cartridge in emulator with only one button (F5)

- many more...

 

When I click on this link, there is no option for English. HEPL PLEASE

It can be downloaded and installed from Download & Install URWIGO - bottom of the page.

 

post-2816453-1266327495.jpgpost-2816453-1266327515.jpgpost-2816453-1266327524.jpgpost-2816453-1266329030.jpg

 

Moderator Note: Use this updated link: http://www.urwigo.cz/index.php/cs/

Link to comment

Does anyone know an easy way to limit the number of items in a player's inventory? I want to limit the player to having a max of one item in inventory at a time.

 

It isn't the right place for this question ...

 

Each time you add something to the inventory, check the number of items in the inventory. If there are more than one item, than don't move the item to the inventory.

Link to comment

hi all

i am trying to down load the URWIGO programme and getting the following errors

 

error is

 

An error occurred attempting to install Urwigo.

 

error log is

 

The following properties have been set:

Property: [AdminUser] = true {boolean}

Property: [ProcessorArchitecture] = Intel {string}

Property: [VersionNT] = 6.1.1 {version}

Running checks for package 'Windows Installer 3.1', phase BuildList

The following properties have been set for package 'Windows Installer 3.1':

Running checks for command 'WindowsInstaller3_1\WindowsInstaller-KB893803-v2-x86.exe'

Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi' and value '3.1': true

Result of checks for command 'WindowsInstaller3_1\WindowsInstaller-KB893803-v2-x86.exe' is 'Bypass'

'Windows Installer 3.1' RunCheck result: No Install Needed

Running checks for package '.NET Framework 3.5 SP1', phase BuildList

Reading value 'SP' of registry key 'HKLM\Software\Microsoft\NET Framework Setup\NDP\v3.5'

Read integer value 1

Setting value '1 {int}' for property 'DotNet35SP'

The following properties have been set for package '.NET Framework 3.5 SP1':

Property: [DotNet35SP] = 1 {int}

Running checks for command 'DotNetFX35SP1\dotNetFx35setup.exe'

Result of running operator 'ValueGreaterThanEqualTo' on property 'DotNet35SP' and value '1': true

Result of checks for command 'DotNetFX35SP1\dotNetFx35setup.exe' is 'Bypass'

'.NET Framework 3.5 SP1' RunCheck result: No Install Needed

Launching Application.

URLDownloadToCacheFile failed with HRESULT '-2146697211'

Error: An error occurred trying to download 'http://apps.yourself.cz/Urwigo/Urwigo.application'.

 

What am i doing wrong or am i missing samethink

Link to comment

I am trying to install urwigo on my Windows 7 Professional computer. When I run the setup.exe I get a message box saying "Application cannot be started. Contact the application vendor". Details are:

 

PLATFORM VERSION INFO

Windows : 6.1.7601.65536 (Win32NT)

Common Language Runtime : 4.0.30319.18444

System.Deployment.dll : 4.0.30319.34244 built by: FX452RTMGDR

clr.dll : 4.0.30319.18444 built by: FX451RTMGDR

dfdll.dll : 4.0.30319.34244 built by: FX452RTMGDR

dfshim.dll : 4.0.41209.0 (Main.041209-0000)

 

SOURCES

Deployment url : http://apps.yourself...igo.application

Server : Apache/2.2.22 (Debian)

 

IDENTITIES

Deployment Identity : Urwigo.application, Version=1.20.0.141, Culture=neutral, PublicKeyToken=f37633858e53e440, processorArchitecture=x86

 

APPLICATION SUMMARY

* Installable application.

 

ERROR SUMMARY

Below is a summary of the errors, details of these errors are listed later in the log.

* Activation of http://apps.yourself...igo.application resulted in exception. Following failure messages were detected:

+ Activation failed.

+ The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

 

COMPONENT STORE TRANSACTION FAILURE SUMMARY

No transaction error was detected.

 

WARNINGS

There were no warnings during this operation.

 

OPERATION PROGRESS STATUS

* [18/10/2014 5:08:14 PM] : Activation of http://apps.yourself...igo.application has started.

* [18/10/2014 5:08:15 PM] : Processing of deployment manifest has successfully completed.

 

ERROR DETAILS

Following errors were detected during this operation.

* [18/10/2014 5:08:15 PM] System.Deployment.Application.DeploymentException (Activation)

- Activation failed.

- Source: System.Deployment

- Stack trace:

at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.SubscriptionStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.ApplicationActivator.Activate(DefinitionAppId appId, AssemblyManifest appManifest, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

--- Inner Exception ---

System.IO.FileNotFoundException

- The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

- Source: System.Deployment

- Stack trace:

at System.Deployment.Application.NativeMethods.CorLaunchApplication(UInt32 hostType, String applicationFullName, Int32 manifestPathsCount, String[] manifestPaths, Int32 activationDataCount, String[] activationData, PROCESS_INFORMATION processInformation)

at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

 

COMPONENT STORE TRANSACTION DETAILS

* Transaction at [18/10/2014 5:08:15 PM]

+ System.Deployment.Internal.Isolation.StoreOperationSetDeploymentMetadata

- Status: Set

- HRESULT: 0x0

+ System.Deployment.Internal.Isolation.StoreTransactionOperationType (27)

- HRESULT: 0x0

 

Any help appreciated.

Link to comment

I got a message from yourself, Urwigo's developer. He let me know there had been some issues with the site, but everything should be up and working now.

 

For those of you who may still have problems starting Urwigo without it crashing, please uninstall it and try installing it again from Urwigo's site. (I mention this because this is a preexisting problem with my installation and I'll have to do the same when I get some time.)

Link to comment

Hello! I am testing my cartridge in the field but occasionally it shows a white screen instead of the message with the information for the player (using whereyougo app). It does not occurs every time that I play the cartridge; for example, if I start over playing the cartridge it does not show the same white screen again...

 

Thks

Link to comment

I modified the link on the first post. I was also able to do an install on a clean machine. Try it again and see if you come across the same problem again.

 

Also, you may have to disable your antivirus software during the installation process because Urwigo's lua parser could trigger a misidentification.

Edited by Ranger Fox
Added the second paragraph.
Link to comment

I posted about this awhile back but was not able to come up with a solution. When I run the emulator for urwigo my computer does not display "tasks." Is anyone else having this issue or know how to fix this? I have attached a screenshot of what I am seeing on the emulator screen.

 

The attached picture is not displayed.

Link to comment

Hi! Im asking in this forum since there seems to be a lot of knowledge here.

Today when i started Urwigo it doesnt display any map. It seems to be a problem to connect with the mapserver?? Can someone confirm this?

 

The problem is most likely with the Google Maps API, check the evening CET.

Link to comment

Hi! Im asking in this forum since there seems to be a lot of knowledge here.

Today when i started Urwigo it doesnt display any map. It seems to be a problem to connect with the mapserver?? Can someone confirm this?

 

The problem is most likely with the Google Maps API, check the evening CET.

 

Same problem here. No maps.

Link to comment

Hi! Im asking in this forum since there seems to be a lot of knowledge here.

Today when i started Urwigo it doesnt display any map. It seems to be a problem to connect with the mapserver?? Can someone confirm this?

 

The problem is most likely with the Google Maps API, check the evening CET.

 

Same problem here. No maps.

Same Problem here also no maps

use the website Down for everyone or just me look like the map sit is down http://maps.gstatic.com

 

hope this helps

Link to comment

The new version 1.21 URWIGO already available.

 

Upgrade perform as always. When you first start your urwigo detects whether a new version is available and when the second launch will start downloading and installing.

 

The new version is a completely re-work the map both in urwigo and the Wherigo Player scored by Groundspeak.

 

It was also fixed a bug in the Wherigo Player when the position indicator (doll) spontaneously began to run.

 

In urwigo was added just smallness and that when editing zone shows the original shape.

Link to comment

Thank you for the update! Works perfect again.

 

I saw, that you also changed the Groundsspeak Wherigo Player.dll. The map.html file isn't used any longer. So the question is, could you ensure, that the next time Microsoft change their interface to Bing, it is easy to change the map?

 

And another question is open: is it possible to add the flag MakeReciprocal to commands?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 61
×
×
  • Create New...