Sign in to follow this  
Followers 55
yourself

URWIGO builder

789 posts in this topic

I have created a file that works .. but I do not know how I can get the unlock code until the user .. there are some who knows how .. ?

You have to drag CompletitionCode from Objects and properties/Player. See the attachments.

post-2816453-1267644617.jpgpost-2816453-1267644628.jpg

 

How do you add the text on both sides of the completion code in the concatenate box?

 

Drag 'Value' from Expessions and enter text in the string.

0

Share this post


Link to post

Drag 'Value' from Expessions and enter text in the string.

 

THANX!

0

Share this post


Link to post

Tequila: I contact you via PM in case of Oregon protection.

Edited by me2d09
0

Share this post


Link to post

How do you put a oregon/colorado in demo mode? I never heard of it.

0

Share this post


Link to post

delta123: In Oregon: Setting ->System -> GPS -> Simulation mode (demo mode)

0

Share this post


Link to post

Has anyone tried the "Simulation Protection Mode" option? It doesn't seem to work for me.

 

I check the option, load the cartridge onto my OR, power the OR on, put it in demo mode and the cartridge appears to run. I do not get the Error Message that I created.

What Type of the Oregon do you have and what firmware version?

0

Share this post


Link to post

Has anyone tried the "Simulation Protection Mode" option? It doesn't seem to work for me.

 

I check the option, load the cartridge onto my OR, power the OR on, put it in demo mode and the cartridge appears to run. I do not get the Error Message that I created.

What Type of the Oregon do you have and what firmware version?

 

Oregon 300 Firmware 3.60

0

Share this post


Link to post

Oregon 300 Firmware 3.60

Try the current version, I have made some changes.

0

Share this post


Link to post

Oregon 300 Firmware 3.60

Try the current version, I have made some changes.

 

BINGO!!!! Thank You.

0

Share this post


Link to post

Does this also work on a Colorado? I get the message but it does not shut down(the protection does not work)

0

Share this post


Link to post

Does this also work on a Colorado? I get the message but it does not shut down(the protection does not work)

 

I get the message. It stays in the cartridge but no zones, items, etc. are visible. So it works fine in the OR.

0

Share this post


Link to post

Yes i see now, the zones are gone. it works.

0

Share this post


Link to post

Yourself,

Thanks for this program!!!

It is working good. I used it to fix my other 2 Wherigo's that cachers with garmins were having problem with. I made them with the builder and now they work great.

I also have made 2 other Wherigo geocaches that are working perfectly that I made with your program.

I just hid 2 more caches I am going to make into Wherigo's and I have 2 other that I am still working on. They are kinda complicated though one has 16zones.

Thanks again! :D;):D:lol::D:lol:

0

Share this post


Link to post

Tried to install URWIGO this evening. Installation failed, log file below. Any suggestions?

It indicates that the MS ClickOnce installer failed to download neccesary installation files. I believe it internally uses Internet Explorer, check you have at least version 7 which I sure works ok with it. Other than that, you are first one with this problem, you'll propably have problems with any ClickOnce installer.

 

Then I am the second one with the same problem, see log below. Maybe someone can help me with this?

 

The following properties have been set:

Property: [AdminUser] = true {boolean}

Property: [ProcessorArchitecture] = Intel {string}

Property: [VersionNT] = 6.0.1 {version}

Running checks for package 'Windows Installer 3.1', phase BuildList

The following properties have been set for package 'Windows Installer 3.1':

Running checks for command 'WindowsInstaller3_1\WindowsInstaller-KB893803-v2-x86.exe'

Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi' and value '3.1': true

Result of checks for command 'WindowsInstaller3_1\WindowsInstaller-KB893803-v2-x86.exe' is 'Bypass'

'Windows Installer 3.1' RunCheck result: No Install Needed

Running checks for package '.NET Framework 3.5 SP1', phase BuildList

Reading value 'SP' of registry key 'HKLM\Software\Microsoft\NET Framework Setup\NDP\v3.5'

Unable to read registry value

Not setting value for property 'DotNet35SP'

The following properties have been set for package '.NET Framework 3.5 SP1':

Running checks for command 'DotNetFX35SP1\dotNetFx35setup.exe'

Skipping ByPassIf because Property 'DotNet35SP' was not defined

Result of running operator 'ValueEqualTo' on property 'AdminUser' and value 'false': false

Result of running operator 'VersionLessThan' on property 'VersionNT' and value '5.1.2': false

Result of running operator 'VersionEqualTo' on property 'VersionNT' and value '5.2.0': false

Result of running operator 'ValueEqualTo' on property 'ProcessorArchitecture' and value 'IA64': false

Result of checks for command 'DotNetFX35SP1\dotNetFx35setup.exe' is 'Install'

'.NET Framework 3.5 SP1' RunCheck result: Install Needed

EULA for components '.NET Framework 3.5 SP1' was accepted.

Copying files to temporary directory "C:\Users\Jaco\AppData\Local\Temp\VSDFD90.tmp\"

Downloading files to "C:\Users\Jaco\AppData\Local\Temp\VSDFD90.tmp\"

(09/03/2010 13:29:39) Downloading 'DotNetFX35SP1\dotNetFx35setup.exe' from 'http://go.microsoft.com/fwlink/?linkid=118076' to 'C:\Users\Jaco\AppData\Local\Temp\VSDFD90.tmp\'

Download completed at 09/03/2010 13:29:46

Verifying file integrity of C:\Users\Jaco\AppData\Local\Temp\VSDFD90.tmp\DotNetFX35SP1\dotNetFx35setup.exe

WinVerifyTrust returned 0

File trusted

Running checks for package '.NET Framework 3.5 SP1', phase BeforePackage

Reading value 'SP' of registry key 'HKLM\Software\Microsoft\NET Framework Setup\NDP\v3.5'

Unable to read registry value

Not setting value for property 'DotNet35SP'

The following properties have been set for package '.NET Framework 3.5 SP1':

Running checks for command 'DotNetFX35SP1\dotNetFx35setup.exe'

Skipping ByPassIf because Property 'DotNet35SP' was not defined

Result of running operator 'ValueEqualTo' on property 'AdminUser' and value 'false': false

Result of running operator 'VersionLessThan' on property 'VersionNT' and value '5.1.2': false

Result of running operator 'VersionEqualTo' on property 'VersionNT' and value '5.2.0': false

Result of running operator 'ValueEqualTo' on property 'ProcessorArchitecture' and value 'IA64': false

Result of checks for command 'DotNetFX35SP1\dotNetFx35setup.exe' is 'Install'

'.NET Framework 3.5 SP1' RunCheck result: Install Needed

Verifying file integrity of C:\Users\Jaco\AppData\Local\Temp\VSDFD90.tmp\DotNetFX35SP1\dotNetFx35setup.exe

WinVerifyTrust returned 0

File trusted

Installing using command 'C:\Users\Jaco\AppData\Local\Temp\VSDFD90.tmp\DotNetFX35SP1\dotNetFx35setup.exe' and parameters ' /lang:enu /passive /norestart'

Process exited with code -2146762496

Status of package '.NET Framework 3.5 SP1' after install is 'InstallFailed'

0

Share this post


Link to post

I am using firefox I hate Internet explorer it's a pain

0

Share this post


Link to post

I had some problems with te normal Wherigo builder.

now i make the last part of the Wherigo with Urwigo and i had to find this program earlier, how nice is it. Thx for making it.

0

Share this post


Link to post

 

How do you add the text on both sides of the completion code in the concatenate box?

 

Drag the "Concatenate" box into view

Drag the "Completion Code" into that box

Go to "Value" and drag that to the LEFT of the Completion Code

Change the settings for "Value" on the right hand side of the screen to "String Text"

Type in your "Before" the code text

Drag another "Value" to the RIGHT of the Completion Code

Change the settings for that "Value" on the right hand side to "String Text"

Type in your "After" the code text

 

RCA777

0

Share this post


Link to post

I have a question about completion codes is the completion code automatically generated when you add that to your cartridge or do I need to do something else like put in a value some where?

0

Share this post


Link to post

A Team Vallejo: Completion code is generated when you download your cartridge from Wherigo.com. Completion code variable in URWIGO is a variable for reading, where that code is stored. You don't need to put that value anywhere else. It is just for showing completion code to player.

0

Share this post


Link to post

A Team Vallejo: Completion code is generated when you download your cartridge from Wherigo.com. Completion code variable in URWIGO is a variable for reading, where that code is stored. You don't need to put that value anywhere else. It is just for showing completion code to player.

Ok Thanks Do they still have to upload the saved file or is the code all they need?

0

Share this post


Link to post

A Team Vallejo: Completion code is generated when you download your cartridge from Wherigo.com. Completion code variable in URWIGO is a variable for reading, where that code is stored. You don't need to put that value anywhere else. It is just for showing completion code to player.

Ok Thanks Do they still have to upload the saved file or is the code all they need?

 

the code is all they need but I recommend you save cartridge in case they don't remember the code.

0

Share this post


Link to post

Hello there,

 

This is realy a great program. I've tried to build a Wherigo with the wherigobuilder bat that was hard to do. Now i've tried it whit Urwigo and it's great and easy. :blink::):)

 

Thanx to YourSelf and the testers.

 

Greetz Tjappie W

(Holland)

0

Share this post


Link to post

What a brilliant piece of work. I have been struggling (as everyone else ) with the Wherigo builder, it kept on crashing for no apparent reason. But your program pointed out the faults straight away. (text too long - who'd have thought it!?)

 

Thankyou very much.

 

You need lots of publicity as I'm sure there are lots out there wanting to Wherigo but getting stuck on 'issues' which should have been fixed long ago.

 

No need now.

 

Thanks again.

0

Share this post


Link to post

hi,

 

I work now a little time with this program and i like it.

there is only one thing i shout like to see in Urwigo.

I like to see te option to put in the wgs84 coördinates. (deg min.min)

this because google maps works with a mistake of 50 till 100 m.

if it is possible i like to hear.

 

thx

Jeebeevee

0

Share this post


Link to post

For those people who are struggling with coordinate types, there's a great little program Fizzy Calc that converts them for you. It works fine until (if) we can enter different types.

 

It's available here... http://www.fizzymagic.net/Geocaching/FizzyCalc/

 

(It is an Exe, but as of 3.17 it's fine)

(It's also helpful for some puzzles too :wub: )

 

FC.

0

Share this post


Link to post

Hello all, first of all sorry for my bad english :D

 

I'm using Urwigo for 2 weeks now to build a cartridge and it works really great but.......

 

When the player enters a zone he'll get a puzzle/riddle (item to player, get input). If the answer he gives is wrong he get a message and the firts hint. So there is a possibility to give a answer again (item commands). If he answers wrong again he'll get a second hint a possibility to give a anwser again.

 

It continues till 3 hints. If the player's answer is wrong again the puzzle/riddle will disapeare.

 

When I try the cartridge in the emulator i'll get the first hint and second hint. After that he'll stays showing the second again and again and again. So I won't get the 3 hint and the puzzel won't disapeare after the 4th wrong answer.

 

The script i'm using is the attachment.

 

I'll someone could help me,

 

Thnx

 

Edit:

Wrong attachment

post-2010533-1268937538.jpg

Edited by Tjappie W
0

Share this post


Link to post

Tjappie W: Is is easy, just change conditions in if/else branches (that with orange background). Correct is only first if/else branch. In others:

2nd branch: Hint 1.Enabled = True --> Hint 2.Enabled = false

3rd branch: Hint 2.Enabled = True --> Hint 3.Enabled = false

4th branch: this condition should be empty

0

Share this post


Link to post

Tjappie W: Is is easy, just change conditions in if/else branches (that with orange background). Correct is only first if/else branch. In others:

2nd branch: Hint 1.Enabled = True --> Hint 2.Enabled = false

3rd branch: Hint 2.Enabled = True --> Hint 3.Enabled = false

4th branch: this condition should be empty

 

Thanks a lot!!! It works.

 

I didn't understood wat went going wrong....no I do!!!!

 

Only 11 puzzles/riddles to go

 

This is why more people should build Wherigo's it is that simple :D

0

Share this post


Link to post

Since downloading this alternative builder and, not getting on with it, uninstalling it, the Wherigo builder will not work. On compiling a LUA file it seems fine then when trying to re-open it I get the following error message

 

error.JPG

 

I also get the same with previously made cartridges. can anyone help please.

 

I am trying to run this on windows 7 64bit.

 

Many thanks

0

Share this post


Link to post

I have a question about proximity is there a way to disable the proximity after a player has entered a zone so that when they leave the zone it does not make a message pop up a second time? I wanted it to only pop up the message when they are on the way to the zone not after they leave the zone.

0

Share this post


Link to post

I have a question about proximity is there a way to disable the proximity after a player has entered a zone so that when they leave the zone it does not make a message pop up a second time? I wanted it to only pop up the message when they are on the way to the zone not after they leave the zone.

 

There are probably more elegant ways but I use a switch. On enter, display msg and turn off switch. A simple IF statement around the display tests the switch. If on, display else don't display.

0

Share this post


Link to post

Then I am the second one with the same problem, see log below. Maybe someone can help me with this?

Try installing .NET Framework 3.5 manually before Urwigo.

http://www.microsoft.com/downloads/details...;displaylang=en

I tried, but with the same result, .NET Framework 3.5 refuses to install :)

 

After a long search I have found the solution: download and install the Microsoft System Update Readiness Tool (checksur.exe). The program looks for errors in the installation of .net framework and tries to repair them. When this works you can use Microsoft Update for the latest version of .net framework and thereafter you can install Urwigo.

0

Share this post


Link to post

Since downloading this alternative builder and, not getting on with it, uninstalling it, the Wherigo builder will not work. On compiling a LUA file it seems fine then when trying to re-open it I get the following error message

 

error.JPG

 

I also get the same with previously made cartridges. can anyone help please.

 

I am trying to run this on windows 7 64bit.

 

Many thanks

Urwigo does not disturb Wherigo Builder installation in any way. The message indicates loading of 32bit library from 64bit process, which is a side effect of original Wherigo Builder installation on 64bit windows. If that is the case, see http://forums.Groundspeak.com/GC/index.php?showtopic=212622 .

0

Share this post


Link to post

After a long search I have found the solution: download and install the Microsoft System Update Readiness Tool (checksur.exe). The program looks for errors in the installation of .net framework and tries to repair them. When this works you can use Microsoft Update for the latest version of .net framework and thereafter you can install Urwigo.

That is great news, I'll make sure to make a note if I see this error elsewhere.

0

Share this post


Link to post

I have a question about proximity is there a way to disable the proximity after a player has entered a zone so that when they leave the zone it does not make a message pop up a second time? I wanted it to only pop up the message when they are on the way to the zone not after they leave the zone.

 

There are probably more elegant ways but I use a switch. On enter, display msg and turn off switch. A simple IF statement around the display tests the switch. If on, display else don't display.

 

Ok thanks Tequila I will try that

0

Share this post


Link to post

I need some help developing the code, in URWIGO, to access system date and time.

 

When I try to import a Builder LUA file that contains an Author Script that does it, I get an "Error While Cartridge Import"

 

So far I have been unable to code the equivalent in URWIGO.

 

Can someone, please, either explain how to do it, or better yet, post a short URWIGO cartridge that does it.

 

Thank you.

0

Share this post


Link to post

Hi Tequila,

 

I dont know what exactly you want to do with time and date, but I created simple cartridge which uses some datetime functions i Wherigo.

 

See attached screenshot from Urwigo, where all important code is visible. Also you can download urwigo file (unzip first).

 

I hope I helped you.

 

PS: Please send your LUA file from builder to youself, he will surely fix it.

post-723638-1269789894.png

datetime.zip

0

Share this post


Link to post

Thanks for the quick response. That is great. I didn't realize there were User Function windows to add code.

 

Attached is the Builder lua file that will not import. It is just a play cartridge I use to try different things.

 

I have not been able to import any lua file that has Author Scripts.

 

Thanks for all your help.

BoilerPlate.zip

0

Share this post


Link to post

I have a very simple cartridge (attached here) that is supposed to tell me the current latitude using the variable, Player.ObjectLocation.latitude

 

When I create a User Function to return this value, it returns an incorrect value. When I put the variable, Player.ObjectLocation.latitude, in a simple message, it returns the correct answer. In this case, 37.869 is incorrect and 45.869 is correct.

 

The user function looks like this:

 

function getIntegerLatitude()

local x = Player.ObjectLocation.latitude; --get raw version of Latitude

return x;

end

 

Ignore the comments about integers. I haven't wrote that part yet.

 

Any ideas?

Latitude_as_Integer_Only.zip

0

Share this post


Link to post

Hi

 

First I'll like to say that Urwigo is a much better Cartridge builder than the one from Groundspeak. Thank a lot for all the work you have made.

 

I found one place that misses translation. Its the Mouse-over hit to "On active changed" on a task

 

One question. How can I create window with 6 buttons? I'm trying to create a Cluedo Wherigo Cartrige and need the 6 buttons for the user to pick between the 6 possibly killers or the 6 possibly murder weapons.

 

Regards

Jens (ninasger)

post-679185-1269970946.jpg

0

Share this post


Link to post

I have a very simple cartridge (attached here) that is supposed to tell me the current latitude using the variable, Player.ObjectLocation.latitude

 

When I create a User Function to return this value, it returns an incorrect value. When I put the variable, Player.ObjectLocation.latitude, in a simple message, it returns the correct answer. In this case, 37.869 is incorrect and 45.869 is correct.

 

The user function looks like this:

 

function getIntegerLatitude()

local x = Player.ObjectLocation.latitude; --get raw version of Latitude

return x;

end

 

Ignore the comments about integers. I haven't wrote that part yet.

 

Any ideas?

 

 

This is really odd.

 

I copied the user function out of the URwigo program and pasted it into a Builder lua file and created the same scenario. It works file. It shows the correct latitude whether I use the function of the variable. When I import the lua code into URwigo, it also works fine.

 

So, it seems the same function gives two different results. Attached here is the URwigo file that works.

Test_Latitude.zip

0

Share this post


Link to post
One question. How can I create window with 6 buttons? I'm trying to create a Cluedo Wherigo Cartrige and need the 6 buttons for the user to pick between the 6 possibly killers or the 6 possibly murder weapons.

You need a multiple-choice input item. (I'm not sure how you do this in Urwigo, but I presume that it's possible.)

0

Share this post


Link to post

I have a very simple cartridge (attached here) that is supposed to tell me the current latitude using the variable, Player.ObjectLocation.latitude

 

When I create a User Function to return this value, it returns an incorrect value. When I put the variable, Player.ObjectLocation.latitude, in a simple message, it returns the correct answer. In this case, 37.869 is incorrect and 45.869 is correct.

 

The user function looks like this:

 

function getIntegerLatitude()

local x = Player.ObjectLocation.latitude; --get raw version of Latitude

return x;

end

 

Ignore the comments about integers. I haven't wrote that part yet.

 

Any ideas?

 

 

This is really odd.

 

I copied the user function out of the URwigo program and pasted it into a Builder lua file and created the same scenario. It works file. It shows the correct latitude whether I use the function of the variable. When I import the lua code into URwigo, it also works fine.

 

So, it seems the same function gives two different results. Attached here is the URwigo file that works.

 

Please disregard. I found the bug. I had an "8-" in my concatenation. :blink::P:P;):PB)

0

Share this post


Link to post
One question. How can I create window with 6 buttons? I'm trying to create a Cluedo Wherigo Cartrige and need the 6 buttons for the user to pick between the 6 possibly killers or the 6 possibly murder weapons.

You need a multiple-choice input item. (I'm not sure how you do this in Urwigo, but I presume that it's possible.)

Yes, you need input and set its type to Choice. It is possible in URWIGO, see attached screenshot (I hope it is understandable).

post-723638-1269985455.png

0

Share this post


Link to post
One question. How can I create window with 6 buttons? I'm trying to create a Cluedo Wherigo Cartrige and need the 6 buttons for the user to pick between the 6 possibly killers or the 6 possibly murder weapons.

You need a multiple-choice input item. (I'm not sure how you do this in Urwigo, but I presume that it's possible.)

Yes, you need input and set its type to Choice. It is possible in URWIGO, see attached screenshot (I hope it is understandable).

 

Thanks a lot. It really helped me.

0

Share this post


Link to post

Hello and thank you for this builder.

Now did I get in trouble again ..

I would like to create a sub-study of some things ..

So to be asked 3 questions relating and these issues must gather points. To be illuminated to last ..

How this is done ..

Buch78

0

Share this post


Link to post

I would like to create a sub-study of some things ..

So to be asked 3 questions relating and these issues must gather points. To be illuminated to last ..

How this is done ..

 

If you want to ask some questions, then you will need to create some 'Inputs'.

Once you create one, for example 'Question 1', you can click 'On Get Input' on the bottom right window.

Then you can add your input checks. Here's a sample screen shot of the activities...

 

post-1064130-1270950010.jpg

 

When correct, you can set flags, enable zones etc.

 

To use the input, you can create for example a character, then add 'Ask Question' as a command, and choose 'Input' as your action, and 'Question 1' as the object. The rest should work then.

 

Hope that didn't confuse you too much.

 

Fingers Crossed.

0

Share this post


Link to post

I would like to create a sub-study of some things ..

So to be asked 3 questions relating and these issues must gather points. To be illuminated to last ..

How this is done ..

 

If you want to ask some questions, then you will need to create some 'Inputs'.

Once you create one, for example 'Question 1', you can click 'On Get Input' on the bottom right window.

Then you can add your input checks. Here's a sample screen shot of the activities...

 

post-1064130-1270950010.jpg

 

When correct, you can set flags, enable zones etc.

 

To use the input, you can create for example a character, then add 'Ask Question' as a command, and choose 'Input' as your action, and 'Question 1' as the object. The rest should work then.

 

Hope that didn't confuse you too much.

 

Fingers Crossed.

 

I got it to work this way ..

but I would like to ask more questions in the same field ..

 

how this is done most easily

post-2047973-1270969295.png

Edited by buch78
0

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 55