Sign in to follow this  
Followers 55
yourself

URWIGO builder

789 posts in this topic

Urwigo request.

How do I make a zone become active after I've given the intro.

And I'm sure that would work the same for making zone2 active after completing zone1...

0

Share this post


Link to post

If you set Zone.Active = true, than the zone is taken into account and events are fired for the zone. If you like to have this zone on the zone list too, than you should set Zone.Visible = true.

0

Share this post


Link to post

Where to I put that line of code?

 

If you set Zone.Active = true, than the zone is taken into account and events are fired for the zone. If you like to have this zone on the zone list too, than you should set Zone.Visible = true.

0

Share this post


Link to post

At the end of the intro. I assume, that you show some messages or dialogs. In the OnClick of the last one you could place this. You don't write it by hand, but drag and drop it from the left side. Use the "Set" item and drop it into the middle of the screen. Than take the "Active" item from your zone and drop it inside the "Set" on the left side of the "=". On the right side of the "=" select a true. Ready.

0

Share this post


Link to post

Wonderful thanks!

Now my questions aren't queuing up

on entering Zone1, it displays a sentence or two, and is wanted it to ask a question when clicking the button, So I dragged SET into the button box, like for activating Zone, and selected True. but it doesn't work...

 

At the end of the intro. I assume, that you show some messages or dialogs. In the OnClick of the last one you could place this. You don't write it by hand, but drag and drop it from the left side. Use the "Set" item and drop it into the middle of the screen. Than take the "Active" item from your zone and drop it inside the "Set" on the left side of the "=". On the right side of the "=" select a true. Ready.

0

Share this post


Link to post

how do I get a question to open inside a zone.

It's not seeming to work the same way a zone is made active with Set...

0

Share this post


Link to post

Sothpaw, did you look at some of the tutorials on YouTube for Urwigo? Perhaps

or
?

 

To open a question when entering a zone, you use the "OnEnter" event of the zone. There you drop the "Input" from the upper left side and than the input you created before from the lower left side.

 

Be aware, that each message, dialog or input you display on the screen removes the last one. There isn't a stack, which keeps track of the displayed screens. So, if you display more than one message in a event, you only see the last one.

0

Share this post


Link to post

I created for the second case a quick and dirty solution for you. It is a module called Language, which has the following capabilities:

- Translate all objects (name and descriptions)

- Translate commands

- Translate MessageBoxes and Dialogs with their buttons

- Translate inputs

- Translate multiple choice entries of inputs and convert it back before call of OnGetInput

 

Who to use? Copy the code of the Lua Author Script (see attachment) to your project. The first in OnStart should be an input, where the user could select his/her language. Than init the language module with a call of "Language.Init(language_number, language_separator)". All texts should be set as "text in language 1##Text in language 2##Text in language 3" (in this example, language_separator is "##"). Than you could select with language_number of Init function, if you want the first, second or third part of the string (e.g. when language_number was 2, you get "Text in language 2" for the string. That's it.

 

Tested it only on Emulator, so be carefull. If you encounter any problems, send a short message and I look into it.

 

Best regards,

Charlenni

 

PS: It could be possible to use the UTF-8 GWZ file to have special characters on Garmins, but I didn't tested this.

 

Sorry to come back to this, but I think I missed the attachment (or can't find it...). Could you repost or let me know how to get it? Thank you very much for the effort.

0

Share this post


Link to post

Sorry, missed this.

 

If I remember correct, the attached files should help. If you have any questions, please make a new thread. Thanks.

Language.zip

0

Share this post


Link to post

I've got it all built, it works great on my smart phone,

but people with Garmins can't use it for some reason...

any thoughts?

0

Share this post


Link to post

To be honest, if you don't say, what is going wrong, no one could say, what is the reason.

0

Share this post


Link to post

I recently completed building a Wherigo cartridge using URWIGO. I received all the information I needed and downloaded the builder from Wherigofoundation.com. Upon posting my Wherigo cache page, my local review rejected it siting:

Your description references and provides a link to WherigoFoundation.com. It is not allowable to reference this website, nor provide a link to it, because that website is not owned by Groundspeak and it is considered to be a competing website for Wherigo. Therefore, it does not comply with the Solicitation and Commercial Content section in the Geocache Cache Listing Requirements / Guidelines. Please remove this reference and link.

 

Is this true?

 

Thanks,

Kent

0

Share this post


Link to post

I recently completed building a Wherigo cartridge using URWIGO. I received all the information I needed and downloaded the builder from Wherigofoundation.com. Upon posting my Wherigo cache page, my local review rejected it siting:

Your description references and provides a link to WherigoFoundation.com. It is not allowable to reference this website, nor provide a link to it, because that website is not owned by Groundspeak and it is considered to be a competing website for Wherigo. Therefore, it does not comply with the Solicitation and Commercial Content section in the Geocache Cache Listing Requirements / Guidelines. Please remove this reference and link.

 

Is this true?

 

Thanks,

Kent

 

Sounds correct, take a look at this thread.

0

Share this post


Link to post

"The first rule of fight club is you do not talk about fight club."

 

Yes, until Groundspeak stops sitting on its hands and finishes partnering with the Wherigo Foundation, they've said no one can mention the site or any of the other third-party applications that are the only things keeping Wherigo alive. On the bright side, I was told I can definitely expect to hear back from them at the end of March 2016. I've yet to remind them of the current date. My nagging never seemed to do much good, anyhow. Eight and a half years into Wherigo--two and a half into the partnership talks--and this is wearing me down.

Edited by Ranger Fox
Font size
0

Share this post


Link to post

"The first rule of fight club is you do not talk about fight club."

 

Yes, until Groundspeak stops sitting on its hands and finishes partnering with the Wherigo Foundation, they've said no one can mention the site or any of the other third-party applications that are the only things keeping Wherigo alive. On the bright side, I was told I can definitely expect to hear back from them at the end of March 2016. I've yet to remind them of the current date. My nagging never seemed to do much good, anyhow. Eight and a half years into Wherigo--two and a half into the partnership talks--and this is wearing me down.

 

Ranger Fox - Stay the course! We all appreciate your hard work on WF and working on the partnership with GoundSpeak!!!!!

 

Thanks - Kent

0

Share this post


Link to post

Hi, I thinking of making a play anywhere cartridge. One problem is that I do not get how to do this with Urwigo. Is there a place with som tutorial/description/video of how to do this?

 

Regards

 

cgocgo

0

Share this post


Link to post

Is there a known incompatibility with the URWIGO emulator and Windows 10? I tried testing a cartridge and it was unable to run the cartridge I am currently building. I ended up testing it on my Windows 7 computer, which ran everything fine.

0

Share this post


Link to post

OK - I have been going great writing my first Wherigo. After trying a few other builders I'm pretty comfortable with this one, and have a functional cartridge in the emulator for as far as I've gone. But there is one bit I cannot make work properly. I am sure it's a lack of understanding on my part - I actually do not understand the difference between a "Dialog" and a "Message" - for what I'm trying though I've tried both, and neither work for me.

 

After finishing a part of the journey, I call a Function to test whether or not the player has collected all the inventory items I have had them chasing. The function sees if the count is the right number (3 so far), and if yes it should display a message on screen, and then display the final location (where the cache is). If not, a different message and the game continues. Everything works as it should here - except no message appears on the screen either way. It is possible the message flashes up and goes away again - I can't see it. Do I need a pause button? I thought it would wait there (like all my other messages do elsewhere) until the player clicked "OK".

 

What have I misunderstood?

 

Thankyou brains trust in advance.

post-3242360-000372500 1466316194_thumb.png

Edited by Pprime (P`)
0

Share this post


Link to post

A MessageBox displays only one message at a time. Normally with one or two buttons, which could be checked in the OnClicked event. If the buttons doesn't have a text, Ok is set. A Dialog displays one or more messages, all with only an Ok button.

 

In this case, it could be, that the messages are shown, but immediately replaced by another message.

0

Share this post


Link to post

I think I was having the same problem with a cartridge I am working on. Try moving the the two set commands and the function call into the on click part of the message command.

0

Share this post


Link to post

Thanks charlenni. I kind of set myself up for the solution, but you also made me go back to the basics. Turns out I routinely had a "Show Main Screen" command as the next thing that ran - not from where it was called (a character function to hand over an inventory item) but from where that character was being called (character interaction). So it was displaying my message but moving straight on to show main screen immediately. I've removed those show screens and it all works now. I've also gone back through and mostly changed my Messages to Dialogs.

 

Chaoswarning - I had tried that a few times .. in and out of the 'onclick' part - made no difference. the reason, I assume, is that the set commands (and that function is just a group of set commands itself) don't do anything on screen and take no time to do it.

 

I'm a happier urwigo programmer now (loose use of the term programmer).

 

Cheers.

0

Share this post


Link to post

Try to use download link which starts the download.

 

The www.maxinoha.cz site seems to be down.

 

Edit: Wow - quick response. Sorry. I'd been trying for an hour.

Edited by Geek_Teach
0

Share this post


Link to post

I posted this on the "Playing Wherigo" Forum, but the more I look at it, I think it's specific to Urwigo... Here's the error message I'm getting:

 

Error During Upload

 

System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Exception of type 'System.ApplicationException' was thrown. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Wherigo.GSPCartridgeService.CartridgeService.GetCompiledCartridgeWithMetaData(GWZMetaData gwzMetaData, String CartridgeFileName, String CartridgeId, Int64 PlayerId, String PlayerName, DeviceType deviceType, String CompletionCode) at cartridge_download.btnDownload_Click(Object sender, EventArgs e)

 

Please post responses to the original thread: http://forums.Groundspeak.com/GC/index.php?showtopic=339905&pid=5592868

Edited by Geek_Teach
0

Share this post


Link to post

I've got it all built, it works great on my smart phone,

but people with Garmins can't use it for some reason...

any thoughts?

 

I have heard that the Garmins limit you to 7 zones. There are also a few features (like "Show Screen" that state that they don't work with "some devices". Most of the "some devices" are Garmins.

0

Share this post


Link to post

Could you explain "some reasons"? That would help.

 

To work around the most Garmin problems you should use the Garmin Tools of the Wherigo Foundation. You could find them at GitHub.

0

Share this post


Link to post

Hi, I'm just trying to fix a problem with my cartridge for https://coord.info/GC6MKPC. It looked to work fine as some cachers already used it and did not report any problems (apart from some Garmins which could not handle the high number of active zones). But one cacher showed me his logfiles as it it crashing all the time after a couple of identified zones. This is the error message the log files show:

:: STOR: unclosed upvalue in function @stdlib.lua:88

Is there anybody that knows the reason for this or could help in analyzing the problem? I used urwigo to programm and the user is using whereyougo. Thanks a lot!

0

Share this post


Link to post

Hi There,

I am sure this has been asked but I cant find the post.

I have now built 2 wherigos with Urwigo. Not many of these in my part of the world.

 

Id like to create a play anywhere Wherigo that still requires people to move from zone to zone, but could be played in any park.

 

Is there a way within the Urwigo platform to do this ?

 

Kyzabra (Breht)

0

Share this post


Link to post

Hi There,

I am sure this has been asked but I cant find the post.

I have now built 2 wherigos with Urwigo. Not many of these in my part of the world.

 

Id like to create a play anywhere Wherigo that still requires people to move from zone to zone, but could be played in any park.

 

Is there a way within the Urwigo platform to do this ?

 

Kyzabra (Breht)

It was mentioned on the first page of this topic that URWIGO doesn't support play anywhere cartidges. That was over 6 years ago, but I don't think it has been changed to support them since then.

0

Share this post


Link to post

To create a play anywhere cartridge you must move all zones when the cartridge starts. For each zone, you calc the distance and direction to the original start point of the cartridge. Then you move all points of a zone in that distance and direction from the player position. All I know, you have to do this by hand.

0

Share this post


Link to post

Hello,

 

can somebody help me?? :unsure:

 

I just created a new cartridge with Urwigo, i tested the cartridge on my samsung Xcover 3, everything went great till i finished my cartridge. After finishing it the follow message pop up:

 

you hit a bug!

please report at openwig.googlecode.com and i'll fix it for you! java.lang.NullPointerException :blink:

 

Also went i put my Phone OFF and back ON, i started an other cartridge that i found a few weeks ago on geocaching.com and when i start the same message suddenly pops up......... i did not have that problem when i was playing the cartridge..... :(

0

Share this post


Link to post

Can you post a screenshot and perhaps the code of the part, where the player crashes?

 

Btw. it is a WhereYouGo problem and not a Urwigo problem :)

0

Share this post


Link to post

Can you post a screenshot and perhaps the code of the part, where the player crashes?

 

Btw. it is a WhereYouGo problem and not a Urwigo problem :)

 

it now already start crashing when i want to choose a cartridge

post-6795088-058741500 1478793970_thumb.png

0

Share this post


Link to post

Can you post a screenshot and perhaps the code of the part, where the player crashes?

 

Btw. it is a WhereYouGo problem and not a Urwigo problem :)

 

it now already start crashing when i want to choose a cartridge

 

It is also my first cartridge that i builed, so i am totally new.... just figured all the basics :ph34r:

0

Share this post


Link to post

Do you load a saved game?

 

maybe i did, the story is, i went outside for my 1st test of cartridge with my samsung, everything went fine and when i was at the ending and finished it (here you get the complecation code and the final coords in your inventory) i quit the game, went back home and want to start again to see if the complecation code and final coords are still in the inventory...

 

And then all the problem started with the bug, i clicked 10x times the bug away, try do open an other cartridge and had the same bug problem appears on the screen, also when i tried to start a new game.... :o

 

But now at the moment, i start the app again and the bug don't show up...... also when i click on the saved game of the cartridge, my inventory is empty....

 

but i'm still thinking about the problem off the bug.... why no bug now....

0

Share this post


Link to post

I recently purchased a laptop with a 4K monitor and the emulator no longer appears correctly in Urwigo (it is almost impossible to see the pictures). Does anyone know if there is a fix for this or if urwigo can be updated to fix the scaling issues? I have tried using the resource hacker program which a number of people have recommended but I am not sure this will work with urwigo.

0

Share this post


Link to post

Maybe a strange question, but I don't find any closure. Is the date/time function in Urwigo OS/machine based or satellite based? I need to need to know when I test on date/time for certain actions, things can be influenced by changing date/time on the smartphone itself.

0

Share this post


Link to post

If I remember it correct, the date/time is different from player to player. So it isn't a Urwigo problem, but a player problem.

0

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 55