Jump to content
Sign in to follow this  
Followers 5
OpinioNate

Release Notes 7/28/09

Recommended Posts

July 09 Geocaching.com Code Release

 

Welcome to the latest monthly code release! This month we're very pleased to announce the return of Google Earth KML functionality to Geocaching.com. The design of this version is greatly streamlined and incorporates the latest changes to KML version 2.2.

 

The link to download the network KML and to learn more about this feature is found on the My Profile page. Many thanks to all of you geocachers who have been patient with us while this replacement feature was being built!

 

The following bug fixes are included in today's update:

 

11441: Text changes for Instant Notify – Premium

Added panels to both Instant Notification pages to present text to the appropriate user type (not logged in, basic member and premium member). Also made additional text updates to both pages.

 

11434: Text change for FAQ page

Text updates on the FAQ page.

 

11432: Text changes on staging

Text updates on Free Trial and Getting Started with Premium Membership pages.

 

11433: Additional link on Premium Member profile page

Added link to top of "Premium Features" section of the "My Profile" page titled "Getting Started" which links to the new "Getting Started as a Premium Member" page.

 

11387: iPhone text/image change on Geocaching.com homepage

Text updates and product imagery updates on home page for iPhone application.

 

11541: First entry of Home Coordinates uses wrong page

On the "My Profile" page, updated all links for adding "home coordinates" to point to the new page in the "My Account" section of the site.

 

11435: Text change for membership page

Updated text on the Memberships landing page and membership Comparison page.

 

11436: Text changes for Premium Member Bookmarks page

Updated text on the Bookmarks page.

 

11046: Geocoin Distributor Link update

Updated geocoin distributor list

 

11178: Embed caching video on geocaching.com/about

Updated /about page to include info and link to Splinterheads movie

 

11438: Text change for Pocket Query page

Updated text on the Pocket Query page.

 

11439: Text changes for Caches Along a Route

Updated text on the Caches Along a Route page.

 

11091: Terms of Use at account creation is outdated

Updated link to current TOU on account creation

 

11156: User not able to allow friend requests

Fixed error preventing user from allowing friend requests

 

11232: Deletion of log on geocoin causing server error

Fixed issue where attempting to delete a geocoin log results in a server error

 

10827: Text Change for Validation thank you page

Improved post validation options and removed redundant text

 

10443: Home Coordinates update reverts to wrong location

Marker will no longer snap to roadways. Some work still needed to prevent unwanted repositioning of flag

 

11425: Hotels by country recently published caches returns event caches

Removed events from latest 3 caches shown on Hotels country pages

 

10754: Shop Groundspeak link wrong on Groundspeak.com

Updated product link on /shop.aspx

 

7867: Cache logs display out of order

Fixed issue of cache logs displaying out of order.

 

10715: Caches along a route - defunct page should be removed

Removed unused /route page

 

11355: Error encountered when attempting to visit hotel page for city with apostrophe or period in it

Hotel links for cities with punctuation now properly resolve

 

11215: Ignored caches should still be seen in a user's profile tab

Refined ignored cache behavior to be more nuanced

 

11219: Microsoft Live maps now called Bing Maps

Changed all instances of the phrase "Microsoft Live Maps" to "Bing Maps."

 

11360: Odd order of entries on Membership History page, several repeats

Fixed membership history to display in chronological order and removed repeats

 

11214: No postback when selecting cache log type please

Rolled back change which introduced this bug

 

11025: Subject line for log notification causes an error

Now truncating the email subject line if too long (this is the cause of many lost watchlist and notification emails)

 

11334: "Nickname" should be changed to "Cache Name"

Changed the bucket title from Nickname to Cache Name on the Cache Report form

 

11218: Visiting account pages when logged out should prompt login

Account pages will now automatically navigate to the Login page if you are not currently Logged-in (my/routeedit.aspx still to be fixed)

 

9508: States/provinces needed for Slovakia

Added provinces for Slovakia

 

9359: States/provinces needed for Austria

Added provinces for Austria

 

11523: New Text Needed at Cache Guidelines Page

Updated the Cache Saturation section of the Cache Guidelines page.

 

6756: Show Mega Events in Local Geocaching Pages

Added Mega Events to local geocaching pages.

 

10457: Bookmark list error

Added dialogue to bookmark description warning user when max number of characters is reached

 

8935: Unclear message on edit page of caches under review

Fixed ambiguous notice on unpublished and inactive cache pages

 

11121: Waypoint entry for bookmarks broken

Fixed quick waypoint entry for bookmarks

 

11521: Trimble page text is wrong

Updated text on Mobile page to indicate that Nokia Series 60 application is no longer free.

Share this post


Link to post

Yes But will it work Jim.... IDK Spock we'll have to give it a shot...

 

Just kidding Thank you all very much for all the hard work to make things continuously better!

 

Groundspeak Geocaching RoCKs like no other...

Share this post


Link to post

Currently investigating an issue with displaying a user's cache finds...

 

Edit: Fixed.

Edited by OpinioNate

Share this post


Link to post
Currently investigating an issue with displaying a user's cache finds...

 

 

Arr beat us to it. This is the message I got when looking at someones cache finds.

 

 

Procedure or function spgsp_GetCacheList_UserFound_ByArray has too many arguments specified.

Share this post


Link to post

Currently investigating an issue with displaying a user's cache finds...

 

Looks like you are already on top of the bug I was going to report. When looking at finds of other cachers you get this error:

 

Procedure or function spgsp_GetCacheList_UserFound_ByArray has too many arguments specified.

 

Looking at my own finds works just fine though.

Microsoft XP using Firefox 3.5.1

Share this post


Link to post

Thank you very much for the return of the KML, viewer, what ever you want to call it. I haven't played with it much yet but I did set it to refresh only on demand. Very happy with that. I think it should have done that before. It may have for all I know. Either way it makes the tool more flexible. Can't wait to play with it but I'm going to have to. Other things need doing first. :D

 

Anyway thanks for bringing this back.

Share this post


Link to post

GE KML: [:D] The new KML is MUCH better! Set to manual refresh, zoom out to where you can see 500 or so caches, then pan around the area a bit at a time.

 

Cache finds error: I had the same problem.

Share this post


Link to post

Can not update cache coordinates. Keeps changing back to the current coordinates.

 

Be sure that you are saving the changes (button in the bottom left of the map).

 

Edit: Sorry, somehow I read "home coordinates" here.

Edited by OpinioNate

Share this post


Link to post

Can not update cache coordinates. Keeps changing back to the current coordinates.

 

Be sure that you are saving the changes (button in the bottom left of the map).

 

I don't see a map on the "Post a new log" page?

Share this post


Link to post

Can not update cache coordinates. Keeps changing back to the current coordinates.

 

Be sure that you are saving the changes (button in the bottom left of the map).

 

I don't see a map on the "Post a new log" page?

 

 

Just tried moving a cache of mine and this is what id did.

 

 

coord_update.gif July 28 by <A style="TEXT-DECORATION: underline" name=78759551>JABs (1415 found)

S 33° 40.609 E 150° 00.562

** Coordinates Changed From **

S 33° 40.609 E 150° 00.562

Distance From Old: 0 feet

moved

 

 

Have tried it twice and both times returned same result.

 

IE Windows

Share this post


Link to post

I've found a little bug with the GE KML you'll probably want to fix pretty quick. I'm using GE Mac version 5.0.11733.9347. After running my used views up to a dozen or so I'll go off and do something else leaving GE open. Returning to GE after a short time (5-6 min.) and panning the map, my used view count drops back down to 1. This happens every time.

Share this post


Link to post

I've found a little bug with the GE KML you'll probably want to fix pretty quick. I'm using GE Mac version 5.0.11733.9347. After running my used views up to a dozen or so I'll go off and do something else leaving GE open. Returning to GE after a short time (5-6 min.) and panning the map, my used view count drops back down to 1. This happens every time.

 

It did the same thing on my XP machine earlier but I haven't been able to repeat it since.

Share this post


Link to post

When clicking on a cache in GE to get details, I encountered an error. Sequence: Click on details, get the frame at the bottom which opens a web page; it tells me I'm not logged in (obviously a different cookie as it is IE and I normally use FF) so I login. When it returns to the cache page I get this script error:

 

An error has occurred in the script on this page

 

Line 2

Char 413

Error: 'YAHOO.util.Selector' is null or not an object

Code: 0

URL: http://www.geocaching.com/seek/cache_details.aspx?wp=GC1VAF5

 

This was repeatable, but not seen when opening that page in FF or a regular IE session.

Share this post


Link to post

I've found a little bug with the GE KML you'll probably want to fix pretty quick. I'm using GE Mac version 5.0.11733.9347. After running my used views up to a dozen or so I'll go off and do something else leaving GE open. Returning to GE after a short time (5-6 min.) and panning the map, my used view count drops back down to 1. This happens every time.

 

It did the same thing on my XP machine earlier but I haven't been able to repeat it since.

 

Just did it again. Seems to be when I let it sit for a longer time than the 6 or 6 minutes.

Share this post


Link to post

I think there is a new bug in the cache order for public profiles. I looked at my public profile and some caches that I found in June were higher in the list than caches that I found in July. I noticed in the release notes (7867) that the cache log order was corrected in this update, however the order seems to be more wrong than before. A couple caches that I found on the same day in June are now separated by cache(s) that I found a month later in July. The order in my private profile seems to be correct though.

Share this post


Link to post

I think there is a new bug in the cache order for public profiles. I looked at my public profile and some caches that I found in June were higher in the list than caches that I found in July.

 

Same here.

 

Also, "nearby caches of this type that I haven't found" is all jumbled up. A cache 4 miles away displays before one that is less than a mile away. It is not consistent either, with farthest to nearest, or oldest to newest, by D/T rating, alphabetically by cache name, by hider name, by last found. Doesn't list caches according to whether I have logged a note or a DNF.

Edited by msrubble

Share this post


Link to post

Also, when you want to post your own coordinates to a cache log:

1) You check "Add a waypoint to the log".

2) The system pre-fills the cache coordinates.

3) You type your own coordinates

4) You submit the log

5) The system ignores what you typed, and shows the cache coordinates in your log, not the ones you entered.

 

EDIT: Somebody already mentioned this in another thread, but the moderator closed that thread as a duplicate of this one, but it isn't a duplicate. There are two separate issues.

Edited by Viajero Perdido

Share this post


Link to post

July 09 Geocaching.com Code Release

<snip>

11214: No postback when selecting cache log type please

Rolled back change which introduced this bug

<snip>

I don't know exactly what this means but there is something going on when I select the type of log for either a TB/Coin or cache.

Whenever the log type is chosen the date field seems to reload changing from 'July' to '07' and deselecting wherever my cursor is at the time. I first noticed this a week or so back but it is still happening now following this release.

Share this post


Link to post

July 09 Geocaching.com Code Release

...

 

11232: Deletion of log on geocoin causing server error

Fixed issue where attempting to delete a geocoin log results in a server error

 

Noticed this behavior for cache logs, "attempting to delete" is a bit missleading

the log actually got deleted, but the far more severe issue was that the owner of the

deleted log never got any email notification about it!

 

Verified that it works (for cache logs) again. Thanks for the fix.

Share this post


Link to post
7867: Cache logs display out of order

Fixed issue of cache logs displaying out of order.

Well ... NO! :D

 

Actually it worked until yesterday. A few minutes ago, I noticed that the cache display sequence (on lists like "Caches found" or my own "Nearest not found") is again garbled. I wondered why, and then saw the update notice.

 

The issue must be really difficult, because the same bug also appeared right after the June 09 update went online. I had hoped that each mistake is made only once ... :D

 

Greetings from Munich

baer2006

Share this post


Link to post

Thanks for the comments, everyone. It seems that in fixing log order in one area it has again rearranged the order in another. We're working on correcting this today.

 

The cache coordinates not being saved issue has been corrected. The fix was to simply roll back the new code there. We'll work on bringing that feature back when it works properly. Edit: Raine already said this.

Edited by OpinioNate

Share this post


Link to post

I think there is a new bug in the cache order for public profiles. I looked at my public profile and some caches that I found in June were higher in the list than caches that I found in July. I noticed in the release notes (7867) that the cache log order was corrected in this update, however the order seems to be more wrong than before. A couple caches that I found on the same day in June are now separated by cache(s) that I found a month later in July. The order in my private profile seems to be correct though.

 

Sorry rtyrie, but I'm just not seeing this. All of your June finds are in sequence, as well as every other find listed.

Share this post


Link to post
rant.gifOK, what the heck did you guys do!? It had to be something you did. I noticed it the first time I used it after yesterdays release. It just wont work any more. WHAT THE HECK DID YOU DO TO MY COFFEE MAKER! :D:D

Share this post


Link to post

I think there is a new bug in the cache order for public profiles. I looked at my public profile and some caches that I found in June were higher in the list than caches that I found in July. I noticed in the release notes (7867) that the cache log order was corrected in this update, however the order seems to be more wrong than before. A couple caches that I found on the same day in June are now separated by cache(s) that I found a month later in July. The order in my private profile seems to be correct though.

 

Sorry rtyrie, but I'm just not seeing this. All of your June finds are in sequence, as well as every other find listed.

If you look at the first page for "All Cache Finds" in my public profile, the first few caches are in the correct order, but then they become unordered. Here is an example from the first page:

 

GC133RE - July 19

GC16TE9 - July 11

GC1EGCH - July 4

GC1K1G9 - June 28

GC1MRRG - June 28

GC1P55D - July 19 **

GC1QH48 - June 28

 

** This cache was found the same day as GC133RE, but is listed in the middle of the June 28 caches

 

I also looked at other pages in my public profile and similar incorrect orders appear as well. Some caches are ordered correctly while others are not.

 

Edit: Added a screenshot

My Public Profile

Edited by rtyrie

Share this post


Link to post

I think there is a new bug in the cache order for public profiles. I looked at my public profile and some caches that I found in June were higher in the list than caches that I found in July. I noticed in the release notes (7867) that the cache log order was corrected in this update, however the order seems to be more wrong than before. A couple caches that I found on the same day in June are now separated by cache(s) that I found a month later in July. The order in my private profile seems to be correct though.

 

Sorry rtyrie, but I'm just not seeing this. All of your June finds are in sequence, as well as every other find listed.

If you look at the first page for "All Cache Finds" in my public profile, the first few caches are in the correct order, but then they become unordered. Here is an example from the first page:

 

GC133RE - July 19

GC16TE9 - July 11

GC1EGCH - July 4

GC1K1G9 - June 28

GC1MRRG - June 28

GC1P55D - July 19 **

GC1QH48 - June 28

 

** This cache was found the same day as GC133RE, but is listed in the middle of the June 28 caches

 

I also looked at other pages in my public profile and similar incorrect orders appear as well. Some caches are ordered correctly while others are not.

 

Edit: Added a screenshot

My Public Profile

Looks fine now.

Share this post


Link to post

I think there is a new bug in the cache order for public profiles. I looked at my public profile and some caches that I found in June were higher in the list than caches that I found in July. I noticed in the release notes (7867) that the cache log order was corrected in this update, however the order seems to be more wrong than before. A couple caches that I found on the same day in June are now separated by cache(s) that I found a month later in July. The order in my private profile seems to be correct though.

 

Sorry rtyrie, but I'm just not seeing this. All of your June finds are in sequence, as well as every other find listed.

If you look at the first page for "All Cache Finds" in my public profile, the first few caches are in the correct order, but then they become unordered. Here is an example from the first page:

 

GC133RE - July 19

GC16TE9 - July 11

GC1EGCH - July 4

GC1K1G9 - June 28

GC1MRRG - June 28

GC1P55D - July 19 **

GC1QH48 - June 28

 

** This cache was found the same day as GC133RE, but is listed in the middle of the June 28 caches

 

I also looked at other pages in my public profile and similar incorrect orders appear as well. Some caches are ordered correctly while others are not.

 

Edit: Added a screenshot

My Public Profile

 

My list is all jumbled up also. When you go to my profile and then look at all caches found, the caches are all jumbled by date. The first page and a half are fine because I just logged these. After that they are jumbled.

When you look at someone Else's finds they look to be in order. Strange!

Share this post


Link to post

I think there is a new bug in the cache order for public profiles. I looked at my public profile and some caches that I found in June were higher in the list than caches that I found in July. I noticed in the release notes (7867) that the cache log order was corrected in this update, however the order seems to be more wrong than before. A couple caches that I found on the same day in June are now separated by cache(s) that I found a month later in July. The order in my private profile seems to be correct though.

 

Sorry rtyrie, but I'm just not seeing this. All of your June finds are in sequence, as well as every other find listed.

If you look at the first page for "All Cache Finds" in my public profile, the first few caches are in the correct order, but then they become unordered. Here is an example from the first page:

 

GC133RE - July 19

GC16TE9 - July 11

GC1EGCH - July 4

GC1K1G9 - June 28

GC1MRRG - June 28

GC1P55D - July 19 **

GC1QH48 - June 28

 

** This cache was found the same day as GC133RE, but is listed in the middle of the June 28 caches

 

I also looked at other pages in my public profile and similar incorrect orders appear as well. Some caches are ordered correctly while others are not.

 

Edit: Added a screenshot

My Public Profile

Looks fine now.

My profile looks fine to other users, the problem seems to occur only when I view my own public profile. I think that there might be some strange logic going on between my find date and the last find date, but I'm not sure. When I view my own public profile the caches are still out of order as seen in the screenshot in my previous post.

Share this post


Link to post

My profile looks fine to other users, the problem seems to occur only when I view my own public profile. I think that there might be some strange logic going on between my find date and the last find date, but I'm not sure. When I view my own public profile the caches are still out of order as seen in the screenshot in my previous post.

 

See Nate's post.

 

Jim

Share this post


Link to post

Not shore if this is related to release.

 

 

Started a new bookmark list tonight (I do at least one a week) got to the 45 cache Ok, but now any other cachers that are added do not show up on list. Page displays 'Total Records 48' but only the first 45 are showing. Have shut down IE, cleared cookies, logged back in but still only shows 45 caches.

 

 

If I try and add one of the missing cache to the list again I get standard -This bookmark already exists for this list. So I know they are there but just not displayed. And no they are not on the next page-currently only displays 2 pages with total of 25 caches each page. First page shows 25 caches and page 2 shows 20 caches.

 

Current IE and Windows XP

Share this post


Link to post

Just a few little issues/suggestions for the KML.

Why use nonstandard size icons? "Regular" sized caches should really not be labeled as "Medium".

Also, the bubble that pops up is always too small for its contents, and gets scrollbars. I wonder why? (never mind, I realized this isn't a Groundspeak problem)

b6reyh.jpg

Edited by Corey

Share this post


Link to post

Corey, this is a known problem with Earth 5.0 on Mac. It miscalculates the size of the required balloon for small windows that don't have constant sizes. That's Google's problem to fix (and they know about it....) and not Groundspeak's.

Share this post


Link to post
11178: Embed caching video on geocaching.com/about

Updated /about page to include info and link to Splinterheads movie

 

 

What the heck is this?????? 000201DD.gif

Share this post


Link to post

 

11215: Ignored caches should still be seen in a user's profile tab

Refined ignored cache behavior to be more nuanced

 

 

Were there complaints about this, or was it never meant to be? I'd find it hard to believe any ignore list users would have complained about this. I kind of liked seeing someone with 100 hides had only 6, or someone with 13 who had zero. :huh:

 

I had also noticed brand new ignored caches weren't even showing up when searching by the State page (not that I had a problem with this). I don't know if that's still happening. They definitely still are not showing up on Geocaching.com Google maps.

Share this post


Link to post
7867: Cache logs display out of order

Fixed issue of cache logs displaying out of order.

Well ... NO! :D

 

Actually it worked until yesterday. A few minutes ago, I noticed that the cache display sequence (on lists like "Caches found" or my own "Nearest not found") is again garbled. I wondered why, and then saw the update notice.

 

The issue must be really difficult, because the same bug also appeared right after the June 09 update went online. I had hoped that each mistake is made only once ... :D

 

Greetings from Munich

baer2006

 

I'm getting this error myself.

 

75620e94-b263-4a78-99e4-001c788d10a8.jpg

Share this post


Link to post
11214: No postback when selecting cache log type please

Rolled back change which introduced this bug

I can't see this fix. I still get postback. Specifically, on the http://www.geocaching.com/seek/log.aspx?ID=xxx page, if I select a new value for the drop-down box "Type of log", a new page loads. This is with Seamonkey 1.1 under Windows XP.

It was there for a day or so, but it caused another problem that coords added to a log wouldn't "stick" so they rolled back the rollback. Maybe next month they'll actually get it right :laughing:

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 5

×