Sign in to follow this  
Followers 1
high beeches

eTrex Venture HC - problems!

16 posts in this topic

Hi,

 

First posting here, be gentle with me..

We've just got into Geocaching and I've had my eTrex Venture HC for about 2 months... today it has decided that it will not stay powered on - I turn it on, the garmin splashscreen comes up, then it does and nothing is visible on the screen at all...

Any ideas? I have a bad feeling it is a return / warranty issue - and I have a big geocaching weekend planned next week - it's bad enough missing out today (and tomorrow I expect)... :)

Anyone had a smialir issue? Yes, I have tried different batteries (three times in fact)

 

Thanks

 

Sarah

0

Share this post


Link to post

Do a HARD reset. Sorry you'll need to do a search for the three buttons to hold down.

0

Share this post


Link to post

Thanks - just tried that:

 

1. Turn off the device

2. Press PAGE, ENTER and POWER.

3. You will see a message on the screen that says "Do you really want to erase all user data?". Select Yes.

4. The device will now reboot, leave it with a clear view of the sky for 30 minutes to acquire the satellite almanac.

 

sadly - still get no screen up after I power it up... the screeen just sort of fades out to nothing.

Will put the children to bed and look at it again later. Sulking big time now... :)

 

Quite glad now that the very last thing I did - (and I hope this didn't break it) was to upload into GSAK the waypoints for the 4 caches I hid yesterday....

 

anyone any other ideas - I have logged a message with Garmin, but you guys are more responsive!

 

Sarah

0

Share this post


Link to post

install the newest firmware for the unit.

0

Share this post


Link to post

2 months old? It's still under warranty so call Garmin.

0

Share this post


Link to post

Thanks - just tried that:

 

1. Turn off the device

2. Press PAGE, ENTER and POWER.

3. You will see a message on the screen that says "Do you really want to erase all user data?". Select Yes.

4. The device will now reboot, leave it with a clear view of the sky for 30 minutes to acquire the satellite almanac.

 

sadly - still get no screen up after I power it up... the screeen just sort of fades out to nothing.

Will put the children to bed and look at it again later. Sulking big time now... :)

 

Quite glad now that the very last thing I did - (and I hope this didn't break it) was to upload into GSAK the waypoints for the 4 caches I hid yesterday....

 

anyone any other ideas - I have logged a message with Garmin, but you guys are more responsive!

 

Sarah

 

Im having the same problem and I do not get a "reset" msg. All I get is an info screen.

0

Share this post


Link to post

I cant even get a "reset" prompt to come up just some info screen.

0

Share this post


Link to post

I can't load the new firmware as the PC won't recognise that there's a unit atatched... will be on the phone to Garmin this am, and am hoping they ahve a very swit turnaround.

A friend of mine with the very same unit had exactly the same problem, after they'd had thiers about the same length of time, and it was replaced in the week apparently, so here's hoping... Will be asking them if there's a known bug / fault..

 

Sarah

0

Share this post


Link to post

Ok mine was just having the same problem and here is what fixed it!

 

"

Thank you for contacting Garmin International.

 

Please do a master reset on your unit. Doing a master reset will delete all user data, but it will also delete any corrupt system data which may be causing the issue. Be sure to back up all user data, if possible, before continuing. To do the master reset, with the unit off, press and hold 'page' + 'enter' + 'power' at the same time for a few seconds. You'll be asked if you're sure you want to delete all user data. Select yes. Now, with the unit off, press and hold 'page' + 'enter' + 'find' + 'power' at the same time for at least five seconds.

 

If the above doesn't correct the issue, the unit will need to come in for repair/replacement. "

 

It's the second step that actually got mine going and I think this is what people are not including.

 

Good luck

 

Len

0

Share this post


Link to post

Same problem here, this worked like a charm. Thanks so much!

 

Note, by 'Enter' button, it means the tilt-stick on the face of the device, 'page' is on the upper right side as you're looking at the screen, and 'find' is on the left, below the up/down buttons.

 

~George J.

 

 

Ok mine was just having the same problem and here is what fixed it!

 

"

Thank you for contacting Garmin International.

 

Please do a master reset on your unit. Doing a master reset will delete all user data, but it will also delete any corrupt system data which may be causing the issue. Be sure to back up all user data, if possible, before continuing. To do the master reset, with the unit off, press and hold 'page' + 'enter' + 'power' at the same time for a few seconds. You'll be asked if you're sure you want to delete all user data. Select yes. Now, with the unit off, press and hold 'page' + 'enter' + 'find' + 'power' at the same time for at least five seconds.

 

If the above doesn't correct the issue, the unit will need to come in for repair/replacement. "

 

It's the second step that actually got mine going and I think this is what people are not including.

 

Good luck

 

Len

0

Share this post


Link to post

I know this is a little late but I had my Venture HC do this today so I just called Garmin CS. They walked me through a couple steps with the unit and my macbook and its all fixed... it took maybe 10 min..... they were great...they are aware of the problem and are great at talking you though it

0

Share this post


Link to post

Thanks for the help - The master reset worked. Same as y'all - Worried that a day of caching was going to be sacrificed.

0

Share this post


Link to post

My firmware upgrade to 3.3 is taking for ever, like 24 hours. Just bought the unit a couple of days ago, any ideas on why this is so!

0

Share this post


Link to post
My firmware upgrade to 3.3 is taking for ever, like 24 hours. Just bought the unit a couple of days ago, any ideas on why this is so!
What part of the upgrade do you mean? Downloading from Garmin?
0

Share this post


Link to post

! What part of the upgrade do you mean? Downloading from Garmin?

 

Well I am using the Garmin WebUpdater so it just told me that there was a v3.3 update, I looked at the update then said sure. I still don't think it should take 24+ hours to update though!

0

Share this post


Link to post

 

Well I am using the Garmin WebUpdater so it just told me that there was a v3.3 update, I looked at the update then said sure. I still don't think it should take 24+ hours to update though!

I wonder if the d/l just stalled out. Here's another approach for you.

 

Assuming we're still talking about an eTrex Venture HC (per the OP) go here and download the 3.3 code:

 

http://www.gawisp.com/perry/etrex/venture/

 

Your code is about the 6th from the bottom, and is called "eTrexVentureHC_330.exe". See how that works out for you. FWIW: The Perry list is 100% legit, and is even referenced by the tech support people at Garmin when users need to back up for earlier firmware that isn't still posted on the Garmin site.

Edited by ecanderson
0

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 1