Jump to content
Sign in to follow this  
Followers 7
OpinioNate

Release Notes 6/24/09

Recommended Posts

 

[*]Fixed issue of bookmark paging timing out and displaying incorrect contents for indicated page.

 

Please comment on any topics mentioned here in this thread. All other topics for another thread. Thanks!

 

I am not able to add a new cache to my bookmark lists now. Is this related to the updates? Is this a general or local problem?

How are you trying to do it? It works for me if I go to the cache page and click the Bookmark Listing link.

 

Thanks, that does work. I had been trying to add the waypoint on the Bookmark List page. It seemed to take, but it never added the Bookmark. That was always the way that I had done that before. :D

Share this post


Link to post
There are a couple reasons for not posting a warning ahead of the site updates. One reason is because as of yet we're incapable of estimating the exact time when the new build will be ready. We're getting better about this but for now we're only confident enough to say a release will take place somewhere within 2 days. The other reason is that, assuming everything goes well (big assumption!) the site should only be down for about 15 minutes.

 

PS - Yes we are now using the Scrum method of software development. We're technically beginning our 6th sprint but have really only fully adhered to all the different aspects in the last two sprints. It's a challenging transition but so far has been pretty effective.

Thank you for demonstrating that Scrum isn't compatible with ITIL methodologies. I'll keep that in mind the next time someone asks me if we should try Scrum out.

 

Don't go comparing our performance to someone who completely adheres to Scrum principles. I should have said we *attempted* to fully adhere to all the different aspects of Scrum in the last two sprints, but we still have some way to go before it is perfected. In Scrum the deadline/release date is sacrosanct, and should never be exceeded even if it means reducing the scope of the project.

Share this post


Link to post
In Scrum the deadline/release date is sacrosanct, and should never be exceeded even if it means reducing the scope of the project.

I think therein lies the problem. You guys seem to be so fixated on releasing on a certain date, that you seem to skip the testing phase, thus releasing code that is still riddled with bugs. You need to learn to think of each sprint as lasting only 3 weeks, followed by a one week testing and bug fixing stage. Seriously, there are bugs in the latest code release that you should be embarrassed about. :D

Share this post


Link to post

I don't what you guys did to the web site but it needs to be fixed. YOU SHOULD POST A WINDOW WHEN CACHERS LOG IN THE SAYS "WILL BE DOWN FOR MAINT." I don't know if I will renew my subscription on July 10. :)

 

 

Well I went back and uncheck my ignore list and now I can see all the caches in my area. Now I have to look at caches that are disable or caches that I used to own. That fix should be removed. Now for the coords I live on a Air Base not out in town were my coords are showing me. I down live by a landmark.

Edited by tlbeers

Share this post


Link to post

we are having problems opening up our geocache.com maps. when we do go to open one we get this message:

 

We were unable to return you to geocaching.com.

 

Internet Explorer has stopped trying to restore this website. It appears that the website continues to have a problem.

What you can do:

Go to your home page

 

Try to return to geocaching.com

 

More information

 

When a website causes a failure or crash, Internet Explorer attempts to restore the site. It stops after two tries to avoid an endless loop.

 

Please help us in resolving this problem...anyhelp is greatly appreciated..

thanks dillonsdaddy(&mommy)

Share this post


Link to post

we are having problems opening up our geocache.com maps. when we do go to open one we get this message:

 

We were unable to return you to geocaching.com.

 

Internet Explorer has stopped trying to restore this website. It appears that the website continues to have a problem.

What you can do:

Go to your home page

 

Try to return to geocaching.com

 

More information

 

When a website causes a failure or crash, Internet Explorer attempts to restore the site. It stops after two tries to avoid an endless loop.

 

Please help us in resolving this problem...anyhelp is greatly appreciated..

thanks dillonsdaddy(&mommy)

Share this post


Link to post

Hi!

 

Where's the "Rewards" feature that was promised last fall? Do you still have it on your list or was it removed for some reason?

Share this post


Link to post

Adding to bookmark list one GC code at a time via the list's page no longer works.

 

I just added a couple of hundred caches before realising!!

 

 

 

Mark

Share this post


Link to post

Would I be correct that the forums are down again today?

Share this post


Link to post

Would I be correct that the forums are down again today?

 

I would say you are correct. I have been trying for four hours to get to the forum. I think this is getting out of hand...

 

StaticTank

Share this post


Link to post

Would I be correct that the forums are down again today?

 

I would say you are correct. I have been trying for four hours to get to the forum. I think this is getting out of hand...

 

StaticTank

 

I'd agree if I didn't think it would get me banned.

Share this post


Link to post

When I search for the nearest caches (e.g. "from home coordinates" or from a specific cache), the 20 nearest are all on the first page, but the sequence within that page is more or less garbled :) !

 

This looks like a bug. If it's a feature, I'd like to know the actual sort criterion within each page of the listing. It appears rather random to me :D .

 

I hope this could never be confused with a feature. We're aware of the issue and will have a quick fix here soon. Sorry for the confusion!

 

Well, the bug had disappeared several days ago, but has now reappeared again. Experimental programming still going on? :D

Share this post


Link to post

When I search for the nearest caches (e.g. "from home coordinates" or from a specific cache), the 20 nearest are all on the first page, but the sequence within that page is more or less garbled :) !

 

This looks like a bug. If it's a feature, I'd like to know the actual sort criterion within each page of the listing. It appears rather random to me :D .

 

I hope this could never be confused with a feature. We're aware of the issue and will have a quick fix here soon. Sorry for the confusion!

 

Well, the bug had disappeared several days ago, but has now reappeared again. Experimental programming still going on? :D

Share this post


Link to post

Adding to bookmark list one GC code at a time via the list's page no longer works.

 

I just added a couple of hundred caches before realising!!

 

 

 

Mark

Share this post


Link to post

Is it a bug?

Only Traditional-Caches from the ignore-list are removed from the google-maps. Multi and Mystery-Caches are still on the Map if they on the ignore-list. Is it possible to change it?

 

Same here. I hope this will be fixed. This feature is usefull.

Share this post


Link to post

Two things:

 

1. The page refreshing after you choose your log type is SO INCREDIBLY ANNOYING! I am one of those hyper people who likes to just do things at top speed and get them done, so I really want to just start typing immediately after choosing the log type, not sit and wait for the page to refresh. I know, it's a minor thing...but I was logging a lot of caches and so many times I would choose "found it" then type the whole log only to realize that nothing had appeared on the screen. Why would I not have noticed sooner than after typing the entire log, you ask? Well, I use about four fingers to type and I look at the keyboard the whole time. So since I am a handicapped typist, I think you are obliged to fix this under certain sections of the American Disabilities Act or something! :):D:D

 

2. Caches on the ignore list cannot be found except by going through the ignore list. A keyword search does not work, a waypoint number search does not work, and looking at the owner's profile does not work. I have our kids' caches under their profiles on my ignore list, and now suddenly I can't see them to look at the cache page or to log a note!

Share this post


Link to post
2. Caches on the ignore list cannot be found except by going through the ignore list. A keyword search does not work, a waypoint number search does not work, and looking at the owner's profile does not work. I have our kids' caches under their profiles on my ignore list, and now suddenly I can't see them to look at the cache page or to log a note!

But... this seems like the whole purpose of an ignore list. It seems to me like it's working as planned.

 

Maybe you could either make a bookmark list of your kids caches, or bookmark the cache pages in your browser under a section called "My Kids Caches" or something.

 

I wouldn't want ignored caches to start showing up on other searches just because someone doesn't really want to ignore them.

Share this post


Link to post
2. Caches on the ignore list cannot be found except by going through the ignore list. A keyword search does not work, a waypoint number search does not work, and looking at the owner's profile does not work. I have our kids' caches under their profiles on my ignore list, and now suddenly I can't see them to look at the cache page or to log a note!

But... this seems like the whole purpose of an ignore list. It seems to me like it's working as planned.

 

Maybe you could either make a bookmark list of your kids caches, or bookmark the cache pages in your browser under a section called "My Kids Caches" or something.

 

I wouldn't want ignored caches to start showing up on other searches just because someone doesn't really want to ignore them.

 

edited to add: I took them off the ignore list, but now they show up on my closest unfound caches list! GRRRR! I want to NOT see them there, but see them when I want to....

 

In the past, the caches on the ignore list did not show up on a search ("show nearest caches" or "show all nearby caches of this type" etc.) or on the maps, but they DID show up when I looked at the kids' hidden caches from their profile pages, or if I did a waypoint search specifically using the cache's GC# or a keyword search using the cache's exact name. Even if I am ignoring a particular hider's caches, I would like to be able to see them when I go to his hides list on his actual profile page. After this recent update, it would show the icons for each cache type, as well as the number of hides, but then when you clicked to see, for example, all the traditional caches the person owns, the page that came up would look like the regular list page, but there would not be any list of caches on it!

Edited by whistler & co.

Share this post


Link to post
2. Caches on the ignore list cannot be found except by going through the ignore list. A keyword search does not work, a waypoint number search does not work, and looking at the owner's profile does not work. I have our kids' caches under their profiles on my ignore list, and now suddenly I can't see them to look at the cache page or to log a note!

But... this seems like the whole purpose of an ignore list. It seems to me like it's working as planned.

 

Maybe you could either make a bookmark list of your kids caches, or bookmark the cache pages in your browser under a section called "My Kids Caches" or something.

 

I wouldn't want ignored caches to start showing up on other searches just because someone doesn't really want to ignore them.

 

I was expecting that ignored caches would only be removed when you looked the maps. Not when I look at the caches hidden in someone's profile page.

 

I still would like to be able to toggle ignored caches on and off when viewing the map. Especially if I am planning on hiding a cache and need to see what is in the area.

Share this post


Link to post

Regarding the page refresh issue that others have mentioned....

 

I have noticed this not after I select the log type, but after I change the date. I recently went out

of town and did some geocaching in another area, and I was unable to complete all of my logging

right then. I saw the screen flash as the page refreshed, and what I first noticed was that the

format of the date changed!

 

Initially the date is of the form: June 30, 2009.

 

After the refresh is becomes: 07 05 2009 (At least it did this morning.)

 

On precious days I have noticed the date format change, but I did not realize it was

resetting the date to the current day! It occurred to me that someone may have "added"

this date format change as a feature to be less "English", but why was it not inserted into

the code before the logging page is first displayed?

 

I try to be accurate in recording the dates I visit caches and pick up or drop off Trackables,

and now it looks as though I will have to go check all of my logs since June 24th. Of course

if I find any date errors, I'll get that annoying "edited by..." note at the bottom of all of the

logs.

 

I would really appreciate this "refresh" issue being fixed, as it is quite annoying and occurs

on almost every interaction I have with the web site!

Share this post


Link to post

I just wanted to update you folks and let you all know that we plan to fix these bugs (and others) for the next release.

 

Page refresh and calendar control on logging page

GCXXX entry for bookmarks

Ignored caches in owner's profile not displayed

Trackable mileage

Cache search results distance sequence

 

Thanks for your patience.

Share this post


Link to post
I just wanted to update you folks and let you all know that we plan to fix these bugs (and others) for the next release.

 

Page refresh and calendar control on logging page

Nate, is this the thing where you'll click "Found It" date changes from July 1, 2009 to 7/1/9?

Share this post


Link to post

I just wanted to update you folks and let you all know that we plan to fix these bugs (and others) for the next release.

 

Page refresh and calendar control on logging page

 

Trackable mileage

 

Thanks for your patience.

 

YES :drama:;):P (especially on the 2nd)

Share this post


Link to post
I just wanted to update you folks and let you all know that we plan to fix these bugs (and others) for the next release.

 

Page refresh and calendar control on logging page

Nate, is this the thing where you'll click "Found It" date changes from July 1, 2009 to 7/1/9?

 

Yep, that's the one! I dunno if it can be hotfixed or if we have to wait for the next release to fix it. Hopefully it can be hotfixed and out the door in the next few days.

Share this post


Link to post
Yep, that's the one! I dunno if it can be hotfixed or if we have to wait for the next release to fix it. Hopefully it can be hotfixed and out the door in the next few days.

Cool. Thanks. Not really a big problem, it's sort of weird when it changes.

Share this post


Link to post
Nate, is this the thing where you'll click "Found It" date changes from July 1, 2009 to 7/1/9?

The underlying bug has actually been around for some time.

 

At one time, (numeric) m/d/y was the only date input format for logs. Then the named months were added, and as a bonus the order (d/M/y or M/d/y) was determined based on whether you had chosen miles or kilometres as your units, the idea being that if you used miles you were probably in the US and otherwise you probably wanted the month in the middle. That worked for most countries except perhaps the UK (where they use miles and the d/M/y format), but it did save people from having to fill in another field in their profile.

 

But, the code to show the months by name and in the right order was apparently never propagated to the version of the log page which appears after a postback (which occurs, for example, if you check the box which says "Add a waypoint to the log"). That didn't affect most people too often, but since the last code release, where that box is implicitly checked if you choose "Update coordinates", there is a postback every time you choose a log type, and so the old, numeric month code shows up every time you log "Found" or anything else.

 

So it's great news that this will finally be fixed. :P

Share this post


Link to post

The page refresh after selecting "Type of log:" is REALLY annoying.

I select "Found it" and start typing my comment only to find that what I've been typing GETS ERASED!!!

Yeesh.

 

I am having the same issues -- it has been somewhat frustrating. This has a significant impact on the speed of logging my caches, particularly when I'm logging for a long weekend when I have 100 or more cache logs to be entered. The page refresh seems to be centered around changing the format of the month from alphanumeric to numeric. This seems like a conversion that could be done in the background without a page refresh. On the front-end page I would prefer to see the alphanumeric form of the month to avoid logging errors caused by confusion with alternate date formats (mm/dd/yy versus dd/mm/yy).

Share this post


Link to post

The page refresh after selecting "Type of log:" is REALLY annoying.

I select "Found it" and start typing my comment only to find that what I've been typing GETS ERASED!!!

Yeesh.

 

I am having the same issues -- it has been somewhat frustrating. This has a significant impact on the speed of logging my caches, particularly when I'm logging for a long weekend when I have 100 or more cache logs to be entered. The page refresh seems to be centered around changing the format of the month from alphanumeric to numeric. This seems like a conversion that could be done in the background without a page refresh. On the front-end page I would prefer to see the alphanumeric form of the month to avoid logging errors caused by confusion with alternate date formats (mm/dd/yy versus dd/mm/yy).

 

I've found that by doing the verbal log first, then fixing the date if necessary, and selecting the log type last, seems to save a bit of time.

Share this post


Link to post

More on the refresh....

 

Since my previous post, I have noticed that the refresh function does seem to be triggered by the log selection action. Apparently the web site was so slow that I was able to not only select the log type, but also the date, and sometimes a Tracking Number, and sometimes even part of my log message before the refresh took affect, which is why it was so annoying, because all of the changes I made after selecting the log type, but before the refresh was complete were lost.

 

Now this has been less of an issue of late, because the web site is usually responding more quickly, and because I've learned to "pause" before continuing. However, I sometimes will still see a long delay. On a whim, I decided to hit the "stop" button (in Internet Explorer 7 it shows up as a red "X" next to the "refresh" button), and that aborts the page refresh. I can then complete my log and submit it, and it works just fine.

 

Your mileage may vary.

Share this post


Link to post
Not really a big problem, it's sort of weird when it changes.
Here's an example of when it can be a real problem. I attended a large outdoor event this past weekend. Somebody I met really wanted me to log his personal TB right away, so I pulled out my just-barely-smart phone. Reception was poor and the link kept coming and going. The WAP site doesn't handle TBs so I slooowly logged in on the standard web site, slowly brought up the page for the TB, slowly brought up the log page, and thought I was just about done when I clicked "discover it" and the page refresh kicked off. This took two more minutes while I was standing awkwardly with something holding out their TB (because I had to enter the tracking number one more time.)

 

When adding fancy Javascript machinations, please think about us mobile users with retro browsers and very limited bandwidth, and keep it simple. Thanks.

Share this post


Link to post
The page refresh after selecting "Type of log:" is REALLY annoying.
I concur. This just hit me -- I had selected the correct date and begun typing when the page refreshed and the date reset. I type quickly, and many of my keystrokes were lost.

 

Please don't refresh a page while I'm filling out a form.

I don't like it either... that was way better before...

Share this post


Link to post
The WAP site doesn't handle TBs

Sure it does. Use option 4.

 

On the general page-refresh topic, any page changes that need to be made should just be done by JavaScript.

Using JS to trigger a page reload seems convoluted. But, that's likely a symptom of the way Microsoft's tools work.

Share this post


Link to post

The refresh is really annoying. I always forget to wait some seconds, I start to write immediately and then lose the text. Geocaching.com server isn't the fastest one and this feature slows it again.

 

Why is the page refresh needed? Fix it please.

Share this post


Link to post

The refresh is really annoying. I always forget to wait some seconds, I start to write immediately and then lose the text. Geocaching.com server isn't the fastest one and this feature slows it again.

 

Why is the page refresh needed? Fix it please.

 

Read posts 71-75 not to far above. Its being worked on :blink:

Share this post


Link to post

The refresh is really annoying. I always forget to wait some seconds, I start to write immediately and then lose the text. Geocaching.com server isn't the fastest one and this feature slows it again.

 

Why is the page refresh needed? Fix it please.

 

Read posts 71-75 not to far above. Its being worked on :D

 

It was listed as a top priority for July and lots of other stuff, most of which I never encountered, did get done. I hope it remains at the top of the list. Just had to endure it while logging a week's worth of caches we did while on vacation. Figure it took about 30% longer to do the logs. I was about ready to resort to a cut and paste comment to save time. Best method for me was to select the date, write the log, then select the log type and click twice on "submit" keeping the clicks about 3 seconds apart. Worked most of the time.

Share this post


Link to post

I just wanted to update you folks and let you all know that we plan to fix these bugs (and others) for the next release.

 

Page refresh and calendar control on logging page

GCXXX entry for bookmarks

Ignored caches in owner's profile not displayed

Trackable mileage

Cache search results distance sequence

 

Thanks for your patience.

 

Can you please fix the tab order issue on the logging page, too? I used to hit tab four times to get to the log text box; now I can't even figure out where the tab goes. Depending on when I catch the refresh, it's somewhere between 6 and 13 tabs to get back to the log text box.

 

Thanks.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 7

×
×
  • Create New...