Jump to content

Garmin Oregon 2.99 Beta Available


g-o-cashers
Followers 11

Recommended Posts

The first one is a nice feature - it looks like we might finally get away from the artificial limitations around only being able to load certain filenames.

 

http://www8.garmin.com/support/download_details.jsp?id=4395

 

I've uploaded it successfully to verify it loads (and it does). I'll post more over on GPSFix as I test.

 

Changes made from version 2.98 to 2.99:

 

* Added ability to load maps from any img file in the Garmin directory

* Improved display of numeric degrees and mills

* Improved Wherigo stability

* Fixed elevation errors when reviewing a point other than a waypoint

Link to comment

That url points to the OR 200 version. I am a little nervous to install 200 on a 300 in case some functionality is disabled.

It doesn't matter because it links to 2.98 I guess they removed the link or he posted a wrong one by mistake.

But I hope that there are more improvements than those you described.

Link to comment

Just installed 2.99 beta and when I turn the unit off (Oregon 300), I get a half black and half white screen. It stays that way until I pull the batteries. Anyone else?

 

JetSkier

 

Same here. It does fade away though without pulling the batteries.

Edited by Warriorrider
Link to comment

Two more things I've noticed ...

 

1) My recreation profile has reset to defaults.

 

2) If I have Garmin Spanner mode selected, it won't connect to the computer when you plug the USB cable in while the unit is off. You have to turn it on first and then connect the cable.

 

JetSkier

Link to comment

Confirmed black / white screen on 300 power down.

 

Garmin spanner mode + USB connection when off worked as normal..unit powered on and asked the normal "Mass storage mode?" prompt.

 

Excited about the .img loading.

 

At the risk of sounding stupid, can someone explain the benefit of the .img loading?? I suspect it might mean we no longer have to use Mapsource to spend an hour combining a set of maps into a single file.

Link to comment

Instead of only loading gmapprom.img, gmapsupp.img, or gmapbmap.img.... you could load topocan.img cn2010.img or any combinations of map images, that you have renamed yourself. This would enable you to add a new mapset without re-compiling the whole lot into a single gmapsupp.img.

 

Of course that is only an assumption on my part, as I dont have an oregon to test it on.

Link to comment

Confirmed black / white screen on 300 power down.

 

Garmin spanner mode + USB connection when off worked as normal..unit powered on and asked the normal "Mass storage mode?" prompt.

 

Excited about the .img loading.

 

At the risk of sounding stupid, can someone explain the benefit of the .img loading?? I suspect it might mean we no longer have to use Mapsource to spend an hour combining a set of maps into a single file.

For one, you beat the 4GB filesize limit thereby taking advantage of >4GB Micro SDHC cards. Before, AFAIK, it would only load multiple img files from internal memory (correct me if I'm wrong on this remark). Apparently, there is still a max tile limit.

Link to comment

Well, you can change the "Heading" under "Setup" and display either Directional Letters, Numeric Degrees, or Mils. This applies to both geocache and POI lists. Which is a neat new feature. I haven't driven yet to see if they change to an arrow, as they did at higher speeds.

Link to comment

I install the beta and after install and verification. It turned into a paperweight. The only thing that it will do now is say "System software missing"

 

Try this procedure:

 

http://garminoregon.wikispaces.com/Miscellaneous#toc3

 

2) If I have Garmin Spanner mode selected, it won't connect to the computer when you plug the USB cable in while the unit is off. You have to turn it on first and then connect the cable.

 

No problems here.

 

At the risk of sounding stupid, can someone explain the benefit of the .img loading?? I suspect it might mean we no longer have to use Mapsource to spend an hour combining a set of maps into a single file.

 

Yep, you can load a bunch of different img files with segments from any maps an the unit "combines them for you". No need to rebuild in mapsource if you need to add new segments.

 

Cool new feature, you get a numeric bearing instead of the Cardinal Point letters.

 

This has been there since day one, but the font has changed to make it a little easier to read.

 

GO$Rs

Link to comment

Cool new feature, you get a numeric bearing instead of the Cardinal Point letters.

 

This has been there since day one, but the font has changed to make it a little easier to read.

 

GO$Rs

 

Have they fixed the bug where if you had selected Mils, and then went to the map and selected a point on the map (red pushpin), the direction in Mils showed up but only the first 3 characters (0-639)? I had reported this to the Beta team, but I did not receive any indication that they had received my report.

 

DCMG

Link to comment

Confirmed black / white screen on 300 power down.

 

Garmin spanner mode + USB connection when off worked as normal..unit powered on and asked the normal "Mass storage mode?" prompt.

 

Excited about the .img loading.

No go on the Garmin Spanner mode for me. I have my Automotive set to Spanner. When I plug in the USB (while the unit is off), I see the Garmin text in the middle, my startup text at the top and the it goes to the black/white screen and fades away.

 

Ok ... I just set my recreation profile to spanner and it worked fine. Still no go with Automotive mode.

 

JetSkier

Link to comment

I just don't get why every new beta version includes at least one new bug. We here on the forum seem to find them within hours of release. How is it Garmin so blindly misses them?

 

That's why they call them Beta Releases. ;) The Beta testers (aka: you and I) help them find the bugs to fix before they make a final release of an upgrade to the software/firmware.

 

Sometimes the developers forget to start with a "clean" unit and end up with a couple of Betas that overlap, thus they don't see the same errors.

Edited by NanoAnimation
Link to comment

Also, we are real world testers and we do things a developer might not think of.

 

My first Wherigo was a mess because I KNEW how to play it. I didn't make any mistakes like a new player would. I had to double the code to handle different things like drifting into zones out of order.

 

I am ok with beta testing for Garmin. For us it is short term pain for long term gain.

Link to comment

Confirmed black / white screen on 300 power down.

 

Garmin spanner mode + USB connection when off worked as normal..unit powered on and asked the normal "Mass storage mode?" prompt.

 

Excited about the .img loading.

No go on the Garmin Spanner mode for me. I have my Automotive set to Spanner. When I plug in the USB (while the unit is off), I see the Garmin text in the middle, my startup text at the top and the it goes to the black/white screen and fades away.

 

Ok ... I just set my recreation profile to spanner and it worked fine. Still no go with Automotive mode.

 

JetSkier

 

I thought changing unit to "Garmin Spanner" mode was a global function and changed all profiles, am I incorrect? I know, way back when I changed my 400t to Spanner I only did it in the Automotive Profile, but when I view this setting in other profiles they all show Garmin Spanner, also.

Link to comment

Confirmed black / white screen on 300 power down.

 

Garmin spanner mode + USB connection when off worked as normal..unit powered on and asked the normal "Mass storage mode?" prompt.

 

Excited about the .img loading.

No go on the Garmin Spanner mode for me. I have my Automotive set to Spanner. When I plug in the USB (while the unit is off), I see the Garmin text in the middle, my startup text at the top and the it goes to the black/white screen and fades away.

 

Ok ... I just set my recreation profile to spanner and it worked fine. Still no go with Automotive mode.

 

JetSkier

 

I thought changing unit to "Garmin Spanner" mode was a global function and changed all profiles, am I incorrect? I know, way back when I changed my 400t to Spanner I only did it in the Automotive Profile, but when I view this setting in other profiles they all show Garmin Spanner, also.

As far as I know, it's always had different settings in each profile. But, I could be wrong.

 

JetSkier

Link to comment

I believe that there is a bigger issue with this shut down crash, at least in the 3-4 tests I've tried settings changes are not being saved across power cycles.

 

If you go to Setup and change any setting it looks changed in the user interface but it must not get saved in the profile on shutdown. When the unit reboots the setting is lost.

 

Edit: seems to only impact some settings not others. System>Battery Type, Display>Backlight Timeout, System>GPS, System>Interface don't seem to be preserved but Units>Distance/Speed was.

 

Anyone else?

Edited by g-o-cashers
Link to comment

In my previous post, I said I changed to Serial mode and it still didn't connect. Turns out that it didn't save Serial mode. I had to change many settings to get it to change. But when I just changed it back to Spanner, it held the setting (and still didn't connect to my PC with the unit off).

Link to comment

Installed without issue. Did notice when you shutdown that my screen also doesn't turn off right. After waiting a few minutes though, all is well.

 

The screen issue probably isn't too big a deal. I'd imagine there's a problem with the shutdown sequence and power is being cut from the display before the pixels are set to off causing a 'ghosting' while the pixels slowly lose their charge and fade to off. I've seen similar behavior when the batteries get really low and the unit has an 'improper' shutdown.

 

Any reports on GPS functionality, accuracy, etc. on this beta release?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 11
×
×
  • Create New...