Jump to content
Sign in to follow this  
Followers 0

Samsung SGH-i780

Recommended Posts

I have a Samsung SGH-i780 with built-in GPS that is optimized to work with Garmin software (which reports the GPS as "intermediate driver", meaning there is some sort of internal connection, not through any COM port).

It runs googlemaps connecting to the GPS without problems, but I don't seem to get Wherigo to detect the GPS.

There is no way to manually turn GPS on other than through an application.

I tried running the Wherigo tutorial but it keeps saying "Your GPS signal si not optimal" and the signal bars in the top right are all red.

The screen is too small to get a full view of the GPS settings screen in Wherigo and I can;t scrol ldown far enough to make any amendments, so I just let teh thing autodetect, but no success.


thanks for any help


Ronald (eikenboom)

Share this post

Link to post

Sounds like you are getting farther than me. My Samsung Omnia works great with Google maps, BasicGPS for Geocaching, ect... but the Wherigo app locks the Omnia up at the GPS detection screen.


Updated to .NET Compact Framework 3.5 Redistributable to see if this would help (others said it helped them), but with no luck. Still locking up.

Share this post

Link to post

I finally was able to get my Samsung to work last night after about 9 hours of hacking and screwing around. My time will be your gain as this process should take less than 15 minutes.


This will temporarily mess up your phone but it works normal later.


Added the GPS through Bluetooth and set the software for port 9, hardware ports never worked with it

Install Wherigo

Go to http://forum.xda-developers.com/showthread.php?t=327830

Register for the site and then download both RealVGA_11 and Respack96dpi

This is the part that will mess up your phone for a bit

Install RealVGA_11 then install Respack96dpi

It will reboot and the phone will generate a lot of errors, just ignore them

Run Real VGA and select 96 dpi

The phone will reboot generating errors still

Run Wherigo

In setting, uncheck Auto Detect and Pick Channel 9 with the first speed level (8900 I think?)

Press the test button

Once it links up and works try the tutorial

Close out of Wherigo but don't save your game

Run RealVGA and change the dpi back

It will reboot again

Go to Remove programs and remove Respack96, cancel the reboot, remove RealVGA

Manually shut down the phone and then start it up

Everything will load normal and you’re ready to test the tutorial


Everything seems to be functioning normal now and am looking forward to really testing the game out this weekend.


If you attempt to change your GPS settings again you'll need to run the steps all over again because Wherigo quits working. It'll be a headache. Save your VGA cab files just in case. Good luck!

Edited by Boss & Abby

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
Followers 0

  • Create New...