Jump to content

Garmin GPSmap 60CSX sw verson 3.90


mjr15197

Recommended Posts

Change History

 

Changes made from version 3.70 to 3.90:

◦Added support for maps greater than 2 GB.

 

I ran mine through the web updater and it also upgraded the GPS software to version 3.00s.

 

http://www8.garmin.com/support/download_details.jsp?id=1245

 

Thanks for the heads up.

 

What's very strange is that I have a 76CSx which is supposedly the same unit internally as the 60CSx.

 

But this new update is not shown as available for the 76CSx.

 

I wonder why ?

 

Tim

Link to post

Story of my life... always in the wrong place. :o

 

I'm also surprised not to see some mention of any tweaks for the 60/76 CSx untis to utilize the g2 Vision charts.

 

Garmin told me that the regular BlueCharts will not be updated any longer for, at least, the 76CSx as they will be upgraded to use the g2 vision Bluecharts.

 

I would think that doind so would be a priority update/upgrade.

 

Something you don't want outdated... are nautical charts.

 

Tim

Edited by pratzert
Link to post

Story of my life... always in the wrong place. :o

 

I'm also surprised not to see some mention of any tweaks for the 60/76 CSx untis to utilize the g2 Vision charts.

 

Garmin told me that the regular BlueCharts will not be updated any longer for, at least, the 76CSx as they will be upgraded to use the g2 vision Bluecharts.

 

I would think that doind so would be a priority update/upgrade.

 

Something you don't want outdated... are nautical charts.

 

Tim

Anybody else lose the "D"'s in there signal strength bars when receiving WAAS or EGNOS?

 

Edit to add: I am receiving a strong signal from #51.

Edited by Klatch
Link to post

Just downloaded and installed it. Took a trip around town and now every time it recalculates a route, the screen fades out and the unit shuts off. Definitely going back to 3.70

 

Well.... THAT'S not good news.

 

I guess we'll be getting more reports as the days go by.....

Link to post

Just downloaded and installed it. Took a trip around town and now every time it recalculates a route, the screen fades out and the unit shuts off. Definitely going back to 3.70

Can someone please post a link to ver. 3.70 unit software for the 76CSX? Thank you.

 

Never mind, I got it from the 76c Yahoo Group. You may have to join the group to access the software.

Edited by Klatch
Link to post

Does this mean that I can now use something like a 4GB micro SDHC card and load all the map data I want just so I do not exceed the 2025 maximum map segment limit on my 60CSX?

That seems to be the purpose of the update. Since no new size limit is stated, the new limit on file size will probably be the 4 GB limit imposed by FAT32 formatting. There is no mention of a change in the number of segments limit, so presumably it is still 2025.
Link to post

I think I will wait to see how others make out with this before I update. My CSx is working great as it is.

 

+1 Especially after the mention of the shutdown after a recalculation. The loss of the WAAS "D"s doesn't bother me that much.

Link to post

Just downloaded and installed it. Took a trip around town and now every time it recalculates a route, the screen fades out and the unit shuts off. Definitely going back to 3.70

A user in the 76C Yahoo group reports that his unit successfully recalculated a route without any problem after upgrading to 3.90. Any chance your problem could have been low batteries?
Link to post

Just downloaded and installed it. Took a trip around town and now every time it recalculates a route, the screen fades out and the unit shuts off. Definitely going back to 3.70

A user in the 76C Yahoo group reports that his unit successfully recalculated a route without any problem after upgrading to 3.90. Any chance your problem could have been low batteries?

 

They were fresh Duracells. I did downgrade it back to 3.70 and the problem went away.

Link to post

The WAAS Ds have definitely been removed. I have a second unit on 3.70; side by side 3.70 displays Ds, while 3.90 does not.

 

I don't mind not having Ds, but what REALLY bothers me is that it's not mentioned in the release notes. What else changed that Garmin didn't decide to include in the notes?

Link to post

Can anyone guess why Garmin would remove the "D" display? Is it to dumb down the display for dumb users? I don't consider myself a dumb 60CSx user, though, and prefer to see the "D".

 

Maybe I'm a skeptic, but it seems more likely to me that Garmin has broken WAAS with this release, thus "D" is not showing up.

Link to post

BUG: USB-Mass-Storage-Mode is not supported anymore (Unit shuts down)

using a SanDisk 8 GB SDHC

 

Tried for 2 days and everthing works fine (the D's are not anymore but it receives EGNOS).

 

Neither problem with the recalculations nor with the USB Mass-Storage-Mode, using a 2 GB Kingston MicroSD.

Link to post

I also had to revert my 60CSx to 3.70.

 

After upgrading to 3.90 I had immediate problems with the uniting hanging during the power down beep when I pressed the power button. Resulting in a neverending beeeeeeeeeeeeeeeeee.... sound - had to remove the batteries to get round that.

 

Also the unit started just freezing up randomly whilst I was using it.

 

Did the update twice from webupdater from the mac, once from web updater on a pc, once as a manual update on a pc and did a couple of factory resets to make sure there wasn't some stuffed config information.

 

Reverted to 3.70 and the unit works perfectly again.

Edited by iamasmith
Link to post

Reverted to 3.70 and the unit works perfectly again.

Did you run the updater twice. The second time updates the chipset FW? If so, did you back off the chipset software too. Both updates may be needed so the two programs are compatible with each other.
Link to post

Reverted to 3.70 and the unit works perfectly again.

Did you run the updater twice. The second time updates the chipset FW? If so, did you back off the chipset software too. Both updates may be needed so the two programs are compatible with each other.

 

Hmmm... good point. When I installed 3.70 I thought it would back off the GPS firmware too. That's showing version 3.00 though. Can't remember if that was at an earlier rev with 3.70.

 

You believe running the 3.70 upgrade again will back that down too?

Link to post

Reverted to 3.70 and the unit works perfectly again.

Did you run the updater twice. The second time updates the chipset FW? If so, did you back off the chipset software too. Both updates may be needed so the two programs are compatible with each other.

 

Hmmm... good point. When I installed 3.70 I thought it would back off the GPS firmware too. That's showing version 3.00 though. Can't remember if that was at an earlier rev with 3.70.

 

You believe running the 3.70 upgrade again will back that down too?

I was just trying to figure out what is going on. I wasn't trying to suggest backing off the chipset FW.

I did the updater twice and the chipset is 3.00s. The funny thing is that when I checked the versions it hung up my GPS. Then the display faded to blank.

Edited by John E Cache
Link to post
When I installed 3.70 I thought it would back off the GPS firmware too. That's showing version 3.00 though. Can't remember if that was at an earlier rev with 3.70.
I have not updated. Chipset firmware version 3.00 is the correct version for use with unit firmware 3.70.
Link to post

The firmware and chipset are separate. Changing firmware from 3.70 to 3.90, or vice versa, will not change the chipset. Running Webupdater will always both to the most current version. You would need to manually run a version of 3.70 to downgrade the firmware. I'm not aware of a manual downgrade version of the chipset (to 2.90, for instance), but it probably exists.

Link to post

The firmware and chipset are separate. Changing firmware from 3.70 to 3.90, or vice versa, will not change the chipset. Running Webupdater will always both to the most current version. You would need to manually run a version of 3.70 to downgrade the firmware. I'm not aware of a manual downgrade version of the chipset (to 2.90, for instance), but it probably exists.

 

Of course it's quite a different process but I assumed that updates would be like the Oregon updates (which I have done a LOT of :laughing:), Those updates carry both GPS Firmware and Unit Software updates and downgrading also downgrades both.

 

You say this isn't the case with the 60CSx typically? (this is the first upgrade I have seen for it since I bought it).

 

Anyway, I think even if they fix this update I think I'll wait for people to confirm that there aren't any losses of precision in the new versions.

 

I think, since 3.70 is SO good that we should probably keep a close eye on comparing newer versions.

Link to post

I have experienced similar finding to others above. When trying to revert to v3.70 using updater.exe it does not seem to work with USB interface. OK with old serial (COM Port) interface but much slower and depends on units batteries. Any one out there any guidance on this problem please?

Link to post

"I assumed that updates would be like the Oregon updates (which I have done a LOT of ), Those updates carry both GPS Firmware and Unit Software updates and downgrading also downgrades both."

 

As written, the firmware and software are different. "Upgrading" via web updater updates both, but they are separate upgrades. You can update one without updating the other, but not with web updater. You can manually revert to older versions, but not with web updater.

Link to post

My only concern is that the new GPS software requests the chipset do a new function that was added in the new chipset update. I have seen cases of other non-GPS software where you need two program updates to stay compatible with each other. I'm not saying that is the case here, though.

Link to post

My only concern is that the new GPS software requests the chipset do a new function that was added in the new chipset update. I have seen cases of other non-GPS software where you need two program updates to stay compatible with each other. I'm not saying that is the case here, though.

I upgraded via Web Updater. The new unit software was installed. It then asked if I wanted to look for additional updates. It found none. I was already running chipset ver 3.00 when I updated to 3.90. Wanting my "D"'s back I reverted to 3.70 manually. My 76CSX is functioning normally.

Edited by Klatch
Link to post

I'm having the same never ending beep problem as iamasmith when powering down with a 2GB card installed. Doesn't happen with a 64MB card. Where can I find instructions for doing a factory reset and downgrading the unit software to version 3.70? I am using a Mac.

Link to post

I'm having the same never ending beep problem as iamasmith when powering down with a 2GB card installed. Doesn't happen with a 64MB card. Where can I find instructions for doing a factory reset and downgrading the unit software to version 3.70? I am using a Mac.

 

I'll PM you a link for the firmware but you need to run it on a PC or through Fusion or something (I just did the upgrade and downgrade again).

 

Anyway, I did some more testing.

 

I have 3 x 2Gb SanDisk MicroSD cards

 

Card A: Gives power off issue and gives periodic hangs. Made in China.

Card B: Gives power off issue but no hangs during limited testing. Made in China.

Card C: Work perfectly. Made in Taiwan.

 

Also note the screenshots. 3.90 DOES come with a GPS firmware update and downgrading ONCE does revert that upgrade.

 

Version screenshots on this thread

Edited by iamasmith
Link to post

Thanks iamasmith. What about the procedure for doing a factory reset?

 

Incidentally, I have a 2GB Sandisk card made in China as well, which is the card that is causing me problems. I will downgrade the firmware for now as I don't have a card larger than 2GB and don't see any other advantages to 3.90.

 

Not sure how this speaks to future updates if we have to worry about the country of origin for our memory cards.

Link to post

Thanks iamasmith. What about the procedure for doing a factory reset?

....

Not sure how this speaks to future updates if we have to worry about the country of origin for our memory cards.

 

IIRC Hold down Quit,Menu and Zoom out whilst powering on the unit and it may take a couple of attempts, I'm not sure if it is significant how long you hold the buttons down for. Anyway G.I.Y.F. on this one, there are a few sites that discuss how to do it.

 

As far as choosing the country of origin for the memory card, well no, clearly there is a problem and some cards may be borderline on spec. Incidentally it isn't a new issue to see some devices having problems with memory cards manufactured in different regions it's often down to the components used, if they implement full or partial command sets etc. I know over on the Sharp Zaurus forums we spend a lot of time trying to get to the bottom of why some cards would work and some wouldn't (that was SD, not MicroSD but I gather it is similar in implementation).

 

Anyway, as long as Garmin don't fall into the trap of thinking these are isolated incidents that may relate purely to specific individual cards we should expect that something will be done about it so I would encourage anybody that has had problems described to verify that the unit functions well otherwise (and perhaps with a different card) then submit a report of the problem to Garmin telling them specific cards that are problematical.

 

My decision to move to a release beyond 3.90 is going to be based upon the tracking performance against 3.70 and any new features. I'm turned off by the fact that they removed the WAAS/EGNOS 'D' indicators and I have to say in the limited time I had 3.90 (with 3.00s FW) on the unit I didn't get one locked on EGNOS bird (it could see 39 but wouldn't lock) whilst reverting to 3.70 (with 3.00 FW) locked instantly when I took the unit back out of the house following downgrade.

Link to post

My decision to move to a release beyond 3.90 is going to be based upon the tracking performance against 3.70 and any new features. I'm turned off by the fact that they removed the WAAS/EGNOS 'D' indicators and I have to say in the limited time I had 3.90 (with 3.00s FW) on the unit I didn't get one locked on EGNOS bird (it could see 39 but wouldn't lock) whilst reverting to 3.70 (with 3.00 FW) locked instantly when I took the unit back out of the house following downgrade.

 

Perhaps I'm being pedantic, but doesn't your experience confirm that, more than likely, Garmin did not remove the "D" display, but has instead broken WAAS / EGNOS with this update? Well, that would be my interpretation, even though there are a few other possibilities.

 

I am a software engineer, and Garmin software quality (and hardware in some cases) leaves a lot to be desired. Although I think the 60CSx currently outperforms the DeLorme PN-40, I think DeLorme is on the right track and offers much better quality than Garmin. Hopefully competition will improve Garmin products.

 

Regards

Link to post

..

Perhaps I'm being pedantic, but doesn't your experience confirm that, more than likely, Garmin did not remove the "D" display, but has instead broken WAAS / EGNOS with this update? Well, that would be my interpretation, even though there are a few other possibilities.

...

 

Well, if my experience alone suggested this then that's the view I would have taken. Maybe it's anecdotal but others on this thread have interpreted that the feature has been removed.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...