Jump to content
Sign in to follow this  
Followers 10
northernpenguin

Ontario Trail Maps for Garmin Units

Recommended Posts

Thanks snaggles8 ... that comment brought a smile to my face :(

 

I have to agree with Keith on the use of the Project files with Topo Canada - that's a pretty good combination with the 3D shading.

 

--

 

I'm getting very close to issuing version 0.67 of the project - this will be a complete release with the Garmin, KML and SHP files to bring everything up to date.

 

Notable enhancements coming in the next release:

 

Kelso CA Trails

Gould Lake CA Trails

More Algonquin PP, Arrowhead PP coverage.

More coverage of the Guelph Radial Line Trail

Island Lake Trail (Orangeville)

 

Improved support for older Garmin GPS units, like the eTrex Legend (not the Hx/HCx version).

Share this post


Link to post

I have heard people with older gamin units are having issues with the map not being compatible. Is this going to be fixed?

Share this post


Link to post

I have heard people with older gamin units are having issues with the map not being compatible. Is this going to be fixed?

 

Keith, if you'd look at my previous post, you'd see that is planned for the next release of the project. The problem was introduced in the 0.60 version, when we added custom TYP support (trails appear as red lines vs similar to dirt roads).

 

I am waiting on a couple tracklogs that I've been offered, before I roll out the release.

 

For those of you that cannot wait until the next release, here's a workaround:

 

Older units do not support NT style maps, so use the .reg file from before 0.60.

 

- or -

 

Here's a .reg file that should revert the maps from the new style back to the old style .... this is for those of you that installed the Trails Project, and get a message that the maps are not supported for your GPS:

http://trailmaps.torontogeocaching.com/maps/ont-revert.reg

 

This is used the same way as the .reg file is in the original install - download, and double-click to merge with the registry. Make sure MapSource is closed first.

 

Note: this will remove the NT map style capabilities - specifically the custom line colours. It is GLOBAL. Meaning if you have both a new Garmin (Colorado/Oregon), and an old Garmin (eTrex) all maps will lose the custom linetype (trails no longer appear as red lines).

 

I don't have a solution for both old and new on the same computer (yet). I do have some ideas though, which will be tested for the next release of the project.

Share this post


Link to post

I'm confused. Using TYP customization should not affect old units as long as you are using line types that are supported in the old units. I have used TYP custom lines for years and the maps work fine on old units.

Share this post


Link to post

I have heard people with older gamin units are having issues with the map not being compatible. Is this going to be fixed?

 

Keith, if you'd look at my previous post, you'd see that is planned for the next release of the project. The problem was introduced in the 0.60 version, when we added custom TYP support (trails appear as red lines vs similar to dirt roads).

 

 

Sorry, my mistake. I thought that meant improving vs make it so people can use it on older models.

Edited by Keith Watson

Share this post


Link to post

I'm confused. Using TYP customization should not affect old units as long as you are using line types that are supported in the old units. I have used TYP custom lines for years and the maps work fine on old units.

 

Entirely possible here. I should probably review that again. I found the only way I could get TYP working was to register the maps under FamiliesNT, which triggered the 'new style' maps. If I can use TYP without forcing to FamiliesNT, that would work nicely too.

Share this post


Link to post

Just a quick update:

 

- I've updated the project files to version 0.68, incorporating a whack of new data sources. Thanks everyone who contributed.

 

This release also sees an update to the KML and Shape Files. The GPX file is going to be updated shortly.

 

While there are still problems on my "Todo List", I felt it was time to release the data that's been provided to me.

 

I am still getting reports about various problems related to older GPS units like the monochrome eTrex legend. Most people that have talked to me are fine if they use the older registry file from before 0.60.

 

The new issue I'm having is it looks like Windows 7 or the newest release of MapSource has moved the registry keys around somewhat. All I can say now is I'm aware of the issue, that it doesn't seem to happen if you upgrade to Win7, but does happen occasionally on a new install. I'll need to setup a test environment to figure out what's different. Hope to get to the bottom of this shortly.

Share this post


Link to post

This was exactly what I was looking for. I downloaded the file into my Oregon 200. And the trails show up great on it - even the trails up my way in Northwest Ontario. I was particularly looking for the Bruce Trail maps - so this helps out greatly.

 

Thanks for your effort on this matter.

Share this post


Link to post

This is a great project!!

I wish I had this stuff before heading down to Sourthern Ontario.

 

Many thanks to NP for these maps.

 

I was wondering if any other regions doing this type of project?

Share this post


Link to post

I was wondering if any other regions doing this type of project?

 

The (Canadian) ones I'm aware of are listed on this page. Mainly in the Ottawa area and out in Western Canada.

 

I know there are many regional groups in the USA as well, but I don't have specific links to them. Naturally, I'll keep updating my page there as I become aware of the other Canadian groups doing this sort of thing.

Share this post


Link to post

I was wondering if any other regions doing this type of project?

 

The (Canadian) ones I'm aware of are listed on this page. Mainly in the Ottawa area and out in Western Canada.

 

I know there are many regional groups in the USA as well, but I don't have specific links to them. Naturally, I'll keep updating my page there as I become aware of the other Canadian groups doing this sort of thing.

 

Thanks NP!!

 

Looks like the east coast needs to 'get on the map'!! :huh:

Share this post


Link to post

I am using version 0.69 BETA 4 and noticed that the trail runs over geocache icons on the Colorado. Is there a way to drop the trails below the geocache icons and still keep them above everything else like the custom maps?

Share this post


Link to post

I am using version 0.69 BETA 4 and noticed that the trail runs over geocache icons on the Colorado. Is there a way to drop the trails below the geocache icons and still keep them above everything else like the custom maps?

 

That's a problem with the newest firmware on the Colorado. I'm not sure if it's even possible for me to fix that problem (suggestions, anyone?). I've seen other people talking about this with transparent maps on other forums too. The newest Oregon firmware is also buggy and hides the GOTO line when a transparent map is in use as well.

 

I have created a new TYP file which makes the trail lines a lot thinner in the meantime, and I'll post that on the site soon.

Share this post


Link to post

It is a problem with the current firmware. Trails also draw over the tracklog. Nothing to do but hope Garmin fixes the firmware.

Edited by Red90

Share this post


Link to post

It is a problem with the current firmware. Trails also draw over the tracklog. Nothing to do but hope Garmin fixes the firmware.

 

Thanks Red90

 

I've also done some more looking around and see that it started after v3.00 Colorado firmware. I know several people who have reverted to v3.00 to fix the issue. It also happens when I run the GPSQuebec topo maps on my GPS (much worse actually, as polygons covering a waypoint do far more than a line does).

 

If anyone is interested, I can whip off a "1 pixel" TYP file to make the trails less pronounced on the GPS.

 

On another note, I got a new batch of trails from the Government yesterday, bringing the project up to 8,639 km of trails ... well that's what Global Mapper says anyway.

Share this post


Link to post

Add me to the list of reverting back to 3.0.0. I will miss the cool zoom, be the trails and other things I like better in 3.0.0

Share this post


Link to post

I downloaded version 0.69 Beta 4 to my Oregon 200

 

I like that the trail colour is a lighter red (although thinner) which no longer looks like my tracking colour (black)

 

Trail lines don't run over the geocache icon on the Oregon 200. And I just updated the Oregon Firware on my unit.

 

Great work - Thanks

Share this post


Link to post

.... and we have a new version on the site (0.70). All formats, GPX, SHP, KML, everything :laughing:

 

I've made a few big changes to the map, and have started expanding out into more detail on the map itself. Trails that are *known* to just follow a road are now represented with a dotted line, and you can see the road (before when the trail followed a road it would just cover the road). I'm also showing some of the parking areas.

 

If you have an older GPS, the trail-on-road should simply show up as an unpaved road, while the rest of the trails use the 'trail' type.

 

The other big thing is we appear to have finally figured out why the product wasn't showing up in Basecamp, and that has been fixed (thanks Avernar). The Colorado firmware 3.1/3.2 bug is still there, and that part is up to Garmin to fix.

 

Here's what I posted on my blog about this release:

--

 

Another update to the Ontario Trails Project is posted, with a bunch of new trails and updates.

Thanks to Avernar, we now have a build that works with Basecamp! Also watch for the new trail designation - trails on roads and also parking areas have been added.

 

There WAS a 0.69 beta, but we've skipped that and gone straight to 0.70 for the Basecamp support.

 

Ont-Trails 0.70 - 13 FEB 2010

 

Changed Line Types:

- Added dotted line to designate trails that follow roadways / shoulders

- Added Parking Area POI type. A $ in the name indicates payment required

Updated build files to accomodate Garmin Basecamp (thanks Avernar!)

Updated build files to properly track Map version number internally

Added - Stouffville Town Trail portions (northernpenguin, GPS/Aerial)

 

Ont-Trails 0.69 BETA 6 - 4 FEB 2010

 

Added - *** MNR Trails from June 2009 - January 2010 Merged - Province Wide Updates ***

Added - Durham Regional Forest Trails - (Dennis Anderson, GPS)

Added - More municipal trails in Markham/North York (northernpenguin, Aerial)

Added - Unopened Rail Trails in West Brantford, details to be added when available (northernpenguin, Aerial)

Added - Millenium Trail System - Woodstock (northernpenguin Aerial)

Added - Lynn Valley Trail - Port Dover/Simcoe (northernpenguin, Aerial)

Added - Howard Watson Nature Trail - Sarnia (northernpenguin, Aerial)

Added - Municpal Trails in Sarnia (northernpenguin, Aerial)

Added - Veteran's Memorial Walk - Tillsonburg (northernpenguin, Aerial/GPS)

Added - Watts Creek Pathway - Ottawa (northernpenguin, Aerial)

Added - West Greenbelt Pathway - Ottawa (northernpenguin, Aerial)

Added - Shoreline Trail - Ottawa (northernpenguin, Aerial)

Added - Old Quarry Trail - Ottawa (northernpenguin)

Added - Sarsaparilla Trail - Ottawa (northernpenguin)

 

Updated - John Lawson Trail - Ingersoll (northernpenguin, Aerial)

Updated - Thomas Ingersoll Scenic Trail - Ingersoll (northernpenguin, Aerial)

Updated - Iroquois Shoreline Trails - Oakville (Avernar, GPS)

Updated - BPACH Trail - Brantford (Avernar, GPS)

Share this post


Link to post

Is there a problems with the website that the Ontario Trails Maps are on?

 

Can't seem to go get into it at the moment

 

Yup. Motherboard went toast in that server, so I'm in the progress of moving it over to my other webserver now. It'll be back soon ... hoping to get everything up and running properly in the next few hours.

Share this post


Link to post

Is there a problems with the website that the Ontario Trails Maps are on?

 

Can't seem to go get into it at the moment

 

Yup. Motherboard went toast in that server, so I'm in the progress of moving it over to my other webserver now. It'll be back soon ... hoping to get everything up and running properly in the next few hours.

 

Everything should be up and running now

Share this post


Link to post

Got a few more trails, so how about a minor update?

 

Ontario Trails Project 0.72 has just been posted to the site.

 

The most recent changes are:

 

Ont-Trails 0.72

 

Updated K&P Trail - Kingston (swimmrguy)

Updated Rideau Trail - Gould Lake C.A. (swimmrguy)

Updated Bruce Trail - Caledon (rovers3)

Updated Oak Ridges Trail to identify some road sections

Updated Bruce Trail Iroquoia - Waterdown (northernpenguin)

Updated Bruce Trail - Third Line Side Trail - Speyside (northernpenguin)

Added - Ridgewalk Trail - Gould Lake C.A. (swimmrguy)

Added - GRLT Smith Side Trail (res2100)

Added - GRLT Starkey Hill Trail (res2100)

Added - GRLT Arkela Side Trail (northernpenguin)

Added - GRLT Portions near Watson Road (northernpenguin)

Added - Bruce Trail - Brown Benton Side Trail - Speyside (northernpenguin)

Added - Bruce Trail - Canada Goose Side Trail - Speyside (northernpenguin)

Added - Bruce Trail - Al Shaw Side Trail - Milton (northernpenguin)

Added - Ganaraska Trail Portion - Port Hope (northernpenguin)

 

Ont-Trails 0.71

 

Updated - Trails in Waterloo area, fixed up OpenStreetMap data

Updated - Trails in Aurora downtown

Added - Hopewell Trail, Breslau

Share this post


Link to post

I just noticed that it still says to use the latest firmware when using the file that is directly copied to a Colorado or Oregon. Not sure about the Oregon but I do know that the Colorado has supported this since the 3.0 release if not earlier. You may want to suggest a minimum version for each. 3.1 and 3.2 do some strange things with the map that users may not want to upgrade to if they don't have to.

Share this post


Link to post

I just noticed that it still says to use the latest firmware when using the file that is directly copied to a Colorado or Oregon. Not sure about the Oregon but I do know that the Colorado has supported this since the 3.0 release if not earlier. You may want to suggest a minimum version for each. 3.1 and 3.2 do some strange things with the map that users may not want to upgrade to if they don't have to.

 

That's a good point, Keith. I'll update the site.

Now I just gotta lookup the Oregon firmware version that added that feature.....

 

Edit: Found it. 2.94b for Colorado, 2.99b for Oregon added the feature.

Edited by northernpenguin

Share this post


Link to post

Probably also worth noting that the x50 Oregon models have separate firmware with distinct version numbering, and afaik, they have supported multiple .img files since launch.

Share this post


Link to post

Probably also worth noting that the x50 Oregon models have separate firmware with distinct version numbering, and afaik, they have supported multiple .img files since launch.

 

Good catch ... edited the page to reflect that information as well.

 

I think it's almost time to migrate that bit of info over to the FAQ page but I'm going to leave it where it is for at least the next couple days. Downloads page is getting a little 'cluttered' for my liking with all the old versions, so a little spring cleaning is in order soon methinks.

Share this post


Link to post

Well, did all that work to update the page and it looks like Garmin noticed.

 

Colorado 3.30 has been released, and seems to fix the transparent map problem!

Run Webupdater to get it (also Oregon x00/x50 and Dakota got updates too).

Share this post


Link to post

have you heard of issiue using the admagmap to DR using Vista OS? i can get it to load trails in SD but when I try in DR i t will not patch the file.

Share this post


Link to post

Not sure if this is related to the trail maps or just a Colorado issue. I notice on version 3.3 that the terrain shading gets repeated for every transparent map active. For example if there is only the base and the DEM topo, the shading is done one. If I add two trail maps it repeats the shading two more times. This makes it very hard to read the area in the shading.

 

Has anyone else noticed this?

Share this post


Link to post

have you heard of issiue using the admagmap to DR using Vista OS? i can get it to load trails in SD but when I try in DR i t will not patch the file.

 

I'm not familiar with admagmap, in fact I'm surprised you got DirectRoute to even work on Vista!

Hopefully someone who reads the forums here can help you out.

 

Not sure if this is related to the trail maps or just a Colorado issue. I notice on version 3.3 that the terrain shading gets repeated for every transparent map active. For example if there is only the base and the DEM topo, the shading is done one. If I add two trail maps it repeats the shading two more times. This makes it very hard to read the area in the shading.

 

Has anyone else noticed this?

 

I've noticed this, and it is a bit annoying. Not as annoying as the previous issue but yeah time to wait for 3.4 firmware I guess. I also had one of those "Colorado is out by 150M until I reboot it" issues today - something I haven't experienced in a while, and is a major issue for trail mapping.

Garmin seems to fix one, break two these days. The BirdsEye imagery is nice though on 3.3, used it on today's BT Hike Event.

Share this post


Link to post

have you heard of issiue using the admagmap to DR using Vista OS? i can get it to load trails in SD but when I try in DR i t will not patch the file.

 

I'm not familiar with admagmap, in fact I'm surprised you got DirectRoute to even work on Vista!

Hopefully someone who reads the forums here can help you out.

 

Ok Thanks. Now only question I have is seeing how i can nnot get this to work with Vista OS can anyone generate this file and possilby send me the .IMI file?

Share this post


Link to post

I have done some more digging into the shading problem. In version 3.0 there is a neat trick. If you select Topo and City Navigator, the City Navigator will be rendered on top of the Topo. Even though the topo is no longer visible, it still renders the shading on the City Navigator map. Cool feature. No matter how many maps you select it does the shading just once. It looks like in version 3.1 and above Garmin started rendering the shading for all maps instead of just doing it once and stopping.

Share this post


Link to post

I have done some more digging into the shading problem. In version 3.0 there is a neat trick. If you select Topo and City Navigator, the City Navigator will be rendered on top of the Topo. Even though the topo is no longer visible, it still renders the shading on the City Navigator map. Cool feature. No matter how many maps you select it does the shading just once. It looks like in version 3.1 and above Garmin started rendering the shading for all maps instead of just doing it once and stopping.

 

What I do is run different profiles - one for Geocaching, with shading turned on, topo and BirdsEye. My automotive modes have shading turned off for clarity. Had to do this as my Colorado INSISTs on enabling TopoUSA and worldwide DEM on all profiles (except 3D view) after a reboot. Annoying.

 

My fix for the driving profile:

 

Setup->Map->Advanced->Turn OFF Map Shading

Share this post


Link to post

I contacted Garmin and they said they would look into it. Hopefully they will recognize this as a regression and get it fixed in the next release.

 

I find it hard when I want to use the trails and shading at the same time and can't make out any details in the shaded areas or have to wait for the multiple re-draws before the rest of the detail is drawn. Kind of pointless to having shading and trails and not be able to use both at the same time. The best I could do would be to merge all my own trails into the Ontario trails and put up with the double draw on the shading.

Share this post


Link to post

I have been trying to track down a problem with the Magellan process. When I create a region from Hockley to Lake Erie, Kitchener to Niagara I have a problem with 1 trail. The Niagara section from Mountain Road to Just past Jones Road. There is something different about this trail from all the others.

Share this post


Link to post

NP - as technologically challenged geocachers it took us a while to download your trail maps, but once we were able to get them loaded what an amazing diffrence they have made. There are no more heated discussions trailside about how to get to the next cache! Thank you for making our geocaching more enjoyable!

Share this post


Link to post

Very cool what you've done here, I'm sending you some tracklogs of North of Sudbury and also Ishpatina Ridge and Maple Mountain. Hope these can be of some help.

Share this post


Link to post

Ontario Trails Project 0.73 is now available!

 

Thanks to Nozzletime, we have a fix for Windows 7 64-Bit Mapsource users - here's a link to the registry file, or use the one in the x64 folder in the 0.73 Zip file.

 

Here's what changed in this release :

 

Added West Perth Thames Nature Trail - Mitchell - northernpenguin

Added Hullett Nature Preserve Trails - Clinton - northernpenguin

Added Grand Trunk Trail - St Marys - northernpenguin

Added Westminster Ponds / Pond Mills Trails - London - northernpenguin

Added Dickson Area trails - Dickson - Zeke_

Added Bannister Lake Trail - Dickson - Zeke_

Added Warsaw Caves Limestone Plain Trail - Murfster

Added Ausable River Trail - Southwest Ontario - rovers3

Added Portions of Ganaraska Trail - rovers3

Added Trout Hollow Trail - Meaford - Paul'n'Susan

Updated Municipal Trails - London - northernpenguin

 

Thanks everyone who has contributed in various ways to the project!

Share this post


Link to post

I've downloaded the V0.73 ONTTRAILS.zip file and installed it in MapSource on my Windows XP machine. I transferred it, using MapSource, to my Garmin Venture Cx.

 

On the Venture, there is a problem with the display of trail names that appear on the map. The lower case characters all appear as dots, as can be seen in this example screen shot.

 

Note that names appear properly in the text at the top of the screen, which describes the pointer location. Also, pop-up text that appears briefly beside the pointer after it is moved (not present in the screen shot) displays proper lower case.

 

An observation: I've looked at City Navigator N.A. maps and Ibycus Topo maps that are also loaded on my Venture Cx. In these maps, all labels and street names appear in upper case only. However, the matching text that appears when you move the pointer, both at the top and in pop-ups, usually contains lower case.

 

Another observation: I also transferred the Ontario Trails map to my Garmin Nuvi 750. With both MapSource and the Nuvi, labels from City Navigator and Ibycus Topo (that are all upper case on the Venture) appear properly with lower case.

 

I'm wondering if there is a separate label field, used only by the Venture, not MapSource or the Nuvi, that should contain only upper case?

 

If there's any additional information that I can provide to help resolve this problem, let me know.

Share this post


Link to post

On the Venture, there is a problem with the display of trail names that appear on the map. The lower case characters all appear as dots, as can be seen in this example screen shot.

 

Note that names appear properly in the text at the top of the screen, which describes the pointer location. Also, pop-up text that appears briefly beside the pointer after it is moved (not present in the screen shot) displays proper lower case.

 

 

Thanks for letting me know, I suspect I know what this problem is caused by

Share this post


Link to post

You are using the wrong code page. Older units want 0 (7 bit ASCII). cGPSmapper default is 1252 and old units do that....

Edited by Red90

Share this post


Link to post

You are using the wrong code page. Older units want 0 (7 bit ASCII). cGPSmapper default is 1252 and old units do that....

 

Well, I just opened up GPSMapEdit and took a look - yup it's 1252. Am I going to break anything in the new units if I switch it over to 0 ?

Share this post


Link to post

Not that I know of. I've always run 0. One version went out as 1252 (not sure why it happened) and I had the same result you are seeing. The cgpsmapper manual says to use 1252....but I got those dots when I did it as well. No real idea why and I have not investigated further.

Share this post


Link to post

Not that I know of. I've always run 0. One version went out as 1252 (not sure why it happened) and I had the same result you are seeing. The cgpsmapper manual says to use 1252....but I got those dots when I did it as well. No real idea why and I have not investigated further.

 

Thanks Red, I'll switch it to 0 for the next release and see what happens

Share this post


Link to post

I have created a copy of the map using code page 0. You can download it here. Unzip the contents to c:\ so it make a folder c:\Ontario0. Then double click on Ontario Trails Code Page 0.reg and a click yes. This will install the map into mapsource. Let me know if it solves the problem with the names.

Share this post


Link to post

I have created a copy of the map using code page 0. You can download it here. Unzip the contents to c:\ so it make a folder c:\Ontario0. Then double click on Ontario Trails Code Page 0.reg and a click yes. This will install the map into mapsource. Let me know if it solves the problem with the names.

 

Thanks Keith for the effort, but I had a release of the Project ready to go with some (large) chunks of the Ganaraska Trail near the Queen Elizabeth Wilderness, The Victoria Rail Trail in the Kawarthas, some minor corrections for trails in Orangeville and added the Fanshawe Lake Trail in London. We also have an easy installer batch file thanks to Avernar, and I've implemented the change to Code Page 0.

 

As always, the official project files are at http://trailmaps.torontogeocaching.com

 

------

 

Here's the changelog for 0.74

 

Ont-Trails 0.74

 

Installer / Uninstaller Program - Avernar

Changed codepage to 0 (Ascii) to correct problems with older units

 

Added Ganaraska Trail - Moore Lake - rovers3

Added Ganaraska Trail - Wilderness Section - Frank Gallimore

Added Victoria Rail Trail - Kawarthas - northernpenguin

Added Fanshawe Lake Trail - London - Brad J. Matuishewski

Share this post


Link to post
Changed codepage to 0 (Ascii) to correct problems with older units

On my Garmin Venture Cx, map text displays properly in upper case now. Example screen shot

 

Everything still looks ok in MapSource and on my Nuvi 750.

 

Thanks

Share this post


Link to post

Could these trails be added to the next release? GC27XM9. The MapSource file looks to be the best detail. This would come in handy for the June get together of the Golden Horseshoe Monthly Geocaching Club. I have created a map to share with others, but inclusion in the this project looks to make sense.

Share this post


Link to post

Could these trails be added to the next release? GC27XM9. The MapSource file looks to be the best detail. This would come in handy for the June get together of the Golden Horseshoe Monthly Geocaching Club. I have created a map to share with others, but inclusion in the this project looks to make sense.

 

Yup, those are scheduled for the next release. I talked to Zeke_ on Friday after Res pointed this out to me. Zeke_ is preparing a more accurate trailmap for me for Dumfries than what is currently posted on that cache.

 

I also received a file with another 4700km of trails on Saturday and I'm sorting through that mountain too.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 10

×