Jump to content

Can my Etrex be saved?


Cladius
Followers 0

Recommended Posts

Hi all. my Etrex Legend old faithfull blue black and white has started crashing. It will go to a blank screen with one vertical line running through it and can not be turned off nor any functions will work. I have to pull a battery to get it to reboot. Is there any hope for my old freind? Or should I just buy a new HCx? Thanks. Cladius.

Link to comment

Update the units software.

 

Question. This is a 4-5 year old unit that isnt being hot sinked or downloaded what will a softwear upgrade do for it?

Dont know, never had to do it. :) Hopefully someone who has will chime in.

Another choice is to turn off WAAS, that is the problem. The unit is seeing another WAAS satellite and doesnt know what to do.

Link to comment

Update the units software.

 

Question. This is a 4-5 year old unit that isnt being hot sinked or downloaded what will a softwear upgrade do for it?

Dont know, never had to do it. :) Hopefully someone who has will chime in.

Another choice is to turn off WAAS, that is the problem. The unit is seeing another WAAS satellite and doesnt know what to do.

 

Yeah, this topic has been covered here many times. Turning off the WAAS fixes it OR updating the firmware fixes it. My Legend was old, too and I updated it without any problems.

Link to comment

There are a couple things that can cause this, some have been mentioned, but the one that sticks out that hasn't is overcharged batteries.

 

Yes, the legend seems very sensitive to this, even compared to other etrex units. I used to always have the problem with mine, and when I dumped my charger (for other reasons) and got a good charger, this problem disappeared completely.

 

Lithium batteries also have a higher voltage and can cause the problem too.

 

Either way, when you first put fresh batteries in, turn on the unit, and hit the light for a couple minutes and see if the problem goes away.

Link to comment

Well the good news is I found the cable the bad news is my laptop doesn't have that old style serial port connection. I will take it to work tonight and see if IT hasn't filtered me from doing it there. So far dissabling waas seems to be working. To be cont..................

Link to comment

Well the good news is I found the cable the bad news is my laptop doesn't have that old style serial port connection. I will take it to work tonight and see if IT hasn't filtered me from doing it there. So far dissabling waas seems to be working. To be cont..................

 

I've had the same problem regarding new computer without a serial port. If you can't find a computer that will accept your cable, you can purchase an adapter cable (USB to SERIAL cable) available at most computer shops. You will then be able to update the GPS with the new computer.

Link to comment

Just to follow up. I turned off the waas and the unit has been fine. I turned waas back on and it still seems to be working like it's old self. I will still do the update when I get a chance. Thanks for all your help.

 

Just a follow up to your follow up. I purchased a cable (usb to serial) at The Source for $29 bucks. The driver software that came with the cable wouldn't work in the Vista OS but they had a download fix available for Vista on their website. This worked fine. I updated my unit to the lastest version of the software and now everything is working fine. No more vertical lines and no more crashes. (I hope) Good luck.

Link to comment

Just to follow up. I turned off the waas and the unit has been fine. I turned waas back on and it still seems to be working like it's old self. I will still do the update when I get a chance. Thanks for all your help.

 

Just a follow up to your follow up. I purchased a cable (usb to serial) at The Source for $29 bucks. The driver software that came with the cable wouldn't work in the Vista OS but they had a download fix available for Vista on their website. This worked fine. I updated my unit to the lastest version of the software and now everything is working fine. No more vertical lines and no more crashes. (I hope) Good luck.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...