Jump to content

Error when uploading Field Notes.

Followers 0

Recommended Posts

I have had some problems uploading a field note file, and could not figure out why.


I have tried this several times, but all of them has failed.

Yesterday I figured out why :yikes:

A field note file can not contain several dates!?!


Since I don't have a colorado or a oregon, I have manually edited the file. For a long time I have thought it was my editing of the file who were wrong, but now I know better :D


Why does the field note files have this limitation?

Link to comment

How are you formatting the dates you include in the log? Does it work with other date formats? Say you input a date like Mar. 12th 2009. Does that work?


I got the original file from a friend with an Colorado, and have just been editing in the same way.


GCXXXX1,2009-02-16T18:55Z,Found it,""
GCXXXX2,2009-02-17T12:00Z,Found it,""

Is there other ways to enter date and time as well?

Link to comment
A field note file can not contain several dates!?!

This is incorrect. I regularly upload files with several different dates. It's probably an issue with the date format, as Nate suggests. Here's the first two lines of a recent file I uploaded:


GC1CH30,2009-01-24T04:39Z,Found it,"blah blah"

GC1K3A1,2009-01-25T04:39Z,Found it,"blah blah"


Note that the time portion is irrelevant. This is what was in the sample file that I found. I just change the date portion as needed.


Also note that the file must be saved in Unicode format, with Unix line endings, or it won't even upload. I found this out the hard way :unsure:


Edit: I see you posted while I was writing my post. Your date formats look fine. Maybe it's the file format?

Edited by Lil Devil
Link to comment

I had the problem that I was using GSAK to customize the cache ID to include the Container & Type descriptions instead of "GC". Instead of GC1K3A1, it would be ST1K3A1 (Small, Traditional and the important part of the number).


When I tried to upload the field notes, the lack of "GC" on each waypoint was causing the file to not upload. After I manually changed them all back from "ST" or whatever to "GC" it worked fine.

Link to comment

Make sure you are not checking the box on field notes upload that suppresses older dates as well.


I'd really like to hear about what happens when you try to upload the file with more than one date. Do you get an error? Does it not upload and that's it?


Have tried both version of check on the date without any change.


When I try to upload the file with more than one date, I am immediately transferred to the "There has been an error, - please write what you were trying to do"-page (Probably not the right text but I guess you know which :unsure: )

This happened in IE, Firefox and Opera.

After entering the first day of loggings manually (by copy/paste from the file), I figured I would have it a go once again.

Guess what, now it worked !?!

My conclution was simple, not more than one date in the file.

Link to comment

Did a quick test. Three different dates. See source in codebox.


Unicode encoded: 3 new notes

UTF-8 encoded: 3 new notes

ANSI encoded: 0 new notes


Then I changed the last waypoint to a nonexisting one.

Unicode encoded: 2 new notes


No error screens. IE7 Vista 64


GC1MPV1,2009-02-22T14:33Z,Found it,"1530"
GC1MXGW,2009-02-23T11:17Z,Found it,"1215"
GC1MX0P,2009-02-24T13:05Z,Found it,"1400"

Link to comment
This topic is now closed to further replies.
Followers 0
  • Create New...