Jump to content

Wherigo Builder and 64-bit Windows


mty55
Followers 6

Recommended Posts

Hi there

I have the same problem

I am using Windows 10 64 -bit and have been trying all the fixes

I downloaded the NET file

I have tried to use the exe file listed above and installed and reinstalled it. When I go to pen it I get an error message saying ! An unhanded exception has occured in your application. If you click continue the application will ignore....and so on

I figured out how to do a .bat extension file and tried using the command line too

I am not very tech savy but am a fast learner

I still cannot open any saved files

Please help

Laura

Link to comment

There should have been a zip file posted towards the beginning of this thread, post #7. You just needed to unzip that and put its contents where the Wherigo Builder is on your computer (usually C:\Program Files (x86)\Groundspeak\Wherigo\Builder).

 

By the way, if one of your questions goes unanswered for a few days again, send me an email. There are times I intentionally back off answering questions in the forum to encourage others to step up and help.

 

(Now that I think about it, why haven't I made a program that automatically patches the builder? Why hasn't anyone else? Hmm...)

Link to comment

I also have this issue and have managed to fix it using the instructions in this thread

 

I was unable to download the attached zip file with the updated .exe file as I was not permitted to view the attachment so I followed the steps below

 

1. Download and install Wherigo Builder

 

http://www.Wherigo.com/builder/download.aspx

 

2. Download and install .NET Framework 2.0 Software Development Kit (SDK) (x64)

 

http://www.microsoft.com/downloads/details.aspx?familyid=1AEF6FCE-6E06-4B66-AFE4-9AAD3C835D3D&displaylang=en

 

3. Run command prompt with administrator privileges and ran the following command

 

"C:\Program Files\Microsoft.NET\SDK\v2.0 64bit\Bin\CorFlags.exe" /32BIT+ "C:\Program Files (x86)\Groundspeak\Wherigo\Builder\WherigoBuilder.exe"

 

My previously saved .lua files now seem to open without error although at the moment they only contain a name an initial coordinates

Link to comment
My previously saved .lua files now seem to open without error although at the moment they only contain a name an initial coordinates

That's a good enough test to verify the fix works for you! Don't forget about the map fix if you have not yet applied that one.

 

Also, as that was your first post, welcome to the forum! Feel free to ask for any help you need.

Link to comment
On 2/22/2009 at 4:37 AM, a_snail said:

:laughing::anibad::P:D:D:)

:D It Works!!!!!!!! :D

:D:D:D:D:D:D

 

A big thanks Certik. Thats been annoying a lot of people.

 

To save everyone having to download 350Mb of stuff and install it, then get past Vista's security measures, I've included the patched exe

 

Install the builder if you have uninstalled it, or not bother installing it yet, then

overwrite your WherigoBuilder.exe which is probably located:

"C:\Program Files (x86)\Groundspeak\Wherigo\Builder\WherigoBuilder.exe"

 

Hopefully this uploaded version is not against copyright or some such thing, if so, perhaps Groundspeak could make the fixes to their install.

 

Finally I can now get rid of my Virtual Machine work around - hurray :laughing:

WherigoBuilder.zip

 

 

I just encountered this same problem! Thank you, your fix worked a treat! I can now open my cartridge, but I cannot use the emulator... Is there a work around for this?

Edited by EatSleepCacheRepeat_
Link to comment
18 hours ago, Tungstène said:

Please stop multiplying the threads. It's hard to follow.

Seconded.  When you have two threads with the same questions, some post to one and others post to another.  Poor moderators who then want to combine the two threads or some posts can't because the posts don't make much sense when grouped all together.

 

Most people who come here read all new posts in the subforum.  If you make a post, they'll see it.  There are very few people only watching only certain threads.

 

This is the part where the community helps you out by offering advice that'll also help you in the long run.

Link to comment
On 8/5/2020 at 6:34 PM, IDILIO49 said:

Hi,

 

I'm moving to Win10 x64 but I'm not able to install the SDK from the link, and the .exe attached is not available anymore...

Can someone be so kind to share the .exe again?

Thanks!

 

I am having this same problem on Windows 10 x64 -- I'm trying to use the Wherigo builder to run the emulator, but when trying to do so, I get an error from the emulator, as described by others.

 

As mentioned previously by IDILIO49, the referenced SDK does not install for me, and the patched .exe link no longer functions.  Any suggestions on how to proceed?

 

Thanks!

Link to comment
30 minutes ago, solid-rock-seekers said:

 

I am having this same problem on Windows 10 x64 -- I'm trying to use the Wherigo builder to run the emulator, but when trying to do so, I get an error from the emulator, as described by others.

 

As mentioned previously by IDILIO49, the referenced SDK does not install for me, and the patched .exe link no longer functions.  Any suggestions on how to proceed?

 

Thanks!

 

I have found that the link to the patched .exe file works only if one is logged in to these forums -- otherwise, one receives a cryptic download error.  So, what ended up working for me was first logging in to these forums, and then following the link to the patched .exe file.

 

There are also instructions on how to do this at the "64_bit_patch" page on the Earwigo Wiki:  http://earwigo.net/WWB/wiki/doku.php?id=64_bit_patch

 

Link to comment

Hi,

Complete noob question time here......

I wish to make a private build based upon the popular Whack-a-Lackey cartridge, where the characters popping up will be pirates - akin to the child's game of Pop Up Pirate.

 

I am using Win 10 x64 and have been reading previous threads about the issues and resolutions required to get the Wherigo Builder to work in that OS.

 

I have managed to download the zip file for the Builder after logging into the forums but all of the map files just return .ipb? files and not zip files.

 

I have saved the notes Ranger Fox kindly wrote about making changes to this cartridge.

 

I have downloaded the original cartridge but the builder does not see the .gwc file on the open command - is this because it is already compiled?

 

I have used WigCrumbler to gain some .lua files but the builder does not like the ones produced.

Screenshot of error message attached.

 

Any help in simple terms would be greatly appreciated to get the map issue sorted and how to open the cartridge file to make the changes.

 

 

Screenshot 2022-03-21 09.01.33.png

Link to comment

You're not opening a GWC using the builder.  You'll have to have the GWZ, change it to a ZIP, and decompress it.

 

Make sure the lua file is a standard text file.  If you can read it using a text editor, that's a good starting point to verify you have a good file.

Link to comment

Hi Ranger Fox, thanks for the response.

 

An obvious question is how do I get hold of the .gwz file?

 

Wig-Crumbler produced  an .lua file that I can open in visual studio and also Notepad but that is also the one producing the error message in builder as shown above.

Wig-Crumbler described the file as .... Description: This is the decompiled Lua-Code extracted from the cartridge.

 

As the author of the original cartridge would you be able to kindly provide a .gwz file to set me on my way?

Link to comment
6 hours ago, Hügh said:

 

Whack-a-Lackey is open-source, so you should be able to download the .gwz from Wherigo.com.

 

https://www.Wherigo.com/cartridge/details.aspx?CGUID=f6002f33-c68a-4966-82ca-3c392a85d892

 

(On the left column of the page, below "License", click on "Download Source.")

 

That's correct.  All but one of my cartridges, Tetris, is open source and you can download the source code from Wherigo.com in the manner Hügh said.

 

Do be aware that my arcade-type cartridges don't have much to show in any builder app.  Almost the entirety of the games' logic is within the author script section.  Whack-A-Lackey's code is a little messier than I'd like because it was the first of such a type of cartridge, therefore an experiment.  I did much better with Battleship and far, far better with Cacher Pursuit.  Part of that was because I knew what I was doing by then (ha, ha) and the other part was because I knew I'd release the source code to the community, so wanted it in such a condition where it was easy for community members to learn from what I did and make adjustments to how the game works (all variables and text the games use are provided at the top of author script, with explanations about what each does).

 

Anyway, when you download the GWZ, you can rename it to ZIP, unzip it, and then you can see the lua file.  If you open it in a text editor and search for the text "author functions", you'll find a good starting point.  About a hundred lines down, you'll see a lot of equals signs to call your attention to something.  That's where a lot of the things you can change start off.

 

Perhaps one day I should rewrite Whack-A-Lackey so it's far easier to modify.  (At the moment, my time is taken up in setting up a demo microservice project for work, so that'll take a while.)

Link to comment

@Ranger Fox Well after a few months of tinkering on and off with this idea... I have managed to get a working version of the Whack-a-Lackey cartridge with pirates instead of moles.

Although testing in the field is yet to take place, the emulators show signs of it working as expected, with one small glitch.

 

Once a game is completed and score of more than 700 is achieved, there is no message to reveal coordinates of the cache.

I am aware of the 20 mile radius limit for this to display.

 

Is this an issue due to use of an emulator?

I have limited knowledge of Urwigo and even less with Builder and next to no knowledge of hand written code.

 

My aim is to get a cache coordinate message to appear after scoring more than 700 on any of the 3 game levels.

At present the cache coordinates are yet to be finalised so the original zmediaCoordinates linked media file is still used, which I can change at a later date.

 

It seems the forum file types prevent me from uploading the cartridge file for those with greater knowledge to see.

Link to comment

There are a couple things I do to determine whether to show the final zone.  First, I test for the first zone point in the final zone, not the zone's original position.  That's a little odd and I think I don't do that in my other arcade cartridges.  You may have updated the zone's OriginalPoint, but perhaps not the Points array.  Second, I test for the player app's name.  Typically, emulators report "desktop" for their names, so testing for this prevented people from finding the final by playing this in an emulator (which was never a concern in my own area).  Search for the comment text "If you are close enough, we will show the coordinates.  If not, we will not bother." and you will see the check two lines below.  You might not have commented this out.  (In my other arcade cartridges, I relegate this to a function call that can be disabled or updated easily.  After creating Whack-A-Lackey, I learned a LOT and made my other cartridges far easier to modify and update, now that I knew what I was doing.  Whack-A-Lackey, by the way, was the second original cartridge I created, though I had been helping others with their cartridges prior to that.)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 6
×
×
  • Create New...