Jump to content
Sign in to follow this  
Followers 2
louchem

Venture HC: Chipset Type M?

Recommended Posts

Does the Venture HC use Chipset Type M? I know someone in an earlier thread mentioned they updated their Venture HC with this chipset. I just purchased one and I am having a problem downloading the latest upgrade using WebUpdater. I was able to use WebUpdater to upgrade the system software to version 2.8 a couple of days ago, but when I try to advance to the "additional downloads" section to hopefully find the chipset upgrade I get an error connecting to the Garmin website:

 

"There was a problem connecting to the Garmin website. Please try again later."

 

But, WebUpdater seems to be connecting okay to check the version tags on itself and the software on the Venture because it tells me there are no new updates for those things. Same results for the last few days so I figure it's not a server problem on their end. I called Garmin tonight to try and get an answer but after waiting on hold for 30 minutes for software support and 5 minutes of fruitless conversation I was disconnected. Of course it was right around closing time for their support so when I tried to call back I just got the "we're closed now, call back tomorrow" message. During the short conversation I asked the tech if the Venture HC used the Type M chipset and he said he wasn't sure and he thought it might be the Type G chipset. But I never got a solid answer before getting disconnected. I've tried three different computers and two different networks and all with the exact same result. Is there any way to find out what chipset I have and what version is running? If I already have the latest chipset on the system would I get this connection error or would it tell me "no additional downloads available"?

 

I've also tried contacting Garmin via e-mail about this issue, but their response has been at a snail's pace. So, I thought I would ask here where I figured I'd get much better support. :rolleyes: Thanks!

Share this post


Link to post

I don't know about the HC, but the HCx definately does, and I just ran the web updater with no problems.. All updates installed, and running on the HCx version Venture.

 

It may've just been a high traffic time when you tried last. Give it another shot, and see if it works.

Share this post


Link to post

Thanks. I tried last night before bed and again this morning with the same results. I just can't figure out why it is failing yet I can connect to the server for the software update. Either my unit already has the updated chipset or there is something blocking communcation for that step. I've tried turning off my firewall and my anti-virus and reinstalling WebUpdater...not sure what else to try.

Share this post


Link to post

Well I think I figured out why the chipset update is failing. After some limited e-mail discussion with Garmin support and more searching through this forum I found how to show the diagnostics screen when starting up the unit. I was surprised to see that my unit has the 2.8 GPS software version already loaded out of the box (unless it did a firmware upgrade at the same time it did the software upgrade and just didn't tell me). Also, it says it is using Bravo version 3. I'm not all that familiar with the different chipsets, but I have yet to find any references to this Bravo version. The Garmin tech said I should have Chipset Type M2 (Regional) so maybe that is related to it being Bravo version 3.

 

Anyway, interesting enough that I thought I should post it in case anyone was curious.

 

14nhais.jpg

Edited by louchem

Share this post


Link to post

Thanks. I tried last night before bed and again this morning with the same results. I just can't figure out why it is failing yet I can connect to the server for the software update. Either my unit already has the updated chipset or there is something blocking communcation for that step. I've tried turning off my firewall and my anti-virus and reinstalling WebUpdater...not sure what else to try.

I've encountered the same problem with my Venture HC. I've tried at least a dozen times in the last three months to update and the software updates, but the chipset won't. I contacted the Garmin technical support about it and they thought it was my firewall, but after letting them log on to my computer and shut off all the security programs, it still didn't update. They also checked the data transmission to and from my Venture to their website and said eveything is working fine. They now think the problem is that I already have the most recent update. I guess I'll have to wait for them to post an update to verify that. Phynd

Share this post


Link to post

Thanks. I tried last night before bed and again this morning with the same results. I just can't figure out why it is failing yet I can connect to the server for the software update. Either my unit already has the updated chipset or there is something blocking communcation for that step. I've tried turning off my firewall and my anti-virus and reinstalling WebUpdater...not sure what else to try.

I've encountered the same problem with my Venture HC. I've tried at least a dozen times in the last three months to update and the software updates, but the chipset won't. I contacted the Garmin technical support about it and they thought it was my firewall, but after letting them log on to my computer and shut off all the security programs, it still didn't update. They also checked the data transmission to and from my Venture to their website and said eveything is working fine. They now think the problem is that I already have the most recent update. I guess I'll have to wait for them to post an update to verify that. Phynd

You can check the software versions installed by going to the System setup page, then press the Menu button and selecting Software Versions.

Share this post


Link to post

I have not been able to use the updater to upload the new chipset either. There was a guy on the forum who had a separate source for these downloads, but I lost the reference. You might search this forum for it and see what you come up with. I am just too lazy to do it today!

Share this post


Link to post

Thanks. I tried last night before bed and again this morning with the same results. I just can't figure out why it is failing yet I can connect to the server for the software update. Either my unit already has the updated chipset or there is something blocking communcation for that step. I've tried turning off my firewall and my anti-virus and reinstalling WebUpdater...not sure what else to try.

I've encountered the same problem with my Venture HC. I've tried at least a dozen times in the last three months to update and the software updates, but the chipset won't. I contacted the Garmin technical support about it and they thought it was my firewall, but after letting them log on to my computer and shut off all the security programs, it still didn't update. They also checked the data transmission to and from my Venture to their website and said eveything is working fine. They now think the problem is that I already have the most recent update. I guess I'll have to wait for them to post an update to verify that. Phynd

You can check the software versions installed by going to the System setup page, then press the Menu button and selecting Software Versions.

 

I found that if I went to the System page and looked up Software version that it would only give me the system software version and my ID# but not the GPS chipset version. The only way I could figure out which GPS software version I was running was to boot the Venture up in diagnostics mode, which is where the screen that I showed in the above shot came from. To do this you need to start the GPS by holding down the joystick and pressing the on/off button on the right at the same time. Once the system flashes on you can then release the buttons and it should go right to the diagnostics page which gives you the information. This can be a little finicky though as the joystick has to be straight down with no side-to-side movement to work. It took me a couple of tries before I got it to work.

Share this post


Link to post

I found that if I went to the System page and looked up Software version that it would only give me the system software version and my ID# but not the GPS chipset version.

This is the s/w version page from my wife's Venture HC ... updated without any problems at all.

 

280tjdi.jpg

Share this post


Link to post

That's interesting. I do not get anything that indicates GPS SW Version on mine. I'll try and post a screenshot tonight.

 

AlunS, can you run the diagnostics on your Venture HC and post a shot of that? How old is the unit? I just got mine 10 days ago. I'm wondering if there is something different about the newer shipping units.

Share this post


Link to post

Okay here is what I get when I load up the Software version page from the System screen

 

24x1f81.jpg

 

As you can see I only show the software version but nothing for the chipset version.

Share this post


Link to post
As you can see I only show the software version but nothing for the chipset version.

 

FWIW I encountered exactly the same thing you encountered when updating. My unit arrived a few days ago with 2.7, updated to 2.8 without issue. No GPS Software version in Setup - Systems - Menu, failure to update additional software, Bravo 3, everything you saw.

 

Appreciate learning about how to get into the diagnostic screen and all the other goodies. Didn't realize that getting a screen grab is possible until I saw your screen and decided to search for it.

Share this post


Link to post

That's interesting. I do not get anything that indicates GPS SW Version on mine. I'll try and post a screenshot tonight.

 

AlunS, can you run the diagnostics on your Venture HC and post a shot of that? How old is the unit? I just got mine 10 days ago. I'm wondering if there is something different about the newer shipping units.

Here you go ...

 

jkatjk.jpg

 

Bravo version 2 as you can see. The unit is just short of 1 year old.

Share this post


Link to post

Just to add ... a guy in our hiking club yesterday had a brand new Venture HC which exhibited the same thing, i.e. only showing one version (2.8 as he'd updated it already) on the S/W version page. His was Bravo version 3 too.

Share this post


Link to post

Just to add ... a guy in our hiking club yesterday had a brand new Venture HC which exhibited the same thing, i.e. only showing one version (2.8 as he'd updated it already) on the S/W version page. His was Bravo version 3 too.

 

Thanks, Alun. I think it's obvious that there is something different in the newer Venture HC's but not sure exactly what the difference is just yet or how significant it is.

 

Would be interesting to get an older one and a newer one side by side to check their performance and see if any differences in satellite aquisition or accuracy are observed. I've noticed that mine seems to have trouble picking up the WAAS signal, but even without the correction I am still getting accuracy readings of 10-13 ft in good conditions with excellent satellite reception. I'm not sure how that compares to an older model.

Share this post


Link to post

I just downloaded software version 2.90 that just became available a few days ago. Mine now says:

 

Software version 2.90

GPS SW Version 2.30

 

When I started it on the diagnostics page it says Bravo 2. Is this correct? Is this the latest version? Just purchased this Venture HC yesterday.

Share this post


Link to post

Thanks for the heads up on v2.9 of the software. I was able to download and install that without a problem using WebUpdater just now. Again, I still have the problem of the "additional downloads" failing, so still no chance to grab any GPS SW updates. My software version screen now shows v2.90 but still no GPS SW version as before. And I now have software version 2.9 on the diagnostics screen along with Bravo version 3.

 

Just a quick update on my correspondance with Garmin. I had a nice e-mail discussion with a service tech who tried to help me but could not solve my problem connecting for GPS SW updates. He passed me off to a software engineer who was not exactly very friendly, basically telling me there is nothing wrong with my device and just "go out and use it". My response to this was that I never said there was anything wrong with my device and I just want the connection to the server for GPS SW updates to work. That was 4 days ago and I haven't heard back. Needless to say I'd not too happy. It almost seems like Garmin changed something but doesn't want their consumers to find out about it. I like the unit and it seems to work well in my hands, but I feel we have a right to know what exactly is in the device we paid hard-earned money for as well as have direct access to any updates that are made available.

Share this post


Link to post

I didn't have any "additional downloads" fail but mine says Bravo 2 while yours says Bravo 3 and my GPS SW version is still 2.3.

 

It just appears from this thread alone that people are getting at least three different results as a result of downloading the SW updates..or so it appears.

 

I don't even know what "bravo" means or what the difference is between "software version" and "GPS SW version" The fact that these numbers aren't the same on everyone's GPSr doesn't necessarily mean that people are having problems downloading the "chip set upgrade" as someone put it.

 

For all we know, the different Bravo numbers might mean when the unit was built or where it was built or something like that?

 

From reading this thread, it doesn't appear that anyone is really 100% sure if there even IS a problem with out SW downloads and updates.

Edited by GrnXnham

Share this post


Link to post

The problem as I see it is I have no idea what my GPS SW version is. It seems in these "Bravo3" units (whatever it means...) that we cannot see that information like you guys with the Bravo2 versions. When you go to your software version screen you get software version, unit ID, and GPS SW version information. So you can check to see what chipset version you are running. On my device when I go to that screen I get info on software version and unit ID, but nothing about GPS SW version. Now to me knowing that I have the most up to date chipset is important because AFAIK that is really the nuts and bolts of the system relating to how the unit processes the data it receives from the satellites. The system software is more or less the GUI interface for how the unit displays the information to the user.

 

All I know is that since I purchased the unit I have not been able to get the "additional downloads" portion of WebUpdater to connect. I have been able to upgrade my system software twice now, but I cannot know whether there is a GPS SW upgrade out there for my device.

Share this post


Link to post
Just a quick update on my correspondance with Garmin. I had a nice e-mail discussion with a service tech who tried to help me but could not solve my problem connecting for GPS SW updates. He passed me off to a software engineer who was not exactly very friendly, basically telling me there is nothing wrong with my device and just "go out and use it".

 

That's an extremely bad response from Garmin, and a prime example of why you should never put developers on first line support :)

 

If you intend to follow up with Garmin, I have some additional information which may help.

 

I decided to grab the traffic between the updater and Garmin's website, and this is what I see (binary information removed). Perhaps they can use that as a starting point in figuring out what is wrong with their own web services. I'd be glad to provide the whole capture, but if they don't know how to capture it themselves, then they really should pay me for it :)

 

POST /support/WUSoftwareUpdate.jsp HTTP/1.1
Accept: text/*
User-Agent: WebUpdater 2.4.1
Content-Type: application/x-www-form-urlencoded
Host: www.garmin.com
Content-Length: 1340
Cache-Control: no-cache
Cookie: ......

req=%3c%3fxml%20....

 

And the response:

 

HTTP/1.1 200 OK
Server: Apache
Content-Length: 22
Content-Type: text/html;charset=ISO-8859-1
Date: Tue, 11 Nov 2008 16:03:24 GMT
Connection: keep-alive
Set-Cookie: LB=jahia2; path=/

500: Exception caught

 

The XML request in the request body, after replacing all the escape code:

 

req=<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<Requests xmlns="http://www.garmin.com/xmlschemas/UnitSoftwareUpdate/v3">
 <Request>
<PartNumber>006-B0695-01</PartNumber>
<TransferType>USB</TransferType>
<Region>
  <RegionId>14</RegionId>
  <Version>
	<VersionMajor>2</VersionMajor>
	<VersionMinor>90</VersionMinor>
	<BuildType>Release</BuildType>
  </Version>
</Region>
 </Request>

 <Request>
<PartNumber>006-D0XXX-00</PartNumber>
<TransferType>USB</TransferType>
<Region>
  <RegionId>16</RegionId>
  <Version>
	<VersionMajor>2</VersionMajor>
	<VersionMinor>0</VersionMinor>
	<BuildType>Release</BuildType>
  </Version>
</Region>
 </Request>
</Requests>

Edited by Chrysalides

Share this post


Link to post

Just updated my Venture to V2.90 with out any problem's. mine now says V2.90

GPS SW Version 2.80

Edited by ricstone

Share this post


Link to post

Just to add one more report:

 

Summit HC (purchased about 9 months ago) - Unit ID: 338039xxxx (don't know if different serial numbers correspond to different hardware, and therefore different behavior with WebUpdater?)

 

I use WebUpdater to update software and firmware - never had a problem yet. I generally run it twice, to make 100% sure I get everything that is available.

 

Currently, the Diagnostic Screen shows Software Version 2.90, Bravo Version 2

 

The System Info page displays Software Version 2.90, GPS SW Version 2.80

Share this post


Link to post

Thanks for this info, Chrysalides. I thought about this very thing this morning, but had no idea how to intercept the traffic to get the info. I will pass it along to Garmin tech support and see if they will actually answer me ever again. :unsure:

 

Looking at the info in the XML request it looks as though it searches for two things to update. One is currently v2.9 on your unit (system software?) and the other is v2.0 (GPS SW?). Interesting...

 

I decided to grab the traffic between the updater and Garmin's website, and this is what I see (binary information removed). Perhaps they can use that as a starting point in figuring out what is wrong with their own web services. I'd be glad to provide the whole capture, but if they don't know how to capture it themselves, then they really should pay me for it :D

 

POST /support/WUSoftwareUpdate.jsp HTTP/1.1
Accept: text/*
User-Agent: WebUpdater 2.4.1
Content-Type: application/x-www-form-urlencoded
Host: www.garmin.com
Content-Length: 1340
Cache-Control: no-cache
Cookie: ......

req=%3c%3fxml%20....

 

And the response:

 

HTTP/1.1 200 OK
Server: Apache
Content-Length: 22
Content-Type: text/html;charset=ISO-8859-1
Date: Tue, 11 Nov 2008 16:03:24 GMT
Connection: keep-alive
Set-Cookie: LB=jahia2; path=/

500: Exception caught

 

The XML request in the request body, after replacing all the escape code:

 

req=<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<Requests xmlns="http://www.garmin.com/xmlschemas/UnitSoftwareUpdate/v3">
 <Request>
<PartNumber>006-B0695-01</PartNumber>
<TransferType>USB</TransferType>
<Region>
  <RegionId>14</RegionId>
  <Version>
	<VersionMajor>2</VersionMajor>
	<VersionMinor>90</VersionMinor>
	<BuildType>Release</BuildType>
  </Version>
</Region>
 </Request>

 <Request>
<PartNumber>006-D0XXX-00</PartNumber>
<TransferType>USB</TransferType>
<Region>
  <RegionId>16</RegionId>
  <Version>
	<VersionMajor>2</VersionMajor>
	<VersionMinor>0</VersionMinor>
	<BuildType>Release</BuildType>
  </Version>
</Region>
 </Request>
</Requests>

Share this post


Link to post

Thanks for this info, Chrysalides. I thought about this very thing this morning, but had no idea how to intercept the traffic to get the info.

If you ever need to do something like that, the tool to use is Wireshark (a.k.a. Ethereal). Good luck with Garmin support - it is disappointing that this issue has been around for so long.

Share this post


Link to post

Well it's been over 6 months since the start of this thread and I just wanted to give everyone an update on my "Bravo3" Venture HC. I never heard anything more back from Garmin about the chipset update. At that point I kind of just gave up on it. I reverted my system back to the original software version 2.7 that it shipped with shortly after and have been using the system regularly ever since with no problems whatsoever. Accuracy has been really good for me and track logs have been right on time after time. I still have no idea what "Bravo3" stands for or really means but I've been extemely happy with my GPS.

Share this post


Link to post
Well it's been over 6 months since the start of this thread and I just wanted to give everyone an update on my "Bravo3" Venture HC. I never heard anything more back from Garmin about the chipset update. At that point I kind of just gave up on it. I reverted my system back to the original software version 2.7 that it shipped with shortly after and have been using the system regularly ever since with no problems whatsoever. Accuracy has been really good for me and track logs have been right on time after time. I still have no idea what "Bravo3" stands for or really means but I've been extemely happy with my GPS.

Thanks for the update (and no thanks to you, Garmin). I'm still using mine as well. I think firmware 2.9, haven't bothered to update to the latest and greatest. Once in a while my Venture HC kind of flaky but eventually it will bring me to the right location.

Share this post


Link to post

Just got a venture HC and tried to update the chipset via the webinstaller and it failed to work. Now it won't find any satellites just called Garmin tried to fix it and it's headed back to Garmin for replacement. I didn't even get to go geocaching with it. :laughing:

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 2

×
×
  • Create New...