Jump to content

Mapsource Update Problem


G & E
Followers 2

Recommended Posts

I just downloaded a newer version of Mapsource and now I can't get the program to run. It is version 6.141 and I'm running Windows XT. I've tried re-downloading it, reinstalling it, and even re-installed an older version from the disk that came with my GPS. I get this message whenever I try to start Mapsource, "There is a problem with program NTDBData installation. Please reinstalled product NTDBData and start Mapsource again. I've searched for that program using a key word search through Windows and nothing comes up. I don't recognize the program either.

 

Any thoughts out there?

Link to comment

Problem solved. I forgot that I had loaded some non-Garmin topo maps that I rarely if ever used. I then deleted them from my hard drive but still no luck. I used the control panel and uninstall removed it that way. Finally the Mapsource program started.

 

I've had all sorts of problems trying to upgrade Mapsource in the past. You would think that Garmin would have fixed some of these bugs. If Windows can upgrade itself without my help, and other programs can do it without incident, Garmin should be able to do the same. Now how many hours did I waste today?

Link to comment

Problem solved. I forgot that I had loaded some non-Garmin topo maps that I rarely if ever used. I then deleted them from my hard drive but still no luck. I used the control panel and uninstall removed it that way. Finally the Mapsource program started.

 

I've had all sorts of problems trying to upgrade Mapsource in the past. You would think that Garmin would have fixed some of these bugs. If Windows can upgrade itself without my help, and other programs can do it without incident, Garmin should be able to do the same. Now how many hours did I waste today?

Most of the non-Garmin maps have been updated to work with the new version of Mapsource. All mine do.

 

Just you wait; you haven't even found 90% of the bugs in this "upgrade". Its slow as molasses among other things. But the reason it worked when you removed it via control panel is because the registry entries are what crashes the new version.

Link to comment

Just a quick defense of Garmin,

 

When did the fact that a product doesn't work with aftermarket, unsupported addons become the problem of the manufacturer? Why should Garmin have to make sure that an upgrade works if you have added some one elses Topo maps?

Those same maps worked with all previous versions of MapSource. So, clearly, Garmin did something that broke their use, with no warning in the change log. I don't think it's unreasonable to be annoyed at Garmin for that.

 

More importantly, as was mentioned by Oz, 6.14.1 has other significant bugs. It doesn't work with Mobile PC, for example, so anyone with Mobile PC on their laptop should avoid it. They just added support for Mobile PC in the previous version of MapSource (6.13.7) so it seems like someone just forgot to link the Mobile PC code in when they compiled the latest. And, as Oz said, they did something that has really slowed it down.

 

It's really a sore thumb for Garmin ... not something that's going to do their reputation for quality any good. I spent half an hour getting it running, another half an hour trying to use it, and another half an hour upgrading back to 6.13.7.

 

Hint for anyone who goes back, if 6.13.7 doesn't run the first time you reinstall it, just run the installer again and it'll work fine on the second try.

 

Here's a link to MapSource 6.13.7 for anyone who needs it. (To the Mods, it's okay. It's a link to Garmin's publicly accessable MapSource download site and only someone with an existing installed copy of MapSource can use it.)

 

...ken...

Link to comment

Just a quick defense of Garmin,

 

When did the fact that a product doesn't work with aftermarket, unsupported addons become the problem of the manufacturer? Why should Garmin have to make sure that an upgrade works if you have added some one elses Topo maps?

I am not upset it broke the custom maps; it actually didn't break any of mine.

 

I am more upset with the fact that it is incredibly SLOW! And lots of the POIs report incorrect information; the proportions are odd. There is an entire thread dedicated to these errors and they don't revolve around custom map errors.

 

I love Garmin products; but as a programmer this should have been released as Beta.

Link to comment

I love Garmin products; but as a programmer this should have been released as Beta.

As a long-time Development and Tech Support manager I would never have approved this for release to Beta. It would never have gotten into the wild. Garmin must have an extremely shoddy quality assurance process. Mapsource is one of their oldest products. If they can't do any better than this on such a mature program, what hope is there for new stuff? :anicute:

 

...ken...

Link to comment

"Garmin must have an extremely shoddy quality assurance process."

 

I agree, and it is sad to see. I've been a Garmin user since 1995, and have been disappointed in their support as of recent. Their stock has dropped nearly 75% year-to-date, compared to the Dow and S&P500 being down about 35% in the same period. I don't know if the drop is due to the poor quality, or the poor quality is due to the drop, but they are not the same Garmin in my opinion. They're still a good company, but not nearly as good as they were.

Link to comment

I just downloaded a newer version of Mapsource and now I can't get the program to run. It is version 6.141 and I'm running Windows XT. I've tried re-downloading it, reinstalling it, and even re-installed an older version from the disk that came with my GPS. I get this message whenever I try to start Mapsource, "There is a problem with program NTDBData installation. Please reinstalled product NTDBData and start Mapsource again. I've searched for that program using a key word search through Windows and nothing comes up. I don't recognize the program either.

 

Any thoughts out there?

 

OK,, here the fix--- no reinstalling at all!!

 

go into registry (run- regedit) and find "ntdbdata" which will apear under "families"

 

both in "ntdbdata" and in "1" where you a "\" whats happening it lost where to find it.... if you look at any other installed map, they all have an exact location.. so.....

 

Verify that this is the directory for you file location " C:\Program Files\TopoMaps "

Then paste it before the \

close regedit.... start mapsouce---- not even a restart needed.....

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 2
×
×
  • Create New...