Jump to content

Wherigo on HTC Touch CDMA with Internal GPS - HOWTO


northernpenguin
Followers 1

Recommended Posts

I've had a few people ask about running the Wherigo Player on HTC Phones. When you attempt to start the application, it will lock up at the Autodetecting GPS screen and typically require a soft-reset to get out of the program.

 

I have an HTC Touch CDMA running Windows Mobile 6.1 with the Internal GPS.

The lockup occurs due to some interaction between the GPSID sharing built into Windows Mobile and the Wherigo GPS Autodetection. The solution is to simply disable the GPS detection in the Wherigo player.

 

Here's how to get Wherigo running:

 

Step One:

Go to Start, Settings, System, External GPS

Make a note of the GPS Program Port for later

Go to Access tab, and disable (uncheck) "Manage GPS Automatically"

 

Step Two:

Start Wherigo Player (Autodetect GPS will fail)

Go to Menu, Settings

Clear "Auto Detect GPS"

Put the GPS Program Port you noted earlier under "Comm Port" (Usually COM4:)

Pick 4800 under Speed.

DO NOT "Test GPS Settings"

Hit OK to save your settings and ignore the error about GPS not working

Exit Wherigo Player

 

Step Three

Go back to Start, Settings, System, External GPS, Access and re-enable

the "Manage GPS Automatically"

 

Step Four

Open Wherigo while outside where you will get GPS Coverage and play normally

* On some HTC Phones you may need to open Google Maps to 'prime' the

GPS first. On Telus I had to go and fudge around with my ROM's GPS

settings to make it work properly.

Link to comment

Thanks for posting this northernpenguin! I had the Wherigo Player set up (and working) on my Telus HTC Touch for some time now. However, when I tried to help my friend with the Bell version of the Touch, we got stuck on the hanging screen. After many futile attempts of installing various versions of .NET, your suggestion is what got it work.

 

I had completely forgotten about that step when I set mine up. I have never had luck on either of my HTC phones (the Touch, and previously the Apache) with autoGPS detection working successfully.

Link to comment

I have an HTC Touch Diamond. I first tried these instructions without success. Wherigo kept telling me that COM4 couldn't be opened, and then wouldn't save the change, so when I re-enabled the autodetect in the phones GPS config, Wherigo would fail upon launch.

 

I then tried COM3 in the phone, and tried to configure Wherigo to use it. Again, it failed. For some reason, when I went back to the phone config and switched it to COM4 again, Wherigo accepted it this time.

 

Scott

Link to comment

Thank You!!

 

I just got an HTC Touch Pro and fought with it for hours last night before giving up out of exhaustion. Started up again this morning looking for answers in the forums and there it was.

 

Now if only there were a real fix for the resolution problem...

 

:D

Link to comment

Step Two:

Start Wherigo Player (Autodetect GPS will fail)

Go to Menu, Settings

Clear "Auto Detect GPS"

Put the GPS Program Port you noted earlier under "Comm Port" (Usually COM4:)

Pick 4800 under Speed.

DO NOT "Test GPS Settings"

Hit OK to save your settings and ignore the error about GPS not working

Exit Wherigo Player

 

Step Three

Go back to Start, Settings, System, External GPS, Access and re-enable

the "Manage GPS Automatically"

 

Step Four

Open Wherigo while outside where you will get GPS Coverage and play normally

 

How do I ignore the error about the GPS not working?

I can't ignore the message. I have to click OK to get on.

When I exit Wherigo player the settings are not saved.

Edited by cagiva
Link to comment

Thank you!

This also helps on HTC Touch HD.

I have a HTC Touch HD too.

But how do you ignore the error message in step 3 and still save the settings?

I have to click OK and then the settings where not saved.

 

Just done it my my HD, with a couple of extra steps :P Once you have manually set GPS in Wherigo, go back to home open gps settings, select automatically manage (again) then fire up google maps and let it aquire the GPS. Then go back to Wherigo press the test gps button, and away you go! :)

Link to comment

Thanks for the instructions!!!

 

I hadn't been able to use Wherigo on my HTC Touch Pro 2, but at Geowoodstock was told of this handy guide.

 

It was entertaining sitting in Carnation, WA trying to get mine working while all the Colorados were breezing by us!

 

Now to fix the bloody VGA issue... :-/

Link to comment
Step One:

Go to Start, Settings, System, External GPS

Make a note of the GPS Program Port for later

Go to Access tab, and disable (uncheck) "Manage GPS Automatically"

 

I have a new HTC Touch Pro 2 and could not find a "system" section under "settings", or anywhere else where I could perform GPS settings. Anyone else get beyond this problem and have Wherigo work on this device?

 

Thanks!

~erik~

Link to comment
Step One:

Go to Start, Settings, System, External GPS

Make a note of the GPS Program Port for later

Go to Access tab, and disable (uncheck) "Manage GPS Automatically"

 

I have a new HTC Touch Pro 2 and could not find a "system" section under "settings", or anywhere else where I could perform GPS settings. Anyone else get beyond this problem and have Wherigo work on this device?

 

Thanks!

~erik~

 

Somewhere down there must be a menu like "All settings", click -> then you will find System and External GPS.

 

cu

Link to comment

I've had a few people ask about running the Wherigo Player on HTC Phones. When you attempt to start the application, it will lock up at the Autodetecting GPS screen and typically require a soft-reset to get out of the program.

 

I have an HTC Touch CDMA running Windows Mobile 6.1 with the Internal GPS.

The lockup occurs due to some interaction between the GPSID sharing built into Windows Mobile and the Wherigo GPS Autodetection. The solution is to simply disable the GPS detection in the Wherigo player.

 

Here's how to get Wherigo running:

 

Step One:

Go to Start, Settings, System, External GPS

Make a note of the GPS Program Port for later

Go to Access tab, and disable (uncheck) "Manage GPS Automatically"

 

Step Two:

Start Wherigo Player (Autodetect GPS will fail)

Go to Menu, Settings

Clear "Auto Detect GPS"

Put the GPS Program Port you noted earlier under "Comm Port" (Usually COM4:)

Pick 4800 under Speed.

DO NOT "Test GPS Settings"

Hit OK to save your settings and ignore the error about GPS not working

Exit Wherigo Player

 

Step Three

Go back to Start, Settings, System, External GPS, Access and re-enable

the "Manage GPS Automatically"

 

Step Four

Open Wherigo while outside where you will get GPS Coverage and play normally

* On some HTC Phones you may need to open Google Maps to 'prime' the

GPS first. On Telus I had to go and fudge around with my ROM's GPS

settings to make it work properly.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...