Jump to content

Loss of Cords From Magellan Explorist 200

Recommended Posts

My grandson and I picked up a few caches just north of Greenville, Texas yesterday along the Chaparral



When heading for home in Sherman, Texas I had the cords set for the center of my yard.....homebase. Wifey and I were talking about driving miles as compared to "as the crow flies" miles.


When we got to within 4.5 miles of home, the gps "froze" to that one position and stayed there, the rest of the way home!


Upon arriving at home I tried to check the battery by pressing Nav button...nothing. Same with all the other buttons....nothing changed, it just stayed frozen on the 4.5 miles. I tried to turn it off and it would not turn off.


Next I took out the batteries and it shut down. I inserted the batteries and it came on, searched and found satellites, etc. I then checked the menu and looked at "my points of interest" where cords for about 30 caches were stored. The unit showed ......"no objects found".


All my coordinates for those caches had disappeared!


What could have caused this?





Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...