Jump to content

2009 upgrade problem


sleecjr
Followers 0

Recommended Posts

I get this very same problem with the free update that I downloaded. I'm currently running Windows Vista, and the Garmin tech that I spoke with on the phone (2 weeks ago) said that I should try to run this on an XP machine to see if that makes a difference (he really didn't know what the problem was). This is also after he told me to try a couple other things that didn't work. I don't have access to a PC running XP at this time, until my friend gets back from vacation this week, so I have been unable to test this suggestion. I should hopefully be able to try sometime this week, and will post back with results if no one has with a fix for this by then.

 

Edit: The exact message that I get when trying to install the 2009 update is: "This Garmin GPS is not eligible for this update because a previous map version is not installed." I checked and double checked to make sure that everything was accurate on my GPS. The previous version installed was CNNA NT 2008. I even put in my unlock code into mapsource again and tried reinstalling the maps to the GPSr, and nada.

Edited by PhilAun
Link to comment

I just had a problem installing the City Navigator NT 2009 Upgrade as well. Right after it detected the GPS I got an unknown error and the only option was to cancel setup. I ran into this on both Windows Vista and Windows XP Pro. I finally got it to work by doing the following:

 

1. Uninstall ALL Garmin products. Delete the c:\garmin folder when you are done.

 

2. Reinstalled City Navigator NT Version 8 (you may have a different qualifiying version)

 

3. Installed the latest Mapsource update (6.13.7)

 

4. Unlocked the maps via the Unlock Wizard

 

5. Connected the GPS

 

6. Install the upgrade

 

7. Installed the rest of the Garmin products (Topo, Web Updater, etc...)

 

When you are done, it should already have the upgrade unlocked (I think it pulls this off the GPS)

 

I know this is a royal pain in the rear, but hopefully it will work!

Edited by roadrage64
Link to comment

I've gotten around the error in the past by creating a C:\Garmin folder and putting a file called mapsource.exe inside it. I think that's all the update looks for. I then run the MSI file off the update DVD, not the setup.exe file that runs when you put the disk in. The MSI is a couple folders deep, but it's easy to locate.

 

It's worked for me in the past, but I don't know if I tried it with the 2009 version. It's better to do the install of a full version if you have it then upgrade, but sometimes that doesn't work out...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...