Jump to content

Custom Map isn't visible in GPS


Followers 1

Recommended Posts

Hi all,

 

I'm new to the forum, but by no means new to GPS and GIS. I graduated last year from NC State and took many of the courses through their geospatial program. I have access to the ESRI Arc suite and have stockpiled all kinds of shapefile data. If anyone ever needs any NC shapefiles let me know! :P I haven't really gotten into geocaching per se; I use mine more for marking locations of reptile and amphibian (mostly snake) records as a personal herp log and to report findings to the NC Museum of Natural Sciences. I've recently been toying with creating the custom maps through GPSMapEdit, cGPSmapper, and M3 (those are the programs I use). I'm still pretty new to this topic, though it fascinates me, and I've hit a roadblock on one of my projects that I am seeking help about.

 

I've successfully created a map of a couple of longleaf pine savannas (polygon layer created with ArcMap), loaded it to the GPS and it worked great. My current project is trying to load a layer of Natural Heritage sites (statewide polygon layer) to the GPS. I've gotten all the way through the map building process and sent it to the GPS via MapSource and it fails to show up in the GPS. I suspect it’s a "levels" problem, but the problem is I don't know how to rectify that. Can anyone provide some guidance? Here is some general info:

 

GPS: Garmin GPSMap 60CSx

SHP: NC Natural Heritage Significant Areas (roughly 30k polygons across the state)

SOME SCREENSHOTS:

 

mapscreencap1.jpg

 

mapscreencap2.jpg

 

Like I said; the map compiles fine and then doesn't show up in the GPS itself. When I import the shapefile, it only has level 0 and I add the other levels and import the same shapefile to populate them as well (the map disappears as I add new levels. Am I even doing that part right? I've tried compiling the map with just the level 0 as it comes with, but I get an error saying that the detail is too high I believe. Also, I've noticed that sometimes in the .img version of the map, the "mini preview" screen in the top left corner of GPSMapEdit will be all black except for a tiny box in the middle, which is I'm assuming my map. Which setting am I getting wrong? Levels, limits? Is the shapefile too big? Is there a "too big?"

 

Any general info will be great as well. Thanks for any help!

Edited by NCGISguru
Link to comment

Have you read any tutorials???

 

Anyway... Import the shape file to level 0. Select them all and right click, then "extend all elements" to whatever levels you want and then they will show on those levels.

 

What are your level settings set to?

 

How are you compiling and how is the map getting onto the GPS?

Link to comment

Yeah I've read many tutorials.

 

Levels: see above; original post edited.

 

I'm using cGPSmapper to compile and convert to an .img and M3 to create the registry and send it to mapsource. I'm using mapsource to load it to the GPS.

Edited by NCGISguru
Link to comment

Where in NC do you live? I'm in Raleigh and have done a lot with custom maps. Do you know about customizing maps with .TYP files? There aren't many choices when picking a polygon type to use for a map, but with .TYP files you can create polygons of any color.

 

You can run into problems with large amounts of data. Sometimes you'll get a warning or error message that the detail is too high for the level. Sometimes the .img file is created but if it is over 8Meg it will cause a problem with mapsource. In those cases you'll need to split up the map.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...