Jump to content
Sign in to follow this  
Followers 52
jjreds

Advanced Nuvi Macro

Recommended Posts

Found a problem w/ the child points.

Should be working in v7.2.11

j

 

j,

 

7.2.11 causes issues for me. All my child points which are set at 0 are showing up as the same distance of my caches which is 1000 feet.

 

Steve

Edited by GeoScouter

Share this post


Link to post

Found a problem w/ the child points.

Should be working in v7.2.11

j

 

j,

 

7.2.11 causes issues for me. All my child points which are set at 0 are showing up as the same distance of my caches which is 1000 feet.

 

Steve

Thanks for pointing that out. There was an error in the ft-m conversion.

Fixed in v7.2.12

j

Share this post


Link to post

Found a problem w/ the child points.

Should be working in v7.2.11

j

 

j,

 

7.2.11 causes issues for me. All my child points which are set at 0 are showing up as the same distance of my caches which is 1000 feet.

 

Steve

Thanks for pointing that out. There was an error in the ft-m conversion.

Fixed in v7.2.12

j

 

Child points distance is working now. Thanks

 

Steve

Share this post


Link to post

I still have a quirk using the "slice and dice" feature. Here are 2 screen captures to show what I'm talking about. The screen capture is for the same cache for both settings.

 

In the first screen capture I'm using my normal settings with "slice and dice" turned off everything works. I get the audio alerts, Tourguide banner and icon. I get the alerts for all caches.

 

Normal

 

normal.jpg

 

 

If I turn on the "slice and dice" feature I do not get the ICON for some caches. I only get the banner and audio alert. I haven't figured out a pattern to the missing ICON.

 

The distance is the same for both examples.

 

Slice and Dice

 

sliceanddice.jpg

 

I can duplicate the quirk. It happens on the same caches every time.

 

Steve

Edited by GeoScouter

Share this post


Link to post

I upgraded to the latest version yesterday and today noticed that I now have a Parking icon appearing. Never noticed that before. And it sure came in handy today as the whole area seemed to have No Parking signs everywhere. The PK icon really helped. Thanks....

Share this post


Link to post

normal.jpg

sliceanddice.jpg

 

The first thing I notice here is the missing "Tourguide" on the second picture. Looks like there could be a filename problem when slice and dice is enable. Seeing as I personally don't use that option, I haven't had a chance to look at the code though....

Share this post


Link to post

I still have a quirk using the "slice and dice" feature. Here are 2 screen captures to show what I'm talking about. The screen capture is for the same cache for both settings.

 

In the first screen capture I'm using my normal settings with "slice and dice" turned off everything works. I get the audio alerts, Tourguide banner and icon. I get the alerts for all caches.

 

Normal

 

normal.jpg

 

 

If I turn on the "slice and dice" feature I do not get the ICON for some caches. I only get the banner and audio alert. I haven't figured out a pattern to the missing ICON.

 

The distance is the same for both examples.

 

Slice and Dice

 

sliceanddice.jpg

 

I can duplicate the quirk. It happens on the same caches every time.

 

Steve

Steve thanks for finding this. After attempting a quick fix, it turns out there are a number of things going wrong with the slice & dice option. I need a little time to fix it right.

j

Share this post


Link to post

Steve thanks for finding this. After attempting a quick fix, it turns out there are a number of things going wrong with the slice & dice option. I need a little time to fix it right.

j

 

j,

 

Take your time. I just wanted to be sure you were aware of it.

 

Steve

Share this post


Link to post

And here is another feature request for the slow burner:

 

Would it be possible to have a function that, similar to the spoiler pics sub-macro, inspects all caches for trackables in them, then downloads the trackable's own page and creates a separate waypoint page for the trackable, with its current location and a link to the cache it's in? Also a link from the cache to the trackable which could be clicked on the nuvi would be nice (or add the trackable as a sub-waypoint just like spoilers).

 

That way one could inspect the missions of trackables in the field, if they don't have their mission set on them.

 

Of course trackables not in caches would need to be wither continued to be tracked to the locations/the cachers holding them...Maybe one's own trackables could be always tracked.stored on the nuvi that way, and so could 'marked' trackables (like a watchlist or so)?

 

I know this will be lots of work again, but it would be soo nice to also have the TB info offline..

Share this post


Link to post

v7.3 Fixed alerts when using "Slice and Dice"

j

Edited by jjreds

Share this post


Link to post

v7.3 Fixed alerts when using "Slice and Dice"

j

 

j,

 

I did a test with the cache closest to my house that I had problems with before. The alert works but all cache icons now have the same icon which is a small gray circle. I turned off "Slice and Dice" and reloaded the Nuvi and I have the proper icons with the regular load.

 

Steve

Share this post


Link to post

I recently bought a nuvi 260 and have been using the macro with no problems, I love it. Today I ran into my first problem. I was going to take a trip outside of my usual caching area so I tried running the macro to load my usual database and some caches from another GSAK database. Ran the first one, once done chose Process Another Database. Selected the other database, ran that one then chose Run POI Loader For Nuvi. Everthing went fine but the second database was not loaded, or at least I can't find it. Am I doing something wrong.

Share this post


Link to post

Check where the POI Loader program is pointing (run the POI Loader manually and look at the fifth screen). Most likely, it's pointing to the folder named after your database. It should be pointing at the folder one level up (Mine is C:\Program Files\GSAK\POI_Loader. That way it will load each folder (each one is named after your database names) as a separate category in the nuvi.

Share this post


Link to post

I thought I had it set properly. It was shown right in the macro dialog but I ran POI loader separately and saw that it was as you said in the dialog box there. Reran and all is goo now, thank you for the help.

Share this post


Link to post

Your macro is sweet! I set it up for a non-technical buddy and update her Nuvi once every few weeks. Today I went to load my own StreetPilot 2720 and accidentally directed the POI loader to the folder set up for my friend's Nuvi. I wasn't surprised when the caches loaded, but was shocked to see all the cache details were there. I had no idea the StreetPilot could do this. WaHoo!! This is the best unadvertised secret I've come across in a long time. I need to read and get smarter on this and looking forward to it.

Share this post


Link to post

I have sort of a weird problem. So far the advanced macro has worked wonderfully. I hid my first cache a few days back, now no matter if I select/deselect the "include own" checkmark or not, the cache(s) I hidden are transferred to the Nuvi 205. They show up the same as other caches, even with the N for (Not found) flag.

 

Is there a way that as the owner of those caches they DO NOT get transferred as POI's ?

Share this post


Link to post

In the macro's dialog box there is a field for your Owned ID number (not your cacher name). Be sure it is set to yours or the macro won't identify the cache as yours.

 

Also, check the record for your cache in the database with the edit function (right-click on the cache record - select Edit) to see if your Owner ID number is correct.

Share this post


Link to post

v7.3 Fixed alerts when using "Slice and Dice"

j

 

j,

 

I did a test with the cache closest to my house that I had problems with before. The alert works but all cache icons now have the same icon which is a small gray circle. I turned off "Slice and Dice" and reloaded the Nuvi and I have the proper icons with the regular load.

 

Steve

 

Thanks Steve. v7.3.1 should fix that.

j

Share this post


Link to post

In the macro's dialog box there is a field for your Owned ID number (not your cacher name). Be sure it is set to yours or the macro won't identify the cache as yours.

 

Also, check the record for your cache in the database with the edit function (right-click on the cache record - select Edit) to see if your Owner ID number is correct.

 

That was the trick. I was using my geocaching NAME, not the ID.

 

Another way I found (maybe has been mentioned already) is to go to "My Account Details" page on GC and the ID number is shown there as Member ID.

Share this post


Link to post

v7.3 Fixed alerts when using "Slice and Dice"

j

 

j,

 

I did a test with the cache closest to my house that I had problems with before. The alert works but all cache icons now have the same icon which is a small gray circle. I turned off "Slice and Dice" and reloaded the Nuvi and I have the proper icons with the regular load.

 

Steve

 

Thanks Steve. v7.3.1 should fix that.

j

 

Its still there on some cache types. I notice in 7.3.1 it even happens on some cache types with "slice and dice" turned off. I went back to 7.3.0

 

Steve

Share this post


Link to post

v7.3 Fixed alerts when using "Slice and Dice"

j

 

j,

 

I did a test with the cache closest to my house that I had problems with before. The alert works but all cache icons now have the same icon which is a small gray circle. I turned off "Slice and Dice" and reloaded the Nuvi and I have the proper icons with the regular load.

 

Steve

 

Thanks Steve. v7.3.1 should fix that.

j

 

Its still there on some cache types. I notice in 7.3.1 it even happens on some cache types with "slice and dice" turned off. I went back to 7.3.0

 

Steve

 

Sry Steve. v7.3.2 fixes that problem.

j

Edited by jjreds

Share this post


Link to post

 

Sry Steve. v7.3.2 fixes that problem.

j

 

I did a simulation run from my route to work and it seems to be working now. I'll play around with it more this weekend when I'm out running around.

 

Thanks!

 

Steve

Edited by GeoScouter

Share this post


Link to post

Running POI Loader 2.5.3.0 and GSAK 7.5.1.28

I am getting this message but not sure how to run loader in manual???

 

Error in Macro at line: 176

$$Alert Type=$Save Alert Type

Error=>Undeclared variable: $$AlertType

 

Macro will now abort

 

End of error message but directions on how to run in manual is foggy. I can load my Nuvi 760 with just the loader but I don't get everything that I am seeing in the examples. Also no more button.

Share this post


Link to post

First, I would like to stand in the line of thank you for a great macro!

 

I have a Nuvi 205 and think I have got everything to work as expected and just have a question:

When i just klick to see the map, it doesn't show any caches at all and if I select one cache and then the map, than that particular cache is shown on the map, no other.

 

Is this "works as designed" or am I doing something unusual?

 

Peter

Share this post


Link to post

Running POI Loader 2.5.3.0 and GSAK 7.5.1.28

I am getting this message but not sure how to run loader in manual???

 

Error in Macro at line: 176

$$Alert Type=$Save Alert Type

Error=>Undeclared variable: $$AlertType

 

Macro will now abort

 

End of error message but directions on how to run in manual is foggy. I can load my Nuvi 760 with just the loader but I don't get everything that I am seeing in the examples. Also no more button.

 

Fixed in v7.3.3

j

Share this post


Link to post

First, I would like to stand in the line of thank you for a great macro!

 

I have a Nuvi 205 and think I have got everything to work as expected and just have a question:

When i just klick to see the map, it doesn't show any caches at all and if I select one cache and then the map, than that particular cache is shown on the map, no other.

 

Is this "works as designed" or am I doing something unusual?

 

Peter

 

I think you have to zoom in quite a ways to get them to show otherwise they pop up with the alerts.

j

Share this post


Link to post

AWESOME macro! I know the answer to this is here somewhere but I can't seem to find it, so apologies...

 

I ran 3 pocket queries, dumped them into one GSAK DB (total of 1100+ caches) and then ran the macro. All seemed to go well, but the final report was only 467 points loaded. Sure enough, when I go to my Nuvi 200 and custom POIs and SPELL, I can't find the ones near the end of my GSAK DB list that are the furthest away.

 

I was assuming (from the forum) that I could go alot more on the NUVI - any idea why less than half loaded? I cleared all POIs from the NUVI prior to doing all this so that I would have a clean slate to work with.

 

Thanks!

 

Netfan

Edited by netfan

Share this post


Link to post

Thanks for the reply regarding the icons, of course they popped up at a more detailed zoom level, also together with all other stuff that is POIs of course. But that is another story, to ask Garmin for tools to shut some off.

 

Another question: My spoiler images are turning up, nice and in good manner as thumbnails at the "Run" screen. BUT, the name of the image is blank, is just say: "Image: "

It would sometimes be of value to read the name as is mights say "this is a nice view, not a spoiler" making it to be captured in the SpoilerSync filter.

 

I guess the field is meant to hold the image file name?

 

Peter

Share this post


Link to post

 

Pilotsnipes, not sure if your URL reference was in response to my post, but it didn't answer my question. I still don't know what caused a 1000+ GSAK list of caches to whittle down to less than 500 via the macro and POI loader...

 

Netfan

Share this post


Link to post

Running POI Loader 2.5.3.0 and GSAK 7.5.1.28

I am getting this message but not sure how to run loader in manual???

 

Error in Macro at line: 176

$$Alert Type=$Save Alert Type

Error=>Undeclared variable: $$AlertType

 

Macro will now abort

 

End of error message but directions on how to run in manual is foggy. I can load my Nuvi 760 with just the loader but I don't get everything that I am seeing in the examples. Also no more button.

 

Fixed in v7.3.3

j

 

v7.3.3 in what? I am lost :D

Share this post


Link to post

Hi-

 

What is the "Not Chosen" category cache? I'm running the 7.3.3 macro version and I never noticed this before - did I just miss it or is this something new?

 

Steve

Share this post


Link to post

Just got a new Nuvi 500, updated all of my software and tried to get the Proximity Points Alerts working. Darn thing just won't alert. :D Not sure what I am doing wrong, but I need help. Please....

Share this post


Link to post

Hi-

 

What is the "Not Chosen" category cache? I'm running the 7.3.3 macro version and I never noticed this before - did I just miss it or is this something new?

 

Steve

It means the owner declined to state what size the cache is. I think the name of it may have just changed to "Not Listed".

Check your GSAK column that is titled "Container".

Edited by Cache O'Plenty

Share this post


Link to post

Hi-

 

What is the "Not Chosen" category cache? I'm running the 7.3.3 macro version and I never noticed this before - did I just miss it or is this something new?

 

Steve

It means the owner declined to state what size the cache is. I think the name of it may have just changed to "Not Listed".

Check your GSAK column that is titled "Container".

 

Thanks!

Share this post


Link to post

Just got a new Nuvi 500, updated all of my software and tried to get the Proximity Points Alerts working. Darn thing just won't alert. :laughing: Not sure what I am doing wrong, but I need help. Please....

 

Figured it out. I had to use the jjreds01 in the advanced mode macro and unselect the default of TourGuide and select Proximity (on Route) to get it to work. Works fine now! Thanks. :laughing:

Share this post


Link to post

Hi JJreds,

 

thanks again for this great macro !

 

Is there a way to get my own (and my wife and son's own, who have their own accounts) caches listed in a separate Tourguide (own) similar to the 'Found' categories? This would likely require ways to store my wife and son's GC IDs somewhere. If not theirs, but can at least mine be separated out that way?

 

Secondly, it would be nice to have the ability to use separate icons for traditional by size (like in slice-dice) but *not* to have the slice-and-diced Tourguide, as it is annoying to have to search in several TourGuides. Or maybe have an extra Tourguide that includes all tratitionals in addition to the slice-and-dice.

 

M

Share this post


Link to post

Is there a way to make it so that additional waypoints show up under a different "folder" on the Nuvi. It is a great macro but this is one thing that annoys me. Also, is there any way to rename additional waypoints to a designated code (Like PK[smartName] for a parking location and TH[smartName] for a Trail head, etc.) This would greatly enhance this macro.

 

Thanks for everything...

 

Kyle

Share this post


Link to post

Is there a way to make it so that additional waypoints show up under a different "folder" on the Nuvi. It is a great macro but this is one thing that annoys me.

If you set up a separate database for your "additional waypoints" and then run the macro against that database, a new folder will appear (named to match your database name). Just be sure your POI_Loader points to the \POI_Loader folder and not the lower database folder.

Share this post


Link to post

Is there a way to make it so that additional waypoints show up under a different "folder" on the Nuvi. It is a great macro but this is one thing that annoys me.

If you set up a separate database for your "additional waypoints" and then run the macro against that database, a new folder will appear (named to match your database name). Just be sure your POI_Loader points to the \POI_Loader folder and not the lower database folder.

 

If I do this, then the additional waypoints will be on the nuvi twice . I don't want to delete all of the additional waypoints from my main database.

 

Please correct me if i'm wrong.

Share this post


Link to post

Yes, they will be there twice. I thought you were referring to a different set of waypoints (i.e. a different set of caches).

 

I'm not sure what "additional waypoints" you may be referring to. Are you referring to Child Waypoints?

Edited by Cache O'Plenty

Share this post


Link to post

I changed a setting in the Macro somehow - the NUVI 360 no longer alerts when when nearing a geocache... any help on how to restore the "ding" and the geocache icon on the display will be appreciated... no idea what I did - voyageurs60

Share this post


Link to post

Hi JJreds,

 

thanks again for this great macro !

 

Is there a way to get my own (and my wife and son's own, who have their own accounts) caches listed in a separate Tourguide (own) similar to the 'Found' categories? This would likely require ways to store my wife and son's GC IDs somewhere. If not theirs, but can at least mine be separated out that way?

 

Secondly, it would be nice to have the ability to use separate icons for traditional by size (like in slice-dice) but *not* to have the slice-and-diced Tourguide, as it is annoying to have to search in several TourGuides. Or maybe have an extra Tourguide that includes all tratitionals in addition to the slice-and-dice.

 

M

 

You want alerts for caches you own? You can already separate yours using the GCID and owned flag in the macro. I could add places for a couple of more ID's to the advanced form.

 

#2 It is possible, the macro would have to be reworked to treat the traditional symbols the same way it does the child symbols.

 

Do I hear a 2nd for either one of these mods?

j

Share this post


Link to post

nice to have the ability to use separate icons for traditional by size

 

I'll second that, although where/what icons will you use!? I haven't seen any that show Trad caches by size...

Share this post


Link to post

Is there a way to make it so that additional waypoints show up under a different "folder" on the Nuvi. It is a great macro but this is one thing that annoys me. Also, is there any way to rename additional waypoints to a designated code (Like PK[smartName] for a parking location and TH[smartName] for a Trail head, etc.) This would greatly enhance this macro.

 

Thanks for everything...

 

Kyle

I thought they were showing up as ex.:

 

FL1MQ42 - Final Location

PK1MQ42 - Parking Area etc.

 

What are you seeing? What Nuvi model are you using?

j

Share this post


Link to post

With Jreds macro, I was wondering if there is any way to get back from the lists to the map without using about 6 touches, like a hot button, especially when driving? I use this all the time and it's perfect for me except what I described.

 

PS. Forgive me if I post this wrong, I'm new to posting...

Share this post


Link to post

 

You want alerts for caches you own? You can already separate yours using the GCID and owned flag in the macro. I could add places for a couple of more ID's to the advanced form.

 

Not so much alerts, but the ability to search/look them up and get their complete description while on the road (eg for a maint trip), in case I need to verify subwaypoint coords etc. And finding them will be easier if they were in their own category..

 

If they are in their own category/Tourguide, I can then set the alert distance to 0 to get no alerts or set it if I want the alerts.

Share this post


Link to post

nice to have the ability to use separate icons for traditional by size

 

I'll second that, although where/what icons will you use!? I haven't seen any that show Trad caches by size...

 

I built my own, by using Paint, moving the 'box' ivcon to the top left and adding an 'M/S/R/L/U' letter below. That visually tells me the size on the map. It woudl be nice to be able to do that also for Multis etc, though I guess for those the icons would get very overloaded.

 

I also do not want to slice and dice into seperate TourGuides, just have the icons separate, so that I don't have to search in several categories for a cache but they have diff icons..

Share this post


Link to post

nice to have the ability to use separate icons for traditional by size

 

I'll second that, although where/what icons will you use!? I haven't seen any that show Trad caches by size...

 

I'm thinking they could be user specified on the slice/dice form......displayed without the alert info.

 

Small = con_small.gif or ?????

j

Share this post


Link to post

duplicate due to timeout. deleting..

Edited by sejtam

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 52

×
×
  • Create New...