Jump to content

Sick 60csx


GCNJ
Followers 0

Recommended Posts

My two year old 60csx decided to act up.

 

Waypoint---Go To and no red arrow on compass and no Distance to Next.

I could live without the compass arrow but not knowing the distance to a cache is NG. I did the software upgrade which is now 3.60 and 2.40 and did the hard reset----still NG

Before I send it to Garmin and pay 150 bucks with only a 90 day warranty on the refurb they will send me I am open to any ideas

Thanks

Link to comment

My two year old 60csx decided to act up.

 

Waypoint---Go To and no red arrow on compass and no Distance to Next.

I could live without the compass arrow but not knowing the distance to a cache is NG. I did the software upgrade which is now 3.60 and 2.40 and did the hard reset----still NG

Before I send it to Garmin and pay 150 bucks with only a 90 day warranty on the refurb they will send me I am open to any ideas

Thanks

 

I am not sure if your issues happened before you upgraded or not but my red compass arrow kept dissappearing on me on my way to the cache. I checked some of the forums and it looks like the battery would lose connection or only have a low power connection causing the arrow to vanish. The clips that hold the battery got bent to far back and caused this issue. So I took the advice and bent out the connectors and put a piece of foam on top of the batteries in the unit and its been ok ever since.

 

Storm180

Link to comment

I just purchased a Vista HCx which is already on its way back to Garmin with no red arrow, bearing or distance info. After pouring though the forums to try to fix it on my own it seems the newest update might have something to do with it, as many people seem to be saying that they are losing the arrow right after the update. I updated mine before I did anything with it, so I don't know if it worked prior, but IMHO and experience if everything else works properly 99.9999999999999% of the time it is a software issue.

Link to comment

My two year old 60csx decided to act up.

 

Waypoint---Go To and no red arrow on compass and no Distance to Next.

I could live without the compass arrow but not knowing the distance to a cache is NG. I did the software upgrade which is now 3.60 and 2.40 and did the hard reset----still NG

Before I send it to Garmin and pay 150 bucks with only a 90 day warranty on the refurb they will send me I am open to any ideas

Thanks

 

I am not sure if your issues happened before you upgraded or not but my red compass arrow kept dissappearing on me on my way to the cache. I checked some of the forums and it looks like the battery would lose connection or only have a low power connection causing the arrow to vanish. The clips that hold the battery got bent to far back and caused this issue. So I took the advice and bent out the connectors and put a piece of foam on top of the batteries in the unit and its been ok ever since.

 

Storm180

Storm180 Thanks you hit the nail right on the head. The battery posts looked ok and the batteries seemed tight but I bent then out some and all is good--red arrow and data fields are back.

Thanks for the other replies also, I will try and get the chipset software updated to 3.00.

Link to comment

I just purchased a Vista HCx which is already on its way back to Garmin with no red arrow, bearing or distance info. After pouring though the forums to try to fix it on my own it seems the newest update might have something to do with it, as many people seem to be saying that they are losing the arrow right after the update. I updated mine before I did anything with it, so I don't know if it worked prior, but IMHO and experience if everything else works properly 99.9999999999999% of the time it is a software issue.

 

I never did an update, the software version was the same as when I bought the unit in Feb 06. It always worked so well I did`nt want to mess with it. So the arrow and distance problem was the battery posts as Storm180 said.

Sometimes it`s just the simple stuff we overlook.

Link to comment

I suggest you do the update, but pull your SD card out first. It is a good way to avoid glitches in the update.

 

OK, I pulled the sd card, reloaded Updater and ran it. Still came up with 3.60 and 2.40.

So I called Garmin and their tech support spent a good 45 minutes with me and now I am up to speed with 3.60 and 3.00

So thanks to Garmins great customer service and all the help I recieved here, my 60csx is working better than ever.

What could be next? Maybe a Colorado?

Thanks Again

Link to comment

I suggest you do the update, but pull your SD card out first. It is a good way to avoid glitches in the update.

 

OK, I pulled the sd card, reloaded Updater and ran it. Still came up with 3.60 and 2.40.

So I called Garmin and their tech support spent a good 45 minutes with me and now I am up to speed with 3.60 and 3.00

So thanks to Garmins great customer service and all the help I recieved here, my 60csx is working better than ever.

What could be next? Maybe a Colorado?

Thanks Again

Never mind.

Edited by Klatch
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...