Jump to content

Vista Hcx not recognized

Recommended Posts

:) I have a vista Hcx which has worked very well until today. I deleted all the waypoints in preperation of sending new waypoints to it via GSAK. When I connected it to my usb port I didn't get the familiar "duh dink" sound one get when connecting a device. Instead I got a pop up message which read " One of the USB devices attached to this computer has malfunctioned, and windows does not recognize it." I've tried everything (hopefully not everything) to no avail. I even restored the system to an earlier date, Also tried running garmins driver.exe file but the gps is still not recognized. For giggles i connected a ventue Hc and it connected fine.


Any help would be wonderful!!!!!!!

Link to comment

Suggestion #1: computerprobs.gif


if that doesn't work, try:




and, if that doesn't do it, you might take a look at "device manager" and see if there is an error message associated with one of the "Human Interface Devices" or with one of the "Universal Serial Bus Controllers". If there is, go back to suggestion #1.

Link to comment

Hi cache_and_dash,


Not sure from what you write above if you have tried what I describe below or not . . .


I ran into a similar problem with my Vista HCx. I had initially installed the USB drivers and everything worked fine. I plugged it in one day and it was not recognized. I tried letting it search the Internet for new drivers. I shut down and restarted. I got very frustrated. Then I re-installed the Garmin USB drivers. It woked, but then it happened again! What the heck?! I eventually figured out that each time I had problems with it being recognized, I had used a different USB Port. Now, I'm sorry to say, that I don't remember if this was on my laptop with XP or the desktop with Vista . . .


Next time this happens:

Choose the option to install the driver yourself (advanced option, if I disremember)

Navigate to the directory that the Garmin Software installed (I went with the default C:\Garmin directory)

Navigate to Garmin\USB_Drivers

Try this for each USB Port and see if you have any luck.


Good luck.


Cache On!



Link to comment

I did finally get it connected to another computer. It recognized the device and I ran the garmin drivers again. I was HAPPY. I went up to my other computer and no good. Device manager says there is no driver installed for the unknown device. I tried updating the driver with the garmin software but since XP does not recognized the device it won't work. ( Garmin driver .EXE doesn't have the options it did on the other computer it just say plug in the cable and turn the gps on) I tried using device manager and updating the driver, leading it to the folder that contains the drivers and it can't find it.


Is there another way I can install the drivers on my HD (Incase they are corrupt) and retry pointing device manager in the right direction????

Link to comment

Is there another way I can install the drivers on my HD (Incase they are corrupt) and retry pointing device manager in the right direction????

Try this:


Use the Device Manager to scan for new hardware. Follow these steps:

1. Click Start, click Run, type Devmgmt.msc, and then click OK.

2. Highlight one of the "Universal Serial Bus Controller" items.

3. On the Action menu at the top, click Scan for hardware changes. This causes Windows to recognize new devices.

4. Repeat for each USB.

5. Close Device Manager and Control Panel.

Link to comment

No good. I have tried all different usb ports and a new cable. Device manager has it as unknown device.

This is really getting maddening.


One other note I did have it connected and was tring to sent one waypoint from GSAK to the gpsr. That is when it seems to have happened. GSAK kept trying to sent the file and didn't come up with an error. in order to stop GSAK I close it with task manager. Then had trouble starting GSAK again.


I think I'm going to try removing and reinstalling GSAK. The only thing is, It seems strange, when I plug in the gps windows doesn't say "found new hardware" just the aforementioned malfunction.

Link to comment

OK Heres the poop.


First of all thanks for all the help but it wasn't going to help. I called Garmin Tech support. It seems for some reason the gps is stuck in USB mass storage mode (How it got there I don't know.)


But bottom line the thing is busted and needs to be sent back for re grooving!


Thanks all

Link to comment
But bottom line the thing is busted and needs to be sent back for re grooving!


computerprobs.gif was the correct advice, but for the wrong piece of hardward. :D


Thanks for the follow up with us. By the way, if you have not sent the unit off yet, I wonder whether your computer really can see it. If it is stuck in mass storage mode, it should be listed as another drive under my computer.

Edited by jmundinger
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...