Jump to content
Sign in to follow this  
Followers 13
OpinioNate

Release Notes 4/16/08

Recommended Posts

Today we updated the site with the following fixes:

  • CITO/Event Cache type attributes expanded
  • Fixed issue with bookmark lists not appearing in dropdown when starting a new session
  • Added link to Communicator test page on garmin/freetrial.aspx
  • Added Geoteaming logo to Geoteaming contact page
  • Added link on CITO page to Cafe Press

The following are HOTFIX cases which have been fixed over the last two weeks:

  • Fixed issue with adding a cache to a bookmark list which already contains said cache
  • Fixed issue where the user wasn't able to add to more than one bookmark list in a session
  • Fixed issue which prevented some basic members from submitting a new cache
  • Removed ability to include HTML forms in cache description
  • Fixed issue which rendered HTML in "placed by" field of cache on the search results page
  • Fixed issue with strange characters being appended to the cache short description
  • Fixed broken link on general FAQ page
  • Fixed spelling error on Waypoint Downloads page
  • Fixed link to Knowledge Base on Contact page

Please feel free to comment in this thread on these changes and report any unusual site behavior. Thanks!

Share this post


Link to post

Kind of wierd but I typed up a cache discripition last night and it worked great. But I went in to change a few things in the discription today and now I can't make paragraphs. They don't seem to show up anymore. Kind of wonding if this is because of todays update. My cache write up is not in HTML. I've went in and reset the paragraphs 4 times now but every time it all comes out looking like one long paragraph.

 

Would this update have cause that????

 

Removed ability to include HTML forms in cache description

 

This is just strange cause it was working fine last night. And I never made any changes to the paragraphs.

Share this post


Link to post

I'm glad to see some progress occurring at the GC.com website. At the same time, however, some of the changes seem to have had negative influence on some existing cache listings.

 

In the few of my caches, for instance, I have been utilizing one of the recently fixed issues as a walk-around for being able to provide my listing text with proper Czech characters (which, if typed literally, get corrupted by the GC.com server).

 

Now, this walk-around does not work anymore, and as a result I am again denied the use of certain letters of the alphabet in my listings. The provisional solution, employed by most of Czech geocachers, is to replace the problematic letters with similarly looking ones from the English alphabet. However, this seems ugly, decreases the readibility of the text, and at some occasions it may even create confusion. The situation may be perfectly compared to such a one when six selected letters of the English alphabet would not be allowed in listings.

 

I realize that full international support in listing text must be a difficult issue. However, in this case I see a solution (a little walk-around, actually) which exists out there, is very easy, secure, and would require no changes in database structure at all: The only step necessary for fixing this bug is to allow the use of HTML entities with listing text (e.g. č) by turning off the feature which now converts these to the respective Unicode character, which later gets crippled, however. Preserving the HTML entity would present a solution for the problem.

 

I will appreciate any feedback on this topic. Apparently, there are lot of people concerned by the discussed issue.

Share this post


Link to post

There also seems there is some more HMTL filtering added on the display of the cachepages, causing some descriptions to loose a lot of the formatting.

See, e.g. De ronde van Maleyenki

 

Most of the formatting on this page has been done using style-attributes (like <SPAN Style="font...">nice text</SPAN> ). However, all these attributes are now filtered out when generating the html-page leaving only <SPAN>nice text</SPAN> which of course does nothing for the formatting.

The formatting is however stil in the database because a download of the .gpx file does show them.

Share this post


Link to post

I noticed today that when I tried to edit a cache page to congratulate the FTF that I could not get the congrats in a separate paragraph.

 

It would be nice if that problem could be fixed.

 

xshooter

Share this post


Link to post

I noticed today that when I tried to edit a cache page to congratulate the FTF that I could not get the congrats in a separate paragraph.

 

It would be nice if that problem could be fixed.

 

xshooter

 

Glad to see I'm not the only one with the problem. (No offense xshooter) But I'm wondering if this is a site wide problem. It kind of stinks. I'm trying to get one ready to be released and wanted to submit it tonight so I could try and get it scedualed to be unleashed early Sat. morning. But it's a long write up and I wouldn't want to read the whole thing all in one paragraph.

 

So yes I second that it would be nice to get this fixed.

Share this post


Link to post

[[*]Removed ability to include HTML forms in cache description

 

WHAT!??? :laughing:

 

Why would you not allow us to use HTML... it is the Internet, you know.

 

Now everyone who used HTML to make their page look great, including me, looks like crap. :laughing:

 

I don't get it, this was the fun part of working with this sport on the net.

 

I liked being creative with my cache pages. I'm a visual person.

 

Please explain why this is happening, it's seems like step back into the nineties.

 

THIS MAKES ABSOLUTLY NO SENSE! :laughing::laughing::laughing:

Share this post


Link to post

[[*]Removed ability to include HTML forms in cache description

 

WHAT!??? :laughing:

 

Why would you not allow us to use HTML... it is the Internet, you know.

Note the word in bold. It's only forms that they are now disallowing. Forms could potentially be a serious secuity problem.

 

Most HTML is still allowed, although it appears there is a new problem with attributes getting filtered out. Hopefully this will be fixed soon.

Share this post


Link to post

It appears style attributes are filtered? Why? I just want to left/right align my images.

It seems not only the style attributes but also the class attributes are disappearing...

 

That's really very annoying if you depend on these attributes for the lay-out of your page. And I really don't want to add another X number of nested tables to get everything in it's place.

Share this post


Link to post

[[*]Removed ability to include HTML forms in cache description

 

WHAT!??? :laughing:

 

Why would you not allow us to use HTML... it is the Internet, you know.

Note the word in bold. It's only forms that they are now disallowing. Forms could potentially be a serious secuity problem.

 

Most HTML is still allowed, although it appears there is a new problem with attributes getting filtered out. Hopefully this will be fixed soon.

 

I noticed that other cacher pages were still able to use limited HTML. But, like my pages, they are just ruined.

This is very disappointing.

I'm no great HTML author, I use the old Netscape composer for most of mine, then repair what doesn't work with the tiny "true HTML" knowledge I have.

I hope they can fix the problem

Share this post


Link to post

Thanks for the list!

 

And like many, all my caches description is affected. Wasn't using forms but style like <font style=""> and it is now ignored but the code is still there if I go to edit.

 

Will it remain banned forever now or it's a mistake with latest hotfix you applied?

Edited by Rhialto

Share this post


Link to post

I will appreciate any feedback on this topic. Apparently, there are lot of people concerned by the discussed issue.

 

I can appreciate the annoyance, blahma. If you would please post here all 6 characters which are not allowed I will do my best to ensure they are allowed in the future. Thanks.

Share this post


Link to post

Kind of wierd but I typed up a cache discripition last night and it worked great. But I went in to change a few things in the discription today and now I can't make paragraphs. They don't seem to show up anymore. Kind of wonding if this is because of todays update. My cache write up is not in HTML. I've went in and reset the paragraphs 4 times now but every time it all comes out looking like one long paragraph.

 

Would this update have cause that????

 

Removed ability to include HTML forms in cache description

 

This is just strange cause it was working fine last night. And I never made any changes to the paragraphs.

 

We noticed this, too, Parabola. A case has been opened and we'll return that functionality to normal shortly. Sorry for the trouble.

Share this post


Link to post

It was not our intention to restrict the usage of HTML to the degree that it has been restricted. As Lil Devil pointed out it is only the Forms which were a security issue on the site. I will make sure this is reviewed as soon as possible so your caches are returned to their prior state. I'm sorry to scare you guys like that.

Share this post


Link to post

In a moment we will release a hotfix that should return your cache pages to their former glory. This will be something of an ongoing process to refine our filtering techniques to get the proper balance of security and freedom, so please report any problems you have designing your caches and we'll go from there. Thank you!

Share this post


Link to post

Kind of wierd but I typed up a cache discripition last night and it worked great. But I went in to change a few things in the discription today and now I can't make paragraphs. They don't seem to show up anymore. Kind of wonding if this is because of todays update. My cache write up is not in HTML. I've went in and reset the paragraphs 4 times now but every time it all comes out looking like one long paragraph.

 

Would this update have cause that????

 

Removed ability to include HTML forms in cache description

 

This is just strange cause it was working fine last night. And I never made any changes to the paragraphs.

 

We noticed this, too, Parabola. A case has been opened and we'll return that functionality to normal shortly. Sorry for the trouble.

 

Thanks for taken such quick notice OpinioNate.

Share this post


Link to post

In a moment we will release a hotfix that should return your cache pages to their former glory. This will be something of an ongoing process to refine our filtering techniques to get the proper balance of security and freedom, so please report any problems you have designing your caches and we'll go from there. Thank you!

 

Thanks, Nate.

 

I wasn't around this morning when the panic was happening (I'd have been panicking as well, I'm glad to have missed it!). So when I read this thread, I took your advice and glanced at my cache pages to see how they looked. I didn't get through all my cache pages, so there may be another issue, but I ran out of steam after about 20 caches.

 

I don't know what a "form" is, I use mostly basic html, except for a couple things that I have borrowed from friends. I have one thing that is broken in my pages. Here is an example cache page: Wood End. The issue is at the end of the cache page, there is supposed to be a little drop down menu showing all my caches. I have a box at the top of the page that hasn't been affected (of course it's not drop down, nor is it as complicated).

 

I'm not hugely attached to the drop down box, if there's some reason that it's not compatible with these changes, I'll take it out of all my cache pages. I'd just like to know if I need to. Thanks! :P

Share this post


Link to post

I don't know what a "form" is, I use mostly basic html, except for a couple things that I have borrowed from friends. I have one thing that is broken in my pages. Here is an example cache page: Wood End. The issue is at the end of the cache page, there is supposed to be a little drop down menu showing all my caches. I have a box at the top of the page that hasn't been affected (of course it's not drop down, nor is it as complicated).

 

I'm not hugely attached to the drop down box, if there's some reason that it's not compatible with these changes, I'll take it out of all my cache pages. I'd just like to know if I need to. Thanks! :P

 

Yes, a drop down box is an HTML form element and is what they are intending to block.

 

-Ben

Share this post


Link to post

Since the new release the lay-out of most of my cache pages is wonky.

 

It appears style attributes are filtered? Why? I just want to left/right align my images.

 

Examples:

Rondje Hoorn

Mijzenpolder

Roode Steen (Nano)

 

Could this change be reverted?

Thanks for fixing it so quickly.

 

My cache pages onze again look as I intended them. :P

Share this post


Link to post

Not sure if this is a result of recent changes...

 

When creating a new cache, the "Who Placed The Cache" field is now blank. In the past it entered by username and was able to be edited. Was this intentional, or is something not working?

Share this post


Link to post

Kind of wierd but I typed up a cache discripition last night and it worked great. But I went in to change a few things in the discription today and now I can't make paragraphs. They don't seem to show up anymore. Kind of wonding if this is because of todays update. My cache write up is not in HTML. I've went in and reset the paragraphs 4 times now but every time it all comes out looking like one long paragraph.

 

Would this update have cause that????

 

Removed ability to include HTML forms in cache description

 

This is just strange cause it was working fine last night. And I never made any changes to the paragraphs.

 

We noticed this, too, Parabola. A case has been opened and we'll return that functionality to normal shortly. Sorry for the trouble.

 

In HTML descriptions, I am getting <br>'s added when I first create the listing. However, if I edit them out, all is fine.

Share this post


Link to post

I don't know what a "form" is, I use mostly basic html, except for a couple things that I have borrowed from friends. I have one thing that is broken in my pages. Here is an example cache page: Wood End. The issue is at the end of the cache page, there is supposed to be a little drop down menu showing all my caches. I have a box at the top of the page that hasn't been affected (of course it's not drop down, nor is it as complicated).

 

I'm not hugely attached to the drop down box, if there's some reason that it's not compatible with these changes, I'll take it out of all my cache pages. I'd just like to know if I need to. Thanks! :(

 

Yes, a drop down box is an HTML form element and is what they are intending to block.

 

-Ben

 

Yep, sorry Ambrosia. The original issue involved radio buttons but unfortunately dropdowns fall in that category as well. We are trying to allow as much as possible but have to draw the line somewhere.

Share this post


Link to post

Please feel free to comment in this thread on these changes and report any unusual site behavior. Thanks!

 

Found an interesting bug.

Go to a cache page, any cache page that has an encrypted log in the found column. If you decrypt a encrypted log, the encrypted hints disappear and are replaced with a duplicate of the Long Description.

The description, pictures, and links are all doubled on the page.

Go ahead give it a try... I've never seen anything like it.

Here, try one of mine;

 

OPERATION: RED SKY

 

Here's someone else's, so you don't think it's just mine;

 

Crossroads - Brothers In Arms Cache

Edited by Big Booty Bob

Share this post


Link to post

I don't know if this is new, but I just noticed that comments get editted out. That certainly messes up a few puzzle caches I know.

Share this post


Link to post

Please feel free to comment in this thread on these changes and report any unusual site behavior. Thanks!

 

Found an interesting bug.

Go to a cache page, any cache page that has an encrypted log in the found column. If you decrypt a encrypted log, the encrypted hints disappear and are replaced with a duplicate of the Long Description.

The description, pictures, and links are all doubled on the page.

Go ahead give it a try... I've never seen anything like it.

Here, try one of mine;

 

OPERATION: RED SKY

 

Here's someone else's, so you don't think it's just mine;

 

Crossroads - Brothers In Arms Cache

 

Interesting. That certainly is a very odd bug that was introduced. I will make sure this is addressed soon. Thank you for pointing it out!

Share this post


Link to post

I don't know if this is new, but I just noticed that comments get editted out. That certainly messes up a few puzzle caches I know.

 

I will look into this as well, thanks.

Share this post


Link to post

Please feel free to comment in this thread on these changes and report any unusual site behavior. Thanks!

 

Found an interesting bug.

Go to a cache page, any cache page that has an encrypted log in the found column. If you decrypt a encrypted log, the encrypted hints disappear and are replaced with a duplicate of the Long Description.

The description, pictures, and links are all doubled on the page.

Go ahead give it a try... I've never seen anything like it.

Here, try one of mine;

 

OPERATION: RED SKY

 

Here's someone else's, so you don't think it's just mine;

 

Crossroads - Brothers In Arms Cache

 

Interesting. That certainly is a very odd bug that was introduced. I will make sure this is addressed soon. Thank you for pointing it out!

 

It needn't to be encrypted log, it also happens with encrypted hint (look at this listing and try to decrypt hint). Also interesting is, that this page generated for FireFox is corrupted (doubled listing without decrypted hint), but version generated for IE works well. But it is not problem of FireFox (because of page code)!

 

On this cache I also see its image in IE correctly, but in forefox it looks like image file is missing (404).

I tried to play with image url and when I use its address with uppercased extension (".JPG" instead of original ".jpg"), it works. Also strange.

 

I'm not sure if the second problem isn't some sort of FireFox bug (I don't believe it much), but the first one is definitely geocaching.com problem.

Edited by ZdenalCZE

Share this post


Link to post

I don't know what a "form" is, I use mostly basic html, except for a couple things that I have borrowed from friends. I have one thing that is broken in my pages. Here is an example cache page: Wood End. The issue is at the end of the cache page, there is supposed to be a little drop down menu showing all my caches. I have a box at the top of the page that hasn't been affected (of course it's not drop down, nor is it as complicated).

 

I'm not hugely attached to the drop down box, if there's some reason that it's not compatible with these changes, I'll take it out of all my cache pages. I'd just like to know if I need to. Thanks! :)

 

Yes, a drop down box is an HTML form element and is what they are intending to block.

 

-Ben

 

Yep, sorry Ambrosia. The original issue involved radio buttons but unfortunately dropdowns fall in that category as well. We are trying to allow as much as possible but have to draw the line somewhere.

Ah, well. Thanks for the answers. I'll take it out of my cache pages! I'm glad that we're able to keep the more essential bits of html. :)

Share this post


Link to post

Please feel free to comment in this thread on these changes and report any unusual site behavior. Thanks!

 

Found an interesting bug.

Go to a cache page, any cache page that has an encrypted log in the found column. If you decrypt a encrypted log, the encrypted hints disappear and are replaced with a duplicate of the Long Description.

The description, pictures, and links are all doubled on the page.

Go ahead give it a try... I've never seen anything like it.

Here, try one of mine;

 

OPERATION: RED SKY

 

Here's someone else's, so you don't think it's just mine;

 

Crossroads - Brothers In Arms Cache

 

Interesting. That certainly is a very odd bug that was introduced. I will make sure this is addressed soon. Thank you for pointing it out!

Just wanted to verify that I see the same problem on this page using Opera 9.26 on XP "Media Edition".

 

That is a very weird bug . . . :)

Share this post


Link to post

Will we be able tu use <font style="font-size: 9pt; text-decoration:underline"> again or it is gone? I know text-decoration:underline could be replaced by <U></U> but it's all there already. And <font size=> is not as flexible as style="font-size".

Share this post


Link to post

In a moment we will release a hotfix that should return your cache pages to their former glory. This will be something of an ongoing process to refine our filtering techniques to get the proper balance of security and freedom, so please report any problems you have designing your caches and we'll go from there. Thank you!

 

I am currently experiencing a problem with Matchmaking via Geocaching.com

 

The blue buttons are supposed to reveal numbers when you single-click on them. Then when you double-click them they are supposed to say "MATCHED"

 

These buttons are no longer working. I hope this is not one of the HTML codes that is going to get blocked.

Share this post


Link to post

I will appreciate any feedback on this topic. Apparently, there are lot of people concerned by the discussed issue.

 

I can appreciate the annoyance, blahma. If you would please post here all 6 characters which are not allowed I will do my best to ensure they are allowed in the future. Thanks.

 

Many thanks, OpinioNate, for the quick feedback! I am glad there is someone willing to discuss the issue, since so far I have heard from the Czech geocacher community only clues of such kind that there is nobody at Groundspeak interested in getting this fixed, which however I myself could not really believe.

 

I made a slight mistake in my previous post: The characters of Czech alphabet which do not appear correctly in listings are not six, but seven, and they of course appear in two variants each (uppercase and lowercase), which makes a total of fourteen characters. The respective character codes are:

 

U+010C & #268; Č Latin Capital Letter C with caron

U+010D & #269; č Latin Small Letter C with caron

U+010E & #270; Ď Latin Capital Letter D with caron

U+010F & #271; Ď Latin Small Letter D with caron

U+011A & #282; Ě Latin Capital Letter E with caron

U+011B & #283; ě Latin Small Letter E with caron

U+0147 & #327; Ň Latin Capital Letter N with caron

U+0148 & #328; ň Latin Small Letter N with caron

U+0158 & #344; Ř Latin Capital Letter R with caron

U+0159 & #345; ř Latin Small Letter R with caron

U+0164 & #356; Ť Latin Capital Letter T with caron

U+0165 & #357; ť Latin Small Letter T with caron

U+016E & #366; Ů Latin Capital Letter U with ring above

U+016F & #367; ů Latin Small Letter U with ring above

 

A straight-forward solution would naturally be "permitting" these characters in the same way like all other Czech characters already do get accepted at the moment. If perhaps the listings are being stored in Unicode, then I guess it would be enough to explicitely accept these characters instead of perform diacritics stripping on them. But since the problem appears to me to be something related just to the character set used for storing the data, I dare suggesting a quick work-around which should be easy to implement and should render those letters usable with just a bit of effort from the author. Such a solution is accepting the HTML entities for the respective characters (I have listed those entities in the second column, although with an extra space between & and # in order to prevent it from being displayed incorrectly in this forum). Presently, all HTML entities in a cache listing seem to get automatically converted into the character they represent, which may not be a desirable behavior, particularly in respect to this particular issue.

 

I am willing to stay in touch with you and help in any way I could in this matter, and I am sure that you would get a lot of cheer from the Czech geocachers community if you succeed in getting this working in one way or the other.

Share this post


Link to post

Well, I saw that there was a fix to the free trial page. I just got me new Colorado, registered it with Garmin, loaded a few caches from GC and then tried to get my " free time". I had the GPS on, and connected to my computer, obviously had the Garmin communicator plug in ( had it running as a matter of fatc) and got not one, but 3 error messages. I was told I needed the latest vbersion of garmin communicator, needed to plug my GPS in to the computer and had to register it.

 

I'm using Firefox if that has any bearing on the issue.

Share this post


Link to post

 

In HTML descriptions, I am getting <br>'s added when I first create the listing. However, if I edit them out, all is fine.

 

 

When creating a new cache, the "Who Placed The Cache" field is now blank. In the past it entered by username and was able to be edited. Was this intentional, or is something not working?

 

Any word on these two items?

Share this post


Link to post

Will we be able tu use <font style="font-size: 9pt; text-decoration:underline"> again or it is gone? I know text-decoration:underline could be replaced by <U></U> but it's all there already. And <font size=> is not as flexible as style="font-size".

Do I have to come to the conclusion we won't be able tu use it anymore? I'd like to know before going into reviewing/editing all my cache listing.

 

Thanks

Share this post


Link to post

Just a quick note about these cache description problems you're all having - we're still working on solutions to each of the issues (special characters, fonts, image alignments etc.) so please be patient and I'll update you as they are fixed.

 

Please don't edit your caches beyond posting a note to let people know certain elements will be missing for a little while. We are working hard to get these fixes in but the ubbtextbox (not htmltidy) is very uncooperative at the moment.

Share this post


Link to post

Hi

 

I had to disable 3 cache listing due to the html bug, bug includes onclick, ondblclick and onmouseover, onmouseout are not working I do hope it gets fixed soon

 

GC124PF Memory Match Game You Just Gotta Play It

GCZN4X Ut-o

GC10EKZ 289 Smile Markers

GC125AM Who Let the Pigs Out

 

Thanks

Share this post


Link to post

Had 9 and edited them all, It was not a big problem in my case, no real bug, mostly cosmetic but when you are perfectionnist like me... I had to make the change. :-)

Share this post


Link to post

Try using KompoZer.

I use it now on all of my listings. I don't know if it will help with some of the issues that are here but give it a shot. As far as I can tell none of my listings have been affected by the change. KompoZer is free.

 

http://www.kompozer.net/

Share this post


Link to post
I had to disable 3 cache listing due to the html bug, bug includes onclick, ondblclick and onmouseover, onmouseout are not working

You can pretty much bet that these won't be allowed again. <script> has always been blocked and if onclick, etc, was allowed it was an oversight that was fixed. You'll need to find another way to do whatever you were doing.

Share this post


Link to post
I had to disable 3 cache listing due to the html bug, bug includes onclick, ondblclick and onmouseover, onmouseout are not working

You can pretty much bet that these won't be allowed again. <script> has always been blocked and if onclick, etc, was allowed it was an oversight that was fixed. You'll need to find another way to do whatever you were doing.

 

Not a script it is all html.

Share this post


Link to post

I had a few complaints that one of my listings was no longer working. Sure enough the form had been disabled - rendering an extremely unique puzzle cache set up for the archive block. One of the early great puzzle caches in the area also will no longer work. Rather disappointed in the route Groundspeak has been taking lately.

 

Features just seem to be disappearing, and being replaced with commercial content. by the way, congrats on the new "fixes"... These "problems" were really begining to get annoying... <_<

 

Today we updated the site with the following fixes:

  • ..
  • Added link to Communicator test page on garmin/freetrial.aspx
  • Added Geoteaming logo to Geoteaming contact page
  • Added link on CITO page to Cafe Press

Share this post


Link to post

If your caches depend on special HTML/javascript, it is perfectly legit to host your puzzle on an external site, like My Puzzle Cache.

 

As long as you can verify that it's going to be permanent, non commercial, and not taking personal info, it's within guidelines to require external sites.

 

Also - if you don't have a site to host it on, there are many free web hosts out there. Just google for them.

 

-Ben

Edited by benh57

Share this post


Link to post

If your caches depend on special HTML/javascript, it is perfectly legit to host your puzzle on an external site, like My Puzzle Cache.

 

As long as you can verify that it's going to be permanent, non commercial, and not taking personal info, it's within guidelines to require external sites.

 

Also - if you don't have a site to host it on, there are many free web hosts out there. Just google for them.

 

-Ben

 

Thanks Ben

 

I may have to do that, I can with no problem create the .htm page, I'll have to find a place to use them at, I tried to use comcast web pages but not sure how to up the file for it.

Share this post


Link to post

Just a quick note about these cache description problems you're all having - we're still working on solutions to each of the issues (special characters, fonts, image alignments etc.) so please be patient and I'll update you as they are fixed.

 

Please don't edit your caches beyond posting a note to let people know certain elements will be missing for a little while. We are working hard to get these fixes in but the ubbtextbox (not htmltidy) is very uncooperative at the moment.

Hmm.. you mentionned special characters, so I guess that would be the problem reported here..

Share this post


Link to post
I had to disable 3 cache listing due to the html bug, bug includes onclick, ondblclick and onmouseover, onmouseout are not working

You can pretty much bet that these won't be allowed again. <script> has always been blocked and if onclick, etc, was allowed it was an oversight that was fixed. You'll need to find another way to do whatever you were doing.

Not a script it is all html.

Umm, last time I looked at the spec, all the stuff inside the quotes after a onclick, onmouseover, or whatever, is javascript. What else would you put in the quotes? :)

Share this post


Link to post
I had to disable 3 cache listing due to the html bug, bug includes onclick, ondblclick and onmouseover, onmouseout are not working

You can pretty much bet that these won't be allowed again. <script> has always been blocked and if onclick, etc, was allowed it was an oversight that was fixed. You'll need to find another way to do whatever you were doing.

Not a script it is all html.

Umm, last time I looked at the spec, all the stuff inside the quotes after a onclick, onmouseover, or whatever, is javascript. What else would you put in the quotes? :lol:

 

<img src=

"http://img.geocaching.com/cache/93625254-87ba-4347-945b-3a8d725f862d.jpg"

onclick=

"this.src='http://home.comcast.net/~rbwarren/images/01.gif'"

ondblclick=

"this.src='http://img.geocaching.com/cache/582538b9-efbe-461f-9080-1ea67187acab.jpg'">

<img src=

"http://img.geocaching.com/cache/93625254-87ba-4347-945b-3a8d725f862d.jpg"

 

So these lines of code are not allowed, all it does is call up a img, images that are stored on the geocache web site, nothing harmful in there is there?

 

So the listing was ok for more then a year, then it was disallowed. Java is not even activated when the commands where called on. There in not even the word script in the lines of code. So what damage is this causing?

Edited by R & B Cache

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 13

×
×
  • Create New...