Jump to content
Sign in to follow this  
Followers 1
TexasGringo

Installing .NET Framework Version 2.0 Redistributable Package

Recommended Posts

To use the builder, it says you need the .NET Framework Version 2.0 Redistributable Package...file name "DotNetFx.exe".

 

If you have .NET Framework Version 2.0 SP1 installed, you will get an ERROR saying that the package is not compatible with the curent Framework version.

 

According to Microsoft Article

 

http://support.microsoft.com/KB/906894

 

--------------------------------------------

Which basically says this:

 

Uninstall the .NET Framework Version 2.0 SP1

 

Install the .NET Framework Version 2.0 Redistributable Package

 

Reinstall .NET Framework Version 2.0 SP1

Edited by Drooling_Mongoloid

Share this post


Link to post

To use the builder, it says you need the .NET Framework Version 2.0 Redistributable Package...file name "DotNetFx.exe".

 

If you have .NET Framework Version 2.0 SP1 installed, you will get an ERROR saying that the package is not compatible with the curent Framework version.

 

According to Microsoft Article

 

http://support.microsoft.com/KB/906894

 

--------------------------------------------

Which basically says this:

 

Uninstall the .NET Framework Version 2.0 SP1

 

Install the .NET Framework Version 2.0 Redistributable Package

 

Reinstall .NET Framework Version 2.0 SP1

How do i do it/

I fancied having a go with this wereigo thingy that others have been raving about, i have put the application on my mio but when i try and run it i get the message

"This application (player.exe) requires a newer version of the Microsoft.NET Compact Framework than the version installed on this device.

I have managed to find a newer version and downloaded it to my PC but cacn't install it on my mio. as it isn't a stand alone program I don't know how to uninstall the one I have then reinstall the newer versionn. Also My PC is runninig Vista so the active sync doesn't work, i usually copy and past files onto my mio then instal from there please cah someone help a techno numty

Cheers Fi

Share this post


Link to post

The redistributable usually does sync. How have you been trying to install the .Net CF on your Mio? Or have you tried installing it?

Share this post


Link to post

The redistributable usually does sync. How have you been trying to install the .Net CF on your Mio? Or have you tried installing it?

i tried running it on my pc thinking that when i next connected my mio it would install it for me but nothing hapened, i have also tried copieing the file onto my mio and running from there but it says "there is no application assosiated with netcfsetupv2"

Share this post


Link to post

Yeah, it looks like it does depend on synching. Have you tried visiting a Mio user forum to seeing if someone has posted about the sync problem?

Share this post


Link to post

I am sorry for wasting your time [:laughing:] on the above post where it says uninstall then reinstal I assumed i had to uninstall in on my PPC not realising that it meant uninstal it from my PC. I have now uninstalled it from my PC and reinstalled the newer package which has sent the relevant info to my PPC.

see i tolk you i was a numty

Share this post


Link to post

Hey, if that worked and solved your problem, any time was worth it. I always enjoy it when a person's problem is solved. Who knows how many others may have had the same problem, but decided not to ask?

Share this post


Link to post

So... I see there's a .NET CF Redistributable v3.5 out there. Does that supersede the 2.0 version, or will the 3.5 version not work properly with Wherigo?

From what I know of .Net 3.0, the 3.5 redistributable should work fine. It uses .Net 2 and extends its functionality. The full version should contain the Windows Foundation set and Windows CardSpace. I don't know which functions are limited in the Compact Framework redistributable package.

 

By the way, from the linked page The Cheeseheads posted:

In addition to version 3.5 support, it also supports applications developed for version 1.0 and 2.0. The .NET Compact Framework 3.5 provides new features such as Windows Communication Foundation, LINQ, SoundPlayer, new runtime tool support, and many other features.

Share this post


Link to post

But if I already have Wherigo running with 2.0, there's really no benefit to run out and upgrade to 3.5?

At this time, not that I know. It's up to Groundspeak if they want to use any of the additional features in .Net 3.5. If that happens, I would hope there will be an announcement on the forum to this effect and the Wherigo.com web site updated with the new link and copy (text on the page).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 1

×